wrong package name 'XStatic-Angular-Irdragndrop' in horizon/requirements.txt

Bug #1438543 reported by Sam Wan on 2015-03-31
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Critical
Rob Cresswell
xstatic-angular-irdragndrop
Undecided
Unassigned

Bug Description

There's a wrong package name 'XStatic-Angular-Irdragndrop' in horizon/requirements.txt.
It should be 'XStatic-Angular-lrdragndrop'.
uppercase 'l'-rdragndrop instead of uppercase 'i'rdragndrop.

This causes devstack fail because there's no such package in pypi.
------------------------------------------------------------------------------------------------------
2015-03-31 05:40:50.388 | Could not find any downloads that satisfy the requirement XStatic-Angular-Irdragndrop>=1.0.2.1 (from horizon==2015.1.dev110)
2015-03-31 05:40:50.388 | Some externally hosted files were ignored as access to them may be unreliable (use --allow-external XStatic-Angular-Irdragndrop to allow).
2015-03-31 05:40:50.704 | No distributions at all found for XStatic-Angular-Irdragndrop>=1.0.2.1 (from horizon==2015.1.dev110)
--------------------------------------------------------------------------------------------------

and this bug is also logged at redhat https://bugzilla.redhat.com/show_bug.cgi?id=1196957

Yang Yu (yuyangbj) wrote :

Also see this error. The jenkins job is blocking!

Sam Wan (sam-wan) wrote :

Seems the package name was renamed because previously in horizon/openstack_dashboard/static_settings.py, there's a module called 'xstatic.pkg.angular_irdragndrop'
----------------------------------------------------
import xstatic.pkg.angular_irdragndrop
----------------------------------------------------

but now there's only 'angular_lrdragndrop'
---------------------------------------------------
/usr/local/lib/python2.7/dist-packages/xstatic/pkg/angular_lrdragndrop
---------------------------------------------

File horizon/openstack_dashboard/static_settings.py needs to change accordingly.

DavidLee (blowdriver) wrote :

@Sam Wan

HI, change "import xstatic.pkg.angular_irdragndrop" to "import xstatic.pkg.angular_lrdragndrop"?

Do I need to change global_requirements.txt?

Hi David,

  I think you need to change both the requirements.txt and the python file.
 If you don’t change horizon/requirements.txt, you'll not be able to install the 'XStatic-Angular-lrdragndrop' package.
 If you don't change horizon/openstack_dashboard/static_settings.py, you'll fail to 'import xstatic.pkg.angular_i rdragndrop' because there's no such module.

Thanks and regards.

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Shan Wan (Sam)

Princ. Systems Int. Engineer – Partner & ISV Certification Engineering, E-Lab Engineering
Customer Solution & Qualification Labs (CSQL)
Engineering Operations, Services & Solutions (EOS2)
Tel: +86-28-82966713
Address: 7F, C12, Tianfu Software Park, Chengdu, Sichuan, P. R. of China
------------------------------------------------------------------------------------------------------------------------------------------------------------------

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of DavidLee
Sent: Tuesday, March 31, 2015 4:30 PM
To: Wan, Sam
Subject: [Bug 1438543] Re: wrong package name 'XStatic-Angular-Irdragndrop' in horizon/requirements.txt

@Sam Wan

HI, change "import xstatic.pkg.angular_irdragndrop" to "import xstatic.pkg.angular_lrdragndrop"?

Do I need to change global_requirements.txt?

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/1438543

Title:
  wrong package name 'XStatic-Angular-Irdragndrop' in
  horizon/requirements.txt

Status in OpenStack Dashboard (Horizon):
  New

Bug description:
  There's a wrong package name 'XStatic-Angular-Irdragndrop' in horizon/requirements.txt.
  It should be 'XStatic-Angular-lrdragndrop'.
  uppercase 'l'-rdragndrop instead of uppercase 'i'rdragndrop.

  This causes devstack fail because there's no such package in pypi.
  ------------------------------------------------------------------------------------------------------
  2015-03-31 05:40:50.388 | Could not find any downloads that satisfy the requirement XStatic-Angular-Irdragndrop>=1.0.2.1 (from horizon==2015.1.dev110)
  2015-03-31 05:40:50.388 | Some externally hosted files were ignored as access to them may be unreliable (use --allow-external XStatic-Angular-Irdragndrop to allow).
  2015-03-31 05:40:50.704 | No distributions at all found for XStatic-Angular-Irdragndrop>=1.0.2.1 (from horizon==2015.1.dev110)
  --------------------------------------------------------------------------------------------------

  and this bug is also logged at redhat
  https://bugzilla.redhat.com/show_bug.cgi?id=1196957

To manage notifications about this bug go to:
https://bugs.launchpad.net/horizon/+bug/1438543/+subscriptions

DavidLee (blowdriver) wrote :

Thanks your answer!
I am new on Ubuntu and Devstack

Thank you!

On 2015年3月31日週二 下午4:41 Wan, Sam <email address hidden> wrote:

> Hi David,
>
> I think you need to change both the requirements.txt and the python file.
> If you don’t change horizon/requirements.txt, you'll not be able to
> install the 'XStatic-Angular-lrdragndrop' package.
> If you don't change horizon/openstack_dashboard/static_settings.py,
> you'll fail to 'import xstatic.pkg.angular_i rdragndrop' because there's no
> such module.
>
> Thanks and regards.
>
> ------------------------------------------------------------
> ------------------------------------------------------------
> ------------------------------------------
> Shan Wan (Sam)
>
> Princ. Systems Int. Engineer – Partner & ISV Certification Engineering,
> E-Lab Engineering
> Customer Solution & Qualification Labs (CSQL)
> Engineering Operations, Services & Solutions (EOS2)
> Tel: +86-28-82966713
> Address: 7F, C12, Tianfu Software Park, Chengdu, Sichuan, P. R. of China
> ------------------------------------------------------------
> ------------------------------------------------------------
> ------------------------------------------
>
>
> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
> DavidLee
> Sent: Tuesday, March 31, 2015 4:30 PM
> To: Wan, Sam
> Subject: [Bug 1438543] Re: wrong package name
> 'XStatic-Angular-Irdragndrop' in horizon/requirements.txt
>
> @Sam Wan
>
> HI, change "import xstatic.pkg.angular_irdragndrop" to "import
> xstatic.pkg.angular_lrdragndrop"?
>
> Do I need to change global_requirements.txt?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1438543
>
> Title:
> wrong package name 'XStatic-Angular-Irdragndrop' in
> horizon/requirements.txt
>
> Status in OpenStack Dashboard (Horizon):
> New
>
> Bug description:
> There's a wrong package name 'XStatic-Angular-Irdragndrop' in
> horizon/requirements.txt.
> It should be 'XStatic-Angular-lrdragndrop'.
> uppercase 'l'-rdragndrop instead of uppercase 'i'rdragndrop.
>
> This causes devstack fail because there's no such package in pypi.
> ------------------------------------------------------------
> ------------------------------------------
> 2015-03-31 05:40:50.388 | Could not find any downloads that satisfy
> the requirement XStatic-Angular-Irdragndrop>=1.0.2.1 (from
> horizon==2015.1.dev110)
> 2015-03-31 05:40:50.388 | Some externally hosted files were ignored as
> access to them may be unreliable (use --allow-external
> XStatic-Angular-Irdragndrop to allow).
> 2015-03-31 05:40:50.704 | No distributions at all found for
> XStatic-Angular-Irdragndrop>=1.0.2.1 (from horizon==2015.1.dev110)
> ------------------------------------------------------------
> --------------------------------------
>
> and this bug is also logged at redhat
> https://bugzilla.redhat.com/show_bug.cgi?id=1196957
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/horizon/+bug/1438543/+subscriptions
>

Serg Melikyan (smelikyan) wrote :

Hi Folks,

This issue is blocking all gates that are using Horizon (essentially all dsvm gates), including Murano gates:
https://review.openstack.org/167701

Changed in horizon:
status: New → Confirmed
Serg Melikyan (smelikyan) wrote :

I found this in devstack installation log:
2015-03-31 08:10:31.055 | Collecting XStatic-Angular-Irdragndrop>=1.0.2.1 (from horizon==2015.1.dev110)
2015-03-31 08:10:31.072 | HTTP error 404 while getting http://pypi.IAD.openstack.org/packages/source/X/XStatic-Angular-Irdragndrop/XStatic-Angular-Irdragndrop-1.0.2.1.tar.gz#md5=7f57941bb72f83fe01875152ddb24ce1 (from http://pypi.IAD.openstack.org/simple/xstatic-angular-irdragndrop/)

Sam Wan (sam-wan) wrote :

Hi,

  I found at least below files need to change (Openstack CI)
--------------------------------------------------------
 /opt/stack/new/horizon/horizon/templates/horizon/_scripts.html
 /opt/stack/new/horizon/requirements.txt
 /opt/stack/new/horizon/openstack_dashboard/static_settings.py
/opt/stack/new/horizon/horizon/templates/horizon/_scripts.html
 /opt/stack/new/horizon/horizon/templates/horizon/jasmine/jasmine.html
-------------------------------------------------------
  I use below command to change them all
---------------------------------------------------------
find /opt/stack/new/horizon -type f -print|xargs -i sudo sed -i 's/irdragndrop/lrdragndrop/ig' {} &>/dev/null
----------------------------------------------------------
  And this works for me.
 Hope it helps.

Rob Cresswell (robcresswell) wrote :
Changed in horizon:
importance: Undecided → High
importance: High → Critical
assignee: nobody → Rob Cresswell (robcresswell)
Rob Cresswell (robcresswell) wrote :

Assigning myself temporarily. Feel free to reassign.

The failures are due to a package rename on pypi. The rename was due to an incorrect name in the first place - now that it's been corrected, https://review.openstack.org/169132 and https://review.openstack.org/169133 are in flight to fix it within OpenStack.

Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/169133
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=4623b448559c814711de3aa814db09540994da63
Submitter: Jenkins
Branch: master

commit 4623b448559c814711de3aa814db09540994da63
Author: Thai Tran <email address hidden>
Date: Mon Mar 30 18:41:47 2015 -0700

    Updated incorrect name for angular lrdragndrop

    Updated incorrect package name.
    Currently blocking packager from uploading due to incorrect name.

    Depends-On: I808b34a9d13a16d82968904dd44515f3d67f0fde
    Closes-Bug: 1438543
    Change-Id: Iecf00771f42b2eb76a9ff790b2ad857cf3cdc809

Changed in horizon:
status: In Progress → Fix Committed
Akihiro Motoki (amotoki) on 2015-04-09
Changed in horizon:
milestone: none → kilo-rc1
Thierry Carrez (ttx) on 2015-04-14
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-04-30
Changed in horizon:
milestone: kilo-rc1 → 2015.1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.