Install the calendar app by default

Bug #1418986 reported by Pat McGowan on 2015-02-06
126
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alan Pope 🍺🐧🐱 🦄
click-sync
Undecided
Łukasz Zemczak

Bug Description

Updated list of dependencies 12/11

See https://launchpad.net/ubuntu-calendar-app/+milestone/0.5

Fixed:
Bug #1339016 Initial sync of calendar takes a prohibitive amount of time
Bug #1445586 Failed sync of Google calendar
Bug #1347836 Events saved to Birthdays do not appear in the timeline
Bug #1445577 Edit of reminder vaults event time back x hours
Bug #1474078 Provide a way to disable notifications for calendar events
Bug #1438946 All day events are stored to previous day

In progress:
Bug #1309042 Calendar sync only syncs the default calendar

To do:
Bug #1440111 Reminder notifications are not integrated into system notifications

Use buteo

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww09-2015
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
Changed in canonical-devices-system-image:
milestone: ww09-2015 → ww13-2015
Pat McGowan (pat-mcgowan) wrote :

Any idea on an eta to revisit this?

Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → Alan Pope  (popey)
assignee: Alan Pope  (popey) → Pat McGowan (pat-mcgowan)
milestone: ww13-2015 → ww17-2015

Given bug #1339016 has landed in RTM and vivid, I'm +1 for this anytime. I understood we were blocking on sync which seems to have improved. Any reason not to land this?

QA tested and failed the app due to sync issues.

https://trello.com/c/SVRoYQIh/1397-calendar-app-popey

Changed in canonical-devices-system-image:
milestone: ww17-2015 → ww21-2015

Imho there are still to many bugs in basic functionality to include this app by default.

For example:
https://bugs.launchpad.net/ubuntu-calendar-app/+bug/1437305
https://bugs.launchpad.net/ubuntu-calendar-app/+bug/1311165

Sorry forgot one very important bug.

https://bugs.launchpad.net/ubuntu-calendar-app/+bug/1309042
(affects 26 people as of today)

That is a big problem. I consider a calendar a crucial part of a
smartphone... I'd hate to see people miss appointments because the calendar
app screwed up. This should really become a priority...

2015-05-13 11:06 GMT+02:00 Alexander Dobetsberger <
<email address hidden>>:

> Sorry forgot one very important bug.
>
> https://bugs.launchpad.net/ubuntu-calendar-app/+bug/1309042
> (affects 26 people as of today)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1444278).
> https://bugs.launchpad.net/bugs/1418986
>
> Title:
> Install the calendar app by default
>
> Status in the base for Ubuntu mobile products:
> Confirmed
> Status in sync click packages:
> New
>
> Bug description:
> Once bug #1339016 is fixed we will consider adding calendar app to the
> image by default.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1418986/+subscriptions
>

I completely agree with Merlijn here.
I know three people who have bought the ubuntu phone but can't use it on a daily basis because the calendar app is buggy or has missing core functionality.

Also sadly there seems to be very little developement happening in the calendar app.
This is a crucial app for nearly every smartphone user and we should get is in a usable state asap.

Pat McGowan (pat-mcgowan) wrote :

Any eta on the set of fixes we need?

Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → Alan Pope  (popey)
milestone: ww21-2015 → ww28-2015
Pat McGowan (pat-mcgowan) wrote :

These bug fixes are required:

Bug #1347836 Events saved to Birthdays do not appear in the timeline
Bug #1445586 Failed sync of Google calendar
Bug #1445577 Edit of reminder vaults event time back x hours
Bug #1309042 Calendar sync only syncs the default calendar

Changed in canonical-devices-system-image:
milestone: ww28-2015 → ww34-2015

https://bugs.launchpad.net/ubuntu-calendar-app/+bug/1440111

This also seems like a very important bug: Calendar reminders do not appear in the notification menu. They act like an alarm...

description: updated
tags: added: lt-category-visible
Changed in click-sync:
assignee: nobody → Łukasz Zemczak (sil2100)
description: updated
Bill Filler (bfiller) on 2015-08-19
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
description: updated
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
description: updated
description: updated
Changed in canonical-devices-system-image:
milestone: ww02-2016 → ww08-2016
tags: added: lt-important
removed: lt-category-visible
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
description: updated
Changed in click-sync:
status: New → Fix Released
description: updated
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers