[calendar] Reminder notifications are not integrated into system notifications

Bug #1440111 reported by Guillaume F on 2015-04-03
272
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu Calendar App
High
Renato Araujo Oliveira Filho
Ubuntu UX
Medium
James Mulholland
indicator-datetime (Ubuntu)
High
Renato Araujo Oliveira Filho

Bug Description

The calendar app does not use the standard notification system. You can't find it in the "Notifications" area of System Settings, and it uses its own notification sound regardless of what is set in "Sound".

Also, reminders are not muted when the phone is in silent mode (I guess it's related).

I'm on bq Aquaris, r20 and with the latest calendar-app.

--- --- --- ---
UX Comment:

Calendar Notifications need to be overhauled:
-- Calendar Notifications are displayed for too brief a period and should conform to the same timing as other notifications.

-- Calendar Notifications are not currently appearing in the notification tray within indicators and should be.

-- Calendar Notification title is misleading ('Alarm') and should make clear that the notification relates to a calendar event ('Event') and not a alarm-clock event.

-- Calendar Notification's should NOT override silent mode (unlike clock-alarms) although the notification should still be displayed, appear in the notification within indicators and cause the device to vibrate (if enabled) - This is accepted/common behaviour for notifications of this type on mobile.

Notifications Spec: https://docs.google.com/document/d/1xDSZ_dnAMAlhgFnnyjJEibaITXjVLp1_pnj_tATNm9I/edit

Related branches

Javier Garcia (jgcalle) wrote :

I set an one event reminder, then, at time, the reminder shows for a short time (with two sounds), then disappear (I don't accept anything) without no note on the notification system.

I am using my Aquaris 4.5 with Ubuntu 14.10 r20, calendar 0.4.600.

Sebastien Bacher (seb128) wrote :

That doesn't seem to be an indicator issue, rather one in the calendar application

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Critical
importance: Critical → Low
status: New → Invalid
Guillaume F (marsguo) wrote :

I should add that in some cases, it can be problematic. There is another bug in the calendar-app, in which all events trigger alarms at the time of the event even though no reminder was set in Google (haven't tried with local calendar). This means that you have no control over the alarms and should you be some place where muting your phone is required, you have no way of doing so…

themeles (themeles) wrote :

I have the same problem as Javier does. I just miss the reminders because, they show up for very little time and afterwards disapear forever.

Also there is no text notification on what event was triggered.
There just is a sound.

I was wondering for a few minuten why my phone played a sound and did not show any information.

Changed in ubuntu-calendar-app:
status: New → Confirmed

Is anyone working on this or can one help you with this?
Can you provide some link to the files which to be fixed.

At the moment I can only switch off my phone if I am in an environment, in which my phone should be muted.

Florent V. (spangenhelm) wrote :

Hi, the reminder should effectively trigger phone's notifications instead of its little tooltip that only shows for a few seconds (with no sound at all on mine, i am in quiet mode so i think this is normal) it seems like none of the developpers has ever really used it, otherwise they would have figure out that this is a really big issue when you count of the notifications to tell you that you have an appointment going on !

This working fine and the possibility to sync the cal via Caldav would make it a really good app so please do something !!!
Thank you

themeles (themeles) wrote :

Could a possible fix work via the alarm clock? Like the Timer app https://launchpad.net/timer does.

Johannes Kempf (johanneskempf) wrote :

I'm using Aquaris with 15.04 (r23).
-> The calendar's reminders are muted when the phone is running in silent-mode. Nevertheless the phone is vibrating regardless of the system-settings for vibration in silent-mode.
-> The reminder should display the tooltip for at least 15 seconds or until the user confirms the message. If no user interaction happens a notification should be added to the list of the "notification" indicator.

I would say this is a big issue. When you ask the calendar to display a reminder, it doesn't appear in the notifications menu. It only shows as an alarm that goes off. This renders the reminder functionality of the calendar (the most important feature of a calendar to me) almost useless...

Pat McGowan (pat-mcgowan) wrote :

AFAIK the indicator service triggers the event, calendar app is not necessarily running
Need design to weigh in

Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Low → Wishlist
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
summary: - Reminder notifications are not integrated into system notifications
+ [calendar] Reminder notifications are not integrated into system
+ notifications
Changed in ubuntu-ux:
status: New → Triaged
assignee: nobody → James Mulholland (jamesjosephmulholland)
importance: Undecided → High
importance: High → Medium
maarten klop (mjdklop) wrote :

Also there is no way to stop the snoozing feature. Every 5 minutes it will ring, there is no way to stop it. For me it also rings on events with no notifications set, which are imported from google calendar, and i've sometimes woken up from repeating reminders in the middle of the night. Not a very cool 'feature'. Also I still didn't know what the reminder was for.

MX4 15.04 r3 cal0.4.688.1

description: updated
Changed in ubuntu-ux:
status: Triaged → Fix Committed
Matthew Paul Thomas (mpt) wrote :

The first problem cited here, that Calendar doesn't show up in the Notifications area of System Settings, is bug 1474078.

Pat McGowan (pat-mcgowan) wrote :
Pat McGowan (pat-mcgowan) wrote :

lets make a plan for this and the related bugs

Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
milestone: none → backlog
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: backlog → ww08-2016
Jamie Strandboge (jdstrand) wrote :

I'm plagued with calendar event sounds due to bug #1533681. Obviously, that bug should be fixed on its own, however it got me thinking about event notifications. A couple of ideas from IRC to throw into the mix:

07:57 < jdstrand> more constructively, I think being able to choose if event notifications should sound or not and having event notifications show up in the notifications area would be great (if the event sounds are on, perhaps only show missed events there, otherwise
07:59 < davmor2> jdstrand: I think the solution is in the indicator have silent mode, night mode and holiday mode. and then have the settings for those be adjustable in sounds in the settings app to suit the indiviuals
08:01 < jdstrand> davmor2: you are talking about the notifications indicator? yes, that would be nice because making it silent wouldn't prevent incoming call sounds.

If changing notifications indicator sounds, I wonder if would/should quiet incoming texts...

Jamie Strandboge (jdstrand) wrote :

Erf, mispaste of IRC conversation:

07:57 < jdstrand> more constructively, I think being able to choose if event notifications should sound or not and having event notifications show up in the notifications area would be great (if the event sounds are on, perhaps only show missed events there, otherwise show each notification plus missed)
07:59 < davmor2> jdstrand: I think the solution is in the indicator have silent mode, night mode and holiday mode. and then have the settings for those be adjustable in sounds in the settings app to suit the indiviuals
08:01 < jdstrand> davmor2: you are talking about the notifications indicator? yes, that would be nice because making it silent wouldn't prevent incoming call sounds.

David Barth (dbarth) on 2016-01-25
Changed in indicator-datetime (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-calendar-app:
status: Confirmed → Fix Committed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress

Thanks for doing this! I've been waiting a long time for this fix! Thank
you so much!

2016-01-25 10:51 GMT+01:00 David Barth <email address hidden>:

> ** Changed in: indicator-datetime (Ubuntu)
> Status: Confirmed => In Progress
>
> ** Changed in: ubuntu-calendar-app
> Status: Confirmed => Fix Committed
>
> ** Changed in: canonical-devices-system-image
> Status: Confirmed => In Progress
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1440111
>
> Title:
> [calendar] Reminder notifications are not integrated into system
> notifications
>
> Status in Canonical System Image:
> In Progress
> Status in Ubuntu Calendar App:
> Fix Committed
> Status in Ubuntu UX:
> Fix Committed
> Status in indicator-datetime package in Ubuntu:
> In Progress
>
> Bug description:
> The calendar app does not use the standard notification system. You
> can't find it in the "Notifications" area of System Settings, and it
> uses its own notification sound regardless of what is set in "Sound".
>
> Also, reminders are not muted when the phone is in silent mode (I
> guess it's related).
>
> I'm on bq Aquaris, r20 and with the latest calendar-app.
>
> --- --- --- ---
> UX Comment:
>
> Calendar Notifications need to be overhauled:
> -- Calendar Notifications are displayed for too brief a period and
> should conform to the same timing as other notifications.
>
> -- Calendar Notifications are not currently appearing in the
> notification tray within indicators and should be.
>
> -- Calendar Notification title is misleading ('Alarm') and should make
> clear that the notification relates to a calendar event ('Event') and
> not a alarm-clock event.
>
> -- Calendar Notification's should NOT override silent mode (unlike
> clock-alarms) although the notification should still be displayed,
> appear in the notification within indicators and cause the device to
> vibrate (if enabled) - This is accepted/common behaviour for
> notifications of this type on mobile.
>
> Notifications Spec:
>
> https://docs.google.com/document/d/1xDSZ_dnAMAlhgFnnyjJEibaITXjVLp1_pnj_tATNm9I/edit
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1440111/+subscriptions
>

Matthew Paul Thomas (mpt) wrote :

I clarified with James that by "notification tray" he meant the list of notifications that appears when you swipe down from "Notifications". He was not referring to the indicator itself.

Charles Kerr (charlesk) wrote :

Some of this is doable for OTA10, and some is not, so we may want to split this workload into two tickets.

OTA 10:
* Calendar notifications should not override silent mode
* Clock alarms should override silent mode
* Calendar notifications' title and icon can be changed to not denote alarms

post-OTA 10:
> Calendar notifications are not currently appearing in the notification tray within indicators and should be.
This is going to require significant work on the notification center)

Need clarification:
> Calendar Notifications are displayed for too brief a period and should conform to the same timing as other notifications.
I believe calendar notifications last for 5 seconds the same as other notifications, so clarification on this request would be helpful for me.

Paty Davila (dizzypaty) wrote :

@charlesk - In the new notifications doc is specified that if the user does not take an action on a notification appearing "in normal use", the bubble will disappear smoothly after a timeout of 3 seconds. This should apply to calendar notifications as well as any other notification bubble appearing in the screen when the phone is being used.

Daniel Frost (k-one) wrote :

@charlesk - post from 2016-02-04
Uhm, I hope you don't mind the question, but why should clock alarms override silent mode?
I did actually file this behavior as a bug (https://bugs.launchpad.net/ubuntu-clock-app/+bug/1542889).
Silent mode should be silent regardless of the action coming up. Or maybe you should be able to choose which actions are allowed to override silent mode?

If we would be able to choose which notifications could override silent
mode, that would be great.

On Wednesday, 10 February 2016, Daniel Frost <email address hidden> wrote:
> @charlesk - post from 2016-02-04
> Uhm, I hope you don't mind the question, but why should clock alarms
override silent mode?
> I did actually file this behavior as a bug (
https://bugs.launchpad.net/ubuntu-clock-app/+bug/1542889).
> Silent mode should be silent regardless of the action coming up. Or maybe
you should be able to choose which actions are allowed to override silent
mode?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1463936).
> https://bugs.launchpad.net/bugs/1440111
>
> Title:
> [calendar] Reminder notifications are not integrated into system
> notifications
>
> Status in Canonical System Image:
> In Progress
> Status in Ubuntu Calendar App:
> Fix Committed
> Status in Ubuntu UX:
> Fix Committed
> Status in indicator-datetime package in Ubuntu:
> In Progress
>
> Bug description:
> The calendar app does not use the standard notification system. You
> can't find it in the "Notifications" area of System Settings, and it
> uses its own notification sound regardless of what is set in "Sound".
>
> Also, reminders are not muted when the phone is in silent mode (I
> guess it's related).
>
> I'm on bq Aquaris, r20 and with the latest calendar-app.
>
> --- --- --- ---
> UX Comment:
>
> Calendar Notifications need to be overhauled:
> -- Calendar Notifications are displayed for too brief a period and
should conform to the same timing as other notifications.
>
> -- Calendar Notifications are not currently appearing in the
> notification tray within indicators and should be.
>
> -- Calendar Notification title is misleading ('Alarm') and should make
> clear that the notification relates to a calendar event ('Event') and
> not a alarm-clock event.
>
> -- Calendar Notification's should NOT override silent mode (unlike
> clock-alarms) although the notification should still be displayed,
> appear in the notification within indicators and cause the device to
> vibrate (if enabled) - This is accepted/common behaviour for
> notifications of this type on mobile.
>
> Notifications Spec:
>
https://docs.google.com/document/d/1xDSZ_dnAMAlhgFnnyjJEibaITXjVLp1_pnj_tATNm9I/edit
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1440111/+subscriptions
>

Download full text (4.7 KiB)

Clock alarms overriding silent mode is default behavior in most phones.
That in itself seems like a good idea to keep that behavior.

2016-02-10 14:37 GMT+01:00 Jos van Houtem <email address hidden>:

> If we would be able to choose which notifications could override silent
> mode, that would be great.
>
> On Wednesday, 10 February 2016, Daniel Frost <email address hidden> wrote:
> > @charlesk - post from 2016-02-04
> > Uhm, I hope you don't mind the question, but why should clock alarms
> override silent mode?
> > I did actually file this behavior as a bug (
> https://bugs.launchpad.net/ubuntu-clock-app/+bug/1542889).
> > Silent mode should be silent regardless of the action coming up. Or maybe
> you should be able to choose which actions are allowed to override silent
> mode?
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1463936).
> > https://bugs.launchpad.net/bugs/1440111
> >
> > Title:
> > [calendar] Reminder notifications are not integrated into system
> > notifications
> >
> > Status in Canonical System Image:
> > In Progress
> > Status in Ubuntu Calendar App:
> > Fix Committed
> > Status in Ubuntu UX:
> > Fix Committed
> > Status in indicator-datetime package in Ubuntu:
> > In Progress
> >
> > Bug description:
> > The calendar app does not use the standard notification system. You
> > can't find it in the "Notifications" area of System Settings, and it
> > uses its own notification sound regardless of what is set in "Sound".
> >
> > Also, reminders are not muted when the phone is in silent mode (I
> > guess it's related).
> >
> > I'm on bq Aquaris, r20 and with the latest calendar-app.
> >
> > --- --- --- ---
> > UX Comment:
> >
> > Calendar Notifications need to be overhauled:
> > -- Calendar Notifications are displayed for too brief a period and
> should conform to the same timing as other notifications.
> >
> > -- Calendar Notifications are not currently appearing in the
> > notification tray within indicators and should be.
> >
> > -- Calendar Notification title is misleading ('Alarm') and should make
> > clear that the notification relates to a calendar event ('Event') and
> > not a alarm-clock event.
> >
> > -- Calendar Notification's should NOT override silent mode (unlike
> > clock-alarms) although the notification should still be displayed,
> > appear in the notification within indicators and cause the device to
> > vibrate (if enabled) - This is accepted/common behaviour for
> > notifications of this type on mobile.
> >
> > Notifications Spec:
> >
>
> https://docs.google.com/document/d/1xDSZ_dnAMAlhgFnnyjJEibaITXjVLp1_pnj_tATNm9I/edit
> >
> > To manage notifications about this bug go to:
> >
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1440111/+subscriptions
> >
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1440111
>
> Title:
> [calendar] Reminder notifications are not integrated into system
> notifications
>
> Status in Canonical System Image:
> In Progress
> Status in Ubuntu Calendar App:
> Fix Committed
> ...

Read more...

Fix committed into lp:ubuntu-calendar-app at revision None, scheduled for release in ubuntu-calendar-app, milestone rtm14

Changed in ubuntu-calendar-app:
importance: Undecided → Medium
assignee: nobody → David Barth (dbarth)
milestone: none → 0.5
Pat McGowan (pat-mcgowan) wrote :

partial fix as described, carry forward

Changed in canonical-devices-system-image:
milestone: ww08-2016 → 11
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
milestone: 11 → backlog
Bill Filler (bfiller) wrote :

Renato has been working on this. In silo 9.

Changed in canonical-devices-system-image:
milestone: backlog → 11
assignee: Alejandro J. Cura (alecu) → Bill Filler (bfiller)
Changed in ubuntu-calendar-app:
assignee: David Barth (dbarth) → Renato Araujo Oliveira Filho (renatofilho)
status: Fix Released → In Progress
Changed in indicator-datetime (Ubuntu):
importance: Wishlist → High
Changed in ubuntu-calendar-app:
importance: Medium → High
Changed in indicator-datetime (Ubuntu):
assignee: Charles Kerr (charlesk) → Renato Araujo Oliveira Filho (renatofilho)
Bill Filler (bfiller) on 2016-04-26
Changed in ubuntu-calendar-app:
milestone: 0.5 → 0.6
Bill Filler (bfiller) wrote :

fyi, what we've implemented for now is the following (in silo 9):
- calendar notifications will vibrate, instead of playing a sound by default. Calendar notifications can be disabled in Settings->Notifications
- calendar notifications will not be displayed for events that you're marked as "Not Attending" (i.e. after google calendar sync)
- calendar notifications will show up in the Notifications menu in case you miss then
- calendar events will remain in the date/time indicator for the duration of the event and not disappear immediately after the event occurs like they current do

After this land, the next step is we plan to implement the extended Notifications panel in System Settings:
https://wiki.ubuntu.com/Notification

This will allow user to choose sound, vibrate, notification bubbles, etc on a per app basis to control notifcations. Once that panel is done we'll cut over Calendar notifications to use it, in conjunction with the work Charles and his team are doing on the notification backend.

Jamie Strandboge (jdstrand) wrote :

@Bill, curious how this relates (if at all) to bug #1533681 (imported google calendar events sound when they shouldn't)?

> On Apr 26, 2016, at 6:36 PM, Jamie Strandboge <email address hidden> wrote:
>
> @Bill, curious how this relates (if at all) to bug #1533681 (imported
> google calendar events sound when they shouldn't)?

That bug is in process of being fixed as well. If the Google event was set for a pop-up notification and you are marked as attending,maybe, or no reply you will get a notification with vibration on the phone (if notifications are turned on for the calendar app). If the Google event is set for no notification you will not get any notification on the phone. You will never get any sound for any calendar events when the proposed changes land, just vibration. Sound will be an option once the extended notification settings work gets done but the above rules will apply still.

>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: ubuntu-calendar-app
> https://bugs.launchpad.net/bugs/1440111
>
> Title:
> [calendar] Reminder notifications are not integrated into system
> notifications
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1440111/+subscriptions

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in indicator-datetime (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Vincas Dargis (talkless) wrote :

>Sound will be an option once the extended notification settings work gets done

Is there a task I could follow? Integration is much better now, but without noisy alarm, I still missed my task...

Bill Filler (bfiller) wrote :

https://bugs.launchpad.net/bugs/1584102

On Jun 7, 2016, at 3:01 PM, Vincas Dargis <email address hidden> wrote:

>> Sound will be an option once the extended notification settings work
> gets done
>
> Is there a task I could follow? Integration is much better now, but
> without noisy alarm, I still missed my task...
>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: ubuntu-calendar-app
> https://bugs.launchpad.net/bugs/1440111
>
> Title:
> [calendar] Reminder notifications are not integrated into system
> notifications
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1440111/+subscriptions

Johannes Kempf (johanneskempf) wrote :

I like the functionality of the new notifications, but the usage of the icons is wrong: see Bug #1591246.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions