Checkbox-gtk still uses the pre-2010 Ubuntu logo

Bug #554202 reported by wilsonliam on 2010-04-02
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Checkbox
Low
Unassigned
ubuntu-branding
Undecided
Unassigned
checkbox (Ubuntu)
Low
Unassigned

Bug Description

Nothing major, just with Ubuntu being re-branded as of 10.04, Checkbox still uses the old Ubuntu logo.

Related branches

wilsonliam (wilsonliam) wrote :
David Murphy (schwuk) wrote :

A completely valid bug report, although I'm not sure we should just fix it without some discussion about branding.

Checkbox is known as "System Testing" in the menus, and has it's own icon, yet the logo/header referred to in this bug is "Ubuntu Hardware Database".

I would suggest that we change the logo to be System Testing, which in turn would address the issue of the artwork being out of date.

Changed in checkbox:
status: New → Incomplete
Marc Tardif (cr3) wrote :

I would refrain from having text in an image in order to support internationalization.

Marc Tardif (cr3) wrote :

For the sake of completeness, here are a few other header images sent to me by David Bensimon.

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
David Murphy (schwuk) wrote :

Some of the attached images include text ("Hardware Database"). I'm also not sure we can alter the Ubuntu 'title' with shadows etc.

If we're including the Ubuntu logo/text, it should be stock. However I think we should use the checkbox icon and perhaps a styled GTK label for the title to support i18n/l10n (since "System Testing" should already be translated in the menu items). Additionally, this would allow us to alter the header for Checkbox variants.

komputes (komputes) wrote :

Please note that the designs above are simply mock-ups. They were made with screenshots of the logo. I have asked the design team to provide me with svg files and fonts for the new look.

Changed in checkbox:
assignee: nobody → David Bensimon (davidbensimon)
status: Incomplete → Confirmed
Marc Tardif (cr3) wrote :

Here is another logo proposed by Kenneth Wimer.

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
David Murphy (schwuk) wrote :

Like it.

Changed in checkbox (Ubuntu):
importance: Undecided → Low
status: New → Triaged

This is still valid. Should probably be addressed. Removed David as assignee as it hasn't been touched since last year (except for being set to triaged by Andrew, above)

Changed in checkbox:
importance: Undecided → Low
assignee: David Bensimon (davidbensimon) → nobody
Daniel Manrique (roadmr) wrote :

There's now code in gtk_interface.py to dynamically render text over the image, thus we can include text that can be translated (e.g. "hardware database", see bug 621880) , the code needs to be modified to place, color and size the text.

However this would enable us to have a background image with whichever logo is needed, all text can be overlaid, and potentially translated.

The "ubuntu" text I'm not sure about, I don't think it should be translated.

Paul Sladen (sladen) on 2011-07-04
Changed in ubuntu-branding:
status: New → In Progress
Paul Sladen (sladen) wrote :

Hello all, Ara just pinged me about this. I'll try and run this past Marcus Haslam, but the SVG done by Kenneth in comment #15 looks good to me. Are you happy with just the logo, or do you still want the text "hardware database" (which has localisation issues) included in the image?

David re: comment #10. Yes, you're correct, applying shadowing/alterations to the text or logo itself are not allowed by the brand guidelines:

  http://design.canonical.com/the-toolkit/ubuntu-brand-guidelines/

Ara Pulido (ara) wrote :

Without the string would be better, as we have fix that now to be translatable.

I modified slightly Ken's design to be able to fit the text when checkbox is running.

I am attaching the .svg and .png

I will create a branch that adds .svg to the code, to make future changes easier.

Ara Pulido (ara) wrote :

Paul,

Re the 'hardware database' text, in the current version of checkbox this is translated 'on the fly' (the image contains no text and the string is translated and then drawn on using Cairo)

Daniel Manrique (roadmr) wrote :

in checkbox_gtk/gtk_interface.py, near the bottom, this call positions the text:

#Position to render text
cairo_drawing_context.move_to(100,45)

I find that changing the X position from 100 to 55 makes the end of the "hardware database" string align nicely with the end of the large "Ubuntu" on top of it.

However this obviously only works in english and with that particular string. If the string is going to change and/or be translated, the text will probably be moving all over the place, so going to a lot of trouble to align it might not be worth it.

Paul Sladen (sladen) wrote :

Thanks to Haw Loeung for pointing out that the actual image is at:

  /usr/share/checkbox/data/images/JPEG_Color_Image_Ubuntu.jpg.

summary: - Checkbox still uses the old ubuntu logo.
+ Checkbox-gtk still uses the pre-2010 Ubuntu logo
Haw Loeung (hloeung) wrote :

Also, the main logo that the application uses:

/usr/share/checkbox/gtk/checkbox-gtk-head.png

And some other images for the tests:

/usr/share/checkbox/data/images/PNG_Color_Image_Ubuntu.png
/usr/share/checkbox/data/websites/PNG_Color_Image_Ubuntu.png

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.12.4

---------------
checkbox (0.12.4) oneiric; urgency=low

  New upstream release (LP: #824180):

  [Brendan Donegan]
  * Refactored job definition files.
  * Fixed dependencies and test naming.
  * Added Online CPU before/after suspend test.
  * Automated wireless tests.
  * Removed redundant sru_suite.txt, updated dependencies accordingly.
  * Automated bluetooth_obex tests.

  [Daniel Manrique]
  * Further improvements to make frontend/backend communication more reliable.
    Prevents stuck backends, failure to close the GUI due to lack of reply
    from the backend, and test specifying "user" not being run.
  * scripts/keyboard_test modified to account for pygi-related GTK API
    changes. (LP: #804369)
  * scripts/sleep_test: improve handling of NetworkManager DBus API
    changes. (LP: #808423)
  * scripts/cdimage_resource: properly handle releases with "LTS" in their
    name (LP: #814085)
  * Updated minimum_resolution test as per latest system requirements, leaving
    just one unified test. (LP: #767166)

  [Javier Collado]
  * Checkbox exits with EX_NOINPUT if a whitelist or blacklist file is
    specified and cannot be found.
  * Deselect a test suite automatically when none of its children is selected,
    in the GTK interface. (LP: #651878)
  * Make the "Next" button the default action when Enter is pressed, to
    streamline testing with the GTK interface.

  [Marc Tardif]
  * Fixed udevam not being found because /sbin not in PATH (LP: #597305)
  * Fixed hardware attachments for udev and dmi (LP: #822682)

  [Sylvain Pineau]
  * Expose the message store to other plugins, via firing an expose-msgstore
    event.

  [Andrew Faulkner]
  * Fix description for nautilus_file_create job (LP: #821141)

  [Kenneth Wimer]
  * New header image that follows brand guidelines (LP: #554202)
 -- Daniel Manrique <email address hidden> Wed, 10 Aug 2011 15:16:39 -0400

Changed in checkbox (Ubuntu):
status: Triaged → Fix Released
Daniel Manrique (roadmr) on 2012-03-31
Changed in checkbox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers