Bazaar Version Control System

bzr+ssh to Launchpad fails with "Agent admitted failure to sign using the key."

Reported by David on 2009-11-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned
Launchpad itself
Undecided
Unassigned

Bug Description

I have registered a ssh key with Launchpad, and given Bazaar my launchpad username with the command "bzr launchpad-login davidboy". Then tried to download the software-center source with the command "bzr branch lp:software-center". It fails and says:
"Agent admitted failure to sign using the key.
Permission denied (publickey).
bzr: ERROR: Connection closed: Unexpected end of message. Please check connectivity and permissions, and report a bug if problems persist."

David (davidboy) wrote :
description: updated
David (davidboy) wrote :

Just tried it as sudo. Still didn't work.

David (davidboy) on 2009-11-25
summary: - Cannot download code from Launchpad
+ Cannot download software-center code from Launchpad using bazaar

Does SSH public key auth to other hosts work? What if you try "ssh
<email address hidden>" without going through Bazaar?

Googling the error message, this sounds like bug #328127, which is not a bug in Bazaar or Launchpad.

affects: launchpad → launchpad-code
Changed in launchpad-code:
status: New → Incomplete
Changed in bzr:
status: New → Incomplete
David (davidboy) wrote :

"ssh <email address hidden>" returns "No shells on this server. Connection to bazaar.launchpad.net closed." I'll try it with my server either tonight or tomorrow.

David (davidboy) wrote :

Tried it in verbose mode and got:
OpenSSH_5.1p1 Debian-6ubuntu2, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to bazaar.launchpad.net [91.189.90.11] port 22.
debug1: Connection established.
debug1: identity file /home/david/.ssh/identity type -1
debug1: identity file /home/david/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file /home/david/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version Twisted
debug1: no match: Twisted
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-6ubuntu2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: sending SSH2_MSG_KEXDH_INIT
debug1: expecting SSH2_MSG_KEXDH_REPLY
debug1: Host 'bazaar.launchpad.net' is known and matches the RSA host key.
debug1: Found key in /home/david/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /home/david/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 277
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
No shells on this server.
debug1: channel 0: free: client-session, nchannels 1
Connection to bazaar.launchpad.net closed.
Transferred: sent 2472, received 1400 bytes, in 0.2 seconds
Bytes per second: sent 10931.0, received 6190.7
debug1: Exit status -1

OK, so SSH run alone seems to be working.

What happens if you try

 unset SSH_AUTH_SOCK

and then run bzr?

--
Martin <http://launchpad.net/~mbp/>

Martin Pool (mbp) wrote :

This does seem to be a dupe of bug 328127. Thanks for finding it.

summary: - Cannot download software-center code from Launchpad using bazaar
+ bzr+ssh to Launchpad fails with "Agent admitted failure to sign using
+ the key."
Martin Pool (mbp) wrote :

... it would be interesting to know why you get this when bzr runs ssh, but not when you run ssh directly. Are you running them from the exact same shell? Is the ssh command printed into ~/.bzr.log, and if so what is it?

Vincent Ladeuil (vila) wrote :

David finally said it worked (https://bugs.edge.launchpad.net/bzr/+bug/488296/comments/7).

It seems that lp send the mail regarding this bug in a strange order (at least not the one displayed here) letting martin comment without noticing that ?

Changed in bzr:
status: Incomplete → Invalid
Changed in launchpad-code:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments