[RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)

Bug #305301 reported by gene on 2008-12-04
148
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Bugzilla
Confirmed
Undecided
Unassigned
Linux
Expired
Medium
X.Org X server
Fix Released
High
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-radeon

Since I upgraded to 8.10 from 8.04 the machine does not resume from suspend.
1) Depending on the tools it behaves the following way: when using usual (gnome) suspend, when trying to resume it turns on and off with a blank screen. When using pm-utils, it turns on but the screen is blank. In all of these cases, the system is irresponsive and requires a hard reboot (held down power button). Sometimes the system just restarts (reboots) on its own after one attempt.
2) There is also one more problem with the X that is conected. Occasionally, when booting the system before getting the login window the system hangs with the blank screen. It also remains totally irresponsive with no Magic Keys working.

The reason why I think the issue is related to "radeon" driver is the following. I've had a lot of problems be with the ATI/AMD proprietary fglrx driver (no dual head support, no xvid etc). However, when I upgraded to 8.10 I found the fglrx in use. Again, the performance was not good either (bad xv support and slow). But I could resume from suspend OK and do not remember any crashes when booting. I removed it and started using "radeon" driver. The performance was better, but I started experiencing the above-mentioned problems. I also tried "ati" driver (not sure if there is difference ) bu with no avail.
Someone found a similar bug a couple months ago and followed the suggested change in the Xorg.conf by trying different values for Option "AGPMode". it didn't work. I also tried hibernate tools. It did similar things. I tried with/without compiz, gives the same problem, as well as with the generic Xorg.conf file. I attach both below
My laptop is Toshiba Satellite l35 with ATI Technologies Inc RC410 [Radeon Xpress 200M].

$uname -a
             2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux
I am attaching some useful files below.
Thanks very much in advance for your help!
[lspci]
00:00.0 Host bridge: ATI Technologies Inc Device 5a31 (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M] [1002:5a62]

gene (eugenios) wrote :
gene (eugenios) wrote :
gene (eugenios) wrote :
gene (eugenios) wrote :
gene (eugenios) wrote :
gene (eugenios) wrote :

Forgot to mention to more things here.
1) the system resumes fom the hibernate without a problem, however
2) occasionally, when waking up from hibernate or booting (when the system gets there and doesn't hang) I see some change in the window decorations. Things appear different from my setting. I go to the gnome appearance menu. It either does not start and complains about gnome-setting-manager or just restarts X and everything look nice. Also when after hibernate I see some colored lines around the window frames, I fix it by the "compiz --replace" command. (But this last one might be just a gnome and/or compiz issue)

gene (eugenios) wrote :

Forgot to mention to more things here.
1) the system resumes from the hibernate without a problem, however
2) occasionally, when waking up from hibernate or booting (when the system gets there and doesn't hang) I see some change in the window decorations. Things appear different from my setting. I go to the gnome appearance menu. It either does not start and complains about gnome-setting-manager or just restarts X and everything look nice. Also when after hibernate I see some colored lines around the window frames, I fix it by the "compiz --replace" command. (But this last one might be just a gnome and/or compiz issue)

gene (eugenios) wrote :

I do not know why this issue does not deserve any attention from the Ubuntu developers.

I found that this problem is escalating now. Because, as I have mentioned earlier, sometimes the system stalls before the graphical login comes up. The ratio of successful logins over failed ones was 3/1, now it seems to be 1/5 and approaches zero as time goes by.

Since this issue is being neglected I am likely not to be able to get here soon...

This might be a very important problem, because it could be tampering with the hardware.

Bryce Harrington (bryce) wrote :

Please isolate whether this is a kernel issue or an X issue by switching to a tty console and running this:

sync; echo 1 > /sys/power/pm_trace; /etc/acpi/sleep.sh force

If you can reproduce the hang using that, then this is really a kernel issue and should be reassigned to linux.

Changed in xserver-xorg-video-ati:
status: New → Incomplete
gene (eugenios) wrote :

Thanks for taking your time to answer.
Yes it does a similar thing. When trying to resume the system (the machine rather, cause it never gets to that level) reboots itself. However, it still concerns the vga driver. Doesn't it? Or the corresponding module in the kernel? Please let me know.

Bryce Harrington (bryce) on 2009-01-17
description: updated
dimitri (dimitri-vanlanduyt) wrote :

The same occurs to me; also Radeon 200M (RC410). After suspending (or hibernating for matter) the machine just returns to a blank screen, none of the Magic Keys (SysRq combinations) work.

I can reproduce this hang with the line presented above, should this bug report be forwarded?

gene (eugenios) wrote :

I switched to fglrx. fglrx is buggier, though.

however, as far as I remember, hibernation worked OK.... not always.

I think, the radeon open source driver developers should be notified about our problem.
I do not know how to do that. Do you?
Thanks

gene (eugenios) wrote :

Having experienced so much trouble with fglrx, decided to give another try to radeon. What bitter surprise. My problem has not been fixed yet. This problem persists. If anyone can give me a link to the radeon driver developers, so that I could notify them about this, I would appreciate.

However, Never never never buy from ati!

gene (eugenios) wrote :

i

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-02-21
Changed in xserver-xorg-video-ati:
status: Confirmed → New
Changed in bugzilla:
status: Unknown → Confirmed

I tried to link this bug to the one I just reported. I did not find how to do that. I do not want it to be a duplicate of the other.
It is https://bugs.launchpad.net/bugs/340152 It concerns jaunty now.

Changed in bugzilla:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
Changed in linux:
status: Unknown → Confirmed
Changed in xorg-server:
status: Unknown → Confirmed
Tormod Volden (tormodvolden) wrote :

It is unclear to me when reading your comments whether this is a problem with any graphics driver or the kernel. Can you please boot with the "text" boot parameter, and log in to the console and run "pm-suspend" ?

A possible related upstream report would be http://bugs.freedesktop.org/show_bug.cgi?id=19581 for radeon.

Also, today the linux-image-generic 2.6.28-11 is released in Jaunty and contains some drm updates. Please try it out.

gene (eugenios) wrote :

I will try that,
Thanks

gene (eugenios) wrote :

booted with the "text" boot parameter and ran "sudo pm-suspend" and was able to successfully resume back two times . However, I tried to reboot to X and ran "pm-suspend" - I failed to resume. Both WITHOUT any X conf file.

I will now try the newest kernel version available. I got 28-10 so far
Thanks

gene (eugenios) wrote :

No resume from suspend with 2.6.28-11-generic kernel

gene (eugenios) wrote :

Forgot to mention: when DRI is on

Changed in xorg-server:
status: Confirmed → Unknown
summary: - [RC410 Xpress 200M] system hangs when resuming from suspend
+ [RC410] Xpress 200M hangs when resuming from suspend with DRI
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in xorg-server:
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Invalid

This happens to me, too. On a fresh Jaunty install with DRI on. I have a Radeon Xpress 200M (RC410), regretfully...

suspending works, returning from suspend makes the machine hang.

Please tell me how I can give more info (which logs, which configfiles)

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :

I would suggest trying out a 2.6.30 kernel, for instance from https://wiki.ubuntu.com/KernelMainlineBuilds and then ping the upstream bug.

Giancaldo (giancaldo) wrote :

I have the exact same problem with an Xpress 200M (RS480). I tried the 2.6.30 kernel but problem persists.

Tormod Volden (tormodvolden) wrote :

Giancaldo, there is a report on RS480 in bug 333377, however the difference there is that disabling DRI does not help. If it helps for you, please attach your Xorg.0.log for reference.

Dimitri (dvanlanduyt) wrote :

Tormod, I just tried the 2.6.30 (Rc3) kernel (linux-image-2.6.30-020630rc3-generic_2.6.30-020630rc3_i386.deb) from that link.
Alas, the problem persists.

Please educate me, which files/logs do I need to provide in order to be informative? To be sure, is "pinging the upstream bug" lingo for adding this information to the Linux Kernel bugzilla, as linked to above? http://bugzilla.kernel.org/show_bug.cgi?id=10258
This is a closed bug, correct?

Tormod Volden (tormodvolden) wrote :

Dimitri, the upstream (kernel bugzilla) bug was closed because of no activity, so it would be nice if you could attach your Xorg.0.log there. If you can attach dmesg output like the original reporter it is also good. Some of the information on https://wiki.ubuntu.com/X/Backtracing might be helpful for you or others trying to debug this.

Tormod Volden (tormodvolden) wrote :

I just realized that the bugzilla.kernel.org bug report was for another chipset, so maybe it is better to file a new bug instead. Anyway, please attach your logs to the bugzilla.freedesktop.org bug, but do the test that cooper suggests there to verify you see the same as Mark.

Darrell Kavanagh (darrell) wrote :

I can confirm that this behaviour persists under kernel 2.6.30rc3.

Giancaldo (giancaldo) wrote :

Actually, my card is an RC410 too so I'll attach my xorg.0.log file here I guess. The PCI bridge is the RS480. Sorry for the confusion.

Giancaldo (giancaldo) wrote :

Sorry, forget the dmesg.txt. I did try to do a backtrace but the net connection couldn't survive the suspend.

Giancaldo (giancaldo) wrote :

attached is dmesg output after the command sync; echo 1 > /sys/power/pm_trace; pm-suspend
I hope that is of some help.

Giancaldo (giancaldo) wrote :

Attached is the Xorg log file of a failed xorg backtrace, if it's of any use.

Tormod Volden (tormodvolden) wrote :

Again, please see https://wiki.ubuntu.com/X/Backtracing which explains how to use "screen" to debug across suspend.

description: updated
Giancaldo (giancaldo) wrote :

i did try backtracing using screen but once ethernet and wifi went down when it entered suspend, I couldn't ssh to it as not even the net connections would resume.

Darrell Kavanagh (darrell) wrote :

Exactly the same here as it was for Giancaldo: backtrace using screen impossible as networking does not return.

I also enabled drm debug during a suspend/attempted-resume cycle. There are no messages in kern.log or syslog from drm after suspend until the machine is hard-rebooted.

Tormod Volden (tormodvolden) wrote :

Oh I see, sure, if not even wired network comes up, the screen trick won't help. If there is nothing written to the logs it could be that the whole bus is frozen and the disk is out of reach. The only trick left would be serial console debugging if you had serial ports, but I guess there are none on your laptops.

(Giancaldo, your Xorg.1.log is from the VESA driver.)

Giancaldo (giancaldo) wrote :

sorry about that, didn't realise it was the VESA driver.

I tried again a few times at backtracing, only once did it resume more or less functioning (after issuing the pm-suspend command only) but gdb for some reason didn't allow me to type any more commands in.

Attached is the message file if it's of any use.

Giancaldo (giancaldo) wrote :

attached is the rom.bin

Tormod Volden (tormodvolden) wrote :

Quite some broken stuff in your messages file, Giancaldo, looks like severe memory corruption on resume. For one thing, how come "Aug 10" shows up in there?

I also see there is some Sysrq calls, does it react to alt-sysrq-S-U-B to reboot? I think Dimitri said above that sysrq does not work.

Can you others please also attach your messages file?

Giancaldo (giancaldo) wrote :

I have no idea why "Aug 10" shows up.

Well I did the altgr-sysrq-k in the hope of rebooting the computer without doing a hard reset.

altgh-sysrq-s-u-b also seems to restart the computer. Sysrq seems to work for me, I also noticed that when i tried to resume after the 'pm-suspend' command, pressing the altgr-sysrq-.... would cause the very top left of the screen to become slightly blue.

Bryce Harrington (bryce) on 2009-05-15
tags: added: freeze
tags: added: resume
Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid
Bryce Harrington (bryce) on 2009-08-14
tags: added: jaunty
Bryce Harrington (bryce) on 2009-08-18
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
summary: - [RC410] Xpress 200M hangs when resuming from suspend with DRI
+ [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs
+ KMS)
87 comments hidden view all 167 comments
Apoorv Parle (apparle) wrote :

I have Radeon Xpress 200 (RC410) on Foxconn RC410MA motherboard
Hibernate works fine
I also cannot resume from suspend. I have checked only with Karmic.
I didn't try building kernels and stuff but would surely try it when I have enough time

Being a desktop user suspend doesn't matter much to me.

Changed in xorg-server:
status: Confirmed → Invalid
Karesz (lengyel-karesz) wrote :

Have this problem got any better with the new 2.6.33 kernel? (It included radeon KMS)

Mark (umberstark) wrote :

Still happening for me (Amilo LI 1718) with the daily live CD (26th).

If I boot with radeon.modeset=0 the desktop won't corrupt and lock up after a few minutes as it does without this option set. But still won't resume the display from suspend or hibernate. Also, using that option results in a garbled login screen until I press alt+SysRq+K .

Download full text (3.2 KiB)

I have not tested on latest kernel but I have been facing the problem ever
since I have been using the earlier kernels ever since I have been using the
radeon driver. And the ati driver is same... it just calls the radeon driver

On Sat, Feb 27, 2010 at 7:10 AM, Karesz <email address hidden> wrote:

> Have this problem got any better with the new 2.6.33 kernel? (It
> included radeon KMS)
>
> --
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
> https://bugs.launchpad.net/bugs/305301
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Bugzilla Bug Tracking System: Invalid
> Status in The Linux Kernel: Invalid
> Status in X.Org X server: Invalid
> Status in “linux” package in Ubuntu: Confirmed
> Status in “xserver-xorg-video-ati” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-radeon
>
> Since I upgraded to 8.10 from 8.04 the machine does not resume from
> suspend.
> 1) Depending on the tools it behaves the following way: when using usual
> (gnome) suspend, when trying to resume it turns on and off with a blank
> screen. When using pm-utils, it turns on but the screen is blank. In all of
> these cases, the system is irresponsive and requires a hard reboot (held
> down power button). Sometimes the system just restarts (reboots) on its own
> after one attempt.
> 2) There is also one more problem with the X that is conected.
> Occasionally, when booting the system before getting the login window the
> system hangs with the blank screen. It also remains totally irresponsive
> with no Magic Keys working.
>
> The reason why I think the issue is related to "radeon" driver is the
> following. I've had a lot of problems be with the ATI/AMD proprietary fglrx
> driver (no dual head support, no xvid etc). However, when I upgraded to
> 8.10 I found the fglrx in use. Again, the performance was not good either
> (bad xv support and slow). But I could resume from suspend OK and do not
> remember any crashes when booting. I removed it and started using "radeon"
> driver. The performance was better, but I started experiencing the
> above-mentioned problems. I also tried "ati" driver (not sure if there is
> difference ) bu with no avail.
> Someone found a similar bug a couple months ago and followed the suggested
> change in the Xorg.conf by trying different values for Option "AGPMode". it
> didn't work. I also tried hibernate tools. It did similar things. I tried
> with/without compiz, gives the same problem, as well as with the generic
> Xorg.conf file. I attach both below
> My laptop is Toshiba Satellite l35 with ATI Technologies Inc RC410 [Radeon
> Xpress 200M].
>
> $uname -a
> 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686
> GNU/Linux
> I am attaching some useful files below.
> Thanks very much in advance for your help!
> [lspci]
> 00:00.0 Host bridge: ATI Technologies Inc Device 5a31 (rev 01)
> 01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon
> Xpress 200M] [1002:5a62]
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/bugzilla/+bug/305301/+subscribe
>

--
Absenc...

Read more...

gene (eugenios) wrote :

We should be talking about two problems now. As I stated in #124, kms's introduces a more severe issue with "radeon.modeset=1" option causing the kernel to freeze on my machine while failing to fix the resume-after-suspend problem.

This results in the corrupted rsyslog data and makes it impossible (for me, at least) to debug. These is all exacerbated by everyone's silence and neglect.

Instead of trying to "fix" this issue, the community, in my mind, should compile a list of devices stubbornly adverse to the linux/BSD systems.

Karesz (lengyel-karesz) wrote :

Anyone who's affected by this bug, should take a look at this one: https://bugs.launchpad.net/bugs/509273
and take a try, if that one also affects her/him, and give a click to the "also affects me" button.

Bryce Harrington (bryce) on 2010-03-30
Changed in xorg-server:
status: Invalid → Unknown
Bryce Harrington (bryce) wrote :

The upstream bug task on this report appears to be closed as fixed. Given the large number of comments on this bug I think maybe it's grown stale.

A couple options going forward:
a) Dupe this bug report to #509273 if it is indeed the same problem
b) File a new bug report upstream at bugs.freedesktop.org about the current state of the problem, and link a new upstream bug task here

Please let us know what option you think should be taken here. And if (b), if you feel like it please go ahead and do it.

Changed in xorg-server:
status: Unknown → Fix Released
gene (eugenios) wrote :

Well, I need to see that "fix". Tried with the option "radeon.modeset=1" and "pci=nomsi" options with 2.6.31-20-generic. Did not seem to get modesetting 1 at first, had to kill gdm and set it manually. Tried suspending - the good old problem remains.

#50927 seems to be related, however it talks about different chipsets (no RC410 and amd cpu ). I built and tested 2.6.32-rc5-custom and did not experience problems reported, except some ones (perhaps msi). Maybe a similar issue awaits us with ver. 33 and in Lucid. It will be scary to upgrade then :)

Mark (umberstark) wrote :

Would there be any benefit in providing the BIOS of the cards? There's a windows utility (not sure about one for linux) called ATI Tray Tools that can download it from the card in .bin format.

gene (eugenios) wrote :

Bryce, yes http://bugs.freedesktop.org/show_bug.cgi?id=22140 is a different one it is supposed to be fixed in 6.12 it says, the chip is RS482 . Can you file another one for us? Let me know, thanks.

to Mark: I guess on Linux you can use various utilities, "sudo lshw" is one of them. I think RC410 has the known internals, except what is the bloody ATI's secret (unavailable even to any Windows utility). This is the mother of all problems people have with ATI, in part., and with hardware, in general. Damn ATI!

subchee (subchee) wrote :

"Changed in: xserver-xorg-video-ati (Debian)
status: Unknown → Fix Released"

Is it serious? Should I try out the Debian sid?

Apoorv Parle (apparle) wrote :
Download full text (3.7 KiB)

It seems there are a lot of things similar to RS482 in my motherboard...
because it required a patch for soundcard similar to one required on a RS482
board.
Anyways....so is this fixed in general for both RS482 and RC410, or anyone
is filing new bug for RC410? And how much time would it take to get it fixed
in ubuntu?

On Thu, Apr 1, 2010 at 8:59 AM, gene <email address hidden> wrote:

> Bryce, yes http://bugs.freedesktop.org/show_bug.cgi?id=22140 is a
> different one it is supposed to be fixed in 6.12 it says, the chip is
> RS482 . Can you file another one for us? Let me know, thanks.
>
> to Mark: I guess on Linux you can use various utilities, "sudo lshw" is
> one of them. I think RC410 has the known internals, except what is the
> bloody ATI's secret (unavailable even to any Windows utility). This is
> the mother of all problems people have with ATI, in part., and with
> hardware, in general. Damn ATI!
>
> --
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
> https://bugs.launchpad.net/bugs/305301
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Bugzilla Bug Tracking System: Invalid
> Status in The Linux Kernel: Invalid
> Status in X.Org X server: Fix Released
> Status in “linux” package in Ubuntu: Confirmed
> Status in “xserver-xorg-video-ati” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-radeon
>
> Since I upgraded to 8.10 from 8.04 the machine does not resume from
> suspend.
> 1) Depending on the tools it behaves the following way: when using usual
> (gnome) suspend, when trying to resume it turns on and off with a blank
> screen. When using pm-utils, it turns on but the screen is blank. In all of
> these cases, the system is irresponsive and requires a hard reboot (held
> down power button). Sometimes the system just restarts (reboots) on its own
> after one attempt.
> 2) There is also one more problem with the X that is conected.
> Occasionally, when booting the system before getting the login window the
> system hangs with the blank screen. It also remains totally irresponsive
> with no Magic Keys working.
>
> The reason why I think the issue is related to "radeon" driver is the
> following. I've had a lot of problems be with the ATI/AMD proprietary fglrx
> driver (no dual head support, no xvid etc). However, when I upgraded to
> 8.10 I found the fglrx in use. Again, the performance was not good either
> (bad xv support and slow). But I could resume from suspend OK and do not
> remember any crashes when booting. I removed it and started using "radeon"
> driver. The performance was better, but I started experiencing the
> above-mentioned problems. I also tried "ati" driver (not sure if there is
> difference ) bu with no avail.
> Someone found a similar bug a couple months ago and followed the suggested
> change in the Xorg.conf by trying different values for Option "AGPMode". it
> didn't work. I also tried hibernate tools. It did similar things. I tried
> with/without compiz, gives the same problem, as well as with the generic
> Xorg.conf file. I attach both below
> My laptop is Toshiba Satellite l35 with AT...

Read more...

Though I haven't been running Ubuntu in a long time, I've experienced this issue with Debian Squeeze. I've been constantly tracking this ubuntu bug for a workaround.
Fortunately I've found a fix that is working pretty well for me.

Go to System Tools > Configuration Editor
Now browse to: apps/gnome-power-manager/general/network_sleep
Enable network_sleep by checking the box.

Now try to suspend/hibernate!

My specs are:

Laptop: HP Pavilion dv5035nr
Video card: ATI Tecnologies Inc Radeon Xpress 200M 5955 (PCIE)
Kernel: 2.6.32-4 (basically 2.6.32.9 upstream with NO backported DRM from 2.6.33)
Radeon driver: 6.12.6 (No KMS capable!)

What strikes me the most about this, is that it works with DRI enabled and user modesetting (no KMS needed). I haven't tried this with KMS enabled. I will try it once Squeeze gets its 2.6.32-10 kernel (with DRM backported from 2.6.33) and the KMS capable radeon driver 6.12.192 or 6.13.0

I got the fix from: http://bbs.archlinux.org/viewtopic.php?pid=705928

Hope this solves this bug once and for all!

gene (eugenios) wrote :

2 acimmarusti : Thanks, I will try this out. However, I doubt it would work. First, your chip is different. I got rc410. Yours is 5955. I once installed Ubuntu on a friends computer last year. It was a desktop x200m with an amd cpu. I feared that Linux would be hostile to the neophytes. Everything went smoothly though then. It never worked for me with dri enabled.

I have no network_sleep nowhere in my gnome configs. gnome-power manager does not have. Maybe it is a different version.

2 Apoorv Parle: of course these two chips have a lot in common, I suppose. the are all x200m series. However , only rc410 is specially honored with this bug. If you'd like to file the bug, it'd be appreciated. I also have a request to you and to the launchpad team. PLEASE, do not publish our email addresses! there's no need to dump the old comments also.

Changed in bugzilla:
status: Invalid → Confirmed
gene (eugenios) wrote :

It is funny, status : fix released. Is it known to work? Where to find it? The fix was released 4 months ago?

I pretty much do not care. I am happy with no dri. GNU/Linux gave me so much opportunity on this chip laptop a Windex user would have never even dreamed of.

The lesson learned: stay away from ATI (and maybe AMD). Listen to rms more carefully next time.

offtopic: why is it not possible to use w3m with emacs to write the comments?

Gene,

It's highly likely our chips are different, but they all seem related to RC410 -> http://www.x.org/wiki/Radeon%20ASICs

Nevertheless, try this: in a terminal run gconf-editor

Now there browse to: apps/gnome-power-manager/general/

On the righthand side you should see network_sleep (hopefully) and you can activate it.

Hope it works

Mark (umberstark) wrote :

The "network_sleep" tweak didn't work for me, Amilo LI1718 X200M, although I haven't tried with KMS disabled, as booting with "pci=nomsi" fixed the problem with KMS for me (although not all), and I'm reluctant to mess with that now.

Mark (umberstark) wrote :

As a follow up. As always happens after an unsuccessful suspend/sleep, my networking is now dead (not related to the "network_sleep" setting), both wired and wireless.

Re-install time...

Mark,

I was having this problem before, you don't need to reinstall.

Just remove this file:

sudo rm /var/lib/NetworkManager/NetworkManager.state

This is known problem with Network-Manager: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=571331

Now restart and upon login everything should work right

Andres

gene (eugenios) wrote :

2 acimmarusti: thanks a lot. It did not work. Strange that the "find" utility in gconf-editor did not fetch "network_sleep" for me. Anyways, isn't it network related option not our marvelous ATI card. So it might be that very secret of the damned ATI to include some specialty in rc410 only that prevents it from functioning properly with our FOSS driver (with dri enabled), as a matter of fact, the ATI's own driver fglrx is much much worse! Maybe in a few hundred years .....

Thanks again, acimmarusti!

Apoorv Parle (apparle) wrote :
Download full text (3.5 KiB)

Finally has anyone filed the bug for our chipset upstream similar to RS482,
I could have done but I am new to all this and not as experienced in linux
as you guys

On Fri, Apr 2, 2010 at 11:55 PM, gene <email address hidden> wrote:

> 2 acimmarusti: thanks a lot. It did not work. Strange that the "find"
> utility in gconf-editor did not fetch "network_sleep" for me. Anyways,
> isn't it network related option not our marvelous ATI card. So it might
> be that very secret of the damned ATI to include some specialty in
> rc410 only that prevents it from functioning properly with our FOSS
> driver (with dri enabled), as a matter of fact, the ATI's own driver
> fglrx is much much worse! Maybe in a few hundred years .....
>
> Thanks again, acimmarusti!
>
> --
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
> https://bugs.launchpad.net/bugs/305301
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Bugzilla Bug Tracking System: Confirmed
> Status in The Linux Kernel: Invalid
> Status in X.Org X server: Fix Released
> Status in “linux” package in Ubuntu: Confirmed
> Status in “xserver-xorg-video-ati” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-radeon
>
> Since I upgraded to 8.10 from 8.04 the machine does not resume from
> suspend.
> 1) Depending on the tools it behaves the following way: when using usual
> (gnome) suspend, when trying to resume it turns on and off with a blank
> screen. When using pm-utils, it turns on but the screen is blank. In all of
> these cases, the system is irresponsive and requires a hard reboot (held
> down power button). Sometimes the system just restarts (reboots) on its own
> after one attempt.
> 2) There is also one more problem with the X that is conected.
> Occasionally, when booting the system before getting the login window the
> system hangs with the blank screen. It also remains totally irresponsive
> with no Magic Keys working.
>
> The reason why I think the issue is related to "radeon" driver is the
> following. I've had a lot of problems be with the ATI/AMD proprietary fglrx
> driver (no dual head support, no xvid etc). However, when I upgraded to
> 8.10 I found the fglrx in use. Again, the performance was not good either
> (bad xv support and slow). But I could resume from suspend OK and do not
> remember any crashes when booting. I removed it and started using "radeon"
> driver. The performance was better, but I started experiencing the
> above-mentioned problems. I also tried "ati" driver (not sure if there is
> difference ) bu with no avail.
> Someone found a similar bug a couple months ago and followed the suggested
> change in the Xorg.conf by trying different values for Option "AGPMode". it
> didn't work. I also tried hibernate tools. It did similar things. I tried
> with/without compiz, gives the same problem, as well as with the generic
> Xorg.conf file. I attach both below
> My laptop is Toshiba Satellite l35 with ATI Technologies Inc RC410 [Radeon
> Xpress 200M].
>
> $uname -a
> 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686
> GNU/Linux
> I am attac...

Read more...

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi gene,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 305301

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 305301 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/305301

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-retested-on-lucid-by-june
Karesz (lengyel-karesz) wrote :

Well, I'm not Gene, but can confirm, that this bug still exists in Lucid :(

2010/5/5 Bryce Harrington <email address hidden>

> [This is an automatic notification.]
>
> Hi gene,
>
> This bug was reported against an earlier version of Ubuntu, can you
> test if it still occurs on Lucid?
>
> Please note we also provide technical support for older versions of
> Ubuntu, but not in the bug tracker. Instead, to raise the issue through
> normal support channels, please see:
>
> http://www.ubuntu.com/support
>
>
> If you are the original reporter and can still reproduce the issue on
> Lucid, please run the following command to refresh the report:
>
> apport-collect 305301
>
> If you are not the original reporter, please file a new bug report, so
> we can work with you as the original reporter instead (you can reference
> bug 305301 in your report if you think it may be related):
>
> ubuntu-bug xorg
>
> If by chance you can no longer reproduce the issue on Lucid or if you
> feel it is no longer relevant, please mark the bug report 'Fix Released'
> or 'Invalid' as appropriate, at the following URL:
>
> https://bugs.launchpad.net/ubuntu/+bug/305301
>
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: Triaged => Incomplete
>
> ** Tags added: needs-retested-on-lucid-by-june
>
> --
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
> https://bugs.launchpad.net/bugs/305301
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Karesz (lengyel-karesz) wrote :

I don't know if Gene is still watching this bug, but in case he doesn't,
should i file a new bug report about this?

2010/5/6 Lengyel Karesz <email address hidden>

> Well, I'm not Gene, but can confirm, that this bug still exists in Lucid :(
>
> 2010/5/5 Bryce Harrington <email address hidden>
>
> [This is an automatic notification.]
>>
>> Hi gene,
>>
>> This bug was reported against an earlier version of Ubuntu, can you
>> test if it still occurs on Lucid?
>>
>> Please note we also provide technical support for older versions of
>> Ubuntu, but not in the bug tracker. Instead, to raise the issue through
>> normal support channels, please see:
>>
>> http://www.ubuntu.com/support
>>
>>
>> If you are the original reporter and can still reproduce the issue on
>> Lucid, please run the following command to refresh the report:
>>
>> apport-collect 305301
>>
>> If you are not the original reporter, please file a new bug report, so
>> we can work with you as the original reporter instead (you can reference
>> bug 305301 in your report if you think it may be related):
>>
>> ubuntu-bug xorg
>>
>> If by chance you can no longer reproduce the issue on Lucid or if you
>> feel it is no longer relevant, please mark the bug report 'Fix Released'
>> or 'Invalid' as appropriate, at the following URL:
>>
>> https://bugs.launchpad.net/ubuntu/+bug/305301
>>
>>
>> ** Changed in: xserver-xorg-video-ati (Ubuntu)
>> Status: Triaged => Incomplete
>>
>> ** Tags added: needs-retested-on-lucid-by-june
>>
>> --
>> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
>> https://bugs.launchpad.net/bugs/305301
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
>

2 Karesz
This is ok with me. I do keep an eye on this one, however, I don't have much faith in the slogan "kms+rc410=love", in another other life maybe... Since the upgrade to 10.04 I get a lot of bugs which as a good citizen I will have to report. So a lot of excuses So, good luck and thanks!

> I don't know if Gene is still watching this bug, but in case he doesn't,
> should i file a new bug report about this?
>

--

Please do not send me Microsoft Office/Apple iWork documents. Send OpenDocument instead! http://fsf.org/campaigns/opendocument

gene (eugenios) wrote :

I am sorry, forgot to also mention that suspend did not work for me either after the upgrade to Lucid:
$uname -a
Linux 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux
Not to mention that KMS has been very buggy for this video card: would frequently freeze the system (will report it later) and has a much inferior xvid performance. Too raw at the moment, the suspend issue is the minor one.

PS Will be using my mutt instead of firefox, since it has no emacs
--
            ἔρρωσο,

            Ευγενιος
--
              ___ __ __
|||/ _ _ ._ |_|_ (_ o._ _ ._ | _ (__|_ ._ o _|||
  |\(/_(/_|_) _|_|_ __)|| | ||_)|(/_o __)|_|_||_)|(_|
          | | / |
___ ___ __ __ _
 ||_ _ | |._ o |/ | (_ (_ |_)._o._ _o._ | _
 || |(/_ |_|| ||>< |\_|___)__) | | || |(_||_)|(/_
                                            |

Please do not send me Microsoft Office/Apple iWork documents. Send OpenDocument instead! http://fsf.org/campaigns/opendocument

Well, you might be interested in this one also:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/576125

2010/5/7 gene <email address hidden>

> I am sorry, forgot to also mention that suspend did not work for me either
> after the upgrade to Lucid:
> $uname -a
> Linux 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686
> GNU/Linux
> Not to mention that KMS has been very buggy for this video card: would
> frequently freeze the system (will report it later) and has a much inferior
> xvid performance. Too raw at the moment, the suspend issue is the minor one.
>
> PS Will be using my mutt instead of firefox, since it has no emacs
> --
> ἔρρωσο,
>
> Ευγενιος
> --
> ___ __ __
> |||/ _ _ ._ |_|_ (_ o._ _ ._ | _ (__|_ ._ o _|||
> |\(/_(/_|_) _|_|_ __)|| | ||_)|(/_o __)|_|_||_)|(_|
> | | / |
> ___ ___ __ __ _
> ||_ _ | |._ o |/ | (_ (_ |_)._o._ _o._ | _
> || |(/_ |_|| ||>< |\_|___)__) | | || |(_||_)|(/_
> |
>
> Please do not send me Microsoft Office/Apple iWork documents. Send
> OpenDocument instead! http://fsf.org/campaigns/opendocument
>
> --
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
> https://bugs.launchpad.net/bugs/305301
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Karesz (lengyel-karesz) wrote :

Okay, I've reported this bug again.
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/577340

2010/5/7 Lengyel Karesz <email address hidden>

> Well, you might be interested in this one also:
> https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/576125
>
> 2010/5/7 gene <email address hidden>
>
> I am sorry, forgot to also mention that suspend did not work for me either
>> after the upgrade to Lucid:
>> $uname -a
>> Linux 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686
>> GNU/Linux
>> Not to mention that KMS has been very buggy for this video card: would
>> frequently freeze the system (will report it later) and has a much inferior
>> xvid performance. Too raw at the moment, the suspend issue is the minor one.
>>
>> PS Will be using my mutt instead of firefox, since it has no emacs
>> --
>> ἔρρωσο,
>>
>> Ευγενιος
>> --
>> ___ __ __
>> |||/ _ _ ._ |_|_ (_ o._ _ ._ | _ (__|_ ._ o _|||
>> |\(/_(/_|_) _|_|_ __)|| | ||_)|(/_o __)|_|_||_)|(_|
>> | | / |
>> ___ ___ __ __ _
>> ||_ _ | |._ o |/ | (_ (_ |_)._o._ _o._ | _
>> || |(/_ |_|| ||>< |\_|___)__) | | || |(_||_)|(/_
>> |
>>
>> Please do not send me Microsoft Office/Apple iWork documents. Send
>> OpenDocument instead! http://fsf.org/campaigns/opendocument
>>
>> --
>> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
>> https://bugs.launchpad.net/bugs/305301
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
>

Petr Šigut (petr-sigut) wrote :

I tried 10.10 alfa (kernel 2.6.35-rc3) and it takes very long to suspend and wake up is not functional at all.

Karesz (lengyel-karesz) wrote :

Same here, but it's a kernel still in development. Still, i don't beleive,
that it'll work in the final release. Hopefuly, the GPU scaling will.

2010/6/16 Petr Šigut <email address hidden>

> I tried 10.10 alfa (kernel 2.6.35-rc3) and it takes very long to suspend
> and wake up is not functional at all.
>
> --
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
> https://bugs.launchpad.net/bugs/305301
> You received this bug notification because you are a direct subscriber
> of the bug.
>

tags: added: kernel-graphics kernel-needs-review
gene (eugenios) wrote :

Hopefully, it will be fixed in a 100 years, when the amd finally decides to negotiate with the community. Long Live AMD/ATI and damn its products!

Tormod Volden (tormodvolden) wrote :

The maverick kernel recently fixed a long-standing Ubuntu-specific resume issue on my RV410 card. It was a general fix AFAIK, so maybe it is worth trying out 2.6.35-6-generic for you also.

Petr Šigut (petr-sigut) wrote :

Tormod Volden: Tried, fully updated Maverick, still the same.

Karesz (lengyel-karesz) wrote :

Hmm, looks promising: http://marc.info/?l=linux-kernel&m=127830148328681&w=2

"Dave Airlie (9):

drm/radeon: add quirk to make HP nx6125 laptop resume."

When it's up on kernel ppa, i'll try it!

Hopefully, it works for all X200m (rc410) notebooks.

2010/6/29 Petr Šigut <email address hidden>

> Tormod Volden: Tried, fully updated Maverick, still the same.
>
> --
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs KMS)
> https://bugs.launchpad.net/bugs/305301
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Tormod Volden (tormodvolden) wrote :

No, that's a specific quirk for that very model. See the "commitdiff" here: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=history;f=drivers/gpu/drm/radeon;hb=HEAD

Steve Conklin (sconklin) on 2010-07-07
tags: added: kernel-reviewed
removed: kernel-needs-review
Bryce Harrington (bryce) wrote :

Closing as expired since requested apport-collect files were not provided.

(Besides, I think this is more likely to be a kernel issue since it has to do with suspend/resume freezing, which almost always is something in the kernel, drm perhaps.)

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid
madbiologist (me-again) wrote :

Re the patch mentioned in comment 161 - a version for the HP DV5000 series has been included upstream in kernel 2.6.35-rc6. From the changelog:

commit 52fa2bbc8ec46255039e2048d616bbd0852ee292
Author: Alex Deucher
Date: Wed Jul 21 23:54:35 2010 -0400

    drm/radeon/kms: add quirk to make HP DV5000 laptop resume

    Fixes:
    https://bugs.freedesktop.org/show_bug.cgi?id=29062

    Reported-by: Andres Cimmarusti
    Signed-off-by: Alex Deucher
    Signed-off-by: Dave Airlie

A PPA of this kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/

Changed in xorg-server:
importance: Unknown → High
Changed in linux:
status: Invalid → Expired

I wonder if this problem still exists in natty. Anyone tried it?

2011/1/24 Bug Watch Updater <email address hidden>

> ** Changed in: linux
> Status: Invalid => Expired
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/305301
>
> Title:
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs
> KMS)
>

Changed in xorg-server:
importance: High → Unknown
Changed in linux:
importance: Unknown → Medium
Changed in xorg-server:
importance: Unknown → High
Karesz (lengyel-karesz) wrote :

Okay, some progress (or regress maybe?)! So, I've tried a new hungarian
distribution called Little Susie ft. KDE3. It's pretty neat, and is made for
older machines. Just for my interest i've tried, if suspend to RAM, then
resume from RAM works on it. IT does! It is based on OpenSuSE 11.1, running
kernel 2.6.27-48 i686.
What if someone smarter than me would check the difference between that
kernel's resume functions, and maverick's/natty's kernel's resume functions,
because (what a surprise :D) it still doesn't work for me in Natty Narwhal
alpha 3! Or if we couldn't integrate the older kernels resume function in
the new kernel because of the new KMS/DRI2, then finding a workaround, like
when suspending to RAM, fallback to older driver, and after resume init the
new driver.

(I don't know if this discussion can be held up here, or if i should file a
new bug for Natty?)

Sincerely: Karesz

2011/2/6 Bug Watch Updater <email address hidden>

> ** Changed in: xorg-server
> Importance: Unknown => High
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/305301
>
> Title:
> [RC410] Xpress 200M hangs when resuming from suspend with DRI (needs
> KMS)
>

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Displaying first 40 and last 40 comments. View all 167 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.