Baltix GNU/Linux

vino (vnc) keyboard mapping problem

Reported by James Wyper on 2007-05-06
116
This bug affects 12 people
Affects Status Importance Assigned to Milestone
vino
Fix Released
Medium
tightvnc (Baltix)
Undecided
Unassigned
vino (Ubuntu)
Low
Ubuntu Desktop Bugs
Feisty
High
Ubuntu Desktop Bugs
vnc4 (Ubuntu)
Undecided
Unassigned
Feisty
Undecided
Unassigned

Bug Description

Binary package hint: vino

I'm pretty sure this started after an upgrade from Edgy to Feisty.

VNC / Vino no longer works correctly. The main alphanumeric keys map from the client to the server OK (so if I press A on the client keyboard A appears on the VNC screen in whatever application I'm working in), but others do not. For example:

| (pipe) is interpreted by vino as ` (backquote)
< and > are interpreted as z and x

Other people seem to have a similar problem - see http://ubuntuforums.org/showthread.php?t=382441

I can't find any obvious configuration files to tweak. Both client and server machines have UK keyboards (and Ubuntu is configured with UK keyboard layout). The client machine is Win98 running realvnc 3.3.6 but I've just tried 4.1.2 and that doesn't fix it.

Thanks in advance for your help.

James.

gregmark (greg-chavez) wrote :

I think the problem is GNOME, not VNC or vino. I am connecting from a Mac Powerbook G4 using Chicken of the VNC 2.0b4, to a freshly upgraded x86 Ubuntu" 7.04 running tightvnc server 1.2.9-21. When I launch programs from X, I have no trouble typing. However, when I run gnome-session, the key mappings become jumbled. Typing "asdfghjkl;'<ENTER>" is translated to GNOME as "abfhjk;'`io<SPACE>".

Mouse and cursor behavior seem normal.

The problem occurs irrespective of whether GNOME is launched from or independently of the x-window-manager.

The thread, page-linked in the originating bug description, includes a posting from a user who claims that the problem does not occur when KDE is launched.

James Wyper (wypers) wrote :

Thakns. If it is GNOME then it's something about the way that GNOME and vino interact. I'm typing this whilst locally attached to a GNOME session on the machine that exhibits the problem when connected to via VNC, and all the keymappings work fine.

Randy Sargent (randy-sargent) wrote :

I have the same problem described in "bug description". On 7.04, I can start a vnc server (tightvnc), and the keyboard is fine until I type "gnome-session", after which point it's remapped as described.

If instead, I run:
gnome-wm &
gnome-panel &
nautilus --no-default-window &
gnome-cups-icon &
gnome-volume-manager &

it seems to give me most of gnome, minus the inconvenient keyboard remapping.

Workaround: I modified my ~/.vnc/xstartup to be:

#!/bin/sh

xrdb $HOME/.Xresources
gnome-wm &
gnome-panel &
nautilus --no-default-window &
gnome-cups-icon &
gnome-volume-manager &
xterm &

Metallinut (metallinut-one) wrote :

For what it's worth. I've experienced this exact same issue on a fresh install of 7.04, so it appears that it's not limited to just upgrades.

Sebastien Bacher (seb128) wrote :
Changed in vino:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Rejected
status: Rejected → Confirmed
Changed in vino:
status: Unknown → Unconfirmed
Jonh Wendell (wendell) wrote :

Fixed upstream.

Changed in vino:
status: Confirmed → Fix Committed
Changed in vino:
status: Unconfirmed → Fix Released
David Ross (david-ross) wrote :

Might someone propose this bug fix for a stable release update? I believe this affects all 7.04 installs, so this means NO installations of vino work on 7.04. This means all installations of 7.04 are broken and unusable.

David Ross (david-ross) wrote :

hrm. one of my fresh installs didn't work by my upgraded machine works fine, so nevermind. Seems to be a user specific problem on my side.

Rainer Langlitz (langlitz) wrote :

It seems to depend on the language/keyboard setting during the Ubuntu installation. If this is not US English, the keyboard via VNC is broken.

Please fix this bug in stable release.

Jonh Wendell (wendell) wrote :

Fixed with tribe 3.

Changed in vino:
status: Fix Committed → Fix Released
timmay (tdhiggs) wrote :

So you say it's fixed. How do I get the fix? Doing:-

apt-get update
apt-get upgrade

only installed updates to firefox! And:-

apt-get install vino/vncserver

Gives the following:-

root@server:~# apt-get install vino
Reading package lists... Done
Building dependency tree
Reading state information... Done
vino is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@server:~# apt-get install vncserver
Reading package lists... Done
Building dependency tree
Reading state information... Done
vncserver is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

There seems to be no update! Please explain how I get the fix. Thanks.

David Ross (david-ross) wrote :

"There seems to be no update! Please explain how I get the fix. Thanks."

The fix has been released for Gutsy, but not Feisty. He did say, "Fixed in Tribe 3", so please be a bit more aware of the release process.

Please read https://wiki.ubuntu.com/StableReleaseUpdates

Rainer Langlitz (langlitz) wrote :

Which release of Ubuntu do you use? This bug is fixed only in unstable 7.10 and not in stable 7.04.

From my point of view this bug has to be fixed in 7.04 too. This is a major bug. It breaks VNC and makes Ubuntu unusable for a large group of users, especially for admins managing lots of machines via VNC.

David Ross (david-ross) wrote :

"From my point of view this bug has to be fixed in 7.04 too. This is a major bug. It breaks VNC and makes Ubuntu unusable for a large group of users, especially for admins managing lots of machines via VNC."

I'm one of the administrators who fell victim to this bug. Bugs can be very embarrassing when you're showing a user Ubuntu over a remote desktop.

Rainer Langlitz (langlitz) wrote :

> I'm one of the administrators who fell victim to this bug.
And do you know a workaround, which is not "walk around"?

To address the Ubuntu release process - I think this criterion for "high-impact bugs" applies here: "Bugs which represent severe regressions from the previous release of Ubuntu"

David Ross (david-ross) wrote :

> And do you know a workaround, which is not "walk around"?
I suppose the problem does lie with the keyboard selection, so I simply fix the type if I did not select the correct mapping in the first place. I suppose someone could actually fix the pacakge in 7.04. I've not bothered since the bug doesn't really affect me after I seen your post on the mapping.

Sebastien Bacher (seb128) wrote :
Changed in vino:
assignee: nobody → desktop-bugs
importance: Undecided → High
status: New → Triaged
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :

The changes are a proposed update for feisty, the patch is already used in gutsy and is working correctly on the machine where I've tested it

Martin Pitt (pitti) wrote :

http://launchpadlibrarian.net/8554101/vino.debdiff is good for upload if you s/gutsy/feisty-proposed/ :-)

Changed in vino:
assignee: desktop-bugs → seb128
status: Triaged → In Progress
Sebastien Bacher (seb128) wrote :

the package has been uploaded to feisty-proposed now

Martin Pitt (pitti) wrote :

Accepted into feisty-proposed, please go ahead with QA testing.

Changed in vino:
status: In Progress → Fix Committed
Matthew Buckett (buckett) wrote :

Just tried the proposed update on feisty (pool/main/v/vino/vino_2.18.1-0ubuntu1.1_i386.deb), restarted my X session and I still see problems with keyboard mappings (I'm using en_GB keyboard on both machines).

< = \
> = |
{ = [
} = ]

and more.

James Wyper (wypers) wrote :

This release has fixed the bug for me - I had to reboot (rather than just disconnect / reconnect to the updated vino) but after that the | < > keys (which were the most annoying ones) work fine.
Thanks for your help with this.

James Wyper (wypers) wrote :

Sorry - spoke too soon. All the keys appear to work (haven't tried function keys yet) EXCEPT for shift+3 (£ sign on a UK keyboard) and shift+7 (ampersand - &).

Instead of £ I get 3 and instead of & I get k (lower case).

When using a local keyboard / screen these keys do what they should do.

I've discovered a work-around which works for my particular environment, but which may also work for others. I suffered from the same symptoms, and eventually started booting into KDE to "fix" it, but it was still "broken", just slightly less so. For instance, my right-arrow key was mapped incorrectly.

I noticed that after working all day long in KDE, the right-arrow key would suddenly start working. It turns out that if my client machine goes to sleep, drops the remote connection, wakes up and rejoins the existing session, the keyboard is mapped perfectly.

YMMV, but it works for me.

My environment:
Xubuntu Fiesty, GDM, FreeNX, and the official NXClient running on a Macbook with OSX 10.4.10.

To reproduce:
Use your remote software on the client to log into GDM as you normally would, in your environment of choice (Xubuntu or GNOME).
Observe your keyboard is just as scrambled as you would expect.
Send your client machine into a sleep/hibernate mode.
Wake your client machine.
Observe the remote software (NXClient in my case) alerting you to the fact that the connection was lost.
Open the connection again, rejoining the previous session.
Observe your keyboard works perfectly.

I don't know if it will work for every combination of remote server/client software, but it works for mine. Good luck.

wjs (wjs-tigernet) wrote :

The only way I can fix this is to

1) set Preferences > Themes to anything but 'Human'
2) Reboot (logout may work, dunno)
3) Log back in.

Key mapping will now work correctly

I am using TIghtVNC 1.3.9

Cheers,

Will

shacharr (shacharr) wrote :

The patch applied in 2.18.0-ubuntu1.1 broke vino much harder on my system - I can't write any capital letters now (as well as any characters created by pressing shift+number). My keyboard settings: us,il grp_led:scroll grp:switch_toggle (set through the gnome keyboard layout setting dialog, install also included setting the keyboard to Hebrew, so when I log in using a non-gnome desktop I get an alt-shift switching behavior).
Going back to 2.18.0-ubuntu1 fixed capital letters and most of the number related items, but for some strange reason shift+0 generates "9" instead of ")". Weird bug, which makes it very hard to use the computer for programing.

Ubuntu Fiesty (original install was hoary, I have been updating since), using backports and proposed repositories, client was Real-VNC viewer 4 on Windows XP SP-2.

i'm using vino 2.18.1-0ubuntu1.1 from feisty-proposed, with an italian keyboard.
capital letters do not work at all, neither with shift or caps lock, and none of the special characters above the numbers. some other special keys work, \| '- èé +* òç ù§ ,; .: -_<>

Sam Peterson (peabodyenator) wrote :

i installed with a dvorak keyboard setup and i can confirm the same problems other people are having. capital letters don't work at all through remote desktop (but these parens type just fine) which should be obvious as i am typing this message via a remote desktop connection to my computer right now and can't capitalize any of my i's without them turning into c's. Captial C and P works, but many others don't.

Please fix this as soon as possible, it makes my desktop unusable for me remotely.

wjs (wjs-tigernet) wrote :

I have a temporary workaround for US English keyboard. I don't know if it will work for any other keyboard settings but you might try and report back.

1) Open gconf editor in a terminal:
     $gconf-editor

obviously if you are trying to do this with a messed up terminal, you won't be able to. The fix for that is to enable gconf editor by right clicking on Applications > Edit Menus and enabling "Configuration Editor" under "System Tools" then you can do everything with mouse clicks

2) navigate to desktop > gnome > peripherals > keyboard > kbd

3) find the key name "layouts" and double click it. This will bring up an "Edit Key" window. Click on add, then type any two characters and click "OK".

Note: it seems that any two characters will work, so what you type shouldn't matter

4) Close out of gconf editor, and then kill and restart your vnc session. You should now see expected characters when you type. You may see an ugly error screen that KBD has failed, but this does not seem to affect anything.

Good luck, this worked for me, hope it works on non US character sets as well

Cheers,

Will

wjs (wjs-tigernet) wrote :

One correction to the above (i went back and tested):

I had to type the letters "u" and "s" (which output as "m" and "b") in that field. So, it figures that you should just need to type whatever 2 character string that applies to your keyboard.

HTH,

Will

Sam Peterson (peabodyenator) wrote :

Thank you very much for this work-around wjs! That worked for me as well. I had to logout and log back in, but it worked. My keybindings are no longer funky anymore, thank you thank you thank you thank you!

Under "desktop > gnome > peripherals > keyboard > kbd" I had two entries, "it nodeadkeys" (my correct keyboard) and "us". Removing "us" solved almost of my issues, and now capital letters and shifted characters work !
The only non-working ones are: 6k àà ìì, they should be 6& à° ì^. Also AltGr characters ( []@# )do not work at all.

Connell (ubuntu-rjconnell) wrote :

I had the same problem with the Final Stable release of Ubuntu 7.10, using TightVNC Server. WSJ's trick noted above of typing US (displayed as mb) in the Configuration Editor > desktop > gnome > peripherals > keyboard > kbd Layout key worked great, but this seems more like a bandage than a real fix. I upgraded from 7.04 to 7.10, and did not have the problem until after the upgrade.

I installed Gutsy final from scratch, with the new vino version all my problems are solved. Every key works perfectly out of the box

Not so if you try to connect via TightVnc.

The problem still exists in 7.10, at least for me...

Cheers,

Will

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Davide Capodaglio
Sent: Thursday, October 25, 2007 2:52 PM
To: <email address hidden>
Subject: [Bug 112955] Re: vino (vnc) keyboard mapping problem

I installed Gutsy final from scratch, with the new vino version all my
problems are solved. Every key works perfectly out of the box

--
vino (vnc) keyboard mapping problem
https://bugs.launchpad.net/bugs/112955
You received this bug notification because you are a direct subscriber
of the bug.

Jonh Wendell (wendell) wrote :

@wjs: Your problem seems to be client related.

Try to connect to the vino using another client, like vinagre (version from svn) - http://www.gnome.org/projects/vinagre/

Tom Eijckmans (tom-eijckmans) wrote :

I'm using vncserver (apt-get vncserver) as the server application and realvnc as my client.
This worked fine on Ubuntu 7.04 and no longer works on 7.10. No changes were done at client side, so I'm not convinced the problem is at client side.
I tried using the VINO application, then the keyboard setting is working fine...
It doesn't make sense for me to re-install from scratch.

Tom Eijckmans (tom-eijckmans) wrote :

Problem can be workaround as described in below link (provided by Randy in this bug report on 7.04) https://bugs.launchpad.net/ubuntu/+source/vino/+bug/112955/comments/3

The reason it worked for me on 7.04 is probably because I installed that one from scratch. Keyboard problems from the moment I upgraded to 7.10. Seems something goes wrong during the upgrade (at least for me...).

If I start the vncserver locally on the server, next connect using realvnc from client, there's no problem! No idea why there's a different behaviour.

Martin Pitt (pitti) wrote :

This is in -proposed for over three months now, and testing feedback has been mostly negative. I removed the -proposed version.

Changed in vino:
status: Fix Committed → Won't Fix
anonym (launch-mailinator) wrote :

C'mon people. This is embarrassing. This seemingly huge bug has been around since may 07. I fixed it too by giving gnome a non-existant keymap "aa" to load on startup, but this is hardly a fix for production environments. Do the gnome devs know about the problem, or do they not care? How do we get this show-stopper escalated? Simple yet ignored bugs like this really hurt my case when i try to get linux taken seriously at my workplace.

After upgrade to Ubuntu 7.10 still suffering of this bug.
I'm tired of working with KDE...

@anonym: Would you tell me how to implement your "aa" fix?

Sebastien Bacher (seb128) wrote :

Could you try if that's still an issue using hardy?

Sorry, this is a production system.
I already rue the upgrade to gutsy because I experienced nasty problems with setserial and lirc.
Using hardy is not an option.

Wolfgang Schnerring (wosc) wrote :

Re wjs https://bugs.launchpad.net/ubuntu/+source/vino/+bug/112955/comments/31

I too can confirm this workaround solves the issue.
You can perform the same setting without the graphical gconf-editor using the following command (e.g. via SSH):

gconftool --set /desktop/gnome/peripherals/keyboard/kbd/layouts --type List --list-type String [aa]

Thanks Wolfgang.
With this workaround the keyboard works. I'm happy now.
BTW: I get a XKB error on Gnome startup. I think it complains about the unknown "aa" layout.

Roel van Os (roel-van-os) wrote :

The workaround is not sufficient for everyone (certainly not me), since it has to be performed for every user. On multi-user systems, this can quickly become a problem. In addition, the workaround assumes that a US keyboard layout is OK for everyone, which is not the case when different layouts are used.

I've tested tightvncserver and vnc4server, both showed the same symptoms. I also tested with a number of different clients: tightvnc on Windows, Chicken of the VNC on Mac OS, and xvnc4viewer on Gutsy. No difference. The problem only occurs when logged into Gnome: GDM and KDE work perfectly.

Is there anything I can do to pinpoint the problem further, so we can locate the problem?

Roel van Os (roel-van-os) wrote :

The problem also exists in Hardy (beta).

Tobias Eberle (tobias-eberle) wrote :

and in the final release

Amit Gurdasani (gurdasani) wrote :

I've also encountered this issue with TightVNC and the hardy release. My solution was to capture the xmodmap -pke output as ${HOME}/.Xmodmap at the login screen (DISPLAY=:0 XAUTHORITY=/var/lib/gdm/:0.Xauth sudo xmodmap -pke > ${HOME}/.Xmodmap). When gnome-settings-daemon starts up and finds an .Xmodmap, it asks if it should be loaded -- I answer yes. As a side effect, if gnome-settings-daemon were to be restarted without the .Xmodmap, it'd scramble the keyboard layout again. With an .Xmodmap in place, it'll load the .Xmodmap every time.

Due to another issue (#199245, gnome-settings-daemon crashing with BadWindow every time a window is mapped), I disabled the keyboard plugin using gconf-editor, at /apps/gnome_settings_daemon/plugins/keyboard. Since it's not being loaded, I suspect it might not garble the layout even if I remove the .Xmodmap now.

So maybe disabling the keyboard plugin is a better fix.

Carl F. (carl-psych) wrote :

One additional comment on this workaround:

     https://bugs.launchpad.net/ubuntu/+source/vino/+bug/112955/comments/31

After typing the characters 'us' (appearing as 'mb'), this keymap needs to be moved to
the top of the list, so that it is the first keymap attempted to be applied.

Everything else works as described by Chris.

This bug persists in Ubuntu 8.04 LTS (which may be the same as Hardy.)

Also, fyi, I'm guessing that the bug is something pretty braindead in a keymap
of some sort somewhere.

<b>Before</b> you apply the fix, if start striking keys in alphabetical order, i.e. 'abcdefg'
you'll see 'asdfghjk' echoed.

I'm not an o/s developer or a sys-admin type, so I'm not sure where to go
looking under the hood. But I'm guessing this may a useful clue for a linux
developer or a handy sys-admin.

Cheers,

Carl F.

This is still a problem under jaunty at this point. The workaround mentioned in this thread re: keyboard layouts does still work, but is naturally very annoying.

This issue seems to be reported and being tracked on the tightvnc sourceforge page, but no progress at this stage:

http://sourceforge.net/tracker/index.php?func=detail&aid=2232405&group_id=14067&atid=114067

Bassu Khan (bashukhan) wrote :

Yes, another pain in Ubuntu? But the question is why doesn't this occur in Fedora, CentOS and Redhat... :P

Bassu Khan (bashukhan) wrote :

Just got that fixed by adding 'export XKL_XMODMAP_DISABLE=1' in $HOME/.vnc/xstartup before the last line /etc/X11/Xsession

Making the server apps work in Ubuntu is like riding a horse without a paddle... :P !!

Changed in vino (Ubuntu Feisty):
assignee: seb128 → desktop-bugs
jcarlyle (jccarlyle) wrote :

Just like to add that this bug is present on my Jaunty system running on ARM using tightvncserver and GNOME. Bassu's XKL_XMODMAP_DISABLE fix does seem to correct this problem.

Sakari Maaranen (sam-iki) wrote :

I have this bug between a xtightvnc client on Jaunty and the tightvncserver on Debian Lenny. I'm using Finnish keyboards with otherwise en_GB locales.

Just confirming that Bassu's XKL_XMODMAP_DISABLE fix on the Lenny server fixed this issue for me as well.

Andy E (virtualandy) wrote :

^ Almost same as Sakari's issue.

Using Jolly VNC client and/or Screen Sharing in Mac OS X 10.5.7 to connect to Ubuntu 9.04 tightvncserver (1.3.4?).
Get jobbled/garbled keys in a terminal.
ssh works fine from same Mac.

Used the XKL_XMODMAP_DISABLE fix as described and that seemed to work.

Najmi (najmi-zabidi) wrote :

Does this issue resolved?
I'm using Ubuntu 9.04, still can't get comment #31 works.

Any clue?

bersyl91 (choppy-free) wrote :

Found the same problem on 9.04 Jaunty Jackalope.

Comment #55 works, even for a french mapping.

graysky (da-audiophile) wrote :

Comment #55 works for a non-Ubuntu Linux as well! Tested on both Arch and Redhat. Thank you Bassu Khan for that!

efffourthirty (coreythom) wrote :

I'm using Jaunty and everything is working fine for me after I removed tightvncserver and instead installed vnc4server.

scott (whittaker007) wrote :

This bug is still present in Karmic. Adding the fake keyboard only seems to work for me if I start the VNC server from an ssh session on the remote client. The gconf-tool setting up the [aa] keyboard command does work, but messes with the desktop themes. However the XKL_XMODMAP_DISABLE fix worked.

jswinner (jswinner) wrote :

I can also confirm Karmic and XKL_XMODMAP_DISABLE fix worked

Carl Gilbert (dnoyeb) wrote :

I can also confirm in Karmic the XKL_XMODMAP_DISABLE fix worked. I should point out that I did not have this problem in 8.10 Hardy. Or it was fixed in some other way.

Y Chow (xscream100) wrote :

The XKL_XMODMAP_DISABLE workaround partially works in 10.04. I am running tightvncserver. The lower case "s" key causes the shutdown menu to be selected. Upper case "S" functions correctly. There might be other keys that don't work properly but lower case "s" is the only one I've discovered so far.

beastiezee (beastiezee) wrote :

i can confirm that the XKL_XMODMAP_DISABLE xstartup does NOT fix the problem with the lower 's' key being mapped to the shutdown button on the gnome desktop in 10.04 unbuntu. I have it installed on 6 systems 2 that were upgraded and 5 fresh installs 64 & 32 bit. I have the same problem Y Chow has if i use tightvncserver or vnc4server. I even compiled the latest tightvncserver and the same result. If i don't use gnome and just keep my xterm the mapping is fine. I have tried the gconftool --set /desktop/gnome/peripherals/keyboard/kbd/layouts --type List --list-type String [aa] and that does not work. I also tried changing it manually in the broken session but that does not work. I have connected from redhat using vnc4viewer, tightvnc, and i have tried from windows using tightvnc, and realvnc. I am using the standard US keyboard with the US local.

If I can do anything to reslove this please let me know. This is a mission critical item where I may have to shift distributions if i cannot find a work around.

beastiezee (beastiezee) wrote :

vino btw works like a charm on all my boxes. However, it is very limited and does not allow for multiple sessions on multiple logins. vino worked out of the box with no setup other than the normal GUI.

Haven't seen this posted, which sums up the problem I have (shift key doesn't do its job over VNC):

http://machine-cycle.blogspot.com/2009/02/vnc-shifty-keyboard-problems.html

Note that this isolates the problem to gnome-settings-daemon.

For x11vnc (which I use) the workaround is the -xkb option.

papukaija (papukaija) wrote :

Feisty is no more supported.

Changed in vnc4 (Ubuntu Feisty):
status: New → Invalid
Muqtar M Usuf (2pac-shakur) wrote :

beastiezee :i can confirm that the XKL_XMODMAP_DISABLE xstartup does NOT fix the problem with the lower 's' key being mapped to the shutdown button on the gnome desktop in 10.04 unbuntu.

I also noticed I have the same problem including the lower case letter "m" which is mapped to the email and chat drop down menu.

I used VNC from XP and also from latest Ubuntu to connect to a vps account, and they both produced the same issues. This even happens when I am running the Terminal. So no chance for commands containing "s" or "m".

Changed in vino:
importance: Unknown → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vnc4 (Ubuntu):
status: New → Confirmed
jswinner (jswinner) on 2013-07-01
Changed in tightvnc (Baltix):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.