multimonitor: Please give me a way to turn off sticky monitor edges

Reported by Darcy Casselman on 2012-03-04
204
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Stewart Wilson
Unity
High
Jason Smith
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

------------------------------------------------------------------------------------------

As seen in 12.04: Precise beta1

Re-iterating my blog comment after the design team asked for feedback on the per-monitor launcher feature: http://design.canonical.com/2012/01/launcher-reveal-prototype/#comment-23596

I regularly use a multi-monitor setup. I want to be able to move the mouse between monitors unimpeded. And I want to be able to move windows between monitors unimpeded.

I don't particularly want or need per-monitor launchers. I understand some users do, and if it's there I'm not going to complain if it doesn't get in my way. Causing the mouse to get stuck between monitors all the time, however, does get in the way.

I just want some way to make sure my mouse never gets stuck at the edge of a monitor. Even if it's a setting hidden away in CCSM, I'm fine with that.

If there's a combination of numbers in the CCSM control panel that ensures my mouse never gets stuck, please let me know. My experiments with different settings didn't reveal anything.

------------------------------------------------------------------------------------------
Proposed solution:

Provide option 'Sticky edges' ON/OFF in Displays panel.
This option is only displayed if there are multiple displays.
OFF disables the edge hold effect on all edges, except the left edge of displays where an auto-hiding Launcher is located.

Please see addendum to System Settings specification: https://docs.google.com/a/canonical.com/document/d/1b3CwE3Wemr347fTxNcu7ixEQBK4YD8JF2pyv5pxiY0U/edit

This addendum also provides a solution proposal for bug 950136: 'multimonitor, launcher: Provide an option to display either a single launcher or a launcher on each display in a multi-monitor environment': https://bugs.launchpad.net/ayatana-design/+bug/950136

Darcy Casselman (dscassel) wrote :

Posted a video to illustrate what I'm talking about: http://youtu.be/elB0nejRU7s

Steve Jackson (aearenda) wrote :

I need a way to turn this off too, and hopefully revert to the previous edge-detection behaviour, so that I can trigger the hidden launcher to appear when using Synergy (even on a single monitor system). It is impossible to push against the edge when using Synergy to share the mouse and keyboard of another computer.

autasis (k-sijtsma) wrote :

Me too !
Running Cinnamon at the moment because of this.

Martin Albisetti (beuno) wrote :

Yes, multimonitor is unbearable as it is now.

Chris Schmidt (nadt) wrote :

I installed Precise Beta a few days ago with a two-monitor-setup. Several times I had the problem, that I couldn't move the mouse from one monitor to the other. I wanted to work on the first monitor but the mouse got stuck on the second monitor. Thanks to Darcy Casselman’s Blog post now I know that I have to move the mouse faster to switch between the monitors.

I think I can live with this now. But I don't think that this is a good "first user experience". So IMO it would be better to switch that feature off by default.

Another point is that the launcher now wastes place on the second monitor. I have the launcher set to "never hide" and I definitely don't use it on the second monitor. So I would really appreciate it if there will be an option in the future to remove the launcher from the second monitor.

Chris, we are scrambling to find a way to make the additional launchers
optional. I think we're close to an own goal with the extra launchers
and need to mitigate that asap.

Mark

Darcy Casselman (dscassel) wrote :

I'm happy to see this is a priority. Thanks, Mark.

Alan Bell posted something of a workaround on my blog post (http://www.flyingsquirrel.ca/index.php/2012/03/04/sticky-monitor-edges/#comment-1749):

"I set the overcome pressure to 1 and the edge stop velocity to 20 and it is now mostly gone, but if I move really slowly it is still there, which is for me about right that it is useful but not annoying."

It helps, but like he says, the mouse still gets caught sometimes. So it becomes less of a problem, but still a problem.

Mark Shuttleworth (sabdfl) wrote :

I think the core idea of the designers of this feature was that rapid
movements should not get "trapped" but fine movements would enable you
to get the launcher on demand. That makes sense in principle, I haven't
tested it

This may be a question of tuning the heuristics (we greatly improved the
false-positive reveals of the left-hand-launcher in general by tuning
heuristics in this cycle) or it may be that the seam-launcher needs to
be totally optional.

Mark

Darcy Casselman (dscassel) wrote :

I would vote for making it optional, of course.

The difference I see with the left-hand launcher is that it rests on what feels like the physical edge of your virtual workspace. "Pushing" against the edge of your workspace to make the launcher appear makes *sense*, almost on a tactile level. Like pushing in an SD card to make it pop out.

Maybe I have a different mental model of my multi-monitor workspace, but there is no physical boundary between monitors in my head. It's all one contiguous area that I'm looking at through two or three monitors. Putting any sort of artificial "physical" barrier between those feels very jarring to me.

Mark Shuttleworth (sabdfl) wrote :

Yes. We had a lot of people saying that it felt wrong to have to go all
the way over to the left of multiple screens, and I think we've
over-compensated. Let's focus on it quickly and find a solution. We
don't have a lot of time for 12.04.

Paul Sladen (sladen) wrote :

Somebody was saying much the same to me at 1AM in Rock City on Sunday morning.

Remember that there another way to access the Launcher:

  <Super> and then roll-over the Launcher

Perhaps having <Super> making the Dash appear on the current screen (and then allowing rollover of that) would be enough a solution, and then just keeping the Launcher static on the very left edge.

That said, the individual who approached me was using a six monitor, two-on-top, four-below setup, and it's unclear where the "extreme left" would be in this case.

Stewart Wilson (stewartw) wrote :

Please see updated description for proposed solution

description: updated
Jared Greenwald (jetsaredim) wrote :

...
</lurker>

This is going to sound off-the-wall, but would it be possible to have the launcher appear at the furthest left and right edges of the workspace? By proposing this, I assume that having something in the launcher space on the desktop (ie gdesklets or similar) would force that launcher into auto-hide mode.

Obviously this could be "toggle-able", but I think that it could be one of at least three states:

* Left-most only (11.10)
* Left of each display (12.04)
* Left/Right edge of workspace

This third option could answer people who didn't want to travel "all the way left" for the launcher, and also answer people that want to be able to move windows/rodent cursors between monitors without hiccup.

Just a thought.

<lurker>
...

description: updated
Gerry Boland (gerboland) on 2012-03-08
Changed in unity-2d:
status: New → Confirmed
milestone: none → 5.8
importance: Undecided → Medium
Changed in unity (Ubuntu):
status: New → Confirmed
David Klasinc (bigwhale) wrote :

My quick fix for this was setting "Launcher Edge Stop Overcome Pressure" to 10 and 'Pressure Decay Rate" to 20. Now the mouse stops if it is moved slowly and if you move it a little bit faster, then passes the edge quickly enough.

For me personally, I'd love to keep the second launcher, but I'd like it on the right side of my right (secondary) monitor.

David Klasinc (bigwhale) wrote :

PS: These two settings are in the Experimental tab under Unity in CCSM.

John Lea (johnlea) on 2012-03-09
description: updated
Changed in ayatana-design:
assignee: nobody → Stewart Wilson (stewartw)
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: New → Confirmed
milestone: none → backlog
importance: Undecided → High
tags: added: udp
tags: added: multimonitor
Omer Akram (om26er) on 2012-03-09
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity-2d (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Achim Behrens (k1l) wrote :

i filed a bug too at this behavior: https://bugs.launchpad.net/unity/+bug/949160
in here: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/929991 there is explained that this behavior is "by design" for not overshooting when you want to place smth at the edge.

in my opinion that is useless. actually i booted win7 on the same laptop with a external monitor in twinview and get crazy because:
1st i accelerate to full power sliding the mouse when i want to switch monitors just because im used to do it to not get stopped at the edge. that makes me feel stupid, honestly.
2nd there is no slowing down at the edge like the "by design" feature for better placing and not overshooting to wrong monitor.
but i can see the problem with a launcher at the other side of the edge. when you overshoot and want to come back to the left monitor the launcher reveals.

I think the push-to-reveal settings are way too heavy anyway. and the "not overshoot" setting is not needed IMHO. user will start to slow down before the edge. and this adaption will be way better than the adaption to go full speed every time you want to go through the edge between monitors.

im really annoyed from the behavior that is shown in Darcy Casselman (dscassel) video in comment 1. that is crippling my workflow in a heavy way.

Omer Akram (om26er) on 2012-03-13
Changed in unity:
status: Confirmed → Fix Committed
milestone: backlog → 5.8.0
assignee: nobody → Jason Smith (jassmith)
Gerry Boland (gerboland) on 2012-03-14
tags: added: multi-monitor
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Gerry Boland (gerboland) wrote :

Right now in Unity2D, for launcher with hide-mode=0 (i.e. fixed) there is no pointer barrier between the screens, so mouse can move unimpeded.

Pointer barrier only created if launcher in auto-hide mode. Marking this as Fix Released.

Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Andrew Austin (andrewaclt) wrote :

andrew@mordor:~$ apt-cache policy unity
unity:
  Installed: 5.8.0-0ubuntu2

andrew@mordor:~$ apt-cache policy gnome-control-center
gnome-control-center:
  Installed: 1:3.4.0-0ubuntu4

Perhaps, I missing the settings, but I don't see this as fixed (or for LP: #950136).

Jared Greenwald (jetsaredim) wrote :

I'm not seeing this as fixed either. I have the launcher setting set to only on the left monitor and I'm constantly getting stuck on the edge between my two monitors. IMHO, the settings should all be automatically tuned down to 0 (or at least something close to 0) when there's no launcher in the middle.

UnSandpiper (aybora) wrote :

Still have the resistance when moving the mouse across screens in any direction.

Dual monitor config with Nvidia Twinview.
Launcher set on left screen only in xrandr and turned "Auto-hide" on in appearance settings.

Chris West (faux) wrote :

Also still seeing this in unity-2d 5.10.0-0ubuntu1, with auto-hide on (hide-mode = 1), nVidia binary twinview.

I can turn off edge resistance by setting the com.canonical.unity-2d.launcher.edge-stop-velocity to "-1", but then you can only access the launcher with the keyboard...

Albert Astals Cid (aacid) wrote :

Chris you mean that using the control panel option to turn off the sticky edges does nothing for you?

Chris West (faux) wrote :

Albert Astals Cid (aacid): By "control panel", you mean "CompizConfig Settings Manager" (ccsm), right? Unity-2d is, as far as I'm aware, using metacity as the window manager.. why would compiz settings affect it?

faux@wilf:~% grep -- -windowmanager /usr/share/gnome-session/sessions/ubuntu-2d.session
DefaultProvider-windowmanager=metacity
faux@wilf:~% ps aux | grep metacity
faux 15708 0.1 0.4 653420 16652 ? Sl 11:26 0:09 metacity
faux 20261 0.0 0.0 9396 908 pts/3 S+ 12:52 0:00 grep metacity

Regardless, changing the autohide and capture mouse settings in ccsm have no effect on the stickyness of the edges (after reverting my dconf-editor changes).

I am assuming here that logging off and on again is enough to ensure that these settings are picked up is fine; I'll try rebooting.

Chris West (faux) wrote :

Ah, no, it's on the "displays" control panel, not the "appearance" control panel unlike all the other Unity settings. This one works. Sorry.

UnSandpiper (aybora) wrote :

D'oh. Turning off sticky edges indeed solves the problem for me as well.
Those launcher settings should really be combined under one control panel, though.

Tim Penhey (thumper) on 2012-04-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
Jimmy Merrild Krag (beruic) wrote :

Values of 5 in "Launcher Edge Stop Overcome Pressure" and 20 in "Pressure Decay Rate" solved it for me. (ccsm > Unity > Experimental)

Jimmy Merrild Krag (beruic) wrote :

20 in "Edge Stop Velocity"

Andrew Gryaznov (realgrandrew) wrote :

1 in "Edge Stop Velocity" solved the issue completely for me (still had the mouse stop with value 20)

Noah Stewart (noah13013) wrote :

After installing and launching Compiz Settings Manager, I chose Ubuntu Unity Plugin under the Desktop section. Click the tab called Experimental. At the bottom, there should be two options: Launcher Monitors and Launcher Capture Mouse. I set the first to Primary Desktop and the second to Launcher Capture Mouse.

It's pretty silly that you have to install compiz just to fix this serious bug. The usability of Unity toolbar leaves a great deal to be desired and its integration should've been postponed until it was more mature.

Noah Stewart (noah13013) wrote :

Sorry, I meant that I deselected Launcher Capture Mouse, which was selected by default.

Tim Penhey (thumper) wrote :

@Noah,

In System Settings > Displays, there is a switch for "Sticky edges".

You can change it there.

Daniel van Vugt (vanvugt) wrote :

Unfortunately that switch/workaround doesn't always work --> bug 990032.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers