Launcher too slow on showing with autohide enabled

Reported by Vladimir Kolev on 2012-02-14
100
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned

Bug Description

Running Ubuntu 12.04 with enabled Autohide behaviour for Launcher.

When the Launcher is hidden, I have to move the mouse up and down till it shows.

It doesn't metter if an opened windows i maximized or there are no windows at all, it's just too slow and doesn't work always.

Should be improved

Nekhelesh Ramananthan (nik90) wrote :

Thank you for reporting this bug. You can adjust the reveal sensitivity of the launch in system settings -> appearance -> behaviour. This would make the launcher much quicker if required. I am marking this bug invalid. However if the issue is still present please reopen the bug.

Changed in unity:
status: New → Incomplete
status: Incomplete → Invalid
Gareth Murphy (gareth-cpm) wrote :

The problem seems to be the velocity of the mouse hitting the edge of the screen. A lot of the times, when I move the mouse to the edge of the screen relatively slowly (not that slowly at all in my opinion) the panel shadow will show, then disappear without actually displaying the panel itself! If you continue to press the mouse against the edge, the shadow may flicker on and off, and sometimes the panel will even show eventually. This doesn't happen if you 'hit' the mouse cursor against the edge of the screen more rapidly. Very annoying!

summary: - Ubuntu 12.04 Launcher to slow on showing with autohide enabled
+ Ubuntu 12.04 Launcher too slow on showing with autohide enabled

PS, the setting in the behaviour dialogue you mentioned have seemingly no effect on this bug whatsoever, the issue is consistent regardless of high or low sensitivity.

Daniel (dansul) wrote :

I am also experiencing this issue and can confirm to what Gareth Murphy said above.

Changed in unity:
status: Invalid → Incomplete
Nekhelesh Ramananthan (nik90) wrote :

On testing it on my system, it seems that the system settings -> appearance -> behaviour settings only affect the pressure required to reveal the launcher and not the speed of the mouse required to reveal the launcher. Hence I am marking this bug confirmed. However whether the setting is actually supposed to affect both the pressure and the speed is a decision to made by the design team.

As temporary workaround, you can change the speed of the mouse in CCSM -> Unity -> Experimental -> Launcher Reveal Pressure. This solution is only temporary since this should be appropriately integrated into the system settings by default.

Changed in unity:
status: Incomplete → Confirmed
Thor (coretratio) wrote :

Same thing here - Gareth Murphy 's description concurred. And quite a different behaviour from Oneiric, this is.

Zinahe Asnake (zinahe) wrote :

Why ? why do you have to fix something that's not broken ?

1. I have set the sensitivity to the highest possible and launcher won't open until I poke the left side of the screen several times. This is really annoying. Please fix it. It's not as if you are breaking new ground here, it used to work with no issues in Oneiric.

2. Overlay scroll bars used to work flawlessly in Oneiric too. Now because of the "new change" (that they will try to show across the whole edge of the window, as opposed to where the thin bars were located) they are competing with window/tab resize cursors all over the place, creating one hell of a flicker-mess

3. What's up with the launcher "hard-coded" chamelon effect that's annoying half the earth's population ??? REALLY ??? I'll give this "LTS" a fair chance for a few more days and will go back to Oneiric. I can't handle this over-optimized user experience.

Omer Akram (om26er) on 2012-07-24
tags: added: autohide
Michael Pancoe (pancoma) wrote :

This Also seems to be a bug on my Toshiba L350d. It seemed to be working fine before but since 12.04 install it is slow to respond, or rather less responsive. As Gareth mentioned, I have to move the cursor "hard against the sidebar in order for the launcher to reveal. Interestingly enough though, the shadow appears whenever the cursor is against the side.

This is actually quite an important fix I feel as it actually affects a very frequent activity/movement when working. Every time i need to access the launcher It takes sometimes two or 3 tries. This is pretty serious to me

Thanks for working on it

John Lea (johnlea) wrote :

@vladimir.kolev, @gareth-cpm, @dansul, @nik90, @coretratio and @pancoma

Hi, if this bug affects you, could you experiment with "CCSM -> Unity -> Experimental -> Launcher Reveal Pressure", and see if there is a value that fixes your problems. If you can find a value that makes things better for you please post it here! If no value improves this aspect of the launcher reveal behaviour please also let us know.

Thanks!

Thanks. I had ccsm installed before but i wondered if it was causing
probems or not. I reinstalled it and put the Launcher reveal pressure to 8
and It works much better I find. Thanks.

On Tue, Aug 7, 2012 at 1:01 PM, John Lea <email address hidden> wrote:

> @vladimir.kolev, @gareth-cpm, @dansul, @nik90, @coretratio and @pancoma
>
> Hi, if this bug affects you, could you experiment with "CCSM -> Unity
> -> Experimental -> Launcher Reveal Pressure", and see if there is a
> value that fixes your problems. If you can find a value that makes
> things better for you please post it here! If no value improves this
> aspect of the launcher reveal behaviour please also let us know.
>
> Thanks!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/931982
>
> Title:
> Ubuntu 12.04 Launcher too slow on showing with autohide enabled
>
> Status in Ayatana Design:
> New
> Status in Unity:
> Confirmed
>
> Bug description:
> Running Ubuntu 12.04 with enabled Autohide behaviour for Launcher.
>
> When the Launcher is hidden, I have to move the mouse up and down till
> it shows.
>
> It doesn't metter if an opened windows i maximized or there are no
> windows at all, it's just too slow and doesn't work always.
>
> Should be improved
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/931982/+subscriptions
>

Omer Akram (om26er) on 2012-08-16
Changed in unity:
importance: Undecided → Medium
Omer Akram (om26er) on 2012-08-16
summary: - Ubuntu 12.04 Launcher too slow on showing with autohide enabled
+ Launcher too slow on showing with autohide enabled
John Lea (johnlea) on 2012-08-16
tags: added: needs-design
Changed in unity:
importance: Medium → Undecided
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/931982

tags: added: iso-testing
Richard Lane (rlane-5) wrote :

This also affects me. Running 12.04 on an ASUS K52J.

Also, in response to the first comment by Nekhelesh Ramananthan (nik90), there is no such thing as

system settings -> appearance -> behaviour

at least not on my system.

caj420 (caj420) wrote :

Since 12.04 is an LTS version, wouldn't this get assigned to someone a bit more rapidly? Importance is still undecided and it hasn't been assigned to anyone, unbelievable!

Way to go guys, keep it up, you're driving everyone away from the Ubuntu Unity experience. More focus on the simple functionality of Unity might keep more people using it. This lack of attention to the "small stuff" is what's killing it. Fix these simple stupid annoyances and most of us will keep using it. Or NOT and we'll go elsewhere.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers