Dash - Update the Dash card view so that the implementation conforms to the attached designs

Bug #901164 reported by John Lea on 2011-12-07
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
Medium
Mirco Müller
unity-2d
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

A 'card view' is currently used in the Gwibber lens, and also in some other 3rd party lenses. Update this view so that the shape, size and positioning of all elements exactly matches the attached designs.

If the images in the card view are a mix of square and landscape icons, the text composed to the right of the icon should consist of:
- 1 'header' line. Text automatically bold, lens has no control over styling
- 3 'body' lines. Text regular style, only control the lens has over styling is the ability to make specific words or letters bold

If the images in the card view are *only* landscape icons (e.g. in the Video Lens), the text composed to the right of the icon should consist of:
- 1 'header' line. Text automatically bold, lens has no control over styling
- 2 'body' lines. Text regular style, only control the lens has over styling is the ability to make specific words or letters bold

Related branches

John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog
tags: added: udp
Andrea Cimitan (cimi) on 2011-12-13
tags: added: unity3p
Tim Penhey (thumper) on 2012-02-07
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Triaged
importance: Undecided → Medium
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 5.6
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Andrea Azzarone (azzar1) wrote :

@John, We need more info:

[a] There is no design input for the highlight state (focus/over state)
[b] What happens if we have not a 64x64 px icon but for example a 256x128 one
[c] I cannot see the blurred effect behind each icons. Is this something wanted?

Didier Roche (didrocks) on 2012-03-05
Changed in unity-2d:
milestone: 5.6 → 5.8
John Lea (johnlea) on 2012-03-09
description: updated
Mirco Müller (macslow) on 2012-03-09
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Mirco Müller (macslow) on 2012-04-02
Changed in unity:
status: Triaged → In Progress
Mirco Müller (macslow) wrote :

The current state of the attached branch looks like this: http://people.canonical.com/~mmueller/after-901164-2.png

John Lea (johnlea) wrote :

Thx! At first glance there is one issue; the area under each card is a different colour from the Dash, however there should not be any difference. See the dash_cardview1.png design design attached to this bug.

Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-04-05
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
milestone: backlog → 5.10.0
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
Gerry Boland (gerboland) on 2012-04-11
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
status: Confirmed → In Progress
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
milestone: 5.12 → 5.14
John Lea (johnlea) on 2012-09-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: removed: top5p udp unity3p
Adolfo Jayme (fitojb) on 2013-03-13
no longer affects: unity-2d (Ubuntu)
Gerry Boland (gerboland) on 2014-08-15
Changed in unity-2d:
assignee: Gerry Boland (gerboland) → nobody
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers