[FFe, UIFe] Dash - When the Dash is open and there is a maximised app in the background, the top bar background should not disappear

Bug #839480 reported by John Lea on 2011-09-02
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
High
Jay Taoko
unity (Ubuntu)
High
Jay Taoko

Bug Description

When the Dash is open and there is a maximised app in the background, the top bar background should not disappear.

To reproduce:
1. Open any window and make it maximised.
2. Open the Dash

What you currently see that is incorrect:
- The background of the top bar disappears showing the background wallpaper in the position where the top bar was.

What you should see:
- The background of the top bar (just the dark bar without any emblems or app title, effectively just the top bar texture) should remain in place, and you should *NOT* be able to see the background wallpaper. For clarity, this change does not change the dash in any way, we are only changing the background *behind* the dash.

Desired solution:
- *ONLY* in the case where there is a maximised window, the top bar background should be displayed when the Dash is open.
- When there is no maximised window the top bar background should not be displayed (as currently happens)
- The attached images "ambiance_topbar.png" and "radiance_topbar.png" show *exactly* the effect we are trying to achieve

Related branches

John Lea (johnlea) on 2011-09-02
description: updated
description: updated
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
John Lea (johnlea) wrote :
Gord Allott (gordallott) on 2011-09-20
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
importance: Undecided → Medium
milestone: none → 4.18.0
status: New → Confirmed
status: Confirmed → Triaged
Omer Akram (om26er) on 2011-09-21
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Gord Allott (gordallott)
Mirco Müller (macslow) on 2011-09-23
Changed in unity:
assignee: Gord Allott (gordallott) → Mirco Müller (macslow)
Changed in unity (Ubuntu):
assignee: Gord Allott (gordallott) → Mirco Müller (macslow)
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
Mirco Müller (macslow) on 2011-09-29
Changed in unity:
milestone: 4.20.0 → 4.22.0
Mirco Müller (macslow) on 2011-09-30
Changed in unity:
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0
Omer Akram (om26er) wrote :

I think it might be better to get this in before final comes out, as SRU policy might not approve and also the change looks really simple to get in even at this stage(TM)

Neil J. Patel (njpatel) on 2011-10-10
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) wrote :

This need to be reeverted, it's an UI change and it's too late.

Andrea Cimitan (cimi) wrote :

that breaks the look with bright themes (Radiance)

Omer Akram (om26er) wrote :

I am not sure if this is what design requested, in anycase looks weird to me even with Ambiance.

John Lea (johnlea) wrote :

@Cimi, @om26er; this is *not* what design requested, the requested change was to modify the background behind the dash when a window is maximised. The Dash itself should not be changed in any way.

description: updated
John Lea (johnlea) on 2011-10-14
description: updated
Omer Akram (om26er) wrote :

Not something that will be fixed for Oneiric as it will be UI change.

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
Changed in unity:
status: Fix Committed → Triaged
Changed in unity (Ubuntu):
status: Fix Committed → Triaged
Changed in unity:
milestone: 4.24.0 → backlog

I've the same problem : the dash doesn't stay on top but on background when a app is maximised

John Lea (johnlea) wrote :

@darkredman, @om26er; that sounds like a technical bug, not a design bug. Could you report this problem as a separate bug against the "unity project"? thx

Omer Akram (om26er) wrote :

darkredman, you might be facing bug 859405 though from the description of your comment I am not sure if thats what you mean so wont be reporting a new bug.

I'm not sure to understand the title of the bug 859405 and I did in the console "ubuntu-bug unity" so I don't really get why I see here "Ayatana Design" so I'm sorry for this mistake.

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
description: updated
Changed in unity:
assignee: Mirco Müller (macslow) → Brandon Schaefer (brandontschaefer)
Omer Akram (om26er) on 2011-12-13
Changed in unity (Ubuntu):
assignee: Mirco Müller (macslow) → Brandon Schaefer (brandontschaefer)
Andrea Cimitan (cimi) on 2011-12-13
tags: added: unity3p

I uploaded some screenshots of what I have so far (it uses the dash tint to do the coloring):

John Lea (johnlea) wrote :

Almost there, however there should not be a hard cutoff on the dash blur. The dash blur should be continuous all the way to the top of the screen with no interruptions. To give a rough idea of the effect we are trying to achieve I have attached a GIMP file that adds a blur on top of the screenshot you provided, blending the hard join.

John Lea (johnlea) wrote :
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
importance: Medium → High
Omer Akram (om26er) on 2012-01-12
no longer affects: unity (Ubuntu Oneiric)
Changed in unity (Ubuntu):
importance: Medium → High

Linked the current branch I have; which reflect the last screenshots I put up.

Left to do:
-make more of blur between the dash the panel
-refactor parts of PanelView

majesty (majesty-nashemisto) wrote :

Dont understand, top panel in maximized dash look ugly now. I'll attach the screenshot.

John Lea (johnlea) wrote :

@brandontschaefer; thanks for working on this, it is one of the biggest visual glitches on the desktop. And idea when the last two todo item you listed above will be done and this fix ready to land? thanks, John

Omer Akram (om26er) wrote :

@John does the fix to this bug need any change now as with the "locked" launcher it currently looks like this ?

John Lea (johnlea) wrote :

@om26er; yes this still needs to be fixed, the screenshot you have attached above is incorrect.

Refer to the image attached to comment #12 for how it should look.

thanks,
John

@John it is on the top of my todo list, Im hoping to have it done as soon as possible!

Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Critical → High
importance: High → Critical
Andrea Cimitan (cimi) wrote :

Updates?

@Cimi

Sorry, some progress is being made, but I need to get some help from Jaytaoko to help get the right finishing touches on it. When he gets sometime this should be fixed in no time!

Omer Akram (om26er) on 2012-03-17
Changed in unity:
milestone: backlog → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Jay Taoko (jaytaoko) wrote :

I don't understand the images radiance_topbar.png and ambiance_topbar.png, because there does not seems to be a maximised window on the desktop. Or are these just mock-ups.

The way we do the rendering of the dash and the panel (Top Bar) is as follows:
 1- Capture the background behind the element (dash or top bar) and blur it.
 2- Blend the blurred background with the desktop background image average color. Lately, we have moved to doing blending operation the way Photoshop blends layer. Both the dash and the top bar use an "overlay" blending mode. The average color is the top layer while the blurred background is the bottom layer.
 3- A shine effect is applied over the elements.

The continuity between the dash and the top bar is ensured by the fact that they uses contiguous elements of the background which are blurred. The shine effect is also continuous between the dash and the top bar.

My understanding is that when a window is maximised on the desktop and the dash is open, the blurred background should no longer be visible on the top bar. We can achieve this in step 2 by choosing a "normal" blending mode between the two layers. This hides the blurred background behind the average color layer. And the shine effect is applied normally in step 3. However we loose the continuity between the top bar and the dash. Only the continuity of the shine effect remains. Se the attached screenshot.

Is this the effect we are looking to achieve?

Jay Taoko (jaytaoko) wrote :

Another screenshot to follow my previous comment.

Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → Jay Taoko (jaytaoko)
Changed in unity (Ubuntu):
assignee: Brandon Schaefer (brandontschaefer) → Jay Taoko (jaytaoko)
Omer Akram (om26er) wrote :

Jay, when there is a maximized app and the dash is opened over it. The expected thing here is that Unity should think that the black panel is part of the window as its border. So the top panel should not be transparent with desktop background color.

Jay Taoko (jaytaoko) wrote :

After some feedback, here is a revised screenshot. I am using the radiance theme on my desktop.

Jay Taoko (jaytaoko) wrote :

With the ambiance theme.

Omer Akram (om26er) wrote :

I think the part above Launcher (window controls) need to be treated as part of the launcher. per https://chinstrap.canonical.com/~sabdfl/12_04/desktop_and_netbook/dash/tweaks_dash.png

Jay Taoko (jaytaoko) wrote :

@Omer
It isn't quite the same case as in the picture since here we have blur activated and a noise component. The reference image doesn't feature blur is seems.

Omer Akram (om26er) wrote :

now with the fix implemented let me explain what I maeant. In the above screenshot (on chinstrap) the launcher and window buttons all have the same background color from top to bottom i.e. the left 48px of the Panel should also blend as if they are part of the launcher. currently in trunk it looks like this

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) wrote :

nevermind, my last comment. The above only happens if you change the wallpaper and then click on the BFB to open dash. Pressing super key to open the dash is fine.

Didier Roche (didrocks) on 2012-04-09
summary: - Dash - When the Dash is open and there is a maximised app in the
+ [FFe] Dash - When the Dash is open and there is a maximised app in the
background, the top bar background should not disappear
summary: - [FFe] Dash - When the Dash is open and there is a maximised app in the
- background, the top bar background should not disappear
+ [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
+ the background, the top bar background should not disappear
Andrea Cimitan (cimi) wrote :

when the dash is fullscreen, the blur is shifted down few pixels, even when there's no maximized window in the background

Andrea Cimitan (cimi) wrote :
Jeremy Bicha (jbicha) wrote :

I think the change is pretty subtle. If it were up to me, I'm not so sure I'd make a difference in the menu bar coloring based on whether there's a maximized window or not. Anyway, I've been running this since the weekend (as it's already landed in the Unity testing PPA). ubuntu-docs doesn't have any screenshots that cover this (and I redid the screenshots Sunday using the Unity testing PPA anyway) so +1 from the Docs Team.

Martin Pitt (pitti) wrote :

I don't particularly like that it introduces this inconsistency -- the panel looks the same all the time, whether or not we have a maximized window. But alas, as long as we have huge design bugs like bug 960048 I won't argue about subtleties like this :-)

This was already tested by several people, and is hard to back out (so I was told), so +1.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Tim Penhey (thumper) on 2012-04-16
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-16
Changed in ayatana-design:
status: Fix Released → Fix Committed
Nick Tait (jnick-tait) on 2012-04-17
tags: added: reviewedbydesignp
removed: udo udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.