Launcher - clicking trash or device icons multiple times opens multiple instances

Reported by Kyle Clarke on 2010-12-20
246
This bug affects 50 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Nautilus
Fix Released
Medium
Unity
High
Marco Trevisan (Treviño)
unity-2d
Medium
Robert Sajdok
bamf (Ubuntu)
High
Unassigned
nautilus (Ubuntu)
Low
Marco Trevisan (Treviño)
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

When you click on the trash icon multiple times, it will keep opening new windows.

Instead it should bring the open window to focus. I can not think of any circumstances where two trash windows are necessary. But in case it ever is, a "Open new window" entry should be in it's quicklist.

---------------------------------------
Desired Solution:

- If a 'trash' Nautilus window is already open, clicking on the Trash Launcher icon should focus the already open Nautilus window that is currently displaying the trash

- However 'window open' or 'running' triangles *should not* be displayed (on either side of the Trash icon)

Matthew Rasmus (mrasmus) on 2010-12-20
Changed in unity:
status: New → Confirmed

 status confirmed

The Trash window should be re-focused by default, and yes, a quicklist
item for "Open the Rubbish Bin again" would be good.

Mark

Jorge O. Castro (jorge) on 2010-12-21
tags: added: bitesize
Changed in unity-2d:
status: New → Confirmed
David Barth (dbarth) on 2011-01-26
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Jason Smith (jassmith)
milestone: none → 3.6
Changed in unity-2d:
milestone: none → 3.6
importance: Undecided → Medium

Assigning to Jason by default, but the bug is still up for grab as a bitesize one.

Changed in unity-2d:
milestone: 3.6 → 3.8
Stefano Candori (cando) on 2011-02-02
Changed in unity:
status: Confirmed → In Progress
assignee: Jason Smith (jassmith) → Stefano Candori (cando)
Neil J. Patel (njpatel) on 2011-02-07
Changed in unity:
milestone: 3.6 → 3.4.2
Carl Simpson (cwd-simpson) wrote :

If you have a trash window open, and it is already focussed, you might not notice- especially if you have a lot of Nautilus windows open at once (or you are just being scatterbrained, which it is so easy to be when handling a lot of information on a computer).

The proposed plan would mean that the trash button does nothing if the trash window is already in focus. You wouldn't think pressing the button had done anything at all, and might think that it is broken, for a moment. Maybe pressing the button could also highlight the window in some way? (But only when the window is already in focus?)

It seems bad for a piece of interface to on occasion do nothing whatsoever.

Cameron Hart (bitshifternz) wrote :

Also if you open a trash window by clicking on the trash icon, what happens if the user navigates away from the trash folder in nautilus? Is is still a trash window at this point or a nautilus window? Should it raise the original window that was opened or a new one? Or does it raise any Nautilius window that is browsing the trash folder at the time?

It seems like something that could lead to quite inconsistent behaviour from a user perspective.

Stefano Candori (cando) on 2011-02-18
Changed in unity:
status: In Progress → Confirmed
Didier Roche (didrocks) on 2011-02-21
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
milestone: 3.8 → none
Wade (starcraftguy40) wrote :

@Cameron Perhaps I don't understand your meaning, but Trash always opens in the Nautilus launcher, and does not provide an indicator under Trash.

Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.4.2 → 3.6.4
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Balassa Máté (balassa-mm) wrote :

What should happen if there are multiple instances open of the same trash/rubbish bin? Wich one will get the focus? This can be a source of other bugs...

On the other hand I've got to agree, it is much more user friendly if it is like imagined in the report...

Balassa Máté (balassa-mm) wrote :

This was marked as a bitsize bug so while trying to help unity I'm trying to do something not so important...
I can not guarantee that I'm doing the right thing, this is my first try.

Changed in unity-2d:
assignee: nobody → Matthew Balassa (balassa-mm)
Changed in unity-2d:
assignee: Matthew Balassa (balassa-mm) → nobody
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
tags: added: delta-with-3d

@Florian: delta-with-3d? But both Unity 2D and Unity 3D are affected by this bug.

Florian Boucault (fboucault) wrote :

@Marco: I know but it seems there is a branch ready to land in Unity 3D that will fix the issue. I am planning ahead :)

Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
Richard Dale (rdale) wrote :

I've been looking into this, and at the moment the trash file manager is launched with a g_app_info_launch_default_for_uri(TRASH_URI, NULL, &error) call. I don't think it is possible to detect whether or not a handler for the 'trash://' uri has already been launched. So it just starts up a new nautilus window every time.

A possible work round would be to simply have a desktop file called 'trash.desktop' with the trashcan icon, that had a line in it 'Exec: nautilus 'trash://'. That way the application would only be launched once as it would be just a normal app icon rather than something special cased.

Robert Sajdok (ris) on 2011-04-14
Changed in unity-2d:
assignee: nobody → Robert Sajdok (ris)
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
Olivier Tilloy (osomon) wrote :

Interesting suggestion Richard! However, for it to be really portable the desktop file should not invoke nautilus directly (the user may have another file manager of choice), but rather xdg-open. `xdg-open trash://` should just do the right thing. Alas, I seriously doubt the launcher, through bamf, will be able to match whatever window opens as a result to the trash. It would be worth a try though, there may be an elegant solution to this problem that I’m overlooking.

Also note how the implementation proposed by Stefano for unity addresses the problem (have a look at the pending merge request, it contains detailed explanations). It does have a weak point, but it’s an original way of tackling the problem, you may be able to get inspiration from it and perfect it ;)

Changed in unity-2d:
milestone: none → 3.10
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
David Barth (dbarth) wrote :

The workaround doesn't feel safe to land in an SRU anymore. I'd rather have the logic of that go outside of the window manager, where it can be stabilized without risking the whole rest of the process.

Changed in unity:
milestone: 3.8.12 → backlog
Olivier Tilloy (osomon) on 2011-05-20
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-05-31
Changed in bamf:
status: Confirmed → Fix Committed
Changed in bamf (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-06-01
Changed in unity:
status: Confirmed → Fix Committed

The proposed branch was not merged with trunk. Reverting to Confirmed.

Changed in unity:
status: Fix Committed → Confirmed
Didier Roche (didrocks) on 2011-06-06
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity-2d:
milestone: 3.10 → 3.8.6
Changed in unity-2d:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-06-14
Changed in bamf:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-06-20
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-08-29
Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-08-29
Changed in unity:
assignee: Stefano Candori (cando) → nobody
Changed in bamf:
status: Fix Released → Confirmed
Changed in unity:
status: Fix Released → Confirmed
affects: bamf (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: Fix Released → Confirmed
Victor Martinez (victored) wrote :

I think that implementing a Trash Place would be a better solution to this bug.

Didier Roche (didrocks) on 2011-10-03
Changed in bamf (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in bamf:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Triaged
summary: - clicking trash multiple times opens multiple instances of it.
+ Launcher - clicking trash or device icons multiple times opens multiple
+ instances
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Confirmed → In Progress
John Lea (johnlea) on 2012-07-19
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
importance: Medium → High
status: New → Triaged
Changed in unity:
status: In Progress → Confirmed
assignee: Brandon Schaefer (brandontschaefer) → nobody
John Lea (johnlea) on 2012-08-08
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Triaged
Changed in bamf (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-12
no longer affects: unity-2d (Ubuntu)
Changed in bamf:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
importance: Medium → High
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Medium → High
Changed in bamf:
importance: Undecided → High
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Stephen M. Webb (bregma) on 2013-01-28
no longer affects: unity-2d (Ubuntu)
no longer affects: bamf
Changed in bamf (Ubuntu):
status: Triaged → Invalid
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Stephen M. Webb (bregma) wrote :

Evidently this was fixed in Unity-2D some time ago but not properly marked in the release.

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → In Progress
Changed in nautilus:
status: In Progress → Fix Released
Changed in unity:
status: Triaged → Won't Fix
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu9

---------------
nautilus (1:3.6.3-0ubuntu9) raring; urgency=low

  * Renamed patches coming from the upstream vcs to be prefixed with git_
  * debian/nautilus-home.desktop:
    - use --new-window in that desktop as well

  [ Marco Trevisan (Treviño) ]
  * debian/patches/10_reuse_already_opened_views.patch
    - Try to reuse the available windows or tabs when opening an already opened
      location (lp: #692444)
  * debian/patches/12_unity_launcher_support.patch:
    - Quicklist entries to show the copy dialog should use a separator (lp: #1154109)
    - Transfer dialog should be presented using the correct timestamp (lp: #1154111)
    - Use the quicklist activation timestamp to set the application user time
      so that the opened windows will be focused (lp: #1154237)
  * debian/patches/17_static_unity_quicklist.patch:
    - Use nautilus --new-window to open a New window
  * debian/patches/19_add_desktop_keywords.patch:
    - Adding .desktop files keywords from upstream
  * debian/patches/20_export_opened_locations_on_dbus.patch:
    - Export the opened locations to dbus (lp: #1063830)
 -- Sebastien Bacher <email address hidden> Thu, 14 Mar 2013 11:23:18 +0100

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.