YAMA update wish

Bug #489299 reported by 6205 on 2009-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Wishlist
onox

Bug Description

Yet Another Menu Applet is fantastic and a very usable adition to Awn. Its look is also consistant with default GTK theme, but please consider to update it in a way that xdg folders in the places submenu have special icons, just like the places submenu of Gnome's main menu. Thanks.

Related branches

Michal Hruby (mhr3) wrote :

As this is an applet-related bug, it should go to awn-extras project.

affects: awn → awn-extras
Changed in awn-extras:
assignee: nobody → onox (onox)

OK, sounds logical.. But then i also propose to add this applet from extras to core applets, because is very good quality.

onox (onox) wrote :

I don't understand what you exactly want.

Changed in awn-extras:
status: New → Incomplete
importance: Undecided → Wishlist

Added second picture of default GNOME panel menu applet. All special folders/xdg folders like music, videos or downloads have custom icons which are missing in YAMA AWN applet. That was my wish, to update YAMA applet to display those special folders icons..

onox (onox) wrote :

So you just want different icons, ok. Could you paste ~/.gtk-bookmarks?

Changed in awn-extras:
milestone: none → 0.4.0
onox (onox) on 2009-11-28
description: updated

mmm.... my /.gtk-bookmarks will not help you, those are only my specific bookmarks.

my point was, that in current ubuntu 9.10/GNOME 2.28 are used for special folders custom icons defined in icon theme (when available)

Name must be same in all icon themes, like "folder-documents" or "folder-downloads" etc.. and i wanted that this applet will use those icons, when they are available, using the same way like GNOME does..

I am not sure if you understand me, how this applet works or if its possible, but here is one bug related to xdg-user-dirs https://bugs.launchpad.net/ubuntu/+source/xdg-user-dirs/+bug/126103

onox (onox) wrote :

Uhm, YAMA doesn't specifically add those folders to the menu, it just iterates through .gtk-bookmarks. Because your YAMA.png screenshot shows these folders, I think that you have them in your .gtk-bookmarks file. I don't have ubuntu 9.10 and I can't get to see the special folders in gnome 2.28 in Arch, so it's difficult for me to reproduce.

onox (onox) on 2009-11-29
tags: added: applet yama

 >> "....it just iterates through .gtk-bookmarks......so it's difficult for me to reproduce..."

Now i understand. In this case maybe its propably not possible and this could be done propably only with rewriting some parts of applet or make entire applet work excactly the same way like default gnome applet for menu is working..

onox (onox) wrote :

Ugh, you don't understand it. Yama does add the directories (as your first screenshot shows), so they _should_ be in your .gtk-bookmarks file. I want you to confirm that this is true.

Yes that's right, they are in my .gtk-bookmarks file.
 I just wish yama could use also xdg folders icons, like default gnome panel applet, but that is propably not possible.

moonbeam (rcryderman) wrote :

onox,

Just a quick note. They're probably not on your Gentoo system but the icons in question (folder-music, folder-picture etc) are available in Debian/Ubuntu.

Cairo-menu does the following when setting the icons for bookmarks menu item: It uses the lda book mark api, but I expect that is just based on the gio api so it should work with gio implementation also.

Get the icon name. Look for a icon of the form "folder"+icon_name. If it's not present then just use the stock icon.

If you want to see to code in question look around line 394 or gnome-menu-builder.c in cairo-menu.

Or maybe you could use part of the code from "File Browser Launcher" applet, who have those icons.

onox (onox) wrote :

Where did you get the impression that it's not possible?!

Can you show me the lines of .gtk-bookmarks that represent those dirs you see in your first screenshot?
And also content of /etc/xdg/user-dirs.defaults and ~/.config/user-dirs.dir (if present)

1 - >>> My content of.gtk-bookmarks is

file:///home/laco/Dokumenty > in english Documents
file:///home/laco/Obrázky > Pictures
file:///home/laco/Hudba > Music
file:///home/laco/Video > Videos
file:///home/laco/Stiahnuté > Download

2 - >>> folowing content of /etc/xdg/user-dirs.defaults

# Default settings for user directories
#
# The values are relative pathnames from the home directory and
# will be translated on a per-path-element basis into the users locale
DESKTOP=Desktop
DOWNLOAD=Downloads
TEMPLATES=Templates
PUBLICSHARE=Public
DOCUMENTS=Documents
MUSIC=Music
PICTURES=Pictures
VIDEOS=Videos
# Another alternative is:
#MUSIC=Documents/Music
#PICTURES=Documents/Pictures
#VIDEOS=Documents/Videos

3 - >>> folowing content of ~/.config/user-dirs.dir

# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
#
XDG_DESKTOP_DIR="$HOME/Plocha"
XDG_DOWNLOAD_DIR="$HOME/Stiahnuté"
XDG_TEMPLATES_DIR="$HOME/Šablóny"
XDG_PUBLICSHARE_DIR="$HOME/Verejné"
XDG_DOCUMENTS_DIR="$HOME/Dokumenty"
XDG_MUSIC_DIR="$HOME/Hudba"
XDG_PICTURES_DIR="$HOME/Obrázky"
XDG_VIDEOS_DIR="$HOME/Video"

onox (onox) wrote :

Thanks, I'll try to come up with a solution tomorrow or tuesday.

onox (onox) wrote :

Feature implemented in revision 1851. Wait for new PPAs to appear.

Changed in awn-extras:
status: Incomplete → Fix Committed

Works great. Thank you..

onox (onox) wrote :

Thanks for confirming that it works :)

Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers