Polish language outdated for 0.2.8.3

Bug #312240 reported by Luke-Jr on 2008-12-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Armagetron Advanced
Undecided
Rafał Cieślak

Bug Description

Many strings are missing from the Polish translation.

Luke-Jr (luke-jr) wrote :
Luke-Jr (luke-jr) wrote :
Changed in armagetronad:
milestone: none → 0.2.8.3
status: New → Confirmed
Luke-Jr (luke-jr) on 2008-12-29
Changed in armagetronad:
assignee: nobody → rafalcieslak256

Hello,

When I was working on this translation I done it so that it worked with 0.2.8.2, but it was 'ready' for 0.2.8.3. I'll check for missing strings (I guess some of them changed from June), and I'll send you the new version when.

Changed in armagetronad:
status: Confirmed → In Progress

Done.

And the transliterated version

Changed in armagetronad:
status: In Progress → Fix Committed
Luke-Jr (luke-jr) wrote :

In the future, "Fix Committed" should be reserved for when the change hits the tree.

Luke-Jr (luke-jr) wrote :

Grr, someone needs to do a strings freeze.

New one for you:

casacl_not_allowed CASACL usage not allowed in this context.\n

Luke-Jr (luke-jr) wrote :

Rafal, there's still a few strings missing in your new files:

#ORIGINAL TEXT: Add virtual voters that oppose every kick vote.
#voting_bias_kick_help UNTRANSLATED

#ORIGINAL TEXT: Add virtual voters that oppose every suspend vote.
#voting_bias_suspend_help UNTRANSLATED

#ORIGINAL TEXT: Add virtual voters that oppose every include vote.
#voting_bias_include_help UNTRANSLATED

#ORIGINAL TEXT: Add virtual voters that oppose every command vote.
#voting_bias_command_help UNTRANSLATED

#ORIGINAL TEXT: This value is multiplied with the current speed and added to CAMERA_SERVER_GLANCE_BACK.
#camera_server_glance_back_fromspeed_help UNTRANSLATED

#ORIGINAL TEXT: This is XORd with ALPHA_BLEND to determine the way to draw zones
#zone_alpha_toggle_help UNTRANSLATED

#ORIGINAL TEXT: Write to ladderlog: WAIT_FOR_EXTERNAL_SCRIPT (see also: WAIT_FOR_EXTERNAL_SCRIPT and WAIT_FOR_EXTERNAL_SCRIPT_TIMEOUT)
#ladderlog_write_wait_for_external_script_help UNTRANSLATED

#ORIGINAL TEXT: Allows players to pass through walls on odd occasions.
#bug_tunnel_help UNTRANSLATED

#ORIGINAL TEXT: CASACL usage not allowed in this context.\n
#casacl_not_allowed UNTRANSLATED

It seems your accurate version (with accents and so forth) is not
encoded with utf8 but with some Windows-ish encoding(Windows-1250 ?). I
see missing characters, clearly wrong characters appearing, and on top
of that, ^M's show up on newlines.

Please encode your file when saving as UTF-8.

PS: ^M's show up in the transliterated version as well, but that's less
of a big deal since we can wipe them out.

Thanks you checked. Most of them I forgot to uncomment :) What's weird is that bug_tunnel_help was actually translated... And of course casacl_not_allowed is a new string.
Hope now it's all right.

Luke-Jr (luke-jr) wrote :

Ok, I imported those into 0.2.8 svn. Since 0.2.8 is still pre-UTF-8 I converted and transliterated the minimum of polish.txt so it would work. What is the purpose of polish_transliterated.txt? It still contains non-Latin-1 characters, and does not make full use of Latin-1 for other areas. Also, I noticed it has lowercase letters for transliterated uppercase ones.

Changed in armagetronad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers