SHP Vehicle coding

Bug #895134 reported by Bug Importer on 2008-11-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Medium
Unassigned

Bug Description

DeathFrames=
StartDeathFrame=
DeathFrameRate=(def=8).

these tags dont work in YR anymore.
They did in TS.
This is another way to have "Remap Death"

DCoder DCoder (dcoder1337) wrote :

What makes you say they don't work? I've looked at the code and they do get read from artmd.ini ... provide a sample of the code so I can test it?

Bug Importer (bug-importer) wrote :

Ok, here can you have a test object, DL a shp(2,06mb o_0)
http://rapidshare.com/files/160328536/SECBOT.shp.html

Use these codes:
[SECBOT]
StartWalkFrame=8
WalkFrames=26
Voxel=no
Remapable=yes
StartStandFrame=0
;StandingFrames=8
StartFiringFrame=216
FiringFrames=29
DeathFrames=28
StartDeathFrame=448
DeathFrameRate=8
Facings=8

[HTNK]
Image=SECBOT
Turret=no

Everything work expect death animation, when unit die, it disapear, leave some debris.

DCoder DCoder (dcoder1337) wrote :

If you check http://modenc.renegadeprojects.com/VehicleTypes#sortable_table_id_3 , those flags belong in the art section.

Bug Importer (bug-importer) wrote :

yes, I know that, I added them in artmd.ini
If I added them in rules, the image would be invisible.
StartDeathFrame n DeathFrameRate is ignored.

DCoder DCoder (dcoder1337) wrote :

Add
MaxDeathCounter= ; the time in frames it takes to play the death sequence
to the art section and test again.

Bug Importer (bug-importer) wrote :

I just tried as you just said.
Same results(not working)

DCoder: "the time in frames it takes to play the death sequence "

thats not what LKO says the tag does, but I tried all kinds of values:
-How many frames one death direction is(28)
-How many directions it have(8)
-Some more...

DCoder DCoder (dcoder1337) wrote :

I will look into the code, but at first glance I didn't see any changes from the TS version... But those flags need to be documented at ModEnc anyway.

Apollo (apollo) wrote :

Would be nice if this got fixed so shp vehicles are better usable again like in TS

Also FiringSyncFrame*= is broken, this prevented unit from firing its weapon until defined frame but is totally ignored in RA2 and unit can fire immediately, normally it was combined with old charges=yes system however which is made redundant and the new replacement

IsAnimDelayedFire=yes
DelayedFireDelay=0

system is only for buildings viable?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.