Application menu for Qt

some qt apps make unity-panel-service go crazy

Reported by Francis J. Lacoste on 2012-02-21
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
High
Unassigned
appmenu-qt
High
Aurélien Gâteau
appmenu-qt (Ubuntu)
High
Unassigned

Bug Description

I upgraded to precise which contains new version of vym (Qt-based mind-mapper tool).

Now, when I start the application, the menu switches from being in the application top window to the global menu to the application to the global menu... etc.

This actually affects all applications as when I switch to them, the global menu flashes on and off.

To get the actual global menu back (as well as the global indicators) I have to close vym.

To reproduce I guess you would simply install vym and start it under Unity 3d.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 1.92-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Feb 21 10:40:03 2012
DistUpgraded: Log time: 2012-02-20 15:18:28.570039
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0209]
   Subsystem: Dell Device [1028:0209]
MachineType: Dell Inc. XPS M1330
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=f718be6c-ed61-4bb8-8004-5eec9940038b ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-21 (0 days ago)
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.name: 0N6705
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn0N6705:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu4
version.ia32-libs: ia32-libs 20090808ubuntu33
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Francis J. Lacoste (flacoste) wrote :
Omer Akram (om26er) wrote :

could you attach a video of the problem you face please?

Changed in unity (Ubuntu):
status: New → Incomplete
Francis J. Lacoste (flacoste) wrote :

Here is a recordmydesktop OGV showing the problem. After the workspace switch - which shows how this continue in GTK+ app (the terminal that is also being resized), the behavior stopped. That's because the global menu is actually completely lost at this point - there is no indicators nor global menu anymore.

Changed in unity (Ubuntu):
status: Incomplete → New
Bilal Akhtar (bilalakhtar) wrote :

Does this happen only with vym? Have you tried any other Qt app?

Francis J. Lacoste (flacoste) wrote :

No, it seems only to happen with vym.

I have tried Mumble and I use konversation as my IRC client. The menu worked fine in both case.

I tried again today, and again got a crash (like at the end of the movie) which was caught by apport this time. Reported in bug #938854.

Omer Akram (om26er) wrote :

Its also happening with MusE see bug 938361

Changed in appmenu-qt (Ubuntu):
importance: Undecided → High
Changed in vym (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in appmenu-qt (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
affects: vym (Ubuntu) → unity
Changed in unity:
status: New → Confirmed
affects: unity (Ubuntu) → appmenu-qt
summary: - global menu fails to capture vym menu and flails
+ some qt apps make unity-panel-service go crazy
Jeff H (jahtech-android-apps) wrote :

FYI, the Muse developer seem to understand what triggers the problem, and have a workaround in Muse.

See:

http://sourceforge.net/tracker/?func=detail&aid=3482422&group_id=93414&atid=604222

Aurélien Gâteau (agateau) wrote :

I am quite sure this is because the application is using two menubars: one for the main window and one to edit notes.

It's easy to fix on the application-side: one just need to call setNativeMenuBar(false) on the inner menubar.

It's quite harder to fix on appmenu-qt side, but I am going to give it a try.

Stephan Springer (geryon) wrote :

As I mentioned in the duplicate bug #948971, removing the package «appmenu-qt» is a workaround which makes vym usable again.

Aurélien Gâteau (agateau) wrote :

bug is not caused by unity-panel-service

Changed in unity:
status: Confirmed → Invalid
Changed in appmenu-qt:
assignee: nobody → Aurélien Gâteau (agateau)
status: Confirmed → In Progress
Aurélien Gâteau (agateau) wrote :

Should be fixed in r45. I pushed a package for it in ppa:agateau/appmenu-qt . Can you give it a try? (version of appmenu-qt should be 0.2.5.bzr45-0ubuntu1)

Changed in appmenu-qt:
status: In Progress → Fix Committed
Stephan Springer (geryon) wrote :

Version appmenu-qt 0.2.5.bzr45-0ubuntu1 fixes vym for me. The menu is in the panel as it should be. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-qt - 0.2.6-0ubuntu1

---------------
appmenu-qt (0.2.6-0ubuntu1) precise; urgency=low

  * New upstream release
    - fix handling of windows with multiple menubars (LP: #937892).
 -- Aurelien Gateau <email address hidden> Thu, 05 Apr 2012 17:23:55 +0200

Changed in appmenu-qt (Ubuntu):
status: Confirmed → Fix Released
Changed in appmenu-qt:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.