Samsung Q45 lacks audible sound post-resume due to missing quirk entry for model=hippo

Bug #200210 reported by pittipatti on 2008-03-09
Affects Status Importance Assigned to Milestone
ALSA driver
alsa-driver (Ubuntu)
Nominated for Hardy by pittipatti
linux (Ubuntu)
Nominated for Hardy by pittipatti
linux-ubuntu-modules-2.6.24 (Ubuntu)
Nominated for Hardy by pittipatti

Bug Description

Codec: hda_intel
Model: ALC262
HW: Notebook Samsung Q45

linux-2.6.24-5 was working fine, since 2.6.24-7 there is no sound after resume.

Even after muting & unmuting all mixers and setting them to 100% I can't get sound.
Unloading and reloading snd_hda_intel get's it back.

There were major changes to the mixers available on this model since alsa 1.0.16. A "master" mixer was introduced with this release and plugging in a headphone automatically mutes the internal speakers.

Hi pittipatti,

Care to test the latest 2.6.24-12 kernel. Then assuming the issue still exists, care to attach the following information per the kernel team's bug policy. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Also, it would be helpful to capture the dmesg output after you've suspended/resumed and had to reload snd_hda_intel. For more information regarding the kernel team bug policy, please refer to . Thanks again and we appreciate your help and feedback.

Changed in linux-ubuntu-modules-2.6.24:
status: New → Incomplete
pittipatti (pittipatti) wrote :


Attached you can find the logs you requested.

I found two interesting hints:
1. after reloading the snd_hda_intel module, the "pcm"-mixer is missing
2. after resume I can hear a hum which stops after reloading the module


pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pelle.k (pele2) wrote :

I'm not 100% sure this is related, but since i don't want to create duplicate bug reports i add to this report instead.
I never did run 2.6.24-5, only 2.6.24-10 >, but i have the same symptoms as you, using snd-hda-intel on an LG-R500 CB laptop.
Attachments will follow;

pelle.k (pele2) wrote :
pelle.k (pele2) wrote :
pelle.k (pele2) wrote :
pelle.k (pele2) wrote :
Brian Rogers (brian-rogers) wrote :

I'm having the same problem on 2.6.24-12 with snd_hda_intel. I built the latest Hardy kernel from git, and the master control is gone again. Also, I don't get any sound out of the speakers on this kernel, even before I suspend and resume.

pittipatti (pittipatti) wrote :

loading the module snd-hda-intel with the parameter "model=hippo" fixes the issue.

Brian Rogers (brian-rogers) wrote :

Hmm, that didn't resolve it for me.

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
pelle.k (pele2) wrote :

I'll have to admit i'm not quite sure if i should create a new bug or not since i use a ALC883 chip. But it seems related. Still no improvement yet, i'm on linux-generic (linux-ubuntu-modules-2.6.24-14-generic 2.6.24-14.19) as of now, and i will report if anything changes with new updates.

Brian, model= options are specific to the chip, are you also using a ALC262 like the bug report author?

Mika Fischer (zoop) wrote :

I can also confirm that on my Q45 Dalia laptop, adding "options snd-hda-intel model=hippo" fixes this issue for me.

I also seem to be using the ALC262 chip.

I suspect that Brian has a different issue. And pelle.k, if adding model=hippo does not fix this for you, you probably also have a different issue and should file a new bug.

Mika Fischer (zoop) wrote :

BTW, is there anything we can provide that can help the kernel team fix this?

MarkS (mark-marksyms) wrote :

Works on the Samsung X65 as well, not that surprising as they're got the same ALC262 chip in.

Fil (ftostevin) wrote :

Also affects Samsung R20, another ALC262 chip. "model=hippo" fixes it here.

ivan ( wrote :

Same bug on Kubuntu 8.04 (2.6.24-16-generic)
Desktop, mother board ECS 945GZT-M
sound card as per lspci: Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
sound card as per mother board spec: Realtek ALC883 6-channel HD audio CODEC

Problem fixed with:

Model name taken from:

Timo Aaltonen (tjaalton) wrote :

I've got a Asus P5K with ALC883, and using "model=6stack-dig" helped here. Without the option dmesg had this on it:

[ 56.155996] hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...

which obviously failed.

Can someone explain to me how to perform this fix? I have ALC883 also, with the same problem but I don't know which startup script loads the driver so I can modify with the "model=..." argument.

Antoine Pairet (b-ly) wrote :

Hi Jarlath,

gksudo gedit /etc/modprobe.d/alsa-base/

and add the following line at the end of the file:

options snd-hda-intel model=hippo

Thanks Antoine,

I'm using the ALC883 and I tried all the options mentioned in this report and none worked. This is surprising since "model=6stack-dig" worked for others with this device.

I went to the website that Ivan linked to, and tried all the options for my card. My laptop is a Hasee but I used "model=mitac" and my sound now works from resume. Unfortunately, the quality isn't as good now and there is less volume in the output, but I think it's more convenient this way so I'll stick with it for now.

pittipatti (pittipatti) wrote :

Dear Guys, is no user-support-forum.
If you have questions or problems *please* use an adequate forum like e.g.

Your posts here get redirected to the developers who could spend more time on solving bugs, if they wouldn't have to handle lots of unrelated emails.

It is in some kind comprehensible to ask here, after some of your keywords of your problem are mentioned here, even though the bug report was on the ALC262 chip and not on any other like ALC883.

So, please stop this conversation here now and move to eg.

Thank you!

Changed in alsa-driver:
status: Unknown → New
Sam Morris (yrro) wrote :

This is fixed for me with Debian's 2.6.24-rc4 kernel.

Sam Morris (yrro) wrote :

Reported to Debian at <>. I can't link this bug to that location because of bug #6777.

Id2ndR (id2ndr) wrote :

Not fixed for me with 2.6.27-2 (Intrepid alpha 5)

Card :
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
 Subsystem: Micro-Star International Co., Ltd. Device 7357

00:1b.0 0403: 8086:293e (rev 02)
 Subsystem: 1462:7357

Adding "options snd-hda-intel model=hippo" to /etc/modprobe.d/alsa-base works for me too, but it's just a workaround til the bug is fix.
Otherwise I had to remove and reload snd-hda-intel (after killing pulseaudio and mixer_applet2).

I also saw this in the dmesg after resuming ; I'm not sure that it is linked but it may be :
[17131.381189] ------------[ cut here ]------------
[17131.381190] WARNING: at /build/buildd/linux-2.6.27/kernel/power/main.c:176 suspend_test_finish+0x75/0x80()
[17131.381191] Modules linked in: snd_hda_intel rt73usb tun aes_x86_64 aes_generic ipv6 binfmt_misc af_packet rfcomm l2cap bluetooth ppdev acpi_cpufreq cpufreq_userspace cpufreq_stats cpufreq_conservative cpufreq_powersave cpufreq_ondemand freq_table wmi video output container pci_slot sbs sbshc battery iptable_filter ip_tables x_tables reiserfs ac sbp2 parport_pc lp parport rt2500usb arc4 ecb crypto_blkcipher snd_pcm_oss snd_mixer_oss snd_pcm crc_itu_t rt2x00usb rt2x00lib snd_seq_dummy rfkill snd_seq_oss snd_seq_midi led_class snd_rawmidi mac80211 snd_seq_midi_event psmouse snd_seq cfg80211 serio_raw nvidia(P) snd_timer snd_seq_device snd i2c_core iTCO_wdt iTCO_vendor_support soundcore snd_page_alloc shpchp pci_hotplug intel_agp button evdev ext3 jbd mbcache sg sd_mod crc_t10dif usbhid hid ahci libata scsi_mod ohci1394 dock ieee1394 sky2 ehci_hcd uhci_hcd usbcore thermal processor fan fbcon tileblit font bitblit softcursor uvesafb cn fuse [last unloaded: snd_hda_intel]
[17131.381234] Pid: 31719, comm: pm-suspend Tainted: P W 2.6.27-2-generic #1
[17131.381236] Call Trace:
[17131.381239] [<ffffffff8024e6b4>] warn_on_slowpath+0x64/0x90
[17131.381243] [<ffffffff80518d96>] ? printk+0x6c/0x6e
[17131.381246] [<ffffffff802126a4>] ? mcount_call+0x5/0x31
[17131.381248] [<ffffffff8027d9d5>] suspend_test_finish+0x75/0x80
[17131.381251] [<ffffffff8027dae4>] suspend_devices_and_enter+0x104/0x1b0
[17131.381253] [<ffffffff8027dda1>] enter_state+0xe1/0x110
[17131.381255] [<ffffffff8027de8a>] state_store+0xba/0x100
[17131.381258] [<ffffffff803a5517>] kobj_attr_store+0x17/0x20
[17131.381261] [<ffffffff8034a92a>] sysfs_write_file+0xca/0x140
[17131.381264] [<ffffffff802eb1fb>] vfs_write+0xcb/0x130
[17131.381266] [<ffffffff802eb355>] sys_write+0x55/0x90
[17131.381268] [<ffffffff8021288a>] system_call_fastpath+0x16/0x1b
[17131.381270] ---[ end trace ee218fa64963938d ]---

Daniel T Chen (crimsun) on 2008-09-21
Changed in alsa-driver:
status: New → Won't Fix
Daniel T Chen (crimsun) wrote :

For the original reporter, the following quirk needs to be added to patch_realtek.c::alc262_cfg_tbl[]:

SND_PCI_QUIRK(0x144d, 0xc510, "Samsung Q45", ALC262_HIPPO),

sam tygier (samtygier) wrote :

I am getting a near identical oops on resume from suspend on a Tyan Tempest i5000XT (S2696) system.

uname -a
Linux oberon-test 2.6.27-4-generic #1 SMP Wed Sep 24 01:29:06 UTC 2008 x86_64 GNU/Linux

[ 101.383745] ------------[ cut here ]------------
[ 101.383747] WARNING: at /build/buildd/linux-2.6.27/kernel/power/main.c:176 suspend_test_finish+0x75/0x80()
[ 101.383748] Modules linked in: ipv6 af_packet binfmt_misc bridge stp bnep rfcomm l2cap bluetooth ppdev cpufreq_userspace cpufreq_ondemand cpufreq_powersave cpufreq_stats freq_table cpufreq_conservative wmi pci_slot video output sbs sbshc battery iptable_filter ip_tables x_tables ac sbp2 lp ath5k mac80211 led_class cfg80211 wlan_scan_sta psmouse ath_rate_sample iTCO_wdt iTCO_vendor_support serio_raw ath_pci wlan ath_hal(P) snd_seq_dummy snd_hda_intel snd_seq_oss snd_seq_midi snd_pcm_oss snd_rawmidi snd_mixer_oss snd_pcm snd_seq_midi_event snd_seq i5000_edac edac_core snd_timer snd_seq_device snd soundcore snd_page_alloc parport_pc parport container tpm_infineon tpm tpm_bios shpchp pci_hotplug button evdev ext3 jbd mbcache sr_mod cdrom ata_generic sg usbhid sd_mod crc_t10dif hid ata_piix ahci pata_acpi libata ohci1394 scsi_mod dock ieee1394 ehci_hcd uhci_hcd usbcore thermal processor fan fbcon tileblit font bitblit softcursor uvesafb cn fuse
[ 101.383799] Pid: 6720, comm: pm-suspend Tainted: P 2.6.27-4-generic #1
[ 101.383800]
[ 101.383801] Call Trace:
[ 101.383807] [<ffffffff8024e8d4>] warn_on_slowpath+0x64/0x90
[ 101.383812] [<ffffffff80518dd6>] ? printk+0x6c/0x6e
[ 101.383816] [<ffffffff802126a4>] ? mcount_call+0x5/0x31
[ 101.383819] [<ffffffff8027de35>] suspend_test_finish+0x75/0x80
[ 101.383822] [<ffffffff8027df44>] suspend_devices_and_enter+0x104/0x1b0
[ 101.383824] [<ffffffff8027e201>] enter_state+0xe1/0x110
[ 101.383827] [<ffffffff8027e2ea>] state_store+0xba/0x100
[ 101.383831] [<ffffffff803a55e7>] kobj_attr_store+0x17/0x20
[ 101.383835] [<ffffffff8034ae0a>] sysfs_write_file+0xca/0x140
[ 101.383838] [<ffffffff802eb81b>] vfs_write+0xcb/0x130
[ 101.383841] [<ffffffff802eb975>] sys_write+0x55/0x90
[ 101.383844] [<ffffffff8021288a>] system_call_fastpath+0x16/0x1b
[ 101.383845]
[ 101.383846] ---[ end trace e8861d39b5fbcc5a ]---

is this the same bug? do you want any more debug info?

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged

I sent a patch the Ubuntu kernel team mailing list based on Daniel's comment -

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-7.10

linux (2.6.27-7.10) intrepid; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: do transaction from interrupt context
    - LP: #277802

  [ Ben Collins ]

  * build/d-i: Change virtio-modules udeb to prio standard

  [ Colin Ian King ]

  * SAUCE: Blacklist IBM 2656 in serio/i8042
    - LP: #21558

  [ Henrik Rydberg ]

  * Revert "SAUCE: applesmc: Add MacBookAir"
  * SAUCE: [PATCH 1/5] hwmon: applesmc: Specified number of bytes to read
    should match actual
  * SAUCE: [PATCH 2/5] hwmon: applesmc: Fix the 'wait status failed: c !=
    8' problem
  * SAUCE: [PATCH 3/5] hwmon: applesmc: Prolong status wait
  * SAUCE: [PATCH 4/5] hwmon: applesmc: Allow for variable ALV0 and ALV1
    package length
  * SAUCE: [PATCH 5/5] hwmon: applesmc: Add support for Macbook Air
  * SAUCE: hwmon: applesmc: Add support for Macbook Pro 4
  * SAUCE: hwmon: applesmc: Add support for Macbook Pro 3
  * SAUCE: hwmon: applesmc: Lighter wait mechanism, drastic improvement

  [ Leann Ogasawara ]

  * Add automatic model setting for Samsung Q45
    - LP: #200210

  [ Tim Gardner ]

  * SAUCE: Correctly blacklist Thinkpad r40e in ACPI
    - LP: #278794
  * SAUCE: Update Wacom tablet driver to 1.49
    - LP: #260675
  * SAUCE: ALPS touchpad for Dell Latitude E6500/E6400
    - LP: #270643
  * SAUCE: Fix Wacom tablet 1.49 porting errors
  * SAUCE: Enable an e1000e Intel Corporation 82567 Gigabit controller
  * SAUCE: Fix Oops in wlan_setup
    - LP: #263309

  [ Upstream Kernel Changes ]

  * ath9k: fix oops on trying to hold the wrong spinlock
  * [Bluetooth] Fix double frees on error paths of btusb and bpa10x drivers
  * [Bluetooth] Add reset quirk for new Targus and Belkin dongles
  * [Bluetooth] Add reset quirk for A-Link BlueUSB21 dongle
  * Revert "ax25: Fix std timer socket destroy handling."
  * ax25: Quick fix for making sure unaccepted sockets get destroyed.
  * netrom: Fix sock_orphan() use in nr_release
  * Revert "V4L/DVB (8904): cx88: add missing unlock_kernel"
  * SLOB: fix bogus ksize calculation
  * net: only invoke dev->change_rx_flags when device is UP
  * tcp: Fix possible double-ack w/ user dma
  * net: Fix netdev_run_todo dead-lock
  * tcp: Fix tcp_hybla zero congestion window growth with small rho and large cwnd.
  * [MIPS] Sibyte: Register PIO PATA device only for Swarm and Litte Sur
  * eeepc-laptop: Fix hwmon interface
  * hwmon: (it87) Prevent power-off on Shuttle SN68PT
  * hwmon: Define sysfs interface for energy consumption register
  * hwmon: (adt7473) Fix some bogosity in documentation file
  * hwmon: (abituguru3) Enable reading from AUX3 fan on Abit AT8 32X
  * hwmon: (abituguru3) Enable DMI probing feature on Abit AT8 32X
  * [CPUFREQ] correct broken links and email addresses
  * SLOB: fix bogus ksize calculation fix
  * Don't allow splice() to files opened with O_APPEND
  * Linux 2.6.27

 -- Tim Gardner <email address hidden> Wed, 08 Oct 2008 21:19:34 -0600

Changed in linux:
status: Triaged → Fix Released

It's not likely that this will qualify for SRU for linux-ubuntu-modules-2.6.24 . For more information refer to . Thanks.

Changed in linux-ubuntu-modules-2.6.24:
status: Triaged → Won't Fix

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.