[system settings] OAuth based plug-ins appear to crash under poor network connectivity

Bug #1349975 reported by dobey on 2014-07-29
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Online Accounts: Account plugins
High
Alberto Mardegan
Ubuntu UX
High
Matthew Paul Thomas
webapps-sprint
High
Alberto Mardegan
account-plugins (Ubuntu)
Undecided
Unassigned
signon-plugin-oauth2 (Ubuntu)
High
Alberto Mardegan

Bug Description

When going to the Accounts page of System Settings, and attempting to add a Google/Twitter/etc… OAuth based account on my Nexus 4, the plug-ins are appearing to crash, and I get sent back to the accounts list. This appears to be due to poor network connectivity, as I'm on wifi, but the AP is at the other end of my house, resulting in poor connection which often drops. If I move the phone close to the AP, the pages then load and do not seem to crash, as the connectivity is greatly improved.

Instead of crashing/exiting/whatever is happening, I think these plug-ins need to show an error or something, to tell the user something is wrong. Otherwise, it simply appears the software is very crashy.

<https://wiki.ubuntu.com/OnlineAccounts#phone-settings>: "If there is a networking or HTTP error in loading the page, or in submitting the form, the contents of the Web frame should be replaced by the text “This service is not available right now. Try again later.” and a “Try Again” button."

Related branches

David Barth (dbarth) on 2014-07-31
Changed in account-plugins:
importance: Undecided → High
status: New → Incomplete
tags: added: rtm14
dobey (dobey) wrote :

Why was this changed to Incomplete status? No additional information has been asked for.

David Barth (dbarth) wrote :

hmm, right, NEW was fine actually. This bug and the other one are the same I'm pretty sure.

Changed in account-plugins:
status: Incomplete → New
David Barth (dbarth) on 2014-09-09
tags: added: touch-2014-09-18
Changed in account-plugins:
assignee: nobody → Alberto Mardegan (mardy)
tags: added: touch-2014-09-25
removed: touch-2014-09-18
David Barth (dbarth) wrote :

Further to that issue, as which may be a separate issue, the account creation process sometimes fails just after the app approval step (ie you approve app Ubuntu to use your identity with provider Evernote say), and just before the account can be created in OA.

davmor2 recently experienced the issue from within the reminder-apps, and then separately from USS and creating an Evernote account. Logs and traces available.

Alberto Mardegan (mardy) wrote :

I also saw something weird, with the Evernote login page appearing for a fraction of a second and then the whole page turning completely white. After rebooting, the problem was gone. However, in that case we didn't get a network error from the webview, so I'm afraid there's nothing we can do in such a situation.

tags: added: beta qa-daily-testing

@mardy: I think that loops to the need to have a clear error indication
when the account creation process fails, for various reasons, including
poor network connectivity.

On Thu, Sep 25, 2014 at 7:36 PM, Jean-Baptiste Lallement <
<email address hidden>> wrote:

> ** Tags added: beta qa-daily-testing
>
> --
> You received this bug notification because you are a member of Ubuntu
> Online Accounts, which is subscribed to Online Accounts: Account
> plugins.
> https://bugs.launchpad.net/bugs/1349975
>
> Title:
> OAuth based plug-ins appear to crash under poor network connectivity
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/account-plugins/+bug/1349975/+subscriptions
>

David Barth (dbarth) on 2014-09-30
tags: added: touch-2014-10-09
removed: touch-2014-09-25
David Barth (dbarth) on 2014-09-30
Changed in account-plugins:
status: New → Triaged
tags: added: lt-category-noimpact lt-date-20141003 lt-prio-high

Adding ubuntu-ux, as we need input from design about whether we need to show an error message in such cases.

Meanwhile, can you try to reproduce the issue by stopping the network,
using cellular data only, or switching to a misconfigured wifi network to
simulate the conditons?

On Tue, Oct 7, 2014 at 3:17 PM, Alberto Mardegan <<email address hidden>
> wrote:

> Adding ubuntu-ux, as we need input from design about whether we need to
> show an error message in such cases.
>
> ** Also affects: ubuntu-ux
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of Ubuntu
> Online Accounts, which is subscribed to Online Accounts: Account
> plugins.
> https://bugs.launchpad.net/bugs/1349975
>
> Title:
> OAuth based plug-ins appear to crash under poor network connectivity
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/account-plugins/+bug/1349975/+subscriptions
>

David Barth (dbarth) on 2014-10-10
tags: added: touch-2014-10-16
removed: touch-2014-10-09
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Triaged

This seems to effect oauth in evernote and fitbit which both seem to be oauth1.0a

Selene ToyKeeper (toykeeper) wrote :

FWIW, even though dbarth's silo rtm-003 today lists this bug as something it fixes, it doesn't. Doesn't look like the silo even attempted to do so. Will need another landing for that.

David Barth (dbarth) wrote :

@Selene: correct, the other branch helped in case of poor network connectivity, but the real fix for that crash will be not to crash...

tags: added: touch-2014-11-13
removed: touch-2014-10-16
tags: added: ota-1
removed: rtm14
Changed in ubuntu-ux:
importance: Undecided → High
summary: - OAuth based plug-ins appear to crash under poor network connectivity
+ [system settings] OAuth based plug-ins appear to crash under poor
+ network connectivity
Changed in ubuntu-ux:
status: Triaged → In Progress
Matthew Paul Thomas (mpt) wrote :
Changed in ubuntu-ux:
status: In Progress → Fix Committed
description: updated
David Barth (dbarth) on 2015-08-05
Changed in webapps-sprint:
milestone: none → sprint-12
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → High
status: New → Triaged
David Barth (dbarth) on 2015-09-21
Changed in webapps-sprint:
milestone: sprint-12 → sprint-14
Alberto Mardegan (mardy) on 2015-09-30
Changed in signon-plugin-oauth2 (Ubuntu):
status: New → In Progress
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → High
David Barth (dbarth) on 2015-10-05
Changed in signon-plugin-oauth2 (Ubuntu):
status: In Progress → Fix Committed
Changed in account-plugins (Ubuntu):
status: New → Fix Committed
Changed in webapps-sprint:
status: Triaged → Fix Committed
Changed in account-plugins:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-plugin-oauth2 - 0.23+16.04.20151028-0ubuntu1

---------------
signon-plugin-oauth2 (0.23+16.04.20151028-0ubuntu1) xenial; urgency=medium

  [ Alberto Mardegan ]
  * New upstream release
    - OAuth: propagate network and SSL errors from SignOnUI (LP: #1349975)
    - Build: remove unused dependency on xmlpatterns, remove unused variables

  [ CI Train Bot ]
  * New rebuild forced.

 -- David Barth <email address hidden> Wed, 28 Oct 2015 15:59:52 +0000

Changed in signon-plugin-oauth2 (Ubuntu):
status: Fix Committed → Fix Released
Matthew Paul Thomas (mpt) wrote :

Verified fixed in Ubuntu 15.04 r224. The "Try Again" button is present and works.

Changed in ubuntu-ux:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2016-04-26
Changed in account-plugins:
status: Fix Committed → Fix Released
Changed in webapps-sprint:
status: Fix Committed → Fix Released
Changed in account-plugins (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers