Zim

Can not create new page in zim 0.45

Bug #545630 reported by nomnex on 2010-03-24
42
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Zim
Critical
Jaap Karssenberg

Bug Description

I have just installed today 0.45

I create a new notebook but no home page is saved as default, as it used to be in version 0.44

See print screen attached

Is it a bug?

nomnex (nomnex) wrote :
nomnex (nomnex) wrote :

all deb_0.45 is not usable for me

nomnex (nomnex) wrote :

Also the notebooks created with zim 0.44 open when I 2x click on a notebook.zim file or use the zim GUI, but the pages do not display any content in zim 0.45 (blank pages).

Can you run "zim -D" from a terminal (after closing all zim windows and trayicon) and attach the output ?

Changed in zim:
status: New → Confirmed
importance: Undecided → Critical

Stupid last minute fix before release broke the template for new pages. Effectively making it impossible to open any page that does not yet exist.

Changed in zim:
assignee: nobody → Jaap Karssenberg (pardus-cpan)
nomnex (nomnex) wrote :

Hey Jaap. Can you update the bug thread to let us know when we can download a new working 0.45 zim.deb package. Thanks in advance.

See mailing list message - will have to release a 0.46 version to fix this bug.

summary: - New all deb 0.45-home page missing
+ Can not create new page in zim 0.45

Zim 0.46 is now available with the fix for this issue.

Changed in zim:
status: Confirmed → Fix Released
Dale L. (doublewitt) wrote :

I am having this problem with ZIM .53

I cannot create a new page. If I select "create new page" from the right-click menu in the index pane, and once the dialog appears, if I begin to type into the text field to enter the page name, my whole system freezes. The only work-around I have found is to use copy/paste into that same input box for the new page name and there is no problem. I can create new page also with camelcase entries. It only happens when I directly type into the input box. I just cannot create a new page in the most obvious or normal way. This has happened to me countless times because I keep forgetting that this problem is there. Other than that, love my ZIM...!

I am using Ubuntu 10.04 LTS.

JesseLiu (alayasix) wrote :

e,I have got the same problem.

After I ran zim 0.57.I saw a page called Home.Then I deleted the page to create a new one.
There came out a dialog said "Could not save page: Home".

here is some information:

This is zim 0.57
Python version is sys.version_info(major=2, minor=7, micro=3, releaselevel='final', serial=0)
Gtk version is (2, 24, 10)
Pygtk version is (2, 24, 0)
Platform is posix
Zim revision is:
  branch: pyzim-trunk
  revision: 600 <email address hidden>
  date: 2012-10-08 21:17:51 +0200

======= Traceback =======
  File "/usr/local/lib/python2.7/dist-packages/zim/gui/widgets.py", line 2893, in do_response
    destroy = self.do_response_ok()
  File "/usr/local/lib/python2.7/dist-packages/zim/gui/__init__.py", line 3111, in do_response_ok
    self.ui.open_page(page)
  File "/usr/local/lib/python2.7/dist-packages/zim/gui/__init__.py", line 1202, in open_page
    raise AssertionError, 'Could not close page'
AssertionError: Could not close page

how could I fix it ,or I had to reinstall it?

@JesseLiu: This report is closed and I'm pretty sure what you experience is a different report from the parent, please open a new report for this item

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers