Zim

Show Link Map returns error 1:44:unexpected char '-'

Bug #1483018 reported by SImon Haisell on 2015-08-09
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Zim
Undecided
Unassigned

Bug Description

Hi, I've been using zim for a couple of years now. Recently the "Show Link Map" option has been returning the error:

Dot viewer:
1:44:unexpected char '-'

I initially thought this might be caused by imported text (soft hyphens?) but I tried it out on a clean wiki and ran into the same problem. Zim can produce maps up to about 30-50 nodes and then starts returning this error and giving a blank map.

I am using the latest 0.63 version of zim on ubuntu.

zim -D shows:

INFO: This is zim 0.63
DEBUG: Python version is sys.version_info(major=2, minor=7, micro=6, releaselevel='final', serial=0)
DEBUG: Platform is posix
DEBUG: Zim revision is:
  branch: zim-trunk
  revision: 765 <email address hidden>
  date: 2015-06-13 21:48:28 +0200
DEBUG: Action: show_linkmap
DEBUG: Opening dialog "LinkMap - Zim"

Any ideas what is causing this?

Probably it is caused by an update in the GraphViz software. The dot viewer
widget parses an internal fomrat of the GraphViz toolkit and tends to break
with syntax changes :(

Can you check the version of the "dot" command that you have?

On Sun, Aug 9, 2015 at 6:34 PM, SImon Haisell <email address hidden> wrote:

> Public bug reported:
>
> Hi, I've been using zim for a couple of years now. Recently the "Show
> Link Map" option has been returning the error:
>
> Dot viewer:
> 1:44:unexpected char '-'
>
> I initially thought this might be caused by imported text (soft
> hyphens?) but I tried it out on a clean wiki and ran into the same
> problem. Zim can produce maps up to about 30-50 nodes and then starts
> returning this error and giving a blank map.
>
> I am using the latest 0.63 version of zim on ubuntu.
>
> zim -D shows:
>
> INFO: This is zim 0.63
> DEBUG: Python version is sys.version_info(major=2, minor=7, micro=6,
> releaselevel='final', serial=0)
> DEBUG: Platform is posix
> DEBUG: Zim revision is:
> branch: zim-trunk
> revision: 765 <email address hidden>
> date: 2015-06-13 21:48:28 +0200
> DEBUG: Action: show_linkmap
> DEBUG: Opening dialog "LinkMap - Zim"
>
> Any ideas what is causing this?
>
> ** Affects: zim
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to Zim.
> https://bugs.launchpad.net/bugs/1483018
>
> Title:
> Show Link Map returns error 1:44:unexpected char '-'
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zim/+bug/1483018/+subscriptions
>

SImon Haisell (sphaisell) wrote :

Dot -V gives:

dot - graphviz version 2.36.0 (20140111.2315)

Nick (nick222-yandex) wrote :

Same error

Xubuntu 15.10

This is zim 0.65
Python version is sys.version_info(major=2, minor=7, micro=10, releaselevel='final', serial=0)
Platform is posix
No bzr version-info found
Not running from a source dir

dot - graphviz version 2.38.0 (20140413.2041)

I was under the impression this issue was fixed, but apparently not completely :(

Tested myself also with dot - graphviz version 2.38.0 (20140413.2041) -- up to date ubuntu install -- but can't reproduce.

In the file "zim/plugins/linkmap.py" line 95 should read:
#~ print '\n'.join(dotcode)+'\n'

Please edit this line and remove the "#~ " from the begin. THis should print out the graphviz code that goes into the linkmap. Having this output should help with debugging.

I also have Jaap's version, and get the error mentioned. The graphviz code (which could be processed with my dot command) is the following:

Nick (nick222-yandex) wrote :

I cannot see anything new after editing line 96 of "/usr/lib/python2.7/dist-packages/zim/plugins/linkmap.py"

If I open help-file Zim - I see good map in "Bugs" and error in "Plugins: Ditaa Editor" (for example).

Xubuntu 17.04-64

Thanks Nick for pointing me to failures in the manual - that helps to
reproduce here :)

On Mon, Apr 24, 2017 at 3:05 PM Nick <email address hidden> wrote:

> I cannot see anything new after editing line 96 of "/usr/lib/python2.7
> /dist-packages/zim/plugins/linkmap.py"
>
> If I open help-file Zim - I see good map in "Bugs" and error in
> "Plugins: Ditaa Editor" (for example).
>
> Xubuntu 17.04-64
>
> --
> You received this bug notification because you are subscribed to Zim.
> https://bugs.launchpad.net/bugs/1483018
>
> Title:
> Show Link Map returns error 1:44:unexpected char '-'
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zim/+bug/1483018/+subscriptions
>

Hack to work around in rev864

Changed in zim:
status: New → Fix Committed

Cool, fixed for me.

Mobile:(+36 20)356 9656
"Olyan lángész vagyok, hogy poroltóval kellene járnom!"

On Tue, Apr 25, 2017 at 8:31 PM, Jaap Karssenberg <
<email address hidden>> wrote:

> Hack to work around in rev864
>
> ** Changed in: zim
> Status: New => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1483018
>
> Title:
> Show Link Map returns error 1:44:unexpected char '-'
>
> Status in Zim:
> Fix Committed
>
> Bug description:
> Hi, I've been using zim for a couple of years now. Recently the "Show
> Link Map" option has been returning the error:
>
> Dot viewer:
> 1:44:unexpected char '-'
>
> I initially thought this might be caused by imported text (soft
> hyphens?) but I tried it out on a clean wiki and ran into the same
> problem. Zim can produce maps up to about 30-50 nodes and then starts
> returning this error and giving a blank map.
>
> I am using the latest 0.63 version of zim on ubuntu.
>
> zim -D shows:
>
> INFO: This is zim 0.63
> DEBUG: Python version is sys.version_info(major=2, minor=7, micro=6,
> releaselevel='final', serial=0)
> DEBUG: Platform is posix
> DEBUG: Zim revision is:
> branch: zim-trunk
> revision: 765 <email address hidden>-
> pygsvbwdn2sefqhe
> date: 2015-06-13 21:48:28 +0200
> DEBUG: Action: show_linkmap
> DEBUG: Opening dialog "LinkMap - Zim"
>
> Any ideas what is causing this?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zim/+bug/1483018/+subscriptions
>

Nick (nick222-yandex) wrote :

Cool, everything become OK :)

Changed in zim:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers