Zim

Comment 1 for bug 1483018

Probably it is caused by an update in the GraphViz software. The dot viewer
widget parses an internal fomrat of the GraphViz toolkit and tends to break
with syntax changes :(

Can you check the version of the "dot" command that you have?

On Sun, Aug 9, 2015 at 6:34 PM, SImon Haisell <email address hidden> wrote:

> Public bug reported:
>
> Hi, I've been using zim for a couple of years now. Recently the "Show
> Link Map" option has been returning the error:
>
> Dot viewer:
> 1:44:unexpected char '-'
>
> I initially thought this might be caused by imported text (soft
> hyphens?) but I tried it out on a clean wiki and ran into the same
> problem. Zim can produce maps up to about 30-50 nodes and then starts
> returning this error and giving a blank map.
>
> I am using the latest 0.63 version of zim on ubuntu.
>
> zim -D shows:
>
> INFO: This is zim 0.63
> DEBUG: Python version is sys.version_info(major=2, minor=7, micro=6,
> releaselevel='final', serial=0)
> DEBUG: Platform is posix
> DEBUG: Zim revision is:
> branch: zim-trunk
> revision: 765 <email address hidden>
> date: 2015-06-13 21:48:28 +0200
> DEBUG: Action: show_linkmap
> DEBUG: Opening dialog "LinkMap - Zim"
>
> Any ideas what is causing this?
>
> ** Affects: zim
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to Zim.
> https://bugs.launchpad.net/bugs/1483018
>
> Title:
> Show Link Map returns error 1:44:unexpected char '-'
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zim/+bug/1483018/+subscriptions
>