Comment 2 for bug 1239834

Revision history for this message
Kurt Griffiths (kgriffs) wrote :

Hi Chandan,

Basically, if an attribute is only used within the class, the name should be prefixed with an underscore to designate it as a "private" attribute.

You'll need to just go through all the classes looking for cases where:

  self.should_be_private

can be renamed to:

  self._should_be_private