ImportError: cannot import name QtWebkit

Bug #1776853 reported by WANG Chao on 2018-06-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Yade
Undecided
Unassigned

Bug Description

Dear Developer,

I have installed the newest YADE trunk on Ubuntu 16.04 and finished the compilation with the option DUSE_QT5=ON. But when i run the executable file, the following error jumps out:

gcf@gcf-OptiPlex-9020:/media/gcf/3TB-FOUR/Yade/install/bin$ ./yade-2018-06-10.git-2878c92
Welcome to Yade 2018-06-10.git-2878c92
TCP python prompt on localhost:9000, auth cookie `csduse'
XMLRPC info provider on http://localhost:21000
Traceback (most recent call last):
  File "./yade-2018-06-10.git-2878c92", line 297, in <module>
    import yade.qt
  File "/media/gcf/3TB-FOUR/Yade/install/lib/x86_64-linux-gnu/yade-2018-06-10.git-2878c92/py/yade/qt/__init__.py", line 16, in <module>
    from PyQt5 import QtWebKit, QtWebKitWidgets
ImportError: cannot import name QtWebKit

I opened the python and tried to import the QtWebKit, but it seems that there is no QtWebKit in the PyQt5.

gcf@gcf-OptiPlex-9020:~$ python
Python 2.7.15 |Anaconda, Inc.| (default, May 1 2018, 23:32:55)
[GCC 7.2.0] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from PyQt5 import QtWebkit
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: cannot import name QtWebkit
>>> import PyQt5
>>>

Please see [1] for similar problem and solution by Klaus:
https://answers.launchpad.net/yade/+question/446239

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers