[i965] low intel graphics performance - again

Bug #416073 reported by Ivan Stetsenko on 2009-08-19
196
This bug affects 34 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
linux (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I've been experiencing it since clean install of alpha2, but now I've booted from Hardy LiveDVD and done some benchmarking.

Extreme Tux Racer IS a benchmark, isn't it?

Game settings: all graphics extras are disable, except from FPS; 800x600 resolution.

Hardy: ~60 FPS
Karmic: ~20 FPS

3 times drop!

glxgears (definitely not a benchmark, but...)

Hardy: 4200 frames in 5 secs
Karmic: 1400 frames in 5 secs

3 times drop again. And compiz feels slower as well.

Lenovo R61i with X3100

libgl1-mesa-dri 7.5-1ubuntu1
xserver-xorg-video-intel 2:2.8.0-0ubuntu2
libdrm-intel1 2.4.12-1ubuntu1
xserver-xorg 1:7.4+3ubuntu5
linux-image-2.6.31-5-generic 2.6.31-5.24

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)

Ivan Stetsenko (stetzen) wrote :

I've noticed low performance since the .31 kernel series (well, once I got it to work without flickering). The .30 kernels all are very fast for my i945.

Could this be related to #382017?

summary: - [karmik][GM965]low intel graphics performance - again
+ [karmic][GM965] low intel graphics performance - again
Ivan Stetsenko (stetzen) wrote :

I've installed 2.6.30-2-386 - no effect. I've installed xorg-edgers packages - no effect as well.

AmadeuS (sarelgrin) wrote :

Same here.

Even though all the corruption stopped everything simply feels more sluggish, mostly with the little things. For instance windows don't move nicely it seems like every moment there's a very small bounce as if the vsync is out. (with compiz enabled)

General responsiveness is bad.

It was better with the 2.6.30 series...

Forwarding this bug from Ubuntu reporter Ivan Stetsenko:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/416073

[Problem]
Extreme Tux Racer shows a significant 66% performance regression compared with Hardy.

[Original Description]
I've been experiencing it since clean install of alpha2, but now I've booted from Hardy LiveDVD and done some benchmarking.

Extreme Tux Racer IS a benchmark, isn't it?

Game settings: all graphics extras are disable, except from FPS; 800x600 resolution.

Hardy: ~60 FPS
Karmik: ~20 FPS

3 times drop!

glxgears (definitely not a benchmark, but...)

Hardy: 4200 frames in 5 secs
Karmik: 1400 frames in 5 secs

3 times drop again. And compiz feels slower as well.

Lenovo R61i with X3100

libgl1-mesa-dri 7.5-1ubuntu1
xserver-xorg-video-intel 2:2.8.0-0ubuntu2
libdrm-intel1 2.4.12-1ubuntu1
xserver-xorg 1:7.4+3ubuntu5
linux-image-2.6.31-5-generic 2.6.31-5.24

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)

Created an attachment (id=28829)
Xorg.0.log

Geir Ove Myhr (gomyhr) on 2009-08-20
tags: added: 965gm karmic performance

I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=23433 and subscribed you to it. Please follow up with them in case they need further information or wish you to test something.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed

Performance regression also affects GM45

After an update to mesa 7.6.0~git20090817.7c422387-0ubuntu2 things became better. I've noticed a 75% performance increase, but 35 fps are still much lower than 60 fps with 7.0.3~rc2-1ubuntu3.

I recently upgraded from Jaunty to Karmic and found that the 3D performance can be greatly effected by the kernel version. Using /usr/games/pinball as a reference ("Tux" table with effects turned off), I get:

--

Linux version 2.6.27-14-generic (buildd@palmer) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11) ) #1 SMP Fri Jul 24 22:19:33 UTC 2009

pinball => 8 fps using software rendering (acceleration will not kick in).

--

Linux version 2.6.28-14-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #47-Ubuntu SMP Sat Jul 25 00:28:35 UTC 2009

pinball => 30 fps using Tungsten Graphics Mesa DRI Intel(R) 945GME GEM 20090712 2009Q2 RC3 x86/MMX/SSE2

--

Linux version 2.6.31-6-generic (buildd@rothera) (gcc version 4.4.1 (Ubuntu 4.4.1-1ubuntu3) ) #26-Ubuntu SMP Fri Aug 21 17:48:16 UTC 2009

pinball => 115 fps using Tungsten Graphics Mesa DRI Intel(R) 945GME GEM 20090712 2009Q2 RC3 x86/MMX/SSE2

--

In all cases:

xserver-xorg-video-intel 2:2.8.0-0ubuntu2
xserver-xorg-core 2:1.6.3-1ubuntu4
libgl1-mesa-dri 7.5-1ubuntu1

CPU is Intel Atom, running hyperthreading at 1600MHz

Using the latest kernel, games run quite smoothly, using older kernels they feel a bit "surgy" like some stop/start is happening. Flash games also run nicely, but not with the older kernels. Strangely, glxgears runs terribly jerky on my system, even with the 2.6.31-6 kernel.

The extreme tux racer only manages around 20 fps but still feels smooth to play.

How about if you disable SwapbuffersWait (in xorg.conf, under intel Device section)?

Well, I changed the SwapbuffersWait setting to false (I also had to write a xorg.conf file since ubuntu 9.10 comes without it).

Performance didn't show any change, however something is changed because the tearing is back now. Tried to re-enable the SwapbuffersWait but no change. The tearing continues unless I delete the new xorg.conf (which is extremely minimal and ordinary)

Anyways the SwapbuffersWait doesn't matter to the performance. windows still don't move very smoothly, tux racer gives the same framerate (it's even slightly better with the original configuration, 35fps-SwapbuffersWait off, 38fps-original)

compiz and kwin performance is still bad. (and with tearing)

Created an attachment (id=28998)
This is the Xorg log from when I changed the SwapbuffersWait option

Added xorg log

Created an attachment (id=28999)
xorg.conf - SwapbuffersWait - disabled

For those who use Kubuntu - at my case this bug is related with that one:

https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/421067

In particular, say, etracer started from fluxbox shows fps ~2x faster rather started from KDE (it's a sin, but glxgears is also ~1.6x faster).

You are using the same version of etracer between the two, right?

Bryce Harrington (bryce) on 2009-09-02
summary: - [karmic][GM965] low intel graphics performance - again
+ [i965] [karmic][GM965] low intel graphics performance - again

I can confirm with KDE effects being turned on I have etracer's fps ~2x slower rather at case when effects are turned off (or, instead of KDE, just using, say, fluxbox). Up to date Kubuntu Karmic (testing) is in use. My card is Intel X3000.

Eric says this is caused by DRI2, unblocking Q3 release.

Ivan, along with the same etracer, are you using the same compositing setup between the two systems?

In KDE it is sufficient to press Alt-Shift-F12 to "toggle" performance almost 2 times *on-the-fly* - i.e. with the same instance of currently running etracer.

Sorry for the delay with providing info...

extremetuxracer 0.4-2ubuntu1, which is a default version from karmik repo.

I'm using default KDE compositing, kde-window-manager 4:4.3.1-0ubuntu8, again default karmik version

Secondly (it looks like I've forgot to mention it in the original report), the regression I'm talking about can be observed in the fullscreen mode; if the application is fullscreen, the performance does not depend from compositing. I mean, Hardy's 60 FPS and Karmik's 30 fps are both fullscreen.

If I'm running etracer in windowed mode, it shows the same lower performance (30 fps) if compositing is enabled and even lower performance (15-20 fps) with compositing. So there are two separate bugs here, I think.

Changed in xserver-xorg-video-intel:
status: Confirmed → In Progress

glxgears runs smooth now. Seems to genlock at exactly 60 frames per second.

Linux version 2.6.31-10-generic (buildd@rothera) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu1) ) #35-Ubuntu SMP Tue Sep 22 17:33:42 UTC 2009

xserver-xorg-video-intel 2:2.8.1-1ubuntu2
libgl1-mesa-dri 7.6.0~git20090817.7c422387-0ubuntu5

Extreme tux racer is down to around 15 frames per second.

pinball now runs at 55 fps or sometimes down to 50, Tungsten Graphics, Inc. Mesa DRI Intel(R) 945GME GEM 20090712 2009Q2 RC3 x86/MMX/SSE2

Same processor as above (intel Atom 1600MHz hyperthreading)

Bryce Harrington (bryce) on 2009-10-03
tags: added: kubuntu
Cian Davis (davisc) wrote :

Not sure this is the right bug. There's a few bugs with similar problems.

I upgraded to Karmic yesterday on a Dell Latitude D410 with a 915GM. Having significant problems with X.org. Absorbing 100% of CPU a lot of the time. Seems to be with Mozilla apps - Firefox and Thunderbird. Seems to be redrawing in these apps. Worse with heavy Web 2.0/AJAX apps on Firefox.

Compiz is disabled and cannot be enabled. The weird thing is I managed to enable Compiz last night and everything was fine. Will attempt to refine the problem.

ilna (a-gaydenko) wrote :

Cian, look at '/dev/dri' - have you something there? Probably it is another problem with workaround to reinstall libdrm2 and libdrm-intel1. There is a dedicated bug wrt /dev/dri problem (try to search).

Shady Samir (shadysamirsobhi) wrote :

I upgraded from Jaunty to Karmic. I cant set my screen resolution higher than 800x600 and the PC does not wake up from display sleep. I'm on an integrated Intel 82945G/GZ display

After inserting a second monitor, use it and then cut it down quite a performance and visual effects have also been disabled.

Excuse my English.

The same like Jacob Peddicord wrote: On the 945GME good performance even with compiz, booting the .30-kernel. Poor performance with the .31-kernel.
Like Cyan Davies wrote- no compiz with kernel .31.
Is the bug related to bug #442197?

hewbert (josh-hewbert) wrote :

Seems like performance here has degraded a bit in the past few days as well. There's been so many updates it's hard to say what the culprit may be ;) (perhaps the kernel bumps)..

I don't have the i965, but it sounds related:
Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

I haven't done any "official" benchmarking, but window redrawing does seem to lack the performance it did a few days ago, and I've noticed a bit more flickering with various other things (noticeably the 'busy' mouse cursor, drawing windows, etc).

2.6.31-12-generic #39-Ubuntu SMP
xserver-xorg-video-intel: 2:2.8.1-1ubuntu2
libgl1-mesa-dri: 7.6.0

ilna (a-gaydenko) wrote :

I have noticed the same degrading as you, Hhewbert , but I guess it is related to changings in kernel's scheduler. Besides less DE responsivity I catched some other slowdown. Say, MPD player clicks when some JVM application is eating CPU actively (such building NetBeans from sources).

ilna (a-gaydenko) wrote :

(ugh.. Sorry for typo in your name, Hewbert!)

hewbert (josh-hewbert) wrote :

After a little testing, it does seem that the culprit (in my case) is xserver-xorg-video-intel-2.8. I reverted to 2.4 and things were definitely improved, but there were obvious side-effects to reverting.

Oddly enough, running glxgears reports a better frame rate under 2.8, but is definitely choppy, whereas 2.4 gave a lower frame rate, but was not choppy.

I'm just going by the overall "feel" of things, so I apologize for the lack of concrete data on this. I'm more than willing to provide more information if it'd be beneficial.

One more vote for this. My lscpi returns:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Forceflow (baertman) wrote :

Another vote for this:

LSPCI returns:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

General sloppyness, worse with Firefox. I have UXA enabled in my xorg.conf, but I think that's default since Karmic?

Emil Oppeln-Bronikowski (opi) wrote :

I can confirm this, too. Running glxgears yelds ~1200 FPS in 5 seconds. Overall interface seems laggy.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

bigbrovar (bigbrovar) wrote :

I don't know if its any related to this blog, but graphic performance on my kubuntu 9.10 just don't cut it. The whole system is so slow and laddy. Is there anything I can do to improve performance. Maybe downgrade to the version of xserver which ships with jaunty? :( . am using the Intel GMi965

PatrikG (patrik-grundstrom) wrote :

Confirmed on this as well:

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

Performance is "stuttering", windows are blurred for about 0.5s when opening, glxgears runs smooth for a couple of seconds, then stops and then continues. Performance has dropped from ~2800 frames/sec to ~1500 with glxgears.

chesterm (mail-rmartins) wrote :

I confirm this too:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

Bram Avontuur (bram-avontuur) wrote :

Same problem here, with latest Karmic:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Linux li3910 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

Tux racer windowed/fullscreen at 640x480 gets 8fps, glxgears 1800-200 frames per 5 seconds.

It's about as bad as it was in Jaunty. Tux racer in vista on the same machine runs many times faster.

Same here:
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

With compiz:
Compiz benchmwark - circa 18-20fps
Tux racer fullscreen - 5.5fps
glxgears window - 3400 frames in 5 secs
glxgears fullscreen - 240 frames in 5 secs

Without compiz:
Tux racer fullscreen - 6.0fps
glxgears window - 3240 frames in 5 secs
glxgears fullscreen - 300 frames in 5 secs

Henrik Peytz (henrik-peytz) wrote :

Another vote for intel drivers not working optimally. Installed netbook-remix interface but the interface is sluggish to say the least. Moving windows around is slow and choppy (the larger the windows, the slower and choppier it is moving it around).

XXXXXXXX@Sephiroth:~$ lspci
00:00.0 Host bridge: Intel Corporation 82Q33 Express DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82Q33 Express Integrated Graphics Controller (rev 02)

Card is an integrated Intel GMA 3100.

Gonna try the Xorg-edgers ppa and see if it makes a difference.

Francisco (fbnaulin) wrote :

Same problem in:

lspci | egrep "VGA"
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

Henrik Peytz (henrik-peytz) wrote :

I tried using the xorg-edgers ppa, it made things a little better for me. Windows now move smoothly if they aren't too big. Still, it's not a panacea, though I'm not certain what kind of performance I'm supposed to expect from an onboard gpu running in 1280x1024.

baytuni (oytun-peksel) wrote :

Just upgraded from jaunty and had to turn compiz off. It was not perfect but more smooth before.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

Paul Loughman (snowhog) wrote :

Running Kubuntu Jaunty 9.04 KDE 4.3.2. My Graphics consist of:

Graphics: Card Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller X.Org 1.6.0 Res: 1440x900@59.9hz
GLX Renderer Mesa DRI Intel 945GM GEM 20090326 2009Q1 RC2 x86/MMX/SSE2 GLX Version 1.4 Mesa 7.4

In Kubuntu Karmic 10.04, desktop performance is 'not good' and I have no compositing. I had to return to Jaunty.

almadana (almadana) wrote :

I just upgraded to Karmic, and windows composition was broken, the whole display became sluggish, with a max resolution of 800x600!

I disabled the UXA line in xorg.conf without effect.

Card:
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

Xserver:
xserver-xorg-core 2:1.6.4-2ubuntu4
xserver-xorg-video-intel 2:2.9.0-1ubuntu2

Kernel
2.6.31-14-generic

I'll try to boot 2.6.30 and see what happens.

almadana (almadana) wrote :

I switched to 2.6.30, and got a reasonable 1200x720(or whatever) resolution back!! Compiz compositing can't be enabled, and the overall performance when drawing windows is still a bit turtlier (I meant slow).

almadana (almadana) wrote :

I don't know if it's been already pointed out, but Xorg CPU load can rise as high as 99% (that is my 2 CPUs running top load) when I resize a window or switch between desktops!!!!!!.

Oleksiy Lukin (alukin) wrote :

After upgrade X works only in log-graphics mode. I seek and tired of ubuntu stories with intel graphics.

Bartek Celary (karaphka) wrote :

After upgrading to Karmic, my display wont come back after it goes to sleep... If you need further logs - let me know.

Looking at the profile of etracer on my GM45, there's not much we can do with this app --there may be a few percent to shave off total, but for the most part the cpu's being wasted on fixed function OpenGL handling. framerate with default config is reported between 30 and 60 fps (sadly, there doesn't appear to be a demo mode that would make etracer a reliable benchmark application) regardless of whether I run xcompmgr -a or not.

To track down a regression, we're going to need to bring up the two systems side by side with sysprof and top. Sadly, we won't be able to compare perf output between the two, which is the other key to performance debugging.

I am also experiencing very sluggish performance recently, while it was quite fast around the 9.10 release.

Francisco Villalobos (belhor) wrote :

Some effects are slow randomly and slows the system, i have Intel 945GM.

Note: The best driver for my Intel 945GM was on Ubuntu 8.10.

Indian Art (goldfish-aol) wrote :
Download full text (5.3 KiB)

I had similar problems but then I manually set it right with the following instructions:
HOWTO: Wrong/Low Resolution and flicker
The Xorg server - the code that provides a graphic display - is very good about determining what an attached monitor can do. There are limitations.

This HOWTO explains one process for obtaining a rock-solid graphics screen within the constraints of your hardware's abilities. There are many other ways to do this.

Overview of the problem:
When Xorg starts, it tries to figure out what kind of monitor you have via DDC/CI and EDID protocols. If your monitor and cabling are first-rate, you will never need to care about any of this. (Yay!)

If not, Xorg will pick a "safe" VESA resolution and use that: probably not at all what you expected, and not likely to be satisfactory. (Grr.)

Lucky for us all, Xorg is highly configurable and it's very easy to get the exact resolution(s) that you want, deserve, and yes, paid-for with your invested time.
Warning: If you are terrified by a Linux command line, at least TRY to follow this procedure. It won't hurt you and it will help.

Still with me? Then let's proceed:

Step #1: What kind of monitor do you have? What are its capabilities? What is its maximum resolution?
Virtually every monitor vendor will publish the specifications for their products on the web. You can find them if you just look but first, you'll need the Vendor Name and Model of that monitor. It will be printed on a plate or tag, glued, screwed, or riveted to the back, top, bottom, or side of your monitor. Go look for it now. Write that information down and keep it handy.
Step #2: Fetch your specs.
Bring up a browser window and search for that model eg, 'dell 3007wfphc'.

Look for any site with details and specifications; the vendor's site is best, but most review sites will provide specifications too.

Ideally, you will find the "Horizontal Sync" range, expressed in kilohertz (KHz or khz), and the "Vertical Refresh" range, expressed in hertz (Hz).

If you found that, write it down like:
Code:
HorizSync 49.31 - 98.71
VertRefresh 60
and proceed to Step #4.

If not, then look for the "Maximum Resolution". This will be listed as something like "2560 x 1600 at 60Hz". Write that down.
Step #3: Calculate the frequencies from the specified resolution.
Open a terminal window (Applications -> Accessories -> Terminal) and enter
Code:
cvt 2560 1600 60
Hit Enter. This will output the following
Code:
# 2560x1600 59.99 Hz (CVT 4.10MA) hsync: 99.46 kHz; pclk: 348.50 MHz
Modeline "2560x1600_60.00" 348.50 2560 2760 3032 3504 1600 1603 1609 1658 -hsync +vsync
Aha! The vertical refresh will be exactly 59.99Hz and the horizontal sync will be 99.46KHz. Write it down as:

Code:
HorizSync 99.46
VertRefresh 59.99
Step #4: Create a basic xorg.conf
Write the following commands down on paper because we're going to turn off the GUI and run a few commands from the console.

Flip to the text console via Ctrl+Alt+F1 and log in.

Execute these commands:
Code:
sudo /etc/init.d/gdm stop
sudo X -configure
sudo /etc/init.d/gdm start ; exit
(ignore any notices about the "new" way of starting/stopping services - those "new" ways work, and so does thi...

Read more...

Indian Art (goldfish-aol) wrote :

My problem was solved by following the above instructions given by Giblet5 from Ubuntu Forums. Thanks Giblet5!

ilna (a-gaydenko) wrote :

Indian Art,

Sorry, the problem you have resolved and decribed here(citing Giblet5) has absolutely nothing related to the bug.

pfxcore (pfxcore) wrote :

im on karmic and using gm965 on this guide
what can i say about that
1 - u follow the howto to upgrade jaunty driver
2 - open synaptic package on local/obsolete
3 - force install for all intel driver
4 - make this remain libgl1-mesa-dev libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev mesa-common-dev
5 - and reboot..
6 - your intel driver now is really fast
7 - i can play games without any problem
8 - hope this help

bigbrovar (bigbrovar) wrote :

Could you be more specific, which guide do are you referring to, and can you provide a link to the how to?

jerrylamos (jerrylamos) wrote :

Ubuntu Forums
Multimedia & Video
HOWTO: Jaunty Intel Graphics Performance Guide

is probably what pfxcore is referring to. See:

http://ubuntuforums.org/showthread.php?t=1130582

I don't remember having much luck when I was trying to follow the suggestions; perhaps you might do better....

I'm usually using lucid lynx 10.04 which isn't much different than karmic koala 9.10 on intel performance. When it's running. Lucid is Alpha level, unstable, and prone to booting to black screen and desktop hangs, seems to be typical of Ubuntu development code as they try new things.

Jerry

warjowuch (lulkoek) on 2010-01-16
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → intel linux graphics (intellinuxgraphics-2008q4)

I upgraded Xorg and its drivers using the Xorg edgers PPA and now performance is good.

http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu
http://ppa.launchpad.net/xorg-edgers/drivers-only/ubuntu

I now have Xorg 1:7.4.3

bigbrovar (bigbrovar) wrote :

@Andres Monroy-Hernandez I tried follwing your tip but I am still getting same performace no improvement here :(

Roman (m01brv) wrote :

Some Extreme Tux Racer tests (intel GMA X3100 (GL360)):

linux version on linux (Karmic): 15-20 FPS
windows version on linux (Karmic) via wine: 15-20 FPS
windows version on windows (Vista) on the same computer: 40-50 FPS
So it looks that linux intel video driver is at least 2-2.5 times more slow than it could be.

Installing new Xorg (only drivers or the whole) from ppa caused very strange things: glxgears reported FPS several times larger than for the default configuration, Tux reported the same 15-20 FPS, but actual apparent performance was very bad in both cases, no more than 10 FPS.

Is there any way to install 2.4 driver on Karmic? I found it in the Jaunty x-retro ppa, but there is no 2.4 driver for Karmic.

Roman (m01brv) wrote :

Very strange, now I have reinstalled updates from xorg-edgers again and indeed found slight improvement of the performance! Maybe thanks to the newer version of mesa. Synaptic says mesa is 7.8.0 now (was 1.6.0), Intel driver is 2.10.0 (was 2.9.0), xserver-xorg-core is 1.6.5 (was 1.6.4).
However, the performance improvement is small - Tux racer now says 18-22 FPS rather than 15-20. But at least Euphoria screensaver does not flicker now, as it was constantly doing since Jaunty. Hope this trend will remain in future versions.

Forgot to mention that tests in the above post and here were done with compositing (kwin) disabled.

Bryce Harrington (bryce) on 2010-03-02
summary: - [i965] [karmic][GM965] low intel graphics performance - again
+ [i965] [i965] [karmic][GM965] low intel graphics performance - again

Is it possible to revert my Intel Driver to 2.4 on karmic. This issue is now unbearable to the extent that am now considering another distro.

almadana (almadana) wrote :

**
@bigbrovar wrote on 2010-04-18: #48

Is it possible to revert my Intel Driver to 2.4 on karmic. This issue is now unbearable to the extent that am now considering another distro.

**

Was that a question? Yes, you can get back to 2.4 driver version from jaunty, as described here:

https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4

Also, you can download a not-so-old version, such as 2.6, from http://www.intellinuxgraphics.org, then install it with dpkg.

Also, you should check this comment here:

**
@Andres Monroy-Hernandez #44.

I upgraded Xorg and its drivers using the Xorg edgers PPA and now performance is good.

http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu
http://ppa.launchpad.net/xorg-edgers/drivers-only/ubuntu

I now have Xorg 1:7.4.3

**

good luck!

Roman (m01brv) wrote :

I have recently upgraded to Lucid. Unfortunately, no apparent progress with intel graphics performance. Neither with official packages nor with any ppa (x-updates, xorg-edgers), which include 2.11 version of the graphics driver and 7.9 of mesa and 1.8 of Xorg. In all configurations that I have tried I got nothing beyond some subtle changes in performance (no more than 10 per cent, increasing as well as decreasing). That are just formal changes in the fps reported by tux/glxgears/glblur, apparently there is no changes at all. I remember that 1.5 yrs ago the old intel driver on my laptop was apparently much faster... Since the time when I had done an upgrade of this old system, I am still waiting and waiting until the graphics performance is restored, but it does not, neither with adding support of DRI2, nor KMS, nor with all the features added to the 2.11 version. Actually, upgrade of the graphics drivers to the ones with DRI2 in Jaunty and KMS in Karmic both caused only regressions in performance, at least to my seeing.
The 2.4 driver available for Jaunty just does not work in Karmic (causes a corrupted screen) and in Lucid it causes broken dependencies, so I could not install it.
:(

bigbrovar (bigbrovar) wrote :

@Roman You took the word out of my mouth. Nothing to add there

almadana (almadana) wrote :

Have you tried installing 2.4 from Jaunty and then dpkg the 2.6 version downloaded from here

http://www.intellinuxgraphics.org/

?

You should force the install ignoring all dependencies. i.e.: dpkg --force-all -i *xorg_intel_driver.deb*

(I apologize for the rather redundant post here)

Roman (m01brv) wrote :

@almandana
thanks for the hint
I have now installed the 2.4 intel driver, but Xorg refuse to load it.
It loads fbdev by default (with terrible performance of course), and when I try
to set Driver "intel" in xorg.xonf I get the error message "Ubuntu started in low
graphics mode" after boot and Xorg.0.log contains the following lines:

(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
dlopen: /usr/lib/xorg/modules/drivers/intel_drv.so: undefined symbol: resVgaShared
(EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so
(II) UnloadModule: "intel"
(EE) Failed to load module "intel" (loader failed, 7)
(EE) No drivers available.

Fatal server error:
no screens found

bigbrovar (bigbrovar) wrote :

Please guys. This thing is really becoming unbearable. Is there a way, a work around this problem. I got an Intel card because I was told it works better with linux. This as been the case till ubuntu 8.10 when the Intel graphic performance for 965 took a nose dive which it never recovered from. Karmic and Lucid have been the worst experience. It seems Intel has totally forgotten about "older" chipset. things are so bad that I am currently considering getting a new laptop just because of this issue :(. And this is not just an ubuntu issue. Infact the situation is worse with fedora and archlinux. Is there a way out of this issue or I need to get a new laptop with Nvidia/ ATI

almadana (almadana) wrote :

Well, all I can say is that I'm running Lucid now, and my 945GM chipset (I know, it's not 965, the one this thread is about) works just great, I even got desktop effects back. So, if you tried to force-install an old driver version and had no improvements, well, I don't know what to say.

@Roman, if xorg doesn't swallow the 2.4 version, you could force install a 2.6+ version and see what happens.

Roman (m01brv) wrote :

Thanks, but it did not work.. Something was changed in the lucid's (and I think karmik's) xorg so it became incompatible with old
intel drivers. And actually the 2.6 driver is the one shipped in jaunty (i.e. the one where the performance regression started). I think at present there is no much sense in trying to install ancient packages in the new environment.
BTW, I tried recent 2.12 driver from xorg-edgers ppa (along with all drm, xorg and mesa complementaries), it seems the performance even decreases when I test it with kwin enabled (e.g. glblur shows 40 FPS instead of 50 FPS as previously). No changes with kwin disabled. I feel likely that the 3D performance issues in the intel graphics will not be seriously dealt with before the 3.0 series. At present they are mainly cleaning the old EXA/DRI code and fixing bugs in the new UXA/DRI2/etc. code.

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Changed in xserver-xorg-video-intel:
status: In Progress → Fix Released
Bryce Harrington (bryce) on 2011-11-15
summary: - [i965] [i965] [karmic][GM965] low intel graphics performance - again
+ [i965] low intel graphics performance - again
description: updated
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: intel linux graphics (intellinuxgraphics-2008q4) → nobody
Bryce Harrington (bryce) wrote :

The upstream bug report has been closed due to no response to their testing requests.

Karmic is no longer supported. From the comments, it sounds like some people found the issue exists on Lucid, others have indicated it works well. Some comments suggest the issue was a kernel regression fixed in newer kernels.

Roman (m01brv) wrote :

To be honest I feel there is a moderate but well-measurable increase of the graphical performance in the new Ubuntu Oneiric.
Now I have Extreme Tux Racer performance in the range 20-25 FPS (~25% comparing to the previous 15-20 FPS that I mentioned above), all on the same laptop with the same intel video card. Similar increase can be noted in the most other 3d applications that I have. In particular, KWin performance is better than it was even in Karmic. This I can note clearly, because in the previous Ubuntu KWin was so slow that I turned it off permanently. Now I do not turn it off even for fullscreen graphical apps, and the performance is good (notice I do not set the option of auto-suspending KWin for fullscreen apps, i.e. KWin continues to work as usually in such a case).

tremby (tremby) wrote :

I'm not sure if I'm experiencing the same bug or a different one. I'm using Lucid. I have the GM45 chipset.

I first noticed bad performance in a game after an upgrade. I've since tried a lot of different kernel versions with these results:

2.6.32-36-generic -- fine
2.6.32-37-generic -- fine
2.6.35-30-generic -- fine
2.6.35-32-generic -- fine
2.6.38-8-generic -- slow
2.6.38-10-generic -- slow
2.6.38-13-generic -- slow
2.6.39-2-generic -- slow
2.6.39-3-generic -- slow
3.0.0-14-generic -- slow

I'm not changing anything else when I test, just rebooting loading a different kernel, then running glxgears.

I'm willing to provide whatever info is needed -- just say what.

Bryce Harrington (bryce) on 2012-02-03
affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Roman (m01brv) wrote :

It seems that in the current KUbuntu 12.04 beta the graphical performance is increased further, but only when the KWin option "suspend desktop effects for fullscreen windows" is enabled. It seems important to use exactly this option and not just turn off KWin manually. In this case the apparent performance for some games running under wine becomes the same as if they were running natively in windows. All movements became much smoother, I have never seen such smoothness in linux with any configuration.
If not the bug 974041then I would say I am completely satisfied now.
It seems that KWin and possibly X were largerly responsible for this performance loss.

lan1967 (lan1967) wrote :

I am on Precise.
My card is Intel GM965 and drivers used from X-swat.
glxgears shows as low as 62 fps.
What can I do to change the situation?

> I am on Precise.
> My card is Intel GM965 and drivers used from X-swat.
> glxgears shows as low as 62 fps.
> What can I do to change the situation?
>

The output is sync on your display, so it's sync at about 60Hz. Don't
consider the result as a benchmark.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.