X.org xf86-video-intel

[i845] xorg hang on video driver 2.8.0

Reported by jerrylamos on 2009-07-29
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
linux (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xorg

i845 karmic 2.6.31-4 KMS intel driver 2.8.0 boots recovery mode, root prompt dhclient, then resume. Black screen no keyboard or mouse response.

ssh logged in v-e-r-y slowly. Key in response v-e-r-y slow. Entered "ls" no response for the last several minutes.

Will power off and log on to dual boot to get logs which I'll enter as subsequent attachments.

i845 fails before login, earlier than i830 which fails after login see bug #403037.

Do note i845 runs O.K. for an alpha 3 using the same 2.6.31-4 however "nomodeset" and driver "vesa".

Jul 29 11:34:12 linux kernel: [ 360.760037] INFO: task events/0:6 blocked for more than 120 seconds.
Jul 29 11:34:12 linux kernel: [ 360.760047] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jul 29 11:34:12 linux kernel: [ 360.760052] events/0 D c0810360 0 6 2 0x00000000
Jul 29 11:34:12 linux kernel: [ 360.760061] f7043f04 00000046 f7033efc c0810360 f7034168 c0810360 46c83c5d 0000002e
Jul 29 11:34:12 linux kernel: [ 360.760072] c0810360 c0810360 f7034168 c0810360 46c82505 0000002e c0810360 ef70dc00
Jul 29 11:34:12 linux kernel: [ 360.760082] f7033ed0 f73f0014 f73f0018 ffffffff f7043f30 c056a166 c073a180 f73f001c
Jul 29 11:34:12 linux kernel: [ 360.760092] Call Trace:
Jul 29 11:34:12 linux kernel: [ 360.760111] [<c056a166>] __mutex_lock_slowpath+0xc6/0x130
Jul 29 11:34:12 linux kernel: [ 360.760119] [<c056a080>] mutex_lock+0x20/0x40
Jul 29 11:34:12 linux kernel: [ 360.760159] [<f81ae5ba>] i915_gem_retire_work_handler+0x2a/0x70 [i915]
Jul 29 11:34:12 linux kernel: [ 360.760173] [<c01520ae>] run_workqueue+0x6e/0x140
Jul 29 11:34:12 linux kernel: [ 360.760195] [<f81ae590>] ? i915_gem_retire_work_handler+0x0/0x70 [i915]
Jul 29 11:34:36 linux console-kit-daemon[2224]: WARNING: Couldn't read /proc/2222/environ: Failed to open file '/proc/2222/environ
': No such file or directory
Jul 29 11:40:12 linux kernel: [ 360.760205] [<c0152208>] worker_thread+0x88/0xe0
Jul 29 11:40:12 linux kernel: [ 360.760212] [<c0156880>] ? autoremove_wake_function+0x0/0x40
Jul 29 11:40:12 linux kernel: [ 360.760219] [<c0152180>] ? worker_thread+0x0/0xe0
Jul 29 11:40:12 linux kernel: [ 360.760225] [<c0156594>] kthread+0x74/0x80
Jul 29 11:40:12 linux kernel: [ 360.760230] [<c0156520>] ? kthread+0x0/0x80
Jul 29 11:40:12 linux kernel: [ 360.760238] [<c0103f17>] kernel_thread_helper+0x7/0x10

jerrylamos (jerrylamos) wrote :

.xsession-errors from black screen boot. Note black screen occurs before login.

Jerry

jerrylamos (jerrylamos) wrote :

Xorg.0.log from black screen

Jerry

jerrylamos (jerrylamos) wrote :

Syslog from black screen. I usually go to the end then search backwards for the latest start.

Jerry

jerrylamos (jerrylamos) wrote :

lspci. Note this was taken on same pc using Intrepid which will boot.

I don't know how to get a batchbuffer dump since ssh barely runs then stops after a couple commands.

Jerry

Bryce Harrington (bryce) on 2009-07-30
description: updated
Bryce Harrington (bryce) wrote :

Okay, well the batchbuffer dump really is necessary before I can send this upstream; your only other option would be to do a git bisect on the kernel if there is a known-good past version that you can bisect from.

I'm not sure why it would be so slow - X usually doesn't impact ssh so drastically, but 845 is a pretty old chipset so who knows. But you might want to check your ps output to see if something is consuming a lot of cpu cycles or something.

Btw, mind if I ask, I notice you've posted bug reports on several different Intel graphics chipset models, which makes me curious what your objectives are? Maybe I can provide some better advice.

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
jerrylamos (jerrylamos) wrote :

Here's a try at the batchbuffer dump.

Booted recovery mode
root prompt dhclient
resume this time it got to login prompt
ssh into test system
logged in, this time it got to the brown screen with pointer then stopped. The pointer would move but the whirligig didn't whirl.

Accidentally found out if I moved the mouse between each key entry I could get commands in.
Followed the batchbuffer dump directions. Copy a line, paste into the ssh, move the pointer, push enter, move the pointer. One shortcut was to type in the commands into text editor, then copy and paste into ssh.

Let me know if the batchbuffer dump has anything useful. I could try it on the 830 as well if it is worth it.

I'm a retired IBM main frame engineer. My wife does some web site updates and I get the older pc's to run, an IBM Thinkpad R31 with i830, an IBM Thinkpad T40 with ATI Radeon Mobility 7500, an IBM ThinkCentre A30 i840, and a Compaq Presario ATI Radeon Xpress 200. When there's something new from ubuntu I give a try on the four. Sometimes the bugs seem to be unique to my pc, sometimes other people have the same bug so maybe the info I send is of use to the developers. My viewpoint is from an "ordinary user" internet browse & download, internet video, internet email, spreadsheet, digital photography, ... No games. I do have a background in performance. I've been learning ubuntu linux by trial and error starting with drake beta.

Jerry

Bryce Harrington (bryce) wrote :

Excellent thanks, that's exactly what we need (I think). I've forwarded the bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=23032 and cc'd you to the bug in case upstream has more info or needs you to test something.

It's really good to have you testing this stuff. Both i830 and i845 have historically had lots of misc. problems, due in part to upstream lacking hardware to test against. We've had people report about problems with both chips to Ubuntu, so we know they're important, but haven't had someone both persistent and technical enough to help close the gaps on the bugs that get encountered.

The good news is that recently a huge swath of the 9xx bugs have suddenly all gotten sorted out, so I have high hopes that if we're persistent about the 8xx bugs upstream, that they'll get attention and sorted out as well.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
jerrylamos (jerrylamos) wrote :

Bryce, installed karmic A2 which boots in KMS on i845. A3 does not which is the subject of this bug.

Put on your PPA which installed xserver-video-intel 2:2.8.0-0ubuntu2~bug382017~1
by commenting out everything else in sources.list except the ppa, then update & upgrade

It does boot O.K. which is the first 2.8.0 that will boot on the i845!
Running GtkPerf tests now.

Thanks, Jerry

Geir Ove Myhr (gomyhr) on 2009-08-03
tags: added: 845g karmic
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
jerrylamos (jerrylamos) wrote :

Latest update 20090812 (is this A4?) is worse.

On CD Live boots to black screen, cursor won't move. If I boot recovery mode I can log in with ssh however continuing boot to black screen keyboard doesn't work, mouse doesn't work, ssh stops responding.

Updated the hard disk to same level. Boots to a brown screen, no cursor, keyboard doesn't work, ssh stops responding.

Since that was a hard disk boot, I re-booted with karmic A2 and copied over the Xorg.0.log, .xsession-errors, and dmesg which I'll attach.

I rebooted in recovery, nano /etc/X11/xorg.conf added Driver "vesa" which works. I'm entering this comment from that.

BTW, last line in apt.sources.list is
deb-src http://ppa.launchpad.net/bryceharrington/blue/ubuntu karmic main
and dpkg lists intel driver as 2:2.8.0-0ubuntu2

Jerry

jerrylamos (jerrylamos) wrote :

dmesg

jerrylamos (jerrylamos) wrote :

.xsession-errors

Changed in xserver-xorg-video-intel:
status: Confirmed → In Progress
jerrylamos (jerrylamos) wrote :

Updated to A5 level with intel driver 2:2.8.1-1ubuntu1 which still fails with the same symptoms.

It does boot with xorg.conf:

Option "DRI" "0"

however video performance with benchmark GtkPerf was 95.6 seconds which is three times slower than 32.2 seconds with driver "vesa".

Then it hung while entering a launchpad comment.

So it's back to driver "vesa". Could that be default for i845 and i830?

Jerry

Bryce Harrington (bryce) wrote :

[According to the upstream bug report, this is an issue in the kernel drm and a potential patch has been flagged, so refiling against linux.]

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Triaged → New
jerrylamos (jerrylamos) wrote :

i845 did boot daily build 20091005 CD, a little post karmic beta. It even installed. Wow. Over three months for a fix but did get fixed.

Video performance is another issue, carried on other launchpad bugs.

It works! Thanks much,

Jerry

Id2ndR (id2ndr) wrote :

I also have poor performances with 845G, slower in karmic that it was in jaunty.
@jerrylamos, if you got some, could you please send the link to the other launchpad bugs about video performance ? Thanks.

Id2ndR (id2ndr) wrote :

About the performance issue :
I founded this comment : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/430694/comments/52
It explains why it's slow with KMS on my computer (video : Intel 845G). KMS is incompatible with XVideo on this GPU (but KMS works normally with XVideo with Intel GMA945 on my laptop). I create bug #460399 about this issue.

jerrylamos (jerrylamos) wrote :

Id2ndR,

There are a bunch, example:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/416073

I've had a priority extended holiday so I've been away from Karmic a while. Just installed the release code which froze up a few minutes ago posting this comment. As I'm able I'll get back to the performance issue.

Jerry

andr40 (andr40) on 2009-12-11
Changed in linux (Ubuntu):
status: New → Incomplete
Brian Rogers (brian-rogers) wrote :

I set up a PPA for Karmic that will roll libdrm and xserver-xorg-video-intel back to the Jaunty versions:
https://launchpad.net/~brian-rogers/+archive/graphics-testing

I haven't tested this yet, so be prepared to undo it from the command line if it breaks X.

If this old userspace stuff works fine in the new kernel, it may not be the kernel's fault at all. In that case, I'll step my PPA forward one version at a time and we can find out when the problem first appeared.

jerrylamos (jerrylamos) wrote :

Tried Brian's PPA, however this is lucid. My karmic works O.K. (quad boot with lucid, jaunty, slax)

In bug #496551 I tried the PPA which didn't work because xserver-xorg-video-intel was kept back. Booted to black screen.

Jerry

 Brian, thanks, I gave it a try, but this is lucid not karmic. I didn't know what to do with that, so I tried it anyway. The xserver-xorg-video-intel got "kept back" so it booted to black screen. Back to hand keying in xorg.conf with driver "vesa".

Thanks for looking at the bug, Jerry

-----Original Message-----
From: Brian Rogers <email address hidden>
To: <email address hidden>
Sent: Thu, Dec 31, 2009 5:03 am
Subject: [Bug 406460] Re: [i845] xorg hang on video driver 2.8.0

I set up a PPA for Karmic that will roll libdrm and xserver-xorg-video-intel
back to the Jaunty versions:
https://launchpad.net/~brian-rogers/+archive/graphics-testing

I haven't tested this yet, so be prepared to undo it from the command
line if it breaks X.

If this old userspace stuff works fine in the new kernel, it may not be
the kernel's fault at all. In that case, I'll step my PPA forward one
version at a time and we can find out when the problem first appeared.

--
[i845] xorg hang on video driver 2.8.0
https://bugs.launchpad.net/bugs/406460
You received this bug notification because you are a direct subscriber
of the bug.

Brian Rogers (brian-rogers) wrote :

Yeah, there's an ABI change for X Server 1.7 in Lucid, so drivers built for earlier versions won't work there. And unfortunately, I wasn't able to build version 2.6.3 for Lucid. But I'm going to post my PPA info to bug 456902, which might be the same issue.

If someone on Karmic verifies that 2.6.3 doesn't experience the freeze on kernel 2.6.31, then we can step forward and find where the issue first appeared in the X driver. If it turns out to be a recent enough version, I should be able to also build a Lucid version before and after the change to find out if your problem is the same.

jerrylamos (jerrylamos) wrote :

Brian, as posted in bug #420594 lucid has been hanging on i845G on this IBM ThinkCentre A30 2 gHz Celeron. Example linux-image 2.6.32-7 and 2.6.32-9 boot to black screen however Ctrl-Alt-F1 gets a command line.

Geir Ove Myhr gave me info on things to try from http://kernel.ubuntu.com/~kernel-ppa/mainline/ and this one is working at the moment:
linux-image-2.6.33-020633rc2-generic_2.6.33-020633rc2_i386.deb

-7 and -9 still fail most of the time. When it did boot, after a while the screen would freeze altogether which is more like this bug #406460. Do note I did do a fresh install with a linux CD at the -7 level; I had to key in an xorg.conf to get the CD to go.

So 2.6.33rc2 is up and hasn't frozen; I've been running about an hour.

Thanks, Jerry

Geir Ove Myhr (gomyhr) wrote :

Jerry, I'm confused. In comment #17 you say that Karmic release froze up, and all comments before that was about Karmic (it was from before Karmic's release). In comment #19 and #20 you say that this is Lucid, not Karmic, and that Karmic works O.K. What is really the status of this bug report?

jerrylamos (jerrylamos) wrote :

Geir, good point. A lot of water goes under the dam when running Ubuntu development levels.

Karmic during development from late June into (I think) August had problems on i845. Bryce had some suggestions and tried his suggestions. Late in Karmic development a linux-image update fixed the problem for me.

Karmic release level and updates to 2.6.31-16 I haven't had a problem. The pc has running currently multi boot Lucid, Karmic, Jaunty, DebianLXDE, and Slax. Only one that hangs up is Lucid.

Lucid started out O.K. for me, no surprise, early in development not much had changed yet.

Lucid around 2.6.32-5 got black screen on boot. I do try combinations of default, "vesa", and nomodeset in attempts to get going.

Based on your suggestions, downloaded the freeze .deb's with Karmic, copied to Lucid, then did recovery command line dpkg -i. No luck with them.

Decided to do a re-install in case some of the fix attempts were clouding the issue. Even the Lucid live CD at level 2.6.32-7 boots to black screen unless I key in an xorg.conf. The installed 2.6.32-7 booted to black screen. Recovery mode command line sudo apt-get update, sudo apt-get dist-upgrade to 2.6.32-9 boots to black screen.

Based on your subsequent suggerstions, downloaded 2.6.32rc1 with Karmic, copied to Lucid, then did Lucid recovery command line dpkg -i. Hooray, it booted! Tried rc3, rc4, rc5, rc6, rc7. Each booted. 2.6.32-7 and 2.6.32-9 still boot to black screen.

Trying 2.6.33rc2 booted O.K. several times. Ran for over an hour and then the screen froze. Command line still worked so I got ubuntu-bug xorg apport report, Xorg.0.log, .xsession-errors. Not sure if anyone has any use for these.

At this point I could try for a buffer trace or whatever it is called, there is a complex Wiki procedure which I may/may not have any luck with. ssh in from another pc, the whole bit. It's a bit complex for my level of linux command line experience because the Wiki directions don't match what happens on the screen. Not sure if anyone has any time to analyze the trace anyway.

I could try some of the rc's to see if they would hang up. This is time consuming because 2.6.33rc2 ran for over an hour before freezing screen. At that point I'm shooting in the dark because I don't know which ones may have had a change of interest. That could take days of my "spare" time between shoveling snow, preparing a computer class demo of Ubuntu, OpenSUSE, Fedora, Debian, Slax, Knoppix, usb boot, etc.

Hmmm. Thanks for your interest. Jerry

Changed in xserver-xorg-video-intel:
status: In Progress → Confirmed
Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
Larry Reid (lcreid) wrote :

Because of the total disinterest in resolving this bug, I've donated all my old computers to Free Geek. Funny. I've heard people say that one of the advantages of linux is that it runs on old computers. That's not my experience.

Changed in linux (Ubuntu):
assignee: nobody → rohit vashisht (rohitashva1987)
jerrylamos (jerrylamos) wrote :

Current status of Ubuntu on my i845G:

Karmic runs solid with kms and intel driver.

Lucid will run intel driver only with ubuntu-proposed fix see launchpad bug #539772

Maveric Alpha 1 ran kms & intel driver however kernel updates since black screen hang dead the instant kms is tried or startx is used.

Lucid & Maverick run fine with i915.modeset=0 in boot line and with /etc/X11/xorg.conf specifying Driver "vesa".

Entering this comment from my older 2004 Thinkpad R31 1GHz Celeron i830 intel video that sits beside my breakfast table, with Lucid, with i915.modeset=0 and "vesa". This older laptop runs just fine with Ubuntu for mail etc, a bit jerky with video.

Should be easy for Ubuntu to just blacklist i830, i845, ... from kms and default to "vesa", I don't know why they won't do it.

By the way, Slax, Sitaz, Debian CD live, openSUSE, ... all run fine as is. None of the problems X has with Ubuntu. I just run Ubuntu because of the nice online community.

Jerry

dn (nobled) on 2010-06-12
Changed in xserver-xorg-video-intel:
status: Invalid → Unknown
Changed in linux (Ubuntu):
status: Incomplete → Triaged
assignee: rohit vashisht (rohitashva1987) → nobody
tags: added: kernel-graphics kernel-needs-review
Steve Conklin (sconklin) wrote :

Since this bug now has information for multiple hardware models and multiple releases, it isn't very useful to us, as we tend to handle bugs based on a single pair of hardware and release. Please open new bugs for each set of hardware on the release it fails on, and we'll match it with other bugs open against those combinations.

Thanks

tags: added: kernel-reviewed
removed: kernel-needs-review
Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
status: Unknown → Confirmed
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.