[i855] X freezing on intel 855GM

Bug #370292 reported by Mike Rose on 2009-05-01
84
This bug affects 13 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Confirmed
Unknown
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Nominated for Hardy by suckertoo
Nominated for Jaunty by suckertoo

Bug Description

Running Jaunty on a Panasonic CF-R3 notebook with intel 855GM graphics chipset and pentium M processor. X (running compiz) will completely freeze seemingly randomly (fairly often though - easily 5 times a day), necessitating a hardware restart (or REISUB) although the mouse pointer is still responsive and disk activity is still continuing. Another generic intel driver freeze it would seem.

I've tried the usual suspects with no avail:
happens on both UXA and EXA
with and without "MigrationHeuristics" "greedy"

Turning DRI off seems to fix the issue though.

Taking a look at my /var/log/kern.log, it seems that every time these lockups occur i'm getting a kernel log error of:
Apr 29 12:49:26 mike-laptop kernel: [ 1032.985907] mtrr: no MTRR for e8000000,8000000 found

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3580] (rev 02)
     Subsystem: Matsushita Electric Industrial Co., Ltd. Device [10f7:8338]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
     Subsystem: Matsushita Electric Industrial Co., Ltd. Device [10f7:8338]

Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This appears to be an X.org bug, and I am refiling this bug to them. Please run the command 'apport-collect 370292' which will include all the info they need for troubleshooting. Thanks in advance.

affects: ubuntu → xorg (Ubuntu)

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xorg 1:7.4~5ubuntu18
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_AU.UTF-8
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout dip lpadmin plugdev sambashare

Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :

Update: Setting the virtual framebuffer to 2048x2048 seems to be stable. I tried this yesterday and didn't get a freeze at all. I reverted back to original configuration to submit the above apport data though.

Perhaps this bug needs to be merged in with the i965 freezing issue

Please leave this bug open a few more days and I will continue testing with Virtual at 2048x2048 and update.

For those playing at home, I added the following to my /etc/X11/xorg.conf in the screen section:
 SubSection "Display"
   Depth 24
   Modes "1024x768"
   Virtual 2048 2048
 EndSubSection

Not entirely sure the Modes line is necessary but it's the only res I use on my laptop anyway.

Mike Rose (mr79) wrote :

Murphy's law. I just got two more freezes, with the above 'fix'

Back to the drawing board :)

Bryce Harrington (bryce) on 2009-05-05
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
summary: - Jaunty - X freezing on intel 855GM - MTRR issue
+ [i855] Jaunty - X freezing on intel 855GM - MTRR issue
Bryce Harrington (bryce) on 2009-05-05
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-05-05
summary: - [i855] Jaunty - X freezing on intel 855GM - MTRR issue
+ [i855] Jaunty - X freezing on intel 855GM - MTRR issue (UXA/EXA)
Bryce Harrington (bryce) on 2009-05-06
tags: added: freeze
Bryce Harrington (bryce) on 2009-05-06
description: updated

For what it's worth, I'm now running on the old 2.4 driver and I'm still getting those MTRR errors, but no freezing. Happens on both XAA and EXA with the old driver, seemingly when X initialises. I can force these errors by 'zapping' X at the login screen.

Sidenote - Interesting excerpt from Xorg.0.log:
(==) intel(0): VideoRam: 131072 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(WW) intel(0): xf86AllocateGARTMemory: allocation of 1536 pages failed
 (Cannot allocate memory)
(WW) intel(0): Allocation error, framebuffer compression disabled
(WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
 (Cannot allocate memory)
(II) intel(0): Allocating 3840 scanlines for pixmap cache
(WW) intel(0): Failed to allocate texture space.
(II) intel(0): Tiled allocation failed.
(II) intel(0): Attempting memory allocation with untiled buffers.
(WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
 (Cannot allocate memory)
(II) intel(0): Allocating 3840 scanlines for pixmap cache
(II) intel(0): Untiled allocation successful.

vince (lapcchan) wrote :

i have the same problem with intel 855GM.

also resume from sleep will result in black screen
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/293242

Bryce Harrington (bryce) wrote :

I wonder if perhaps this is a dupe of 314928. Symptoms differ, but both seem to be caused by missing MTRR's

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

Perhaps not...

<jbarnes> the mtrr thing should just cause a big slowdown but not a hang

suckertoo (webmaster-welter) wrote :

Ich bin von mid auf diesen Bugreport hingewiesen worden. Ich habe die gleichen Probleme mit meinem Laptop AmiloPro und ich würde mich freuen ,wenn das Problem durch ein update behoben werden könnte. Solange muß ich wohl bei Ubuntu 8.10 bleiben.

Gruß
Hans

Bryce Harrington (bryce) wrote :

English only in launchpad please.

Mike.lifeguard (mikelifeguard) wrote :

Are you serious? What happened to http://www.ubuntu.com/community/ubuntustory/philosophy ? Surely if we believe that people have a right to software localized for them then they also have a right to use any language they want in the bug tracker etc?! If suckertoo can't be understood, it's not their fault - use Google translate, find someone proficient in de and en to translate, but please please don't be a dick WRT other languages.

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new major version of the -intel driver is now available in Karmic.

This version includes a major reworking of the acceleration
architecture, which resolves a huge number of issues. We do not know
whether it resolves the issue you reported.

Would you mind testing Karmic Alpha-2 and seeing if it is still a
problem? CD ISO images are available here:

  http://cdimages.ubuntu.com/releases/karmic/

If the issue can still be reproduced on karmic, please report here with
your findings, and attach a fresh Xorg.0.log from your test, and we will
be able to forward the bug upstream.

Otherwise, if the bug no longer exists in Karmic, let us know that as
well.

In the off chance you encounter different bugs while attempting to test
Karmic, please report those as new bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → New
status: New → Incomplete

Hello,
If mine excuses please bad english.
It is about a test of Karmic alpha 2.
I cannot carry out this test, because I for a year
to Afgahnistan is sent.
Greetings
suckertoo

suckertoo, no problem, hopefully Mike Rose can test. I am fairly certain this bug is gone in Karmic, so if no one is able to test, I'm confident we can close it, but I'll give a month for people to try.

Good luck in Afghanistan

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete

Sure thing Bryce, I'll get to testing when I can. I've got a thesis that
needs finishing first, so it might not be for another few weeks though.
I don't know if I originally commented on this bug, but I've been
tracking the 955GM freeze bug too, and I've tried the intel 2.4 drivers
which work a charm. UbuntuStudio gives some strange hangs, but I think
this is more due to the RT kernel as standard ubuntu jaunty with intel
2.4 drivers is rock solid.

I'll update the bug when I test Karmic. Thanks for all your help! :)

Cheers
Mike

On Sat, 2009-06-27 at 04:13 +0000, Bryce Harrington wrote:
> suckertoo, no problem, hopefully Mike Rose can test. I am fairly
> certain this bug is gone in Karmic, so if no one is able to test, I'm
> confident we can close it, but I'll give a month for people to try.
>
> Good luck in Afghanistan
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Incomplete => New
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: New => Incomplete
>

Have been running Karmic alpha 2 for approx 5 hours now.

Good news is that the MTRR errors are gone.
Bad news is the freezes are still happening.

Two lockups. One occurred when I had firefox open, lots of tabs open,
'Normal' visual effects enabled. REISUB'ed.

Decided to try turning off visual effects, but got another lockup, this
time in terminal looking through kernel logs from the last lockup
looking for clues :)

I did notice that for approx a minute before the lockup, everything in
the terminal went real slow. Like, scrolling via mouse wheel would take
2 seconds before it would start scrolling. Very laggy. It's quite
probable that this has happened with past freezes without me noticing
however, as I've found some websites slow my computer down to a crawl
anyway (probably due to flash).

Nothing in the logs showing anything. For what it's worth, I also got
the lockup on the livecd too and I noticed before it happened I had a
slight font corruption (every instance of 'e' had a line through it).
Funnily enough, I also noticed this in terminal before it locked up
(this time 'r' was missing a bit) so I don't know if it's related or not.

I've reverted to intel 2.4 drivers (
https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4 )
and they've been stable as a rock, full compositing (albeit slowish,
it's only intel 815 :)

Let me know if there's any diagnostic tools I can run to give some more
information. Maybe a version of the intel drivers with verbose debugging
output or something. I don't mind it running a little slow while I'm
testing, I just want this bug sorted. :)

Mike

Bryce Harrington wrote:
> suckertoo, no problem, hopefully Mike Rose can test. I am fairly
> certain this bug is gone in Karmic, so if no one is able to test, I'm
> confident we can close it, but I'll give a month for people to try.
>
> Good luck in Afghanistan
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Incomplete => New
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: New => Incomplete
>
>

Bryce Harrington (bryce) on 2009-07-06
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed

Hi Mike, thanks, it's good to hear the MTRR problem is at least gone.

The next step with freezes is to collect a batchbuffer dump. Directions on how to do this are available here:

  https://wiki.ubuntu.com/X/Troubleshooting/Freeze

First, you may want to update to latest Karmic, since a few more freeze fixes have filtered in, though I don't know of any specific to 855 so no guarantees...

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Mike Rose (mr79) wrote :

Well I got it to happen again, everything updated/upgraded as of about 15 minutes ago. Switched back over to xserver-xorg-video-intel (from xserver-xorg-video-intel-2.4) rebooted, followed the instructions at https://wiki.ubuntu.com/X/Troubleshooting/Freeze#How%20to%20Get%20a%20Batchbuffer%20Dump%20(-intel%20only)

Enjoy your batchbuffer dump driver-gods :)
Note that my framebuffer is larger than default because I have two monitors (internal LCD + external CRT), though this issue occurs on LCD only too. Both running at 1024x768

Let me know if there's anything else I can do to help

Bryce Harrington (bryce) on 2009-07-10
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-07-14
tags: added: jaunty
summary: - [i855] Jaunty - X freezing on intel 855GM - MTRR issue (UXA/EXA)
+ [i855] X freezing on intel 855GM - MTRR issue (UXA/EXA)
summary: - [i855] X freezing on intel 855GM - MTRR issue (UXA/EXA)
+ [i855] X freezing on intel 855GM
Bryce Harrington (bryce) wrote :

Hi Mike,

Thanks, I've forwarded your bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=22771 - please subscribe to that bug in case upstream needs further information or wishes you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.7.99.902+git20090720.bb300738-0ubuntu1

---------------
xserver-xorg-video-intel (2:2.7.99.902+git20090720.bb300738-0ubuntu1) karmic; urgency=low

  * Update to git 20090720 (master branch) up to commit bb300738
    - Fix intel driver reports Couldn't find PLL settings on i915
      (LP: #312133)
    - Fix X freezing on intel 855GM
      (LP: #370292)
    - Implement vblank sync'd GL buffer swap
      (LP: #377090)

 -- Bryce Harrington <email address hidden> Mon, 20 Jul 2009 22:05:31 -0700

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
Mike Rose (mr79) wrote :

Incorrect. Not fixed as of 2:2.8.0-0ubuntu1

In addition, I can't even seem to install the older 2.4 version over the top anymore, so now I'm stuck with this buggy driver. Very frustrating when I'm trying to work.
Bryce, is it at all possible to put the old intel driver in the official ubuntu repos? Perhaps call it xserver-xorg-video-intel-old or something. This is getting ridiculous.

This driver should never have been released as stable without testing on all hardware it supposedly supports, and if it was released as unstable, it should have never found it's way into ubuntu without an alternative.

nomnex (nomnex) wrote :

@Mike Rose and everybody on the thread.

Hi, glad I found this thread. I am fairly new to Ubuntu and certainly less experienced than any of you. I use Jaunty on a Panasonic Let's note model CF-W2 I bought in Japan a few years ago (Intel chipset must be very close to CF-R3).

I experience exactly the same symptoms: Random freezes (the machine is a little sluggish a few minutes before). The mouse can move on screen. The only way to recover is to operate a cold-boot.

It is very frustrating since I do love using Linux Ubuntu (vs. M$). Do you mind if I ask for help on the thread? Do I have to follow a link: Reverting the Jaunty Xorg intel driver to 2.4 - and if I do will I experienced any graphic change - or do I have to install Karmic (but reading the thread freezes still occur).

Sorry, I am not helpful to the thread, I only ask for advice/help.

Hi Nomnex,
I'm no ubuntu bugsmith, so I don't know if you should be asking for
advice or not here, but I'm happy to give it. :)

If you follow that link you talk about, it will give you instructions on
how to revert to the older version of the display driver. This older
version is still fine and I haven't yet found any issues. It is,
however, not very fast at 3D. If you're into gaming, I'd suggest
having/keeping a dual boot with windows as you won't get very good
performance out of the 855 under linux (well, under anything really, but
windows will be better). I also suggest you turn off visual effects
(system -> preferences -> appearance -> visual effects -> none) but you
can try without and see if it's fast enough for you.

It seems that this bug has been submitted upstream and for some reason,
subsequently closed, even though the bug has not been fixed.
<rant>
It's the unfortunate state of affairs that some driver/software
developers don't want to hear about bugs in their code and seem to react
with derision towards anyone reporting. Possibly this is the case here,
I don't know. I can understand their frustration though, as it seems
that too many newcomers to linux don't understand how FOSS works and
treat the developers as if they *should* or *have to* help them. It can
be frustrating to both parties, however everyone needs to remember that
the developers are putting in their own time and effort for free and
have no obligation to do *anything* for *anyone*.
</rant>

I have given up hope on this bug being fixed and will continue to use
the 2.4 drivers until it's time to upgrade my laptop. Hopefully these
older drivers remain compatible with future X changes until this time.

If you want to take this bug further, I'm sure someone else subscribed
to this bug report will be able to direct you in the right direction.
Just remember the point above; in this community, the developers are
considered gods and justifiably so. For a developer to fix this bug is
to do you a favour so try to avoid getting angry or frustrated if they
decline.

I hope this helps. :)

Mike

On Thu, 2009-09-17 at 04:02 +0000, nomnex wrote:
> @Mike Rose and everybody on the thread.
>
> Hi, glad I found this thread. I am fairly new to Ubuntu and certainly
> less experienced than any of you. I use Jaunty on a Panasonic Let's note
> model CF-W2 I bought in Japan a few years ago (Intel chipset must be
> very close to CF-R3).
>
> I experience exactly the same symptoms: Random freezes (the machine is a
> little sluggish a few minutes before). The mouse can move on screen. The
> only way to recover is to operate a cold-boot.
>
> It is very frustrating since I do love using Linux Ubuntu (vs. M$). Do
> you mind if I ask for help on the thread? Do I have to follow a link:
> Reverting the Jaunty Xorg intel driver to 2.4 - and if I do will I
> experienced any graphic change - or do I have to install Karmic (but
> reading the thread freezes still occur).
>
> Sorry, I am not helpful to the thread, I only ask for advice/help.
>

Mike Rose (mr79) wrote :
Download full text (4.0 KiB)

On Thu, 2009-09-17 at 07:25 +0000, nomnex wrote:
> Panasonic Driver
>
> Hi, thank you very much for your answer. It brings much clarity. I was
> slow to answer because I did some research in the meantime.
> Nevertheless, it is bit technical for my understanding. May I ask your
> advice to help me go along the process. Disclaimer: English is my second
> language. I master it very imperfectly. Thank you to take it in
> consideration.
>
> -----------------------------------------------------------------------
>
> First: Your bug report "Upstream" - what does mean Upstream in the
> Ubuntu terminology (vs. the bug report in Launchpad)?
>
> https://bugs.freedesktop.org/show_bug.cgi?id=22771
>
> Eric Anholt says: [...] The batchbuffer dump doesn't conclusively point
> to the bug I just fixed [...] Please re-open if the bug persists [...]
>
> I don't see any link to a patch or other indication and as stated in
> your message - sadly, there is little to expect on this side.

Exactly what I was referring to when I said upstream. To reopen the bug
I had to sign up and I wasn't prepared to do this with a site with an
invalid certificate (I am doing a phd in information security, I'm a bit
paranoid when it comes to these things :) so I just gave up and went
back to 2.4.

It seems that no one (ubuntu or X) is interested in something that is a
total show-stopper, at least for some subsection of the community. I
wonder how many new users haven't even bothered to raise a bug report,
bagged linux for being so unstable and went back to windows. And some
people wonder why linux isn't ready for mainstream adoption.

> -----------------------------------------------------------------------
>
> I can use the tutorial "Reverting the Jaunty Xorg intel driver to
> 2.4" (as you did), however before doing so, you would mind following the
> links below and tell me if any of them could be relevant to our Intel
> driver problem?
>
> A. Title: ATI unsupported cards in jaunty: full effects:
> http://ubuntuforums.org/showthread.php?t=1164013
>
> B. How To Fix Freezes in Ubuntu on hp 540 - simlar complain and a work
> around
> http://ubuntu.igameilive.com/2009/05/how-to-fix-freezes-in-ubuntu-on-hp-540.html
>
> Maybe a topic of interest (C and D are related)
>
> C. HOWTO: Jaunty Intel Graphics Performance Guide
> http://ubuntuforums.org/showthread.php?t=1130582
>
> Although the disclamer looks like a stopper - I use an external
> boardband wirless card btw.
> "*Disclaimer: Using a third-party kernel means that you will no longer
> have access to "restricted" drivers such as FGLRX, NVIDIA, some Broadcom
> wireless chipsets, certain webcams and a handful new sound cards that
> require restricted firmware to function. If you believe that you have
> restricted hardware on your machine, you should continue using the
> official Jaunty kernel - in other words, stick to the Safe
> configuration."
>
> D. X Updates on Launchpad (see title and link E below):
> https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
>
> -----------------------------------------------------------------------

I really have given up, feel free to try these things though and please
report back i...

Read more...

Mike Rose (mr79) wrote :

> And since you have tested your Panasonic under Karmic, could you install
> the old driver too? What is your advice? Karmic is available soon. I was
> planning to install it on the notebook.

Don't touch Karmic until it's released. It's the same story there,
you'll need to install the 2.4 drivers. I've been using linux for close
to 10 years now and even I tend to stay away from development versions.
For you, I'd suggest you wait for the actual release as karmic is
currently in development/testing and things can and will go wrong. And
I'm not just talking about your graphics driver.

I would also suggest staying away from custom kernels if you're a
newcomer to linux, as it's not very user friendly. Don't get me wrong,
it's a lot better than what it used to be, but I'd suggest trying the
other options first and only go to the custom kernel route if you really
have to.

Mike

Changed in xserver-xorg-video-intel:
status: Fix Released → Confirmed
nomnex (nomnex) wrote :

Fix release: where can we get the fix?

nomnex (nomnex) wrote :

I have clean-installed Karmic 9.10. Freeze occurs more often than on Jaunty 9.04. (nothing new here).

Can someone explain me the bug process. Status is confirmed and Fix released. What's next for a end user?

Thanks

Hello, I experiment a similar problem with my ASUS S5N (Graphic card intel 92852/855GM)

Since I upgraded my laptop to 9.10 from 9.04 I experiment random freeze on GDM sessions. Sometimes I can move the mose but nothing else can be done.

I didn't tried SSH because I never installed this on my computers (I think I wil try)

But it is clearly link to XOrg or GDM as I didn't have problems when I quickly switch to console tty1 (CTRL+ALT+F1)
I suspect an interaction with kernel.
When I boot on "normal" 2.6.31-15-generic kernel My computer freezes.
When I boot on "Old" 2.6.28-16-generic kernel My computer does not freeze but I don't see mouse cursor and my touchpad is deactivated.

If someone wants more experiments on this computer I cant give all the logs you can ask me or try all experiment you can imagine.

god_at_hell (god-at-hell) wrote :

same thing here.
With Jaunty the system freezes occasionally. It's nerving but not a show stopper .. i hope the downgrade to 2.4 will do the trick here.
But when i boot the Karmic, the x-server freezes after a random amount of seconds. Sometimes the mouse cursor still moves ... sometimes not. I tested the ubuntu-x-swat and the xorg-edgers drivers, but that didn't help. The console on the other hand works like a charm. The only way to get a stable x-server under karmic is by blacklisting the i915 module. This however comes with the disadvantage of having no dri (not so bad, because the 855gme as dast as a snail) and no xv (bad ... very bad). Switching to an external monitor works though.

My system is a ASUS M5200N laptop (Pentium M 1.6ghz with 855gme chipset).

PS: please excuse mistakes ... my english is a bit rusty.

The issue persists in karmic, after login X freeze.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Confirmed
ken830 (kleung1) wrote :

Seems this issue is even more frequent on Karmic Koala (9.10). I'm also on an Asus M5200N notebook.

with SSH installed and a gnome session freezed I can stay connected by SSH to the computer.

I can confirm this.

I tried to see if there was something into Xorg logs or into GDM logs, I installed some debug symbols package bu I can see nothing to explain this freeze.

I have an Asus M5200N as well and the cause of the freeze has been identified in bug 447892. I have installed the "599" testing kernel and haven't had a freeze since.

I made the test trying to install

linux-image-2.6.31.1-855gmtest599-git522bb74_gomyhr2nopae_i386.deb 04-Jan-2010 18:21 30M

But my computer does not boot with this image.

Geir Ove Myhr (gomyhr) wrote :

For anyone on Lucid, I have uploaded a version of Lucid's libdrm to my PPA which has this patch: http://cgit.freedesktop.org/mesa/drm/commit/?id=4f0f871730b76730ca58209181d16725b0c40184 .

This patch is supposed to fix many of the freeze problems that has occurred lately. The PPA is at https://launchpad.net/~gomyhr/+archive/standard .

Bryce Harrington (bryce) on 2010-03-02
summary: - [i855] X freezing on intel 855GM
+ [i855] [i855] X freezing on intel 855GM
Bryce Harrington (bryce) on 2010-03-02
summary: - [i855] [i855] X freezing on intel 855GM
+ [i855] X freezing on intel 855GM
Changed in xserver-xorg-video-intel:
status: Confirmed → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Thanks for reporting this bug to help making the Intel graphics driver
better. We hear from upstream that a number of bugs (possibly including
this one) have been fixed in the newer DRM code from the 2.6.33 kernel.
I don't know if your bug is one of the ones fixed in this release,
though, but we've prepared a PPA with this DRM update. Would you mind
installing this, rebooting, and testing if the original issue can be
reproduced with it or not?

The DRM PPA is here:

    https://edge.launchpad.net/~apw/+archive/red

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug linux' (for kernel or DRM or KMS bugs) or
'ubuntu-bug xorg' if you suspect them to be X.org issues.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete

Sorry for the delay but after some professional issues, I made some manipulations on my laptop, and yesterday I managed to boot on the 2.6.31.1-855gmtest599-git522bb74 kernel.

I installed both image and headers, in first the boot seem to freeze, but after booting on a previous kernel version with XOrg freeze and ssh connection to reboot the laptop, I managed to boot. In fact I write this text from my laptop.

does anyone made an other package I cant test form Karmic As I will not upgrade to any version of Lucid Lynx if this correction is not released.

I think it is dangerous to try an upgrade with the risk of a XOrg freeze ...
(If I understand, the apw/red ppa is for lucid only ?)

Chris Halse Rogers (raof) wrote :

It might be worth testing the Lucid Beta 2 (or, soon, the RC) LiveCDs. There's been some work to stabilise these old cards, at the expense of some functionality.

If you could test out the LiveCD it would be good to know either way - if what we've done so far is enough, or whether it is still unstable.

I tried today's Live CD on two of my computers (the third one is an AMD 64) but I couldn't do anything. it does not work.

nomnex (nomnex) wrote :

still not working on the Lucid LTS 10.04...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.