laptop hangs on lid close unless ForceEnablePipeA option enabled

Reported by Andrea Bocci on 2007-09-08
72
This bug affects 5 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
High
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Debian)
Confirmed
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Hi,
I'm using a Dell Inspiron 510m, with an Intel 855GM:

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Using the Xorg server with the xserver-xorg-video-i810 driver (and 915resolution to get 1400x1050) works well enough (compiz, decent 3d, xv support).
Recently, I've tried the xserver-xorg-video-intel driver which works equally well, with one exception: when I close the laptop lid, the screens my system hangs: music stops playing, black screen except for the mouse pointer which is stuck.

/var/log/messages doesn't show anything, and I don;t have the corresponding Xorg.0.log any more since I switched back to i810. I'm attaching my Xorg configurations for both i810 and intel drivers.

[Update]
The fix for this issue is to quirk your card to force enabling Pipe A. If you suspect you're having this bug, try setting this option in your xorg.conf:

  Section "Device"
    ...
    Option "ForceEnablePipeA" "true"
  EndSection

If that eliminates the issue, then please file a new bug report with the following information:

  * Title the bug report "Need a Pipe-A quirk for <your video card PCI ID>"
  * Paste in the output of `lspci -vvnn | grep -A1 "VGA compat"`
  * Give the laptop model name and number
  * Confirm that adding "ForceEnablePipeA" solved the problem
  * Mention this bug, number 138256

Andrea Bocci (fwyzard) wrote :
Andrea Bocci (fwyzard) wrote :
Changed in xorg-server:
status: Unknown → Confirmed
Tomasz Rozynek (kleofas) wrote :

The same bug appears on DELL Latitude D500, also i810, xorg hangs when I close the lid, no matter if I have acpi turned on or off. My system is Debian Unstable(Sid) updated yesterday (2007-10-02).

Linux d500-kleofas 2.6.22-2-686 #1 SMP Fri Aug 31 00:24:01 UTC 2007 i686 GNU/Linux

X.Org X Server 1.4.0
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4-3)
Current Operating System: Linux d500-kleofas 2.6.22-2-686 #1 SMP Fri Aug 31 00:24:01 UTC 2007 i686
Build Date: 29 September 2007 04:19:41PM

Matt (mmmurf) wrote :

I'm also having this problem with a Toshiba Portege R-205 S-209 with that xorg driver. Please let me know if there are any files or config settings that i can upload that will help someone fix this bug.

urbanslayer (urbanslayer) wrote :

I am also having this problem with the xserver-xorg-video-intel driver in Ubuntu Gutsy on a Dell Latitude X300, I do not have the problem with the i810 driver though.

moschops (simon-waddington) wrote :

I have the same problem with Dell Inspiron 700m which also uses the i855GM chip - it worked fine with the i810 driver so long as I used the i955 fix which would change the resolution to 1280x800 for me. The new Intel driver gives me correct resolution out of the box but I get the same "black screen of death" experiences that are unrecoverable by anything other than power cycling.

I've seen them a) when logging out and b) when trying to hibernate.

I have tried both with and without the frame buffer option in xorg.conf.

It seems that if I reboot, login and logout immediately it sometimes works, otherwise it will fail and I have to power cycle.

If I turn off the desktop effects the problem is much less common but I've still seen it - especially trying to hibernate or suspend.

Bryce Harrington (bryce) wrote :

Please test this against gutsy-final, which has a newer version of this driver, and let us know how it goes. See https://wiki.ubuntu.com/X/Debugging for more info on debugging X problems, and other info you could include to help triage this bug.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Peter Clifton (pcjc2) wrote :

http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/xserver-xorg-video-intel_2.1.1-0ubuntu10~pcjc2.2_i386.deb

This encorporates all unreleased fixes I've been working on, and an additional line which aims to reset the 3D state of the card after VT switch. This may help after suspend, and has been reported to help issues with crashes after VT switch and textures on 855 hardware after resume.

Please let me know if this helps, both on the 855 and 810 hardware.

Peter Clifton (pcjc2) on 2007-10-22
Changed in xserver-xorg-video-intel:
status: Incomplete → In Progress
Aaron Whitehouse (luna-tick) wrote :

I have tested this with Gutsy Final and the problem still occurs. I will test with Peter's driver soon.

Aaron Whitehouse (luna-tick) wrote :

Please note that, as I posted in Bug #150109 , this does not occur with hibernation - only suspend to RAM.

Problem still occurs with gutsy final and Peter's driver on a 945GM

On 10/23/07, Aaron Whitehouse <email address hidden> wrote:
>
> I have tested this with Gutsy Final and the problem still occurs. I will
> test with Peter's driver soon.
>
> --
> xserver-xorg-video-intel hangs the system when laptop lid is closed
> https://bugs.launchpad.net/bugs/138256
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--

My email address has changed to <email address hidden>

From October <email address hidden> will no longer be active. Please update
your address book.

Cheers,

Rory

Please also note that my system freezes occur at different times. When I Suspend to RAM, it freezes when I try to wake the system up (see full description in Bug #150109 ). The cursor is visible (and movable) over the top, but I can't click anything or do anything. When I push the laptop lid button, I have the system immediately hang with the cursor frozen in place on the screen.

Are these separate bugs or the same one?

I am using Gutsy Final. Do you need any logs from me?

Aaron Whitehouse (luna-tick) wrote :

(Most of my logs are available in Bug #150109 )

Aaron Whitehouse (luna-tick) wrote :

After a hang from pushing the Lid Close (Blank Screen) button.

Aaron Whitehouse (luna-tick) wrote :

After a hang from pushing the Lid Close (Blank Screen) button.

I have an Toshiba Tecra A1 with the Intel 855GM graphics chipset. I am using Gutsy final.
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 01)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 01)

 In addition to this bug, the backlight would not turn on after a resume from hibernation, and the video would be corrupted after a resume from suspend. Disabling compiz fusion removed these problems.

I just installed Peter Clifton's updated driver and the problems have disappeared while running compiz fusion. Bother resume from ram and resume from hibernation works as expected.

Bryce Harrington (bryce) wrote :

Stephen, thanks that's good news.

Aaron, have you also had a chance to test Peter's deb?

Not yet, sorry Bryce, I've been really busy and wanted to run all the
tests for LaptopTesting on the normal driver first. I'll do my best to
do it this weekend. Fingers crossed!

No, it didn't fix the issue :(.

I have attached my Xorg log. I have not rebooted since the hang/crash (I have pulled it over from a different install on a separate partition), so all my logs should be as at the hang. Are there any others that you would like?

Aaron Whitehouse (luna-tick) wrote :

Note that I have only tested the lid-close button - not suspending. Let me know if you want any other logs and then I will try suspending to RAM.

Andrea Bocci (fwyzard) wrote :

Back after some more testing. To summarise: my problem is not related to hybernation or suspension, just closing the lid (or hitting the close lid button) makes the system hang.
One funny thing is that the screen goes black (not blank) except for the mouse pointer!

1.) If I plug in a second monitor to the VGA connector, the blanking on lid close is disable, and this problem disappears. Is it possible to forcibly disable the screen blanking even when no external monitor is attached?

2.) I've tried xserver-xorg-video-intel_2.1.1-0ubuntu10~pcjc2.2_i386.deb , but it doesn't help me: my system still lock as soon as I close the lid.

3.) The system hangs even when I'm running only KDM, so it shouldn't be related to Compiz & company.

How should I go on debugging ?

Andrea Bocci (fwyzard) wrote :

4.) /var/log/Xorg.0.log doesn't show anything after reboot (and before launching X again) - all the messages are related to startup and present way before the system lock up.

anco (ancovanbergeijk) wrote :

Just for the stats. I'm experiencing this bug too on a toshiba satellite R15-S829 855GM intel. Since my upgrade to Gutsy.. Also total crash if screensaver kicks in. Not always, but too often... weird. Switched off screensaver even when on battery power and leave my laptop open... Than it still crashes after like two hours on Ac power. My nightly downloads don't work anymore... Every morning my system has crashed...

Hopefully some smart guys solve this soon. Thanks already.

Peter Clifton (pcjc2) wrote :

Raúl Sánchez Siles has a good lead on this in the fd.o bug 11432,
https://bugs.freedesktop.org/show_bug.cgi?id=11432

He's working around the crash by forcing PipeA to be enabled, without an external screen attached. This is a step in the right direction to debugging the issue. We may be able to get a better solution still by identifying where this specific crash occurs, and either enabling PIpeA for that portion of code, or avoiding that code-path when PipeA is disabled.

Peter Clifton (pcjc2) wrote :

Could someone give the following package a test. The bug will be present, but there will hopefully be more interesting information in the logs. I've added sync(); calls after the debug prints I added, so these _SHOULD_ make it to disk if you turn off HDD write caching:
hdparm -W 0 <device>

http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/debug/xserver-xorg-video-intel_2.1.1-0ubuntu10~pcjc2.tst3_i386.deb

Please post the logs back, if I've added enough print messages, we'll catch where the crash is occuring and will be a lot closer to figuring out a fix.

Peter Clifton (pcjc2) on 2007-10-28
Changed in xserver-xorg-video-intel:
status: In Progress → Incomplete
anco (ancovanbergeijk) wrote :

19 hours ago I still had this problem with crash too when closing lid..... Well for me it is gone. I changed my xorg.conf to driver "intel" and installed the latest driver I found on another bugdiscussion.
http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/xserver-xorg-video-intel_2.1.1-0ubuntu10~pcjc2.2_i386.deb

I'm just an ubuntu user and not a hacker/programmer orso. Appearently after my upgrade from feisty to gutsy my xorg.conf wasn't changed to the intel driver, but anyhow I directly had very buggy X behavior. Then because when somebody asked me to look at xorg.conf there was i810 in my config...changed it to intel.... I've tried like 20 times closing the lid and it works fine now, before 50% off the lidclosings went into full crash. So toshiba R15-S829 with 82852/855GM runs great again including suspend and hibernation. Thanks Peter

Aaron Whitehouse (luna-tick) wrote :

Here is the log from the new package. Hopefully it is more useful.

For the record, mine is a clean install and uses Intel.

Aaron Whitehouse (luna-tick) wrote :

I did disable HD caching and attached the log. Setting back to confirmed - let me know if you need any further logs.

Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Peter Clifton (pcjc2) wrote :

Thanks for the log... just a heads up though, bugs which have replies since being marked incomplete may be easier to "find" than bugs marked as confirmed. Doesn't matter in my case, as I'm reading the bugmail, but there is a lot and it might get missed.

I don't see any of the debug statements hit at the end of the log unfortunately. I notice its not the Xorg.0.log.old you attached, however as you comment above that you retrieved the logs from a different install, I'll assume you did the same in this case unless you post otherwise.

Peter Clifton (pcjc2) wrote :

To get a better feel for when / how this happens, can you let me know what is effected (display power / brightness controls / crash when closing lid etc..) if you remove the "video" ACPI module:
sudo rmmod video

This may identify if the bug is in the driver / BIOS, or can be avoided. If this avoids the crash, we've learned a lot. If it still crashes, we may have learn't a little.

Can you report the output of:
cat /proc/acpi/video/*/DOS

(Before and after removing the video module)

Can you run:
sudo cat /proc/acpi/dsdt > ~/dsdt.aml

and attach the dsdt.aml file created in your home-dir. (It _might_ be useful to take a look at the ACPI firmware from one or more affected machines.)

Peter Clifton (pcjc2) on 2007-10-29
Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Andrea Bocci (fwyzard) wrote :

Hi Peter,
I don't know if this helps, but if I connect an external monitor to the VGA output, the lid button works properly, and using the "debug" intel driver I see these lines at the end of Xorg.0.log

(II) PM Event received: Capability Changed
I830PMEvent: Capability change
(WW) intel(0): Disabling pipe 0 (4)
(WW) intel(0): Survived poke
(WW) intel(0): Disabling pipe 1 (4)
(WW) intel(0): Survived poke
(II) PM Event received: Capability Changed
I830PMEvent: Capability change
(WW) intel(0): Enabling pipe 0 (3)
(WW) intel(0): Survived poke
(WW) intel(0): Enabling plane 0 (3)
(WW) intel(0): Survived poke
(WW) intel(0): Enabling pipe 1 (3)
(WW) intel(0): Survived poke
(WW) intel(0): Enabling plane 1 (3)
(WW) intel(0): Survived poke

with no external monitor attached, the system hangs (black screen but for the mouse pointer) and after reboot in text mode I don't see anything in the Xorg.0.log .

I'll try again without external monitor with the ACPI stuff you posted.

.Andrea

Andrea Bocci (fwyzard) wrote :

OK, I tried after removing the "video" module. I still get a system lock :-(

# cat /proc/acpi/video/*/DOS (before rrmod'ing)

DOS setting: <4>
DOS setting: <4>

# cat /proc/acpi/video/*/DOS (after rrmod'ing)

cat: /proc/acpi/video/*/DOS: No such file or directory

/proc/acpi/dsdt is attached

Janna (horsecrazyinca) wrote :

Problem is also occuring on Toshiba U205. Very unpleasant...my computer is crashing 2-3 times per day, and I can't close my laptop lid without having to restart the computer. Considering I'm a student, this is a BIG problem. Let me know if you need logs.

Stan Couix (s-couix) wrote :

Hi,
Don't know if this can help but I experienced this bug (as originally posted) on and Dell laptop 510m, with intel 855GM chip and "intel" driver on a fresh install of gutsy. Everything was fine when I was under feisty with i810 driver, so I switch to i810 driver and everything go back to normal ! Compiz fusion works great too and no problem with totem-xine video player.

MaxNegro (maxnegro) wrote :

I can confirm the bug on a Toshiba Satellite A510. Strange thing is: I'm experiencing this (screen stays blank on lid close) _and_ still using "old" i810 driver.

output from lspci:
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Relevant part of Xorg.0.log:
(II) LoadModule: "i810"
(II) Loading /usr/lib/xorg/modules/drivers//i810_drv.so
(II) Module i810: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.7.4
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2

Relevant part of Xorg.0.log.old (hopefully near or during freeze):
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetGrabKeysState - disabled
f000:5503: 01 ILLEGAL EXTENDED X86 OPCODE!
SetGrabKeysState - enabled
SetGrabKeysState - disabled

Aaron Whitehouse (luna-tick) wrote :

Stan,

I already reported that i810 fixes the issue (in Bug #150109 ), but the comment isn't in this bug.

"

I have been playing with this and have determined the following
(rebooting/hard-powering-off in between tests):

Three times I tested suspending with the Intel driver. It seems to
resume correctly and then reaches the password prompt to unlock the
screen. I enter my password, press enter and it freezes. This occurred
each of the three times. Sometimes it froze while the prompt was still
on the screen, sometimes it disappeared first leaving a black screen.

I then dpkg-reconfigure xserver-xorg and changed the driver to i810.
This works perfectly and never hanged. I tried this three times with
no issues.

I then dpkg-reconfigure xserver-xorg and changed the driver to Intel.
I used the configuration editor to stop the screen locking on suspend.
I then rebooted and tried again. It behaved the same as the initial
Intel tests: appearing to work, but hanging before the desktop is
displayed - leaving a black screen.

Turning off the desktop effects makes the suspending work properly and
it does not hang."

Clearly, this happens with the lid-button as well as suspending.

Stan, as your machine sounds identical to mine, you may like to check over my page at https://wiki.ubuntu.com/LaptopTestingTeam/DellInspiron510m - your help on that page and linked bugs would be great.

Peter - yes, that was from a different install, so Xorg.log was attached instead of the old one; sorry, I thought that the log would make it clear that it was with the new driver.

I'll run the new tests when I get a chance. Thanks a lot for your help on this bug, Peter.

Aaron Whitehouse (luna-tick) wrote :

Before removing video module:
$ cat /proc/acpi/video/*/DOS
DOS setting: <1>
DOS setting: <1>

Aaron Whitehouse (luna-tick) wrote :

After removing the video module:
$ cat /proc/acpi/video/*/DOS
cat: /proc/acpi/video/*/DOS: No such file or directory

I've attached the dsdt output after removing the module. I didn't know whether it would change, but attached it anyway.

Aaron Whitehouse (luna-tick) wrote :

The crash still occurs on pressing the lid-close button. I will attach my Xorg log (I am back in the testing install, so will attach the "old" log).

Changing brightness is not affected (that occurs in BIOS on a Dell laptop) and nothing else seems to be affected either.

Download full text (19.2 KiB)

This is not a suspend issue at all. Suspend works fine. It is resuming an
X session after the screen is locked that is the problem.

My laptop is a Dell 640m, with intel 945GM chipset. The bug occurs when the
screen is blanked/locked under the following circumstances:

Compiz enabled, intel xorg driver (using Peter's tst3 driver above).
Compiz enabled, i810 xorg driver.

the password prompt to unlock the screen shows up, the keyboard works fine
until you unlock the screen. Then I am faced with a blank, backlit screen,
with the mouse pointer visible and working. The keyboard is unresponsive.
the only key that works for me is the wireless switch function key. Screen
brightness does not work. The only method of recovering my computer is to
hard reset tthe machine.

Attached is the output of lspci -vv, my xorg.conf, and my x log .

I wonder if this bug might be related to the gnome screensaver?

Thanks for the efforts,

Rory

On 11/1/07, Aaron Whitehouse <email address hidden> wrote:
>
> The crash still occurs on pressing the lid-close button. I will attach
> my Xorg log (I am back in the testing install, so will attach the "old"
> log).
>
> Changing brightness is not affected (that occurs in BIOS on a Dell
> laptop) and nothing else seems to be affected either.
>
>
> ** Attachment added: "Xorg.0.log.old"
> http://launchpadlibrarian.net/10230493/Xorg.0.log.old
>
> --
> xserver-xorg-video-intel hangs the system when laptop lid is closed
> https://bugs.launchpad.net/bugs/138256
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--

My email address has changed to <email address hidden>

From October <email address hidden> will no longer be active. Please update
your address book.

Cheers,

Rory

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
 Subsystem: Dell Unknown device 01d8
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
 Latency: 0
 Capabilities: [e0] Vendor Specific Information

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA])
 Subsystem: Dell Unknown device 01d8
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at eff00000 (32-bit, non-prefetchable) [size=512K]
 Region 1: I/O ports at eff8 [size=8]
 Region 2: Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Region 3: Memory at efec0000 (32-bit, non-prefetchable) [size=256K]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [d0] Power Management version 2
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/G...

Changed in xorg-server:
status: Confirmed → Incomplete
Changed in xorg-server:
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2007-11-16
Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: Incomplete → Triaged
Changed in xorg-server:
status: Confirmed → Incomplete
Changed in xorg-server:
status: Incomplete → Confirmed
Changed in xorg-server:
status: Confirmed → Incomplete
Changed in xorg-server:
status: Incomplete → Confirmed
Changed in xorg-server:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) on 2008-02-06
Changed in xserver-xorg-video-intel:
status: New → Invalid
status: Triaged → Fix Released
sklp (sklp) on 2008-02-09
Changed in xserver-xorg-video-intel:
status: Fix Released → Confirmed
29 comments hidden view all 109 comments

I just switched my system to use the i810 drivers, and there it works properly.

This is on a Dell Latitude D500 with Intel 855GM video.

So I agree that this is a bug with the intel driver.

Alex Mauer (hawke) wrote :

Setting

Option "ForceEnablePipeA" "true"

worked around the problem on my machine.

Just found this bug is requested to open by jbarnes.

The problem still persists in Ubuntu 7.10 (2.6.22-14-generic) on a Dell Latitude D505 Intel 855GME chipset.
Will anybody do something about it? Who should I contact and with what information?
How do I switch the drivers? Where do I write "ForceEnablePipeA" "true"?

It has also been reported on the Ubuntu launchpad system that this also still affects Latitude D505

Can you get the info for the Latitude D505? I haven't seen a bug for that...

I've asked the reporter of D505 to provide the same output for lspci. If he does, I'll add it here.

Let me know if you want it in a new bug instead.

Please file a new bug when you get the info for the other platform. I've fixed this one in commit 02c0ffb1d8112a6fb03f9c8eae9ec1a1fca123ef, please test and make sure it works for you.

Yep, works for me.

Thanks.

in /etc/X11/xorg.conf, change:

Section "Device"
        Identifier "Configured Video Device"
        Driver "intel"
EndSection

to

Section "Device"
        Identifier "Configured Video Device"
        Driver "intel"
        Option "ForceEnablePipeA" "true"
EndSection

Alex Mauer (hawke) wrote :

D505:
If you can provide the output from 'sudo lspci -v' and 'sudo lspci -vn' we can get the fix built in for you.

Alex Mauer (hawke) wrote :

(assuming that option fixes the problem for you)

Download full text (10.7 KiB)

Attached are the output of lspci -v and -vn on my machine (v.txt and
vn.txtrespectively):

On Mon, Mar 10, 2008 at 1:22 PM, Alex Mauer <email address hidden> wrote:

> (assuming that option fixes the problem for you)
>
> --
> xserver-xorg-video-intel hangs the system when laptop lid is closed
> https://bugs.launchpad.net/bugs/138256
> You received this bug notification because you are a direct subscriber
> of the bug.
>

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
 Subsystem: Toshiba America Info Systems Unknown device 0001
 Flags: bus master, fast devsel, latency 0
 Capabilities: [e0] Vendor Specific Information

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03) (prog-if 00 [VGA])
 Subsystem: Toshiba America Info Systems Unknown device 0001
 Flags: bus master, fast devsel, latency 0, IRQ 21
 Memory at cff80000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at cff8 [size=8]
 Memory at b0000000 (32-bit, prefetchable) [size=256M]
 Memory at cff40000 (32-bit, non-prefetchable) [size=256K]
 Capabilities: [d0] Power Management version 2

00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
 Subsystem: Toshiba America Info Systems Unknown device 0001
 Flags: fast devsel
 Memory at 64000000 (32-bit, non-prefetchable) [disabled] [size=512K]
 Capabilities: [d0] Power Management version 2

00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03) (prog-if 00 [UHCI])
 Subsystem: Toshiba America Info Systems Unknown device 0001
 Flags: bus master, medium devsel, latency 0, IRQ 18
 I/O ports at cf80 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03) (prog-if 00 [UHCI])
 Subsystem: Toshiba America Info Systems Unknown device 0001
 Flags: bus master, medium devsel, latency 0, IRQ 19
 I/O ports at 28c0 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03) (prog-if 00 [UHCI])
 Subsystem: Toshiba America Info Systems Unknown device 0001
 Flags: bus master, medium devsel, latency 0, IRQ 20
 I/O ports at 28e0 [size=32]

00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03) (prog-if 00 [UHCI])
 Subsystem: Toshiba America Info Systems Unknown device 0001
 Flags: bus master, medium devsel, latency 0, IRQ 21
 I/O ports at 2c00 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03) (prog-if 20 [EHCI])
 Subsystem: Toshiba America Info Systems Unknown device 0001
 Flags: bus master, medium devsel, latency 0, IRQ 18
 Memory at 64080000 (32-bit, non-prefetchable) [size=1K]
 Capabilities: [50] Power Management version 2
 Capabilities: [58] Debug port

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3) (prog-if 01 [Subtractive decode])
 Flags: bus master, fast devsel, latency 0
 Bus: primary=00, secondary=02, subordinate=04, sec-latency=32
 I/O behind bridge: 00001000-00001fff
 Memory behind bridge: cfe0...

Alex Mauer (hawke) wrote :

n/m, I see you have the Portege.

Oh no, it's from a Toshiba Portege that appears to experience the same
problem.

On Mon, Mar 10, 2008 at 1:57 PM, Alex Mauer <email address hidden> wrote:

> Matt: That's from a D505?
>
> --
> xserver-xorg-video-intel hangs the system when laptop lid is closed
> https://bugs.launchpad.net/bugs/138256
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alex Mauer (hawke) wrote :

Matt: the ForceEnablePipeA option fixes the problem for you, right?

Hi,

just to tell you ForceEnablePipeA seems to fix the problem here, on a Vaio VGN-SZ4.

lspci -v | grep VGA gives me :
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA])

Here there side effects on using ForceEnablePipeA ?

Changed in xorg-server:
status: Unknown → Fix Released
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Alex Mauer (hawke) wrote :

If you can provide full output of 'lspci -v' and 'lspci -vn' that would be much appreciated, and the problem can be forwarded upstream.

The only side effect I know of from using ForceEnablePipeA is slightly increased power usage. That's according to the upstream bug.

Colin Macdonald (cbm755) wrote :

FYI: Thinkpad R31 needs the Pipe A quirk. Submitted upstream as:

https://bugs.freedesktop.org/show_bug.cgi?id=14960

Attached are full output of lspci -v and -vn for my Sony Vaio VGN-SZ4MN

1 comments hidden view all 109 comments
Rok Lenardic (spuzvica) wrote :

Same problem with hardy alpha 6, updated to the latest package names on 22-03-2008.

My laptop is HP 6510b.

lspci -vn attached

Franck (alci) wrote :

Hi,

I reinstalled my system (previously under Gusty) in with Hardy beta. The bug is still here.
When installing, default xorg.conf device section is minimalist :

Section "Device"
        Identifier "Configured Video Device"
EndSection

So the ForceEnablePipeA option workaround is not activated. In fact you don't even know which video driver will be used ??

Anyway, if I either try to hibernate or suspend, I get a console with a blinking cursor, and then nothing anymore. I have to hard reboot. (nb: I already attached lspci)

Bryce Harrington (bryce) on 2008-04-05
description: updated
Bryce Harrington (bryce) wrote :

I just uploaded 2:2.2.1-1ubuntu7 which syncs a bunch of the pipe A quirks from upstream. I notice that the bulk of these new quirks originated from the diligence of folks on this bug report who reported them upstream. Props to you guys. :-)

For those not familiar with quirks, each quirk applies to a very specific graphics card model. So while we've fixed the issue for the cards that people provided pci id's in this bug report, it is not unlikely that other folks with different card models will have the same issue. So what you'll need to do is:

  a. Test setting Option "ForceEnablePipeA" "true" in your Device section

  b. If that works, then yes you have this bug; go to (c). If not, file the issue as a new bug report.

  c. Get your 'Subsystem Vendor PCI ID'. The easiest way to get this is from lspci. For example, `lspci -vvnn | grep -A1 "VGA compat"`. Or just attach your Xorg.0.log or the full output from `lspci -vvnn`.

  d. File a new bug against xserver-xorg-video-intel with a title like "Need a Pipe-A quirk for <your video card PCI ID>". Include the info from (c). You might also want to reference this bug report in the comments.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Aaron Whitehouse (luna-tick) wrote :

All working for me now, thanks :).

Bryce Harrington (bryce) wrote :

Oh, also:

e. Give the name of your laptop (or motherboard) for documentation purposes

Bryce Harrington (bryce) on 2008-05-02
description: updated
tomaszr (tomasz-rosinski) wrote :

HP6710s is affected too, now works fine when add: Option "ForceEnablePipeA" "true"
before i used "blacklist video" and was ok but now is better :)
thanks

lspci -vvnn | grep -A1 "VGA compat"

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Compaq 6710b [103c:30c0]

tomaszr (tomasz-rosinski) wrote :

but not work suspend and hibernate :( before this not work too.

Bryce Harrington (bryce) wrote :

tomaszr, please report as a new bug as per the previous instructions, so we can properly track it for sru's, etc.

ForceEnablePipeA worked for my dell latitude d400
I filed a new bug report, as per instructions, here: Bug #228519
thanx!

before finding this bug report, i found Bug #210339
the bug reporter has the same symptoms, though he has a nVidia GeForce Go 7600. will this also help him? should he try it even though he doesn't have an intel chipset?

Bryce Harrington (bryce) wrote :

Hi frankie,

I'll get the d400 in for intrepid (and maybe hardy-proposed later after it's been verified).

I don't know if the PipeA approach would be valid for nVidia. Some quirks are highly particular to a driver, others are more general, but I don't know where Pipe A falls. It would be worthwhile to test.

The force
    Option "ForceEnablePipeA" "true"
  EndSection

works I can confirm this. ! please add this option if it works in testing for others. fixed on a dell system (latitude similar to the the inspiron system listed below ) (laptop can switch vt's and back many times and close and then open the screen it looks like from initial testing. 138256 BUG number. This fix might only help out dell intel computers (may have a different acpi protocol to other laptops / systems.)

Changed in xserver-xorg-video-intel:
assignee: nobody → dbmoodb
status: Invalid → Confirmed

Following the comment, I added ForceEnablePipeA to xorg.conf, like below

Section "Device"
 ... <other options here> ...
 Option "ForceEnablePipeA" "true"
EndSection

I tried 10x to reproduce the problem without success (login/logout). I was possible to hibernate and suspend as well. This option seems to solve the problem. I am using a newer gdm version as well (2.20.6-0ubuntu1) but problem was happening with it if I don't use the cited option.

Just to keep the bug tracker up to date. I will test more. I have a Dell Latitude D505 with Intel 855GM.

Bryce Harrington (bryce) wrote :

Remember to file a *new* bug, and follow the directions in the description of this bug. We have to apply the fix for each specific chip version separately, so it's important to provide all the needed info each time, else fixes for your chipset will be missed.

Nathan Hartley (treestryder) wrote :

I have a Dell C400 running Lubuntu (happened in Ubuntu as well) 10.04 that is exhibiting the same behavior. When I attempted to add the option "ForceEnablePipeA" to my xorg.conf file I learned that Xorg now favors auto-configuration and does not start with a configuration file. Please advise. Thanks.

Peter M. Clausen (pclausen) wrote :

Have the same problem (see bug #462939) and ForceEnablePipeA did not do the trick

tags: added: lucid
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Changed in xorg-server:
importance: Unknown → High
Peter M. Clausen (pclausen) wrote :

@Bug wathcer Updater: see apport-collect in bug #462939. I wont double post unless you say so.

Changed in xorg-server:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → High
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 109 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.