Wubi.exe on http://releases.ubuntu.com/lucid/ is the wrong version (10.04.1 instead of 10.04.2)

Bug #722955 reported by bcbc on 2011-02-22
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
High
Colin Watson
Ubuntu Website - OBSOLETE
Undecided
Unassigned
Wubi
High
Colin Watson

Bug Description

As mentioned in the summary, the version of wubi.exe on http://releases.ubuntu.com/lucid/ is still 10.04.1. This doesn't work anymore, since 10.04.2 has been released.

I've confirmed that running the 10.04.2 wubi.exe from http://people.canonical.com/~evand/wubi/lucid/wubi-r191.exe works but running wubi.exe from http://releases.ubuntu.com/lucid/ (10.04.1) fails.

=======================================================================
This is what happens when you run wubi.exe 10.04.1:
--------------------------------------------------
02-21 17:00 DEBUG CommonBackend: Could not find any ISO or CD, downloading one now
02-21 17:00 DEBUG TaskList: New task get_metalink
02-21 17:00 DEBUG TaskList: ### Running get_metalink...
02-21 17:00 DEBUG downloader: downloading http://releases.ubuntu.com/10.04.1/ubuntu-10.04.1-desktop-amd64.metalink > C:\ubuntu\install
02-21 17:00 ERROR CommonBackend: Cannot download metalink file http://releases.ubuntu.com/10.04.1/ubuntu-10.04.1-desktop-amd64.metalink err=[Errno 14] HTTP Error 404: Not Found
02-21 17:00 DEBUG downloader: downloading http://cdimage.ubuntu.com/daily-live/current/lucid-desktop-amd64.metalink > C:\ubuntu\install
02-21 17:00 DEBUG downloader: Download start filename=C:\ubuntu\install\lucid-desktop-amd64.metalink, url=http://cdimage.ubuntu.com/daily-live/current/lucid-desktop-amd64.metalink, basename=lucid-desktop-amd64.metalink, length=1010, text=None
02-21 17:00 DEBUG downloader: download finished (read 1010 bytes)
02-21 17:00 DEBUG downloader: downloading http://cdimage.ubuntu.com/daily-live/current/MD5SUMS-metalink > C:\ubuntu\install
02-21 17:00 DEBUG downloader: Download start filename=C:\ubuntu\install\MD5SUMS-metalink, url=http://cdimage.ubuntu.com/daily-live/current/MD5SUMS-metalink, basename=MD5SUMS-metalink, length=257, text=None
02-21 17:00 DEBUG downloader: download finished (read 257 bytes)
02-21 17:00 DEBUG downloader: downloading http://cdimage.ubuntu.com/daily-live/current/MD5SUMS-metalink.gpg > C:\ubuntu\install
02-21 17:00 DEBUG downloader: Download start filename=C:\ubuntu\install\MD5SUMS-metalink.gpg, url=http://cdimage.ubuntu.com/daily-live/current/MD5SUMS-metalink.gpg, basename=MD5SUMS-metalink.gpg, length=198, text=None
02-21 17:00 DEBUG downloader: download finished (read 198 bytes)
02-21 17:00 INFO saplog: Verified a signature from ID:'46181433FBB75451'.
02-21 17:00 INFO saplog: Checking block bindings..
02-21 17:00 INFO saplog: Key verified successfully.
02-21 17:00 DEBUG CommonBackend: metalink md5sums:
2b8731d74a30fcb3ad22ae5b58c8b0d6 natty-desktop-amd64+mac.metalink
d16cf0bd4223dd0150ec785c6a57b0e9 natty-desktop-amd64.metalink
1ec2a8e66cf5e5b128916e9933681ac1 natty-desktop-i386.metalink
08ba9f6620fe3b99a93ba1af30fc2e96 natty-desktop-powerpc.metalink

02-21 17:00 ERROR CommonBackend: The md5 of the metalink does match
02-21 17:00 ERROR CommonBackend: Cannot authenticate the metalink file, it might be corrupt
Traceback (most recent call last):
  File "\lib\wubi\backends\common\backend.py", line 367, in get_metalink
  File "\lib\wubi\backends\common\downloader.py", line 79, in download
  File "\lib\urlgrabber\grabber.py", line 927, in urlgrab
  File "\lib\urlgrabber\grabber.py", line 845, in _retry
  File "\lib\urlgrabber\grabber.py", line 913, in retryfunc
  File "\lib\urlgrabber\grabber.py", line 1001, in __init__
  File "\lib\urlgrabber\grabber.py", line 1072, in _do_open
  File "\lib\urlgrabber\grabber.py", line 1182, in _make_request
URLGrabError: [Errno 14] HTTP Error 404: Not Found
02-21 17:00 DEBUG TaskList: ### Finished get_metalink
02-21 17:00 DEBUG TaskList: New task download
02-21 17:00 DEBUG TaskList: ### Running download...
02-21 17:00 DEBUG btdownloader: downloading http://cdimage.ubuntu.com/lucid/daily-live/20110211.1/lucid-desktop-amd64.iso.torrent > C:\ubuntu\install\lucid-desktop-amd64.iso
02-21 17:00 ERROR TaskList: problem getting response info - HTTP Error 404: Not Found
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\btdownloader.py", line 79, in download
  File "\lib\bittorrent\download.py", line 129, in download
  File "\lib\wubi\backends\common\btdownloader.py", line 70, in error_callback
DownloadError: problem getting response info - HTTP Error 404: Not Found
02-21 17:00 ERROR TaskList: Non fatal error problem getting response info - HTTP Error 404: Not Found in task download
02-21 17:00 DEBUG TaskList: ### Finished download
02-21 17:00 DEBUG TaskList: New task download
02-21 17:00 DEBUG TaskList: ### Running download...
02-21 17:00 DEBUG downloader: downloading http://cdimage.ubuntu.com/lucid/daily-live/20110211.1/lucid-desktop-amd64.iso > C:\ubuntu\install\lucid-desktop-amd64.iso
02-21 17:00 DEBUG downloader: Download start filename=C:\ubuntu\install\lucid-desktop-amd64.iso, url=http://cdimage.ubuntu.com/lucid/daily-live/20110211.1/lucid-desktop-amd64.iso, basename=lucid-desktop-amd64.iso, length=721129472, text=None
02-21 17:18 DEBUG TaskList: ### Finished download
02-21 17:18 DEBUG downloader: download finished (read 721129472 bytes)
02-21 17:18 DEBUG TaskList: New task check_iso
02-21 17:18 DEBUG TaskList: ### Running check_iso...
02-21 17:18 DEBUG CommonBackend: Checking C:\ubuntu\install\lucid-desktop-amd64.iso
02-21 17:18 DEBUG Distro: checking Ubuntu ISO C:\ubuntu\install\lucid-desktop-amd64.iso
02-21 17:18 DEBUG WindowsBackend: extracting .disk\info from C:\ubuntu\install\lucid-desktop-amd64.iso
02-21 17:18 DEBUG Distro: parsing info from str=Ubuntu 10.04.2 LTS "Lucid Lynx" - Release amd64 (20110211.1)
02-21 17:18 DEBUG Distro: parsed info={'name': 'Ubuntu', 'subversion': 'Release', 'version': '10.04.2', 'build': '20110211.1', 'codename': 'Lucid Lynx', 'arch': 'amd64'}
02-21 17:18 DEBUG Distro: wrong version: 10.04.2 != 10.04.1
02-21 17:18 DEBUG TaskList: ### Finished check_iso
02-21 17:18 ERROR TaskList: Could not retrieve the required installation files
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\backend.py", line 498, in get_iso
Exception: Could not retrieve the required installation files
02-21 17:18 DEBUG TaskList: # Cancelling tasklist
02-21 17:18 DEBUG TaskList: # Finished tasklist
02-21 17:18 ERROR root: Could not retrieve the required installation files
Traceback (most recent call last):
  File "\lib\wubi\application.py", line 56, in run
  File "\lib\wubi\application.py", line 130, in select_task
  File "\lib\wubi\application.py", line 156, in run_installer
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\backend.py", line 498, in get_iso
Exception: Could not retrieve the required installation files

bcbc (bcbc) on 2011-02-22
Changed in wubi:
status: New → Confirmed
bcbc (bcbc) wrote :

Confirmed that R191 from http://people.canonical.com/~evand/wubi/lucid/ works correctly. Also confirmed that the image ubuntu-10.04.2-desktop-i386.iso contains the correct version of wubi.exe (rev191).

bcbc (bcbc) on 2011-03-06
description: updated
Changed in ubuntu-website:
status: New → Invalid
bcbc (bcbc) wrote :

@Chris Johnston,
Isn't ubuntu-website responsible for releases.ubuntu.com? If not, do you know who is responsible for this? I'm not aware of who to contact to get this problem fixed.

Or maybe just state the rationale for marking it invalid.

Download full text (7.6 KiB)

Please note, the bug was marked invalid in one project and reported to
another project.
On Mar 9, 2011 11:01 PM, "bcbc" <email address hidden> wrote:
> @Chris Johnston,
> Isn't ubuntu-website responsible for releases.ubuntu.com? If not, do you
know who is responsible for this? I'm not aware of who to contact to get
this problem fixed.
>
> Or maybe just state the rationale for marking it invalid.
>
> --
> You received this bug notification because you are a member of Ubuntu
> Website Editors, which is subscribed to Ubuntu Website.
> https://bugs.launchpad.net/bugs/722955
>
> Title:
> Wubi.exe on http://releases.ubuntu.com/lucid/ is the wrong version
> (10.04.1 instead of 10.04.2)
>
> Status in Ubuntu Website Product:
> Invalid
> Status in Ubuntu Website Content:
> New
> Status in Wubi, Windows Ubuntu Installer:
> Confirmed
>
> Bug description:
> As mentioned in the summary, the version of wubi.exe on
> http://releases.ubuntu.com/lucid/ is still 10.04.1. This doesn't work
> anymore, since 10.04.2 has been released.
>
> I've confirmed that running the 10.04.2 wubi.exe from
> http://people.canonical.com/~evand/wubi/lucid/wubi-r191.exe works but
> running wubi.exe from http://releases.ubuntu.com/lucid/ (10.04.1)
> fails.
>
> =======================================================================
> This is what happens when you run wubi.exe 10.04.1:
> --------------------------------------------------
> 02-21 17:00 DEBUG CommonBackend: Could not find any ISO or CD, downloading
one now
> 02-21 17:00 DEBUG TaskList: New task get_metalink
> 02-21 17:00 DEBUG TaskList: ### Running get_metalink...
> 02-21 17:00 DEBUG downloader: downloading
http://releases.ubuntu.com/10.04.1/ubuntu-10.04.1-desktop-amd64.metalink >
C:\ubuntu\install
> 02-21 17:00 ERROR CommonBackend: Cannot download metalink file
http://releases.ubuntu.com/10.04.1/ubuntu-10.04.1-desktop-amd64.metalinkerr=[Errno
14] HTTP Error 404: Not Found
> 02-21 17:00 DEBUG downloader: downloading
http://cdimage.ubuntu.com/daily-live/current/lucid-desktop-amd64.metalink >
C:\ubuntu\install
> 02-21 17:00 DEBUG downloader: Download start
filename=C:\ubuntu\install\lucid-desktop-amd64.metalink, url=
http://cdimage.ubuntu.com/daily-live/current/lucid-desktop-amd64.metalink,
basename=lucid-desktop-amd64.metalink, length=1010, text=None
> 02-21 17:00 DEBUG downloader: download finished (read 1010 bytes)
> 02-21 17:00 DEBUG downloader: downloading
http://cdimage.ubuntu.com/daily-live/current/MD5SUMS-metalink >
C:\ubuntu\install
> 02-21 17:00 DEBUG downloader: Download start
filename=C:\ubuntu\install\MD5SUMS-metalink, url=
http://cdimage.ubuntu.com/daily-live/current/MD5SUMS-metalink,
basename=MD5SUMS-metalink, length=257, text=None
> 02-21 17:00 DEBUG downloader: download finished (read 257 bytes)
> 02-21 17:00 DEBUG downloader: downloading
http://cdimage.ubuntu.com/daily-live/current/MD5SUMS-metalink.gpg >
C:\ubuntu\install
> 02-21 17:00 DEBUG downloader: Download start
filename=C:\ubuntu\install\MD5SUMS-metalink.gpg, url=
http://cdimage.ubuntu.com/daily-live/current/MD5SUMS-metalink.gpg,
basename=MD5SUMS-metalink.gpg, length=198, text=None
> 02-21 17:00 DEBUG downloader: download finished (read 198 b...

Read more...

bcbc (bcbc) wrote :

Ah... my mistake. All I saw was the invalid bit.

Thanks!

Richard Henry Lee (rhlee) wrote :

ACTION:

Assign to correct project

Changed in ubuntu-website-content:
status: New → Confirmed
importance: Undecided → Medium
bcbc (bcbc) wrote :

Bump...

Someone has now changed the wubi.exe on http://www.ubuntu.com/desktop/get-ubuntu/windows-installer to be the same one mentioned here: version 10.04.1. (new bug 762833).

I don't know how to make a bug critical... but users are downloading this invalid wubi.exe and letting it download the 700MB 10.04.2 image and then rejecting it - it's a pain, doesn't look good, and really it should be a simple fix.

So could someone figure out who is responsible and ask them to change it? Pretty please?

PS... a suggestion. State what version of Ubuntu is being downloaded from http://www.ubuntu.com/desktop/get-ubuntu/windows-installer so users are aware what release it is... and also when you change wubi.exe the next time - you can let me know and I'll be very happy to test it to prevent problems like this in the future. It takes pretty much 5 minutes to check it's the correct .exe.

Thanks

Colin Watson (cjwatson) wrote :

releases.ubuntu.com is handled via the ubuntu-cdimage project.

affects: ubuntu-website-content → ubuntu-cdimage
Colin Watson (cjwatson) wrote :

Apologies for this - it was probably my fault that http://releases.ubuntu.com/lucid/wubi.exe didn't get updated, although the www.ubuntu.com maintainers didn't think to ask me before pointing the website at that instead of maverick either ...

I've updated http://releases.ubuntu.com/lucid/wubi.exe to the version from the 10.04.2 release, and added an entry to https://wiki.ubuntu.com/PointReleaseProcess to try to make sure this doesn't happen again. Since www.ubuntu.com tries to redirect you to a local mirror, it may take a little while before this fix is visible to everyone, but it shouldn't take too long.

Changed in ubuntu-cdimage:
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Released
Changed in wubi:
status: Confirmed → Fix Released
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
Changed in ubuntu-cdimage:
importance: Medium → High
Changed in wubi:
importance: Medium → High
Colin Watson (cjwatson) wrote :

Issues about www.ubuntu.com are probably better off in bug 762833.

bcbc (bcbc) wrote :

@Colin Watson, thanks for sorting this out!

Andrew (legoman666) wrote :

This is still not working. I downloaded the wubi.exe 2 hours ago and ran it. It downloaded lucid-desktop-amd64.iso which contained version 10.04.2 which then caused the installer to fail with the error "Distro: wrong version: 10.04.2 != 10.04.1"

bcbc (bcbc) wrote :

@Andrew, I'm getting the correct wubi.exe and it's installing on my computer (with i386 version of 10.04.2 lucid desktop). Make sure that Wubi shows 10.04.2 (top middle), and rev191 (bottom left). Also, where are you downloading it from?

Colin Watson (cjwatson) wrote :

Can you get the md5sum of the wubi.exe you downloaded? It could just be
a stale mirror.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers