After install completed bar wasn't all green and installer hung

Bug #204128 reported by Brian Murray on 2008-03-20
12
Affects Status Importance Assigned to Milestone
Wubi
High
Agostino Russo

Bug Description

LATEST ISO TESTED:
kubuntu amd64 build 20080417.1

I received the installation complete dialog but the green throbber was only about 75% full.

description: updated
Brian Murray (brian-murray) wrote :

This has happened a second time when I was installing it. The dialog says "Installation Complete" the bar extends approximately between the "back" and "close" buttons and the CD drive has ejected. After clicking the close button the "Ubuntu Setup" application is indicating it is not responding.

Agostino Russo (ago) wrote :

I can confirm that, but it does not seem to have any implication for the installation. In my case the last steps (after ISO is downloaded/extracted/checked) are quite quick and before the bar reaches the end you are shown the reboot window.

The progress status is calculated directly by nsis, so changing that might not be that easy.

Agostino Russo (ago) on 2008-03-20
Changed in wubi:
assignee: nobody → ago
importance: Undecided → Low
status: New → Confirmed
Agostino Russo (ago) wrote :

As mentioned the progress is calculated directly by nsis and changing that would be too invasive.

Changed in wubi:
status: Confirmed → Won't Fix
Changed in wubi:
status: Won't Fix → New
description: updated
Brian Murray (brian-murray) wrote :

Testing today with daily build 20080411 the installer got hung up at the same point. I'll attach a screenshot and the log. Could this happen if Wubi did not have internet access? After killing the hung Wubi process I noticed a message about authorizing Wubi's internet access.

Brian Murray (brian-murray) wrote :
Agostino Russo (ago) wrote :

Brian, the (last) log indicates that the installation completed successfully. I noticed that in the previous logs you might have experience a segfault (with Wubi not showing at all). I am wondering whether the missing reboot page is linked to the same issue.

Agostino Russo (ago) on 2008-04-15
Changed in wubi:
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I tested with Kubuntu AMD64 daily build from 20080417.1 which has rev 487 and ran into the bug again.

description: updated
Agostino Russo (ago) wrote :

Brian reported that new builds work well

Changed in wubi:
status: Confirmed → Fix Committed
Brian Murray (brian-murray) wrote :

Yes, rev 488 exited well for me.

Agostino Russo (ago) on 2008-04-22
Changed in wubi:
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

In rev 495 the green bar wasn't all the way full and it entered a Not Responding state again.

Brian Murray (brian-murray) wrote :

I take it back. My last comment should be expunged from the record.

Brian Murray (brian-murray) wrote :

For some reason if I run rev 495 off a USB stick on the Windows system it works fine and gives me the reboot dialog. However, if I run rev 495 off the 20080423 daily build of Kubuntu KDE4 it doesn't and I get this bug.

Changed in wubi:
status: Fix Released → Confirmed
Agostino Russo (ago) wrote :

Brian, can you post the 495 log? Are the eject CD lines at the bottom reasonable? is it the right drive? Does the disk actually eject? Does it work with an emulated CD (Daemon Tools and such) or another CD drive?

Brian Murray (brian-murray) wrote :

I've been thinking about the testing I did yesterday and here is some more information:

With 495 from the CD the disk does eject but the app enters the Not Responding state. Additionally, the only way I have been able to successfully exit Wubi was by reinserting the CD and running Windows task manager. If the CD is ejected I can not force Wubi to exit. Additionally, task manager gives an error message regarding "disk" and isn't usable. I could grab the exact error message if necessary.

With 495 from a USB stick the CD ejects and then I'm shown the Wubi screen about rebooting.

Agostino Russo (ago) wrote :

That's probably because the wubi executable is on the CD which you are ejecting and the system needs to access it. And since I'd assume you run 488 off the CD that would explain why it worked then. Also in my testing I used emulated CDs...

Brian Murray (brian-murray) wrote :

There are 2 possible workarounds:

1) Run wubi from the Vista system and not the CD

2) A bit messy
a) After the CD is ejected, reinsert the CD.
b) click "Close" in the Installation Complete dialog of Wubi that shows "Not Responding" in the title bar
c) you'll be presented with a "Microsoft Windows" dialog saying "Windows based UBuntu Installer is not responding"
d) click "Close the program"
e) the Wubi program will end and you can reboot and then choose Ubuntu in the Windows boot loader to complete the installation

At step "d" I've also chosen wait for the program to respond and nothing happens.

Agostino Russo (ago) wrote :

Simply using upx-ucl to repackage the executable should address the issue. I will also postpone the CD ejection just before the reboot command.

Agostino Russo (ago) on 2008-04-24
Changed in wubi:
importance: Low → High
Agostino Russo (ago) wrote :

To test:

1) unpack the ISO (mount -o loop /path/to/iso /path/to/unpacked/iso && cp -a)
2) replace wubi.exe with the file attached
3) repack the ISO

mkisofs -r -V 'Ubuntu 8.04 i386' -o hardy-i386-hacked.iso -cache-inodes -J -l -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table /path/to/unpacked/iso

4) burn CD and run wubi.exe from the CD with the argument "--skipmd5check"

Note that Vista has to be fully updated and Wubi must be run from within the CD.

Dave Morley (davmor2) wrote :

Every which way I try to burn this the wubi.exe fails I'll report the fail text tomorrow.

Agostino Russo (ago) wrote :

davmor2, I can confirm that upx and wubi.exe do not go hand in hand. I will have to provide a new binary.

Agostino Russo (ago) on 2008-04-29
Changed in wubi:
milestone: none → 8.04.1
Agostino Russo (ago) wrote :
Agostino Russo (ago) wrote :

davmor2 can you pls try with the above build when you have a couple of minutes?

Agostino Russo (ago) on 2008-04-30
Changed in wubi:
status: Confirmed → In Progress
Agostino Russo (ago) wrote :

Other go

Dave Morley (davmor2) wrote :

The wubi-selfextract.exe didn't work. It restarted the machine correctly however the wubi-mbr didn't work correctly I couldn't select Ubuntu from the mbr screen.

Agostino Russo (ago) wrote :

davmor2, if the machine gets to reboot then wubi-selfextract has worked. The mbr is a different issue.

Agostino Russo (ago) on 2008-05-04
Changed in wubi:
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

I tested the wubi-selfextract.exe, revision 504 I believe, by downloading it and running it from my desktop with an Ubuntu 8.04 i386 disc in the drive and was presented with the reboot screen. Subsequently, I believe this bug is fixed!

Agostino Russo (ago) wrote :

To test this bug wubi-selfextract.exe (rev 503) has to be on a CD. Running wubi.exe from hard disk will always work (thus invalidating the test)

At the time of writing rev 495 ships with the CD, until wubi is updated on the daily ISO, you will need to create your own CD by unpacking, replacing wubi.exe and packing back the ISO, then burning the CD.

That also requires vista with latest patches, since it is the only set-up that triggered the problem in the first place

Dave Morley (davmor2) wrote :

This is now fixed with wubi-self-extractor.

Tested using Ubuntu 20080620.1 and adding Wubi-self-extract rev 504.

No issues with the installer part at all.

Only issue comes after the install but is known.

Agostino Russo (ago) on 2008-06-26
Changed in wubi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers