Wubi, Windows Ubuntu Installer

Out of date Wubi 12.04 installs broken 13.04 disk image

Reported by bcbc on 2013-03-08
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned

Bug Description

Wubi installs the development release (13.04) instead of 12.04. If for some reason there is a 404 on the 12.04 diskimage download it defaults to the development release. This is not a desirable outcome.

In this particular case, the reason it downloaded the dev release is that the incorrect version of wubi.exe (12.04.1) was used. The user had previously used this and didn't realise that it had been updated to 12.04.2 and that the older version would not work. But I've also seen reports of this happening using the 12.10 wubi.exe (although no log files have yet been provided) so i suspect that any temporary server problem or internet connectivity issue could result in the development release being downloaded accidentally.

This problem is specific to the DISK IMAGE installs, not the ISO installs using Wubi. Because with the ISO installs, Wubi would still reject the development ISO when the release didn't match.

03-08 13:45 DEBUG TaskList: New task download
03-08 13:45 DEBUG TaskList: ### Running download...
03-08 13:45 DEBUG downloader: downloading http://releases.ubuntu.com/12.04.1/ubuntu-12.04.1-wubi-i386.tar.xz > D:\ubuntu\disks\ubuntu-12.04.1-wubi-i386.tar.xz
03-08 13:45 ERROR TaskList: [Errno 14] HTTP Error 404: Not Found
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\downloader.py", line 77, in download
  File "\lib\urlgrabber\grabber.py", line 927, in urlgrab
  File "\lib\urlgrabber\grabber.py", line 845, in _retry
  File "\lib\urlgrabber\grabber.py", line 913, in retryfunc
  File "\lib\urlgrabber\grabber.py", line 1001, in __init__
  File "\lib\urlgrabber\grabber.py", line 1072, in _do_open
  File "\lib\urlgrabber\grabber.py", line 1182, in _make_request
URLGrabError: [Errno 14] HTTP Error 404: Not Found
03-08 13:45 ERROR TaskList: Non fatal error [Errno 14] HTTP Error 404: Not Found in task download
03-08 13:45 DEBUG TaskList: ### Finished download
03-08 13:45 DEBUG TaskList: New task download
03-08 13:45 DEBUG TaskList: ### Running download...
03-08 13:45 DEBUG downloader: downloading http://cdimage.ubuntu.com/wubi/current/i386.tar.xz > D:\ubuntu\disks\i386.tar.xz
03-08 13:45 DEBUG downloader: Download start filename=D:\ubuntu\disks\i386.tar.xz, url=http://cdimage.ubuntu.com/wubi/current/i386.tar.xz, basename=i386.tar.xz, length=576048376, text=None

bcbc (bcbc) wrote :
bcbc (bcbc) wrote :
bcbc (bcbc) wrote :

Marked as confirmed as it affects more than one user.

Note that currently the 13.04 install fails to work due to bug 1155704 (13.04 installer doesn't create user account)

Changed in wubi:
status: New → Confirmed
bcbc (bcbc) wrote :

To fix this, download a new copy of wubi.exe from http://releases.ubuntu.com/12.04

summary: - Wubi 12.04 installs development release
+ Out of date Wubi 12.04 installs broken 13.04 disk image
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers