Wubi, Windows Ubuntu Installer

Wubi fails to detect 12.04.2 and 13.04 AMD64 ISO

Reported by Salem on 2013-02-27
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned

Bug Description

Wubi from Raring daily iso (Version 13.04-rev275) fails to detect either CDROM and ISO image on the same directory as Wubi. I have tried to install it several times and it always downloads the raring*.xz file from the web.

In the wubi log I get the following messages:
(omitted lines)
02-27 19:29 DEBUG Distro: checking whether F:\ is a valid Ubuntu CD
02-27 19:29 DEBUG Distro: does not contain F:\casper\vmlinuz
02-27 19:29 DEBUG CommonBackend: Searching for local ISO
02-27 19:29 DEBUG Distro: checking Ubuntu ISO \\vboxsrv\user\raring-desktop-amd64.iso
02-27 19:29 DEBUG Distro: does not contain casper\vmlinuz

This happened on a vm with Windows 7, but as the file vmlinuz does not exists (only vmlinuz.efi) I guess it should happen also on a physical installation.

Wubi version:13.04-rev275

bcbc (bcbc) on 2013-03-16
Changed in wubi:
status: New → Confirmed
bcbc (bcbc) wrote :

Yes it happens on a physical installation. I mounted the current cdimage raring-desktop-amd64.iso and it contains /casper/vmlinuz.efi but not /casper/vmlinuz.

All the files in /casper:
filesystem.manifest
filesystem.manifest-remove
filesystem.size
filesystem.squashfs
initrd.lz
vmlinuz.efi

On an older ISO (11.10) it is identical, except that vmlinuz.efi is not there (obviously) and vmlinuz is there.

bcbc (bcbc) wrote :

On the 12.10 ISO (ubuntu-12.10-desktop-amd64.iso) the following files exist in /casper:

bcbc@10:23:54:~$ ls -al /mnt/casper
total 760059
dr-xr-xr-x 1 root root 2048 Oct 17 11:36 .
dr-xr-xr-x 1 root root 2048 Oct 17 11:36 ..
-r--r--r-- 1 root root 47291 Oct 17 08:03 filesystem.manifest
-r--r--r-- 1 root root 971 Oct 17 08:03 filesystem.manifest-remove
-r--r--r-- 1 root root 11 Oct 17 08:03 filesystem.size
-r--r--r-- 1 root root 750882816 Oct 17 08:03 filesystem.squashfs
-r--r--r-- 1 root root 17103673 Oct 17 08:04 initrd.lz
-r--r--r-- 1 root root 5129040 Oct 17 08:04 vmlinuz
-r--r--r-- 1 root root 5130968 Oct 17 08:04 vmlinuz.efi.signed
bcbc@10:31:02:~$

Salem (salemsaberhagen) wrote :

In Wubi source there is a file (data/isolist.ini) which has the listings of the files that need to be present to make an ISO image valid.
I tried to build Wubi but I got an error ("No module named subprocess"), which makes sense because subprocess was just introduced in Python 2.4 and it uses Python 2.3 (why Wubi uses such an old version? Compatibility/dependencies?).

So, if the new ISO would not containt vmlinuz changing that file may solve the problem...

This is happening in 12.04.2 installs as well:

03-18 01:11 DEBUG Distro: checking Ubuntu ISO C:\Users\Ofer\Desktop\ubuntu-12.04.2-desktop-amd64.iso
03-18 01:11 DEBUG Distro: does not contain casper\vmlinuz

See http://askubuntu.com/questions/269280/could-not-retrieve-the-required-disk-image-files-when-using-wubi-exe-iso-in

summary: - Wubi fails to detect raring CD/ISO
+ Wubi fails to detect 12.04.2 and raring CD/ISO
tags: added: precise raring
bcbc (bcbc) wrote :
bcbc (bcbc) wrote :

Files on ubuntu-12.04.2-desktop-amd64.iso:
bcbc@21:07:20:~$ ls -al /mnt/casper
total 691054
dr-xr-xr-x 1 root root 2048 Feb 13 14:21 .
dr-xr-xr-x 1 root root 2048 Feb 13 14:21 ..
-r--r--r-- 1 root root 43125 Feb 13 14:14 filesystem.manifest
-r--r--r-- 1 root root 874 Feb 13 14:14 filesystem.manifest-remove
-r--r--r-- 1 root root 11 Feb 13 14:14 filesystem.size
-r--r--r-- 1 root root 685928448 Feb 13 14:14 filesystem.squashfs
-r--r--r-- 1 root root 16470093 Feb 13 14:14 initrd.lz
-r--r--r-- 1 root root 5191168 Feb 13 14:14 vmlinuz.efi
bcbc@21:07:32:~$

Files on ubuntu-12.04.1-desktop-amd64.iso:
bcbc@21:36:05:~$ ls -al /mnt/casper
total 694578
dr-xr-xr-x 1 root root 2048 Aug 23 2012 .
dr-xr-xr-x 1 root root 2048 Aug 23 2012 ..
-r--r--r-- 1 root root 42023 Aug 23 2012 filesystem.manifest
-r--r--r-- 1 root root 863 Aug 23 2012 filesystem.manifest-remove
-r--r--r-- 1 root root 11 Aug 23 2012 filesystem.size
-r--r--r-- 1 root root 691204096 Aug 23 2012 filesystem.squashfs
-r--r--r-- 1 root root 15034652 Aug 23 2012 initrd.lz
-r--r--r-- 1 root root 4960752 Aug 23 2012 vmlinuz
bcbc@21:36:15:~$

summary: - Wubi fails to detect 12.04.2 and raring CD/ISO
+ Wubi fails to detect 12.04.2 and 13.04 AMD64 ISO
bcbc (bcbc) wrote :

I've patched the 12.04.2 version - not much point doing 13.04 wubi.exe since it's been dropped (and it would also need the diskimage install disabled because of bug 1155704). But the fix would be similarly simple to change the kernel and remove the diskimage=xxx keypairs.

bcbc (bcbc) wrote :

I decided to patch the 13.04 version as well. That's been tested and it installs 13.04 Ubuntu (amd64) correctly now. Diskimage installs were disabled to provide a workaround for bug 1155704.

Mirko (mirko-thalmann) on 2013-07-14
affects: wubi → ubuntu
bcbc (bcbc) on 2013-07-14
affects: ubuntu → wubi
Changed in wubi:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers