Comment 3 for bug 1134770

In Wubi source there is a file (data/isolist.ini) which has the listings of the files that need to be present to make an ISO image valid.
I tried to build Wubi but I got an error ("No module named subprocess"), which makes sense because subprocess was just introduced in Python 2.4 and it uses Python 2.3 (why Wubi uses such an old version? Compatibility/dependencies?).

So, if the new ISO would not containt vmlinuz changing that file may solve the problem...