installing indicator-synapse breaks wingpanel

Bug #1358490 reported by Tim on 2014-08-18
188
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Wingpanel
Invalid
Undecided
Unassigned

Bug Description

I installed Indicator Synapse for elementary os freya 0.3 and restarted my computer and the next thing i know, my whole top panel is missing please help!

http://www.pixentral.com/pics/19tqHUZkrUy8Fdw7I8RO5ZeqRKH3sm.png

Sascha Heuterer (theanachron) wrote :

Did you try reinstalling the wingpanel with "sudo apt-get install --reinstall wingpanel"?

Daniel (danielberjninger) wrote :

Confirmed that reinstalling wingpanel doesnt seem to work.

Running wingpanel from the shell gives:

$ wingpanel

[_LOG_LEVEL_INFO 10:04:10.324409] Application.vala:155: Wingpanel version: 0.2.4
[_LOG_LEVEL_INFO 10:04:10.324482] Application.vala:157: Kernel version: 3.13.0-24-generic
[_LOG_LEVEL_WARN 10:04:10.372903] [GLib-GObject] cannot add interface type 'GeeIterable' to type 'SynapseResultSet' which does not conform to prerequisite 'GeeTraversable'
Segmentation fault (core dumped)

Uninstalling indicator-synapse results in wingpanel working again.

Tasos (tasosventouris) wrote :

I confirmed that the problem is there. I installed the indicator-synapse and top panel was gone. After removing it, top panel returned.

Tasos (tasosventouris) on 2014-12-01
Changed in elementaryos:
status: New → Confirmed
Cody Garver (codygarver) on 2015-03-23
summary: - Top Panel Disappeared
+ installing indicator-synapse breaks wingpanel
affects: elementaryos → wingpanel
Changed in wingpanel:
status: Confirmed → New
Victor Martinez (victored) wrote :

Not a bug in the panel. Indicator-synapse is crashing and bringing the panel down with it.

The crash seems related to the fact that indicator-synapse was built using libgee 1.0 instead of libgee 0.8. This is also the reason why PPA builds for the indicator are failing too https://launchpadlibrarian.net/172567198/buildlog_ubuntu-trusty-amd64.indicator-synapse_0~525-0~ubuntu14.04.1_FAILEDTOBUILD.txt.gz

Changed in wingpanel:
status: New → Invalid
Karut (kraeutermann) wrote :

So what is supposed to happen to fix?

Karut (kraeutermann) wrote :

Manually installing a newer (sucessfully built) build of synapse (529) actually solves this problem. Once you update synapse via package manager the problem of course will reappear.

Download it here.

https://launchpad.net/~elementary-os/+archive/ubuntu/unstable-upstream/+sourcepub/4275868/+listing-archive-extra

Jason Gambrel (jaygambrel) wrote :

Works for me! Thanks Karut!
I also found the same file listing at https://code.launchpad.net/~elementary-os/+recipe/indicator-synapse-daily as an alternate source.
Jay

Murat Asya (murat-asya) wrote :

Yes works on my Freya 64bit too. I have manually installed files which are given links by Karut..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers