can't access "add to panel..." dialogue

Reported by Jeff Waugh on 2008-07-14
128
This bug affects 22 people
Affects Status Importance Assigned to Milestone
window-picker-applet
Medium
Neil J. Patel
window-picker-applet (Ubuntu)
Medium
Neil J. Patel

Bug Description

Because window-picker-applet uses all available free space, and there's no space around any of the other applets, there's no way to get to the "add to panel..." dialogue (usually accessed via the panel context menu).

Perhaps the go-home-applet could provide an "add to panel..." menu item in its context menu?

Pete Goodall (pgoodall) wrote :

I'm pretty sure there is a nubbie (highly technical term) handle at the left-hand side of the applet. You can just drag it slightly to the right to clear space between the window picker and go-home applets. Am I misunderstanding?

Jeff Waugh (jdub) wrote :

The applets in the default ume-config-netbook layout are all locked, and a casual user is unlikely to figure out how to move things around in order to create free space. That said, they shouldn't have to -- there should be a way to access the "add to panel" dialogue without mucking around with the well-designed ume-config-netbook layout at all. My suggestion is just one method.

Pete Goodall (pgoodall) wrote :

I think your second comment is more relevant and a different bug. The casual user also isn't going to know they can add applets, much less having to right-click on the panel and choose "Add to panel". Please create a separate bug on that issue.

A user that is aware what a panel applet is and how to add one may need to unlock the window picker applet anyway in order to have space for new applets, if they are adding more than one.

That being said, I did not realize that ume-config-netbook locked the applets in place. I don't see why we can't leave a bit of space.

Jeff Waugh (jdub) wrote :

There's no point arguing that potential solutions are signs of different bugs. The bug, as titled, is very straightforward, no matter how it is solved: "can't access 'add to panel...' dialogue". We could retitle it "can't add applets" and it would mean the same thing. Yes, ultimately it's a problem with the panel, but the problem is not badly exposed with normal desktop configs.

There's no point leaving space in the ume-config-netbook default configuration, because it's already a well-designed setup (particularly considering that window-picker-applet *should* use all available space).

[ By the way, the goofy way to add panel applets at this point is to hit alt-f1 (to get the main menu), right click a launcher, click "add to panel" (which adds a launcher next to the window-picker-applet, restricting it to its minimum size), then right clicking the newly opened space on the panel and choosing "add to panel..." -> hilarity! ]

Neil J. Patel (njpatel) wrote :

I'm not sure there's a way to invoke the 'Add to panel' dialog from a panel-applet. Even letting the 'right-click' event pass down to the panel won't work as it will show the applet-menu rather than it's own.

I think the only way to solve this problem right-now is to have a little space between the go-home and window-picker applets, but then the user would have to know to click there...

Changed in netbook-remix:
assignee: nobody → njpatel
importance: Undecided → Medium
status: New → Confirmed
Bill Filler (bfiller) on 2008-08-26
Changed in netbook-remix:
milestone: none → rc2
Bill Filler (bfiller) on 2008-09-05
Changed in netbook-remix:
milestone: rc2 → none
Luca Ferretti (elle.uca) wrote :

> I'm not sure there's a way to invoke the 'Add to panel' dialog from a panel-applet.

No, it's a gnome-panel (the process, not the module) only feature, not exposed to applets.

You could open a bug against gnome-panel asking for a method (dbus? command line option?) to open this dialog, then add a menu entry to go-home-applet invoking the method.

Neil J. Patel (njpatel) wrote :

> You could open a bug against gnome-panel asking for a method (dbus? command line option?) to open this dialog,
> then add a menu entry to go-home-applet invoking the method.

Done, http://bugzilla.gnome.org/show_bug.cgi?id=557232.

Ahmad Syukri Abdollah (syockit) wrote :

I think you can document somewhere that the panel is a gnome panel, you can unlock the applets and move the nubbie to create space and add applets as you want. As Pete commented, a casual user wouldn't know it can be customized, because one wouldn't know it's actually a gnome panel. A power user would have known, and only needs a little more pointers to be able to do so, and sought help regarding customizing gnome panel somewhere else. That's why this bug is mostly invalid, at least in my opinion.

snakeman21 (snakeman-21) wrote :

Ahmed is right. Here's a detailed description. The icon farthest to the left (on the RIGHT side) should be the battery indicator. Place your cursor just to the left of it and uncheck "lock to panel". You can then click and drag, and both the battery and network indicators will move. Move them to the left to create a space. Right-click the space, and click "add to panel". Add whatever apps you want. It took me a few minutes to figure out, but once I realized it, I was like, "Duh..."

Hope this is helpful!

snakeman21 (snakeman-21) wrote :

EDIT: Sorry, I meant to say: place your cursor just to the left of the battery indicator, RIGHT-CLICK, then uncheck "lock to panel."

Brion Vibber (brion) wrote :

Bug is definitely not invalid. :) Presence of workarounds is nice, but they're not particularly obvious even to a seasoned user and should certainly not be inflicted on new users.

snakeman21 (snakeman-21) wrote :

Well, to be perfectly honest, I don't think I would call it a "bug." More than that, it's just bad planning with the size of the panel. That said, it IS a pain in the butt, especially if you aren't aware of the workaround.

José Cabo (folcwine) wrote :

And.. then? What can we do?

Brion Vibber (brion) wrote :

Personally, I tried at least the following before searching for this bug entry and discovering the workarounds:
* Look for a panel-applet setup app in Preferences folder in app launcher
* Look for a panel-applet setup dialog in Menu Editor app
* Unhide "Panel" launcher icon via Menu Editor, then launch it and look for some sort of configuration dialog
* Right-click on home icon, look for "Add to panel..." in context menu
* Right-click on the UME magic title bar space, look for "Add to panel..." in context menu
* Right-click on the notification icon area, look for "Add to panel..." in context menu
* Right-click on every little bit of black space between or to the side of icons in the top bar, look for "Add to panel..." in context menu

Suggested fixes so far on this bug include:

'Perhaps the go-home-applet could provide an "add to panel..." menu item in its context menu?'
for which http://bugzilla.gnome.org/show_bug.cgi?id=557232 might aid in implementation.
and
'I think the only way to solve this problem right-now is to have a little space between the go-home and window-picker applets, but then the user would have to know to click there...'

I might also add the suggestion of having a preferences item to add things to the panel, though that might not play super nice with the gnome desktop model where there might be multiple panels present.

Paul Larson (pwlars) wrote :

Moving bug to Ubuntu distribution

Changed in window-picker-applet (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
status: New → Confirmed
Changed in netbook-remix:
status: Confirmed → Won't Fix
tags: added: ubuntu-unr
Jason (jmvarner) wrote :

On Ubuntu Netbook Remix (9.04), was looking for a way to add the 'gweather' applet (for easy access to weather forecasts). #9/10 above provided the solution!

Paul Larson (pwlars) on 2009-11-13
affects: netbook-remix → window-picker-applet
Changed in window-picker-applet:
status: Won't Fix → Triaged
Changed in window-picker-applet (Ubuntu):
status: Confirmed → Triaged
Huston (h-bokinsky) wrote :

If this problem is still under consideration, here is what I just did to solve it (I've already posted this to a thread about adding a keyboard layout switcher):

For those who want to add applets to the panel (such as the keyboard layout switcher) of a standard UNR 9.10 Gnome desktop, first right-click on the open panel (black strip at the top of the screen) and select "Remove from panel." After that, you can again right-click in the same space and select "Add to panel" to add any applet you like from the Gnome desktop.

As near as I can tell, this works this way because what appears to be the panel on an out-of-the-box installation is actually a working applet called Window Picker (you can find it in the "Add Applet" dialogue box). You must first remove this before you can get to the real panel and start adding other applets. Don't forget, though, once you've added the applet(s) you want (in my case, the keyboard switcher) and moved it/them into the desired location on the panel, to add either Window Picker or one of the other window selectors back to your panel. Otherwise you won't be able to see your running applications at all!

I have just upgraded to Lucid, and all of the above workarounds have become invalid, since all panel-changing options are grayed out on every menu. There is no obvious way to unlock an applet from the panel, remove or even add a new laucher, because all of these options seem to have been disabled.

I noticed this while trying to add the music-applet back to my panel after the upgrade.

Didier Roche (didrocks) wrote :

The rational of why and how to do that is in the following link:
https://help.ubuntu.com/community/UbuntuNetbookEdition/ConvertGnomeSession

well, you will use your GNOME session then

Bkmz (bkmz92) wrote :

Hi all. I'm using Ubuntu 10.04 NBR. And I don't want to use a default GNOME session. And all of the solution from net are not waorking for me. Anyone can help me?
And why Canonical developers decided to disable customisation function from gnome panel??? I'm angry.... =\

Didier Roche (didrocks) wrote :

It was compulsory because of a demand of having both GNOME and UNE session.
Can you read the link above please? You have all the tool for people wanting to do some "tweaking" of the session.

Bkmz (bkmz92) wrote :

I have done "converting". But nothing have been changed (((

Didier Roche (didrocks) wrote :

Well, as you converted the GNOME session, you have to logout and select the "GNOME" session in GDM once you pick up your name.

> I have done "converting". But nothing have been changed (((

You have to choose "Gnome" as your default session by the time of logon.

--
Daniel

Bkmz (bkmz92) wrote :

Yes. After log in my GNOME session, i see my default gnome-panel from GNOME session, not from UNE.

Didier Roche (didrocks) wrote :

try rm -rf ~/.gconf/apps/panel/

then logout and login again.

Bkmz (bkmz92) wrote :

Thank you. I have solved this trouble. But after that i have 2 volume controller applets. And there are different! Why? And which it's names?
PS. There are Russian locale

John Gilmore (gnu-gilmore) wrote :

The changes in 10.04 seem to have made the problem worse, not better. Clever people in 9.10 used to be able to work around the problem. Now in 10.04 you have to be a true genius, or merely insane, (or find this bug report) to work around the problem.

The proposed fix in #19 is to tell users to ignore the default UNR interface, switch to GNOME, and then spend a bunch of time (both in a terminal, with commands that nobody will ever find on their own, then doing further mucking about on the screen) to customize GNOME so it looks just like the default UNR interface. Then, finally, you can add one item to your panel!!! And the rationale seems to be "it's compulsory".(*) Yeah, we know you made it compulsory not to edit the panel in 10.04. But this is software freedom. We can, and should, change things we don't like.

Is the problem that the UNR interface is "cheating" by using a bunch of GNOME components, but not using a wholly separate set of GNOME properties? (So that you could customize your UNR screen, and customize your GNOME screen, and your home directory dot-files could remember both of those settings.) If it's impossible for one user to have two fully functional GNOME screen layouts, and choose among them at login time, perhaps this should be an upstream bug or feature request to the GNOME folks?

(*) Perhaps this was just a non-native English speaker being unclear "why" it's not possible. The word "compulsory" often has a connotation of people who are ordering you around for no good reason -- like a corrupt policeman might, or like a bureaucrat who cares nothing for you or your freedoms. Like "we'll force you, whether you like it or not".

Didier Roche (didrocks) wrote :

Calm down, please :)
Thanks for the explanation on compulsory, and no, I'm not a native English speaker, let's say "mandatory" so.

Your last statement about an upstream bug is right, do you care about opening a bug on gconf and gsettings on the GNOME bugzilla?

cholt45 (cholt45) wrote :

What was the team thinking when you made this decision. Why did you disable this option to ad and rearange aplet? I dont understand, realy.

Bigfoot (me-eckschi) wrote :

Are there any news on this issue? It seems to me that when you keep it that way you drive away quite a bunch of users who then not use netbook remix at all? Then all you efforts of making it are worthless... Is that the intention?

datakid (datakid) wrote :

2 years on? Any movement?

Craig (craigrock-smith) wrote :

I don't know how relevant this still is, but I recently got round this issue by attempting to start another instance of the panel with 'sudo gnome-panel'

terminal threw out an error as expected

** Message: Could not connect to session manager: Could not get owner of name 'org.gnome.SessionManager': no such name

** (gnome-panel:3426): WARNING **: Could not connect to session manager: Could not get owner of name 'org.gnome.SessionManager': no such name

but after doing so I got a totally stock (al la Ubuntu) panel with normal menu lauchers etc that I WAS able to adjust through add/remove from panel. Then it was just a case of putting the gnome HOME applet and adding DockX/Namebar etc as I pleased.

Hope that helps people out. A really annoying 'quirk' of UNR this one.

The GNOME desktop runs with user privileges, not root. The error messages in Craig's experiment were not because there's another panel already running (I guess this is why xe said it was expected), but because there's no running GNOME session for the root, and hence the panel application can't connect to it. But this error is not fatal to the panel, so it keeps running, hiding the old panel behind it. (Proof: if you kill it in the terminal via a Ctrl+C, the old panel is back, so it's not replaced, only obscured.)

This has a very nasty side-effect: the new panel runs as root, and if you launch any programs from it, they will also be run with root privileges. (Proof: open a terminal from the Applications menu, and check your user name.) This is bad; you shouldn't use root privileges for your daily work.

This bug persists on Maverick. But with Unity, @didrocks's workaround does not work anymore.

Anyone knows a new one?

Ted Gould (ted) wrote :

On Fri, 2010-10-15 at 20:40 +0000, Daniel Carrasco Guariento wrote:
> This bug persists on Maverick. But with Unity, @didrocks's workaround
> does not work anymore.
>
> Anyone knows a new one?

Unity does not have a configurable panel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.