GPL Text should maybe not be translateable

Bug #994712 reported by Jens Beyer on 2012-05-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

See http://www.gnu.org/licenses/translations.en.html

FSF does not want to have translated GPL texts as official documents.

So we should either not allow it to be translated (but we do), or we should show in the menu first the untranslated one, and provide a way to show the translated text with the hint that this is not an officially published translation and only the English original is the real license, while the translation is to help understanding the terms better, but does not bind legally.

Related branches

Angelo Locritani (alocritani) wrote :

maybe adding a hint that the original license can be found at <link> would be enough.

Jens Beyer (qcumber-some) wrote :

True. On the other hand many translators seem to have trouble translating the GPL, as you can see from the translations pages.

I'm feeling it is simply not worth the trouble.

My suggestion for lowest-effort would be only displaying the english one, and linking to the page mentioned above in the web.

Venatrix (elisabeth) wrote :

Is there really a problem? I think in every existing translation there is the hint at the beginning, that the translation is not legally binding and one should stick to the English version and where this version can be found (in the COPYING file or the FSF homepage). The only problem I can see is when the translators try to translate the GPL themselves. In most languages that should not be necessary.

Jens Beyer (qcumber-some) wrote :

@#3:
True, but in Widelands, we can translate the GPL without this hint.

See yourself: https://translations.launchpad.net/widelands/trunk/+pots/texts/de/8/+translate

This is a link to a part of Widelands' German translation of the GPL.

Hans Joachim Desserud (hjd) wrote :

Also mentioned in the forum (https://wl.widelands.org/forum/topic/369/). I do wonder whether allowing unofficial translations of something such as the license text here might do more harm than good.

It might be better to present it in it's original, unaltered form, or alternatively remove the button from the main menu alltogether. Afterall, it is mentioned in the readme/other places, and if necessary we can point people to the where they can find the full-text version.

tags: added: i18n internationalization
SirVer (sirver) wrote :

I personally would love to get rid of the license button in the menu and just ship the GPL with the game. If this is possible, let's go for it!! Noone reads it as rich text anyways.

Changed in widelands:
status: New → Confirmed
SirVer (sirver) wrote :

With possible I meant legally possible - I am not a lawyer, so I hope someone will come up with a program that does only ship the license file.

Jens Beyer (qcumber-some) wrote :

I read the GPL in that way that it is enough to state that this program is under the GPL V2, no warranties etc., and how one can read the full license (e.g. check the "docs" directory for the file COPYING..., however this could be difficult to write down since we distribute sources, windwos binaries, linux binaries and mac binaries, the description how to read the license must be good for each distribution. For linux this also means we need to give the packagers a chance (we might need to use the path to the game data from the config.h file).

GPL V3 defines it more clearly, but I think the same can be applied to GPL V2.

(from GPL V3 Definitions:
"An interactive user interface displays “Appropriate Legal Notices” to the extent that it includes a convenient and prominently visible feature that (1) displays an appropriate copyright notice, and (2) tells the user that there is no warranty for the work (except to the extent that warranties are provided), that licensees may convey the work under this License, and how to view a copy of this License. If the interface presents a list of user commands or options, such as a menu, a prominent item in the list meets this criterion. ")

SirVer (sirver) wrote :

So we could get rid of displaying all the changes and instead show a short rich text copyright notice with a link to the web? Can someone come up (or find?) a short snippet that would help here?

Jens Beyer (qcumber-some) wrote :

Lincity-ng does not display their license ingame.
Wesnoth only displays the English original in their ingame help.
Openttd does not display their license ingame. They have sections in the settings which talk about components and their license, with buttons to view their license (but those buttons are all disabled).

So I guess this is somewhat ok to do.

@SirVer: A link to the web may legally be enough, but we should provide the license (the COPYING file) with the package (and tell the user to view *this* license). A link to the web is nevertheless a good addition, this could also be a wiki page which explain stuff and links to the license.

As for what to do, my suggestion would be:

1) Extend the Copyright notice in the Main menu (bottom left) by something like "Licensed under GPL V2.0"
2) Keep the "License" Main menu item, but the content should be a nice little description that the game is under GPL V2.0 and how to display the shipped license, and the link(s) to the web for the license itself (http://www.gnu.org/licenses/old-licenses/gpl-2.0 or even http://www.gnu.org/licenses/old-licenses/gpl-2.0.de.html because this text is translateable)
3) update the translation template to not allow translation of the GPL anymore ;-)

Jens Beyer (qcumber-some) wrote :

But... I forgot to mention... I am not a lawyer either;-)

SirVer (sirver) wrote :

Sounds like a reasonable way forward. Are you interested in taking this on, Jens?

Changed in widelands:
status: Confirmed → In Progress
assignee: nobody → Jens Beyer (Qcumber-some) (qcumber-some)
milestone: none → build18-rc1
Changed in widelands:
status: In Progress → Fix Committed
assignee: Jens Beyer (Qcumber-some) (qcumber-some) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers