"no use for ships on this map" blocks building ships in first Atlantis campaign (atl01.wmf)

Reported by Hans Joachim Desserud on 2012-04-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Critical
Unassigned
widelands (Debian)
Fix Released
Unknown

Bug Description

"The main objective in atl01.wmf is to get to the lake at the top of the island
and build three ships there using a shipyard. However, when I build a shipyard
there, it tells me "no use for ships on this map", refusing to build any ships.
The result is a flooded island and me failing the mission :("

Forwarded/taken straight from the Debian BTS [1]. I have not tried to reproduce this issue, but from reading the description it makes sense.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=668894

Changed in widelands (Debian):
status: Unknown → New

Damn. We need to clear this one up for b17 I think. Another release
candidate?

  status confirmed
  importance critical

Changed in widelands:
importance: High → Critical
status: New → Confirmed
Nasenbaer (nasenbaer) wrote :

should not happen. Exactly for that case I added the port_spaces file to atl01.wmf It contains two dummy buildspaces

Nasenbaer (nasenbaer) wrote :

The saved game is from build16. The scenario had no port build spaces back in these days, thus they are of course not saved in the saved game. When reloaded in build17(rcx) the shipyard does not find any port buildspaces and thus does not produce ships.

so the issue is a kind of backward incompatibility specifical for this scenario.

I set this to invalid, as I do not think that this can be easily fixed and won't appear often.

Changed in widelands:
status: Confirmed → Invalid
Nasenbaer (nasenbaer) wrote :

Jepp. :)

However we should think about writing a "Known issues" section in the release notes, including this problem, the fact that you can't send expeditions until now (often mentioned on the forums) and maybe some other notes about unfinished features or bugs still not fixed (like the starting position problem when loading a map in the editor)

SirVer (sirver) wrote :

Would you volunteer drafting such a section? I am quite busy as my
dissertation is due in 1 month.

Changed in widelands (Debian):
status: New → Confirmed
SirVer (sirver) wrote :

How can this be set to invalid in debian? or won't fix or so. Because it is intended behavior of sorts.

Nasenbaer (nasenbaer) wrote :

Am 16.04.2012 18:17, schrieb SirVer:
> Would you volunteer drafting such a section? I am quite busy as my
> dissertation is due in 1 month.
>
jepp I will at least try to :).
I'll send you a mail as soon as it is ready.

Hans Joachim Desserud (hjd) wrote :

>How can this be set to invalid in debian? or won't fix or so.
Seems like the Debian bug was set to Wontfix when it synced the status from this bug report.

I'm happy this was less critical than I first assumed. Good luck with your dissertation. :)

freedomrun (freedomrun) wrote :

Are there any plans for fixing this bug?

freedomrun (freedomrun) wrote :

Ok I `m attaching the save game file here in hope this can be resolved. Thank you.
Started with trunk version some time before 1 week or so.

Hans Joachim Desserud (hjd) wrote :

Reopening since it looks like this might be possible to trigger in trunk as well. Thanks for letting us know, freedomrun.

Changed in widelands:
milestone: none → build18-rc1
status: Invalid → New
tags: added: savegame
Nasenbaer (nasenbaer) wrote :

I disagree. I don't see any possibility how this could be triggered in current trunk. The saved game is from a trunk version, but I guess the initial game was started in build16. Or am I missing something?

Nasenbaer (nasenbaer) wrote :

Sorry for my fast answer. There was indeed a change, which caused this bug. The fix is in bzr revision 6538.

As before, that unfortunally does not fix the saved game, but will avoid to again let the game create such broken saved games.

@freedomrun: if you want to fix the saved game:
* unzip it
* overwrite the "port_spaces" file (in subdir "map") with the one of <widelands directory>/campaigns/atl01.wmf
* either let it as it is (directory with ending ".wgf") or zip it again (as well file ending ".wgf")

Thanks for reopening the bug report

Changed in widelands:
status: New → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
Changed in widelands (Debian):
status: Confirmed → Fix Released
Changed in widelands (Debian):
status: Fix Released → Confirmed
Changed in widelands (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.