Inconsistent behaviour in soldier creation leads to irregular economy state

Bug #974679 reported by Jens Beyer on 2012-04-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
High
Nicolai Hähnle

Bug Description

This bug is not easy to provoke.

First, the best is to decrease the number of soldiers in a starting script (tribes/atlanteans/scripting/sc00_headquarters_medium.lua) to 1.

Then start a new game with Atlanteans and Headquarters.

Build a Warehouse.
Send the Tabards out of the HQ, they are moved to the Warehouse.

Now, build a military building.

The first soldier leaves the HQ and goes to the military building.
Then, a trident is moved from HQ to warehouse.

And then... nothing. The Trident lies together with the Tabards in the Warehouse, while the military building is still waiting for a soldier.

Workaround:
Destroying and rebuilding the road between the military building and the Warehouse finally creates and sends the soldier to the military building.

Related branches

Hans Joachim Desserud (hjd) wrote :

By following the steps provided, I was able to reproduce this issue.

>And then... nothing. The Trident lies together with the Tabards in the Warehouse, while the military building is still waiting for a soldier.

I noticed, the trident+tabard actually produce a soldier, which then stays in the warehouse. (Though, this might be bug 726139 striking yet again...) It looks like the game notice it must move the trident to produce additional soliders, but the soldiers doesn't receive any "orders" once they are created.

Changed in widelands:
status: New → Confirmed
Jens Beyer (qcumber-some) wrote :

Just tried it "the other way round" - moved the tridents out instead of the tabards.

Again, the trident goes on the journey, this time to the HQ, but then the same problem appears, the vacant spot in the military building is not filled. So it is nothing warehouse-specific, but also applies to the HQ (and, if I remember correctly the harbors are HQs, too... so they would probably also affected).

Nicolai Hähnle (nha) wrote :

I followed the steps in the bug description and was able to reproduce the bug.

As soon as I cause anything else to be done in the economy, e.g. by starting to build another building, the soldiers move out of the warehouse and into the military building.

This suggests that we only fail to properly trigger a new request balancing after the soldiers are created.

Changed in widelands:
assignee: nobody → Nicolai Hähnle (nha)
Nicolai Hähnle (nha) wrote :

Fix committed to trunk in bzr6510.

Changed in widelands:
status: Confirmed → Fix Committed
milestone: none → build18-rc1
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers