Frontiers should not move in fogged area

Reported by Nasenbaer on 2012-02-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Nasenbaer

Bug Description

An area, that was previously seen by a player shows the immovables in the state they were, when the area was last seen - even if they do not exist any longer.

The frontier of a player should show the same behaviour, but at the moment you can see through the fog of war, when a frontier is moving (own or from other players).

Nasenbaer (nasenbaer) on 2012-02-28
Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) on 2012-02-28
Changed in widelands:
status: Confirmed → Incomplete
Nasenbaer (nasenbaer) wrote :

The fix for the problem itself was pushed in revision 6271. On areas that are hidden under fog of war, border markers are now drawn exactly the way they were seen the last time, that area was seen by the player.

This information is now saved and loaded in a borders file for each player in new saved games.

However older savegames will not show any border markers at the moment. This behaviour can be fixed, but I am not sure if it should and if yes in what way.

Generally this is some kind of backwards compatibility question. old saved games are playable the way it is now. And as we do not know, how the border markers situation looked like, when the player last saw fogged areas, we do not show any border markers at all.

A fix would be to post load the border markers at the position they are at the gametime the game was saved and now is loaded. However this would be kind of hackish because it must be done after a complete player load of the saved game file . At the place of the current border loading it can't be handled, because the borders are calculated with neighbour fields, that are not all loaded at that moment - so I am a bit against it and wonder whether it is worth the trouble and the "hack".

Any opinion?

Shall we keep it the way it is now or should we post load the border markers somehow?

Astuur (wolfsteinmetz) wrote :

+1 for keeping it as is - that is I consider this a very minor flaw and not worth the trouble.

SirVer (sirver) wrote :

+1 for keeping. I do not care for safegame comaptibility....

Nasenbaer (nasenbaer) wrote :

okay set the bug to fix committed. Thanks for your feedback :)

Changed in widelands:
status: Incomplete → Fix Committed
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers