Preview required building costs before building or upgrading

Bug #740401 reported by Astuur on 2011-03-22
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Wishlist
Gabriel Margiani

Bug Description

Here is another one for the wishlist (in case this finds supporters)
I might be a help for both newcomers and experienced players alike to first show the construction site dialog
asking for confirmation, before the player initiates a construction or upgrade for a building.
This way you could quickly check what materials are needed without having to remember it.

Tags: ui Edit Tag help

Related branches

Hans Joachim Desserud (hjd) wrote :

Personally, I don't like how this would add an additional step you need to go through when building/upgrading. Remember, a player will be building a lot of buildings, and clicking "yes, I want to build this" gets old really fast. And to some extent, even if you are currently lacking wares, in most cases it works out sooner or later. I like the idea that you should be able to see the build costs before building anything, but I don't think this is the best way to do it.

What do others think?

Changed in widelands:
importance: Undecided → Wishlist
status: New → Incomplete
tags: added: ui
summary: - Show construction site window before building r upgrading
+ Show construction site window before building or upgrading

Well, at least about a buildings costs preview there was a discussion a while ago at the forums: http://wl.widelands.org/forum/topic/601/ Most people seemed to like that idea.

It didn’t cover a similar function for upgrading, though. That’s something worth to think about.

Astuur (wolfsteinmetz) wrote :

Yes - I'm myself not happy about enforcing an extra click for each and every lumberjack.
How about showing the construction window when doing a mouse over in the building selection dialog then?
Or even CTRL+mouse over?

Nicolai Hähnle (nha) wrote :

Please check that discussion thread. Gannaf created some mockups that met with general approval: http://wl.widelands.org/forum/post/3770/

A similar preview could be shown also for upgrading buildings.

Astuur (wolfsteinmetz) wrote :

I jumped to the idea of the construction site window, because it was already exisiting.
Gannaf's suggestion is more elegant and for my taste contains all the relevant info.
If that can be programmed for the upgrade, too, all is fine with me.

SirVer (sirver) wrote :

Is there a bug report for the thread suggestion already? If so, this bug should be marked as duplicate.

Hans Joachim Desserud (hjd) wrote :

Thanks for the link, Venatrix. Haven't read the entire discussion, but I really like Gannaf's idea. I skimmed the thread but couldn't find any reference to already reported bugs. Can't remember seeing any bugs like this before either.

Venatrix (elisabeth) wrote :

No, there was just that blueprint. (At least I didn’t find any bug reports in the discussion.)

SirVer (sirver) on 2011-03-24
Changed in widelands:
status: Incomplete → Confirmed
Joachim Breitner (nomeata) wrote :

This looks like another candidate for things to tackle at some future WiHack.

Hans Joachim Desserud (hjd) wrote :

I just marked the older bug 536420 as a duplicate of this. The main suggestion discussed there was to display this information in a tooltip.

I'm also targetting this towards build18, since I think it is a nice feature we should implement.

Changed in widelands:
milestone: none → build-18rc1
summary: - Show construction site window before building or upgrading
+ Preview required building costs before building or upgrading
Gabriel Margiani (gamag) on 2012-06-24
Changed in widelands:
assignee: nobody → Gabriel Margiani (gamag)
SirVer (sirver) wrote :

Merged Gabriels work in 6407.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers