All workers die, when warehouse/hq is destroyed

Bug #590631 reported by Nasenbaer on 2010-06-07
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
widelands
High
Borim

Bug Description

When a warehouse or headquarters gets destroyed, the workers inside are dying (seems only soldiers will survive).

This makes a loose of such a building *much* too hard. It should be like in Settlers 2, that the workers survive and try to find a way to the next warehouse.

Related branches

Nasenbaer (nasenbaer) on 2010-06-07
Changed in widelands:
status: New → Confirmed
importance: Undecided → High
Nicolai Hähnle (nha) wrote :

Actually, it is unincorporated workers that survive, which includes also workers that have experience.

I believe the solution should be to launch all workers in Warehouse::destroy(). Warehouse "explosions" FTW! ;)

Timowi (timo-wingender) wrote :

I think it a good idea to filter out all workers without buildcost (carriers). Then the "explosion" is not so extreme. In most cases there are only a couple of other workers.

Victor Pelt (victor-pelt) wrote :

i think there is no problem with making losing a warehouse expensive. so i would consider this a feature, not a bug

SirVer (sirver) wrote :

would be a rather unlogic feature: all workers with experience and all soldiers survive, all others die? I also vote for launching all incorporated workers (also carriers, because if they get more expensive someday, they do not deserve a special treatment).

fuchur (fuchur77) wrote :

What should happen if it's the last building of the enemy? Currently all workers would walk over the whole map forever without a chance of finding a new home.

SirVer (sirver) wrote :

They die eventually when they cannot find a new home. That is already implemented.

Astuur (wolfsteinmetz) on 2011-08-09
tags: added: gameplay
Nasenbaer (nasenbaer) on 2011-08-21
Changed in widelands:
milestone: none → build17-rc1
LAZA (laza74) wrote :

As i remember in Siedler 1 the behaviour was also, that after the enemy has won the fight ALL people came out and the soldiers waited till the building was empty.

All other buildings where burned down from the own people so the enemy gets no other building and wares.
So the only won ware was the gold inside the military buiding (if there was one).

Borim (borim) on 2012-01-24
Changed in widelands:
assignee: nobody → Borim (borim)
Borim (borim) on 2012-01-30
Changed in widelands:
status: Confirmed → In Progress
Borim (borim) wrote :

in the attached branch (lp:~borim/widelands/bug590631) all workers are launched when a warehouse is destroyed. There is no distinction if the warehouse is destroyed by its owner, or due to an assault.

I do not know if this behaviour is ok, or if the explosion should only be triggered by an assault.

Also all workers are launched at once. This cause that stacked workers running around the map. For a better understanding see the attached image. With a small delay between the launches, this can be avoided, or at least reduced. But currently I do not know how to do this.

Hi,

>I do not know if this behaviour is ok, or if the explosion should only
>be triggered by an assault.
We have never made a difference between ripping or loosing a building,
so I think it is okay.

>Also all workers are launched at once. This cause that stacked workers
>running around the map. For a better understanding see the attached
>image. With a small delay between the launches, this can be avoided, or
>at least reduced. But currently I do not know how to do this.
I think this behaviour is fine.

Thanks for caring for this bug, borim. If you feel it is ready for
prime-time, please create a merge request.

SirVer (sirver) wrote :

Patch looks clean to me! I just merged this into trunk. Thanks for your work, borim!

Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers