Crash in opengl fonthandler_cc:99

Bug #1159968 reported by Jens Beyer on 2013-03-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
widelands
Critical
Unassigned

Bug Description

Start game in windowed mode
Go to Options
Change resolution
Apply
Go back to Options
Change resolution
Move the mouse over one of the + or - buttons (change resolution or Autosave stuff)
----> crash

(gdb) bt
#0 0x00000000012d62b0 in ?? ()
#1 0x0000000000bd25bf in UI::Font_Handler1::render (this=0x15a7530, text="<rt><p><font face=DejaVuSerif size=14 bold=1 color=ffff00>Verkleinere den Wert um 10</font></p></rt>", w=360)
    at /xxxxxxx/widelands/widelands/src/graphic/font_handler1.cc:99
#2 0x0000000000bb1c84 in UI::Panel::draw_tooltip (dst=..., text="Verkleinere den Wert um 10") at /xxxxxxx/widelands/widelands/src/ui_basic/panel.cc:1122
#3 0x0000000000bafe01 in UI::Panel::run (this=0x1d28180) at /xxxxxxx/widelands/widelands/src/ui_basic/panel.cc:192
#4 0x00000000009c9203 in Options_Ctrl::handle_menu (this=0x7fffffffc6a0) at /xxxxxxx/widelands/widelands/src/ui_fsmenu/options.cc:646
#5 0x00000000009c9177 in Options_Ctrl::Options_Ctrl (this=0x7fffffffc6a0, s=...) at /xxxxxxx/widelands/widelands/src/ui_fsmenu/options.cc:637
#6 0x000000000099eeb4 in WLApplication::mainmenu (this=0x1273190) at /xxxxxxx/widelands/widelands/src/wlapplication.cc:1603
#7 0x000000000099a0c0 in WLApplication::run (this=0x1273190) at /xxxxxxx/widelands/widelands/src/wlapplication.cc:482
#8 0x000000000099828f in main (argc=1, argv=0x7fffffffdcc8) at /xxxxxxx/widelands/widelands/src/main.cc:107

This should also be the cause for the mail by "Lars Schim­mer" <l.schim­mer@cg­v.tugr­az.at> at the public mailing list.

Related branches

Jens Beyer (qcumber-some) wrote :

Additional problem:
After changing resolution like above, it is also not possible to start a game anymore.

Bot happens also without bumblebee/Optimus in the run, so this fact from the mail does not count.

tags: added: crash ui
SirVer (sirver) wrote :

likely a reinitialization error somewhere.

Changed in widelands:
assignee: nobody → SirVer (sirver)
status: New → Confirmed
importance: Undecided → Critical
milestone: none → build18-rc1
Hans Joachim Desserud (hjd) wrote :

Looks like this is also triggered by toggeling fullscreen/windowed mode, see bug 1137765. I don't know whether we simply wish to mark this as a duplicate or to keep both bugs open to make sure we double check both ways of triggering the crash is fixed once we have solved this.

SirVer (sirver) wrote :

I started working on this and I have something that sortof works - but it crashes in random places on my machine. I would appreciate some testing and maybe a reliable way to reproduce a crash. The code is in lp:~widelands-dev/widelands/graphic_resetting

cghislai (charlyghislain) wrote :

could not make it crash here

SirVer (sirver) wrote :

It should definitively crash if you change your bpp to something else.

Charly, could you also test lp:~widelands-dev/widelands/graphic_resetting

cghislai (charlyghislain) wrote :

I tested that branch when i posted #5. But I don't have any option to change the bpp, its always 32 on my linux box.

SirVer (sirver) wrote :

You should still be able to trigger it by switching between OpenGL and SDL - something should crash :).

cghislai (charlyghislain) wrote :

ah yeah, indeed, i wasn't using opengl. With opengl rendering, i get a crash whenever stats are turned on. It comes from various places, so I'm not sure it is specially related to this bug. I'll investigate

Borim (borim) wrote :

When I disable opengl, widelands crash after I pressed the apply button the second time(advanced options and normal options)

I am not sure if this have the same reason as the bug described here, but it sounds familiar. The backtrace is attached.

Steps to reproduce:
1. start widelands
2. enter advanced option
3. disable opengl
4. click apply
5. in the normal option screen click, aplly again. -> crash

Hans Joachim Desserud (hjd) wrote :

Borim: yes, see also bug 1130905. I'm not sure either if all these crashes when changing settings are duplicates of each other, but I don't think we'll really find out until it is properly fixed.

tags: added: opengl regression
SirVer (sirver) wrote :

Fixed in r6635.

Changed in widelands:
status: Confirmed → Fix Committed
assignee: SirVer (sirver) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments