wicd-client not getting start as normal user

Bug #677304 reported by Navaneeth on 2010-11-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned

Bug Description

wicd version : 1.7.0
wicd log file : no errors found
linux distro : Arch linux

After the last update "wicd-client" is not getting started as normal user. It gives the following error.

Traceback (most recent call last):
  File "/usr/share/wicd/gtk/wicd-client.py", line 1033, in <module>
    main(sys.argv)
  File "/usr/share/wicd/gtk/wicd-client.py", line 91, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/wicd/gtk/wicd-client.py", line 1005, in main
    tray_icon = TrayIcon(animate, displaytray=display_app)
  File "/usr/share/wicd/gtk/wicd-client.py", line 139, in __init__
    self.icon_info = self.TrayConnectionInfo(self, self.tr, animate)
  File "/usr/share/wicd/gtk/wicd-client.py", line 198, in __init__
    self.update_tray_icon()
  File "/usr/share/wicd/gtk/wicd-client.py", line 91, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/wicd/gtk/wicd-client.py", line 353, in update_tray_icon
    self.set_not_connected_state(info)
  File "/usr/share/wicd/gtk/wicd-client.py", line 91, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/wicd/gtk/wicd-client.py", line 329, in set_not_connected_state
    self._show_notification(language['disconnected'], None, 'stop')
  File "/usr/share/wicd/gtk/wicd-client.py", line 233, in _show_notification
    self._last_bubble.show()
glib.GError: Unable to connect to server

When I run as root, "sudo wicd-client" it works. It used to work fine with a normal user. Is there a way to fix it?

wicd daemon is running correctly. Here is the output from ps aux | grep wicd.

root 3978 0.2 0.3 106764 9812 ? S 07:54 0:05 /usr/bin/python2 -O /usr/share/wicd/daemon/wicd-daemon.py
root 4013 0.0 0.3 94568 9444 ? S 07:54 0:01 /usr/bin/python2 -O /usr/share/wicd/daemon/monitor.py

Adam Blackburn (adamblackburn) wrote :

It looks like the notification daemon on your system is not working. Please check the permissions or you can run wicd-client with a switch to disable notifications, I think (I don't remember what it is off the top of my head and I can't check but you can use --help to find it -- I'm not 100% sure it exists but I think it does)

Navaneeth (navaneethkn) wrote :

@Adam : Thanks for the reply. But notification daemon is running.

ps aux | grep notify

root 21 0.0 0.0 0 0 ? S 07:54 0:00 [kacpi_notify]
nkn 4253 0.0 0.1 130188 4940 ? S 07:55 0:00 /usr/lib/xfce4/xfce4-notifyd

BTW, I am running XFCE.

Tasos (tlatsas) wrote :

@Adam : the only switches available are --no-tray, --no-animate and --only-notifications

If I run wicd-client with the --no-tray switch it works fine.
Also wicd-curses works fine.

(Archlinux with latest xfce and wicd 1.7.0)

Carnagex420x (carnagex420x) wrote :

broken for me as well.

Carnagex420x (carnagex420x) wrote :

more python problems?

/var/log/wicd/wicd.log:
"Exception KeyError: KeyError(140610867111680,) in <module 'threading' from '/usr/lib/python2.7/threading.pyo'> ignored"

also,

Temporary workaround but notifications dont show up with wicd-gtk or wicd-client.

# Wicd workaround
# Start Wicd tray icon as root!
# ( see https://bugs.launchpad.net/wicd/+bug/677304 )
##
%network ALL = NOPASSWD:/usr/bin/wicd-gtk

Carnagex420x (carnagex420x) wrote :

using visudo ^^^

Adam Blackburn (adamblackburn) wrote :

Apparently Debian had the same problem but I didn't know that they did. A little Googling popped up some answers.

http://osdir.com/ml/debian-bugs-dist/2010-07/msg01570.html
http://osdir.com/ml/debian-bugs-dist/2010-07/msg01705.html

Apparently it's related to the version of some notify stuff you're using (specifically the xfce notification daemon)

Tasos (tlatsas) wrote :

so it seems like a xfce4-notifyd bug
I think I'll pass the sudo workaround and stick with wicd-curses for the time being

Carnagex420x (carnagex420x) wrote :

thats only for the tray icon, the daemon starts and connects fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers