[Browser] Top bar should overlay the page, not anchoring on top of it

Bug #1365179 reported by Andrea Cimitan on 2014-09-03
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
James Mulholland
webbrowser-app
Fix Released
High
Olivier Tilloy
webbrowser-app (Ubuntu)
Undecided
Olivier Tilloy
webbrowser-app (Ubuntu RTM)
Undecided
Olivier Tilloy

Bug Description

As in the subject, the top bar, address bar, should overlay the current web view, and hide/appear on top.

In the current solution, you see the webpage scrolling slowly up and down when the top bar shows or hides.

Related branches

Changed in webbrowser-app:
assignee: nobody → Giorgio Venturi (giorgio-venturi)
status: New → Confirmed
status: Confirmed → New
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Giorgio Venturi (giorgio-venturi)
Changed in webbrowser-app:
assignee: Giorgio Venturi (giorgio-venturi) → nobody
John Lea (johnlea) on 2014-09-05
summary: - Top bar should overlay the page, not anchoring on top of it
+ [Browser] Top bar should overlay the page, not anchoring on top of it

I completely second that. That would solve the screen jittering when scrolling down the page

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

Related to oxide bug #1370366.

Olivier Tilloy (osomon) on 2014-09-25
Changed in webbrowser-app:
status: New → Confirmed
Olivier Tilloy (osomon) on 2014-10-08
Changed in webbrowser-app:
importance: Undecided → High
Olivier Tilloy (osomon) on 2014-10-21
Changed in webbrowser-app:
importance: High → Medium
tags: added: design-gap
Olivier Tilloy (osomon) on 2015-03-30
Changed in webbrowser-app:
assignee: nobody → Olivier Tilloy (osomon)
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Changed in webbrowser-app:
status: Confirmed → In Progress
Changed in webbrowser-app (Ubuntu):
status: Confirmed → In Progress
Changed in webbrowser-app:
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.04.20150331.2-0ubuntu1

---------------
webbrowser-app (0.23+15.04.20150331.2-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Olivier Tilloy ]
  * Always initialize member attribute at construction time.
  * Remove two broken symlinks. removed:
    src/Ubuntu/Components/Extras/Browser/favicon-image-provider.cpp@
    src/Ubuntu/Components/Extras/Browser/favicon-image-provider.h@
  * Rewrite URLs with an uppercase scheme. (LP: #1436312)
  * Use the new locationBarController API available in oxide 1.5 to
    control the position of the chrome. (LP: #1365179, #1429132)
 -- CI Train Bot <email address hidden> Tue, 31 Mar 2015 15:17:22 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Olivier Tilloy (osomon) on 2015-04-07
Changed in webbrowser-app:
status: In Progress → Fix Released
Changed in webbrowser-app (Ubuntu RTM):
status: New → Confirmed
Andrea Cimitan (cimi) wrote :

So much better on vivid! Thanks!

Changed in ubuntu-ux:
assignee: Giorgio Venturi (giorgio-venturi) → James Mulholland (jamesjosephmulholland)
Olivier Tilloy (osomon) on 2015-06-16
Changed in webbrowser-app (Ubuntu RTM):
status: Confirmed → Fix Released
assignee: nobody → Olivier Tilloy (osomon)
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers