Support Arabic language

Bug #1314673 reported by costales on 2014-04-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
webbrowser-app
Fix Released
High
Olivier Tilloy
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

Hello
Support Arabic language writing?
When I switch layout to Arabic and start writing, I see English letters .

Related branches

costales (costales) on 2014-04-30
Changed in unity-webapps-telegram:
status: New → Invalid
Adnane Belmadiaf (daker) wrote :

I can confirm this, you can try the word "منتدى" which will be converted to "d5نتدى"

The last or the first letter is converted to "dNumber"

David Barth (dbarth) wrote :

Can you guys indicate which type of input method is required to try that? Also, are you able to input those characters into a "regular" QML widget like the webbrowser-app URL bar? I'm trying to see if the issue is with Oxide or with Qt.

Nikolay Ivanov (nikolay-k) wrote :

Not only Arabic, Bulgarian (New phonetic) too. Suppose it affects all langages. Problem appeared on Gmail and Google docs web applications.

Adnane Belmadiaf (daker) wrote :

Also happen with French keyboard, type "Aléatoire" in the url bar, press "Enter" and see the result.

Olivier Tilloy (osomon) wrote :

Not sure if the two issues are related.

As to the one with typing "aléatoire" in the address bar and getting "al?atoire" in the google search box, it appears the "é" character is escaped as "%E9" in the URL, whereas it should be escaped as "%C3%A9".

Olivier Tilloy (osomon) wrote :

It seems that using encodeURIComponent() instead of the custom function currently in use yields much better results.
Interestingly, it breaks the existing unit tests, likely because AddressBar.requestedUrl is of type URL, which when it is built converts back some encoded characters to their decoded form (such as "'" or "é").

Changed in webbrowser-app:
status: New → In Progress
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
costales (costales) on 2014-06-06
no longer affects: unity-webapps-telegram
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+14.10.20140609.1-0ubuntu1

---------------
webbrowser-app (0.23+14.10.20140609.1-0ubuntu1) utopic; urgency=low

  [ Olivier Tilloy ]
  * Use encodeURIComponent() to encode search queries entered in the
    address bar. (LP: #1314673)
 -- Ubuntu daily release <email address hidden> Mon, 09 Jun 2014 17:14:23 +0000

Changed in webbrowser-app (Ubuntu):
status: New → Fix Released
Adnane Belmadiaf (daker) wrote :

I can confirm that this bug has been fixed

Olivier Tilloy (osomon) on 2014-06-26
Changed in webbrowser-app:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions