Empty domain names in navigation history

Bug #1207233 reported by Olivier Tilloy on 2013-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webbrowser-app
Fix Released
High
Olivier Tilloy
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:

 1) rm ~/.local/share/webbrowser-app/history.sqlite
 2) rm ~/.cache/webbrowser-app/thumbnails/*
 3) Launch the browser, and wait for the home page to be loaded (ubuntu.com)
 4) Open the activity view, and verify that the navigation history contains only one row ("Today") which itself contains one entry ("ubuntu.com")
 5) Close the browser application
 6) Launch the browser again, and open the activity view (no need to wait for the home page to be loaded)

Expected result: the navigation history contains only one row ("Today") which itself contains one entry ("ubuntu.com").

Current result: the navigation history contains all possible rows ("Yesterday", "Last 7 Days", "This Month", "This Year", "Older") and each of these rows contains a single entry ("ubuntu.com") that, when expanded, is empty.

Related branches

Changed in webbrowser-app:
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

This regression doesn’t seem to have been introduced when we started sorting domain names chronologically.
For a quick test, I commented out the use of HistoryDomainListChronologicalModel in TimelineView.qml, using the HistoryDomainListModel as a model directly, and I’m still seeing the same issue.

Olivier Tilloy (osomon) wrote :

It looks like calling invalidateFilter() in HistoryTimeframeModel::setStart(…) and HistoryTimeframeModel::setEnd(…) doesn’t do what I expected: the model doesn’t emit any signal to inform that the layout has changed due to the filter change. Replacing those calls by calls to invalidate() instead does the trick: the model emits layoutChanged().

Changed in webbrowser-app:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:webbrowser-app at revision 260, scheduled for release in webbrowser-app, milestone ubuntu-13.04-month-5

Changed in webbrowser-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.22+13.10.20130802.1-0ubuntu1

---------------
webbrowser-app (0.22+13.10.20130802.1-0ubuntu1) saucy; urgency=low

  [ Alexandre Abreu ]
  * Add custome app-id launch argument to allow a more customizable
    behavior (for webapps mostly).

  [ Olivier Tilloy ]
  * Use a MainView. This will allow adding new tabs to the activity view
    in a clean way. As a side-effect benefit, the activity view is now
    instantiated only when needed.
  * Ensure that the timeframe models are invalidated when the start date
    or the end date change. (LP: #1207233, #1204875)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 260
 -- Ubuntu daily release <email address hidden> Fri, 02 Aug 2013 09:09:45 +0000

Changed in webbrowser-app (Ubuntu):
status: New → Fix Released
Olivier Tilloy (osomon) on 2013-08-08
Changed in webbrowser-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers