Comment 12 for bug 576501

Hi Serge.

Sorry for the late reply. I'll do some testing asap. I'll return back
to you within a week.

-Henrik

On Sun, Apr 3, 2011 at 3:22 AM, Serge Hallyn <email address hidden> wrote:
> The attached updated EC2 class works for me.  Can you please test it?
> If it works for you, I'll update the vmbuilder package and pursue and
> SRU for all previous releases.
>
> To test, please replace your VMBuilder/plugins/ec2/__init__.py file with
> the attached one.  I.e.:
>
> dest=`find /usr/lib -maxdepth 3 -name VMBuilder | tail -1`
> cp $dest/plugins/ec2/__init__.py $dest/plugins/ec2/init.py.orig
> cp newinit.py $dest/plugins/ec2/__init__.py
> chmod ugo+x $dest/plugins/ec2/__init__.py
>
> ** Attachment added: "new ec2 init.py"
>   https://bugs.launchpad.net/ubuntu/+source/vm-builder/+bug/576501/+attachment/1971044/+files/__init__.py
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/576501
>
> Title:
>  vmbuilder doesn't recognize --ec2 flag
>
> Status in Virtual Machine Builder:
>  New
> Status in “vm-builder” package in Ubuntu:
>  In Progress
>
> Bug description:
>  Description:    Ubuntu 10.04 LTS
>  Release:        10.04
>
>  python-vm-builder-ec2:
>    Installed: 0.12.3-0ubuntu1
>    Candidate: 0.12.3-0ubuntu1
>    Version table:
>   *** 0.12.3-0ubuntu1 0
>          500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ lucid/universe Packages
>          100 /var/lib/dpkg/status
>
>  Hi,
>
>  I can't generate EC2 images with vmbuilder. I'm using a command like
>  this:
>
>  sudo vmbuilder xen ubuntu --suite=lucid --ec2 \
>  --ec2-cert=.ec2/cert-XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX.pem \
>  --ec2-key=.ec2/pk-XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX.pem \
>  --ec2-access-key=WHATEVER \
>  --ec2-secret-key=WHATEVER \
>  --ec2-user=424242424242 --ec2-bucket=anyrandombucket --ec2-prefix=test \
>  --ec2-version='first' \
>  --firstboot=/usr/share/doc/python-vm-builder-ec2/examples/ec2-firstboot.sh \
>  --part=/usr/share/doc/python-vm-builder-ec2/examples/ec2-i386-part-file.txt \
>  --debug
>
>  Actually, I was following this howto:
>  https://wiki.ubuntu.com/EC2Vmbuilder
>
>  When I run vmbuilder with those flags, I just get this message:
>
>  Usage: vmbuilder hypervisor distro [options]
>
>  vmbuilder: error: no such option: --ec2
>
>  So, I can not build images for Amazon EC2.
>
>  I inspected /usr/share/pyshared/VMBuilder/plugins/ec2/__init__.py and I found
>  at the last line of that file this:
>
>  #register_plugin(EC2)
>
>  I uncommented that line and it didn't work.
>  Also I tried using register_hypervisor_plugin(EC2), but it didn't work