VM (View Mail) for Emacs

Mailbox size doubles each time it's saved

Reported by Mwelinder on 2011-06-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VM
Low
Unassigned

Bug Description

This is with 8.2.0a running under:
xemacs --version
XEmacs 21.5 (beta29) "garbanzo" [Lucid] (x86_64-suse-linux, Mule) of Tue Feb 22 2011 on build34

Configuration is:
(add-to-list 'load-path (expand-file-name "~/vm/lisp"))
(add-to-list 'exec-path (expand-file-name "~/vm/bin"))
(add-to-list 'Info-default-directory-list (expand-file-name "~/vm/info"))
(load-library "auto-autoloads")

With the soon-to-be-attached mailbox, the mailbox size approximately double every time
it is saved because a non-ascii part of the message, "ShakespeareÃÃ[...]‚™s " gets
doubled. This happens, for example, after:
1. M-x vm RET
2. M-x vm-edit-message RET
3. Add or remove a space somewhere
4. C-c ESC
5. q

Note: right now the non-ascii part is only about 128 bytes so the attachment won't be too big.

Mwelinder (mwelinder) wrote :

That might be an XEmacs issue. I didn't find such a growth on Gnu Emacs.
Those control characters might be causing some problem. Gnu Emacs 22 went
into a big loop when I tried to edit the message.

I think I will punt the problem, unless you think it is important.

Cheers,
Uday

Changed in vm:
status: New → Won't Fix
importance: Undecided → Low
Mwelinder (mwelinder) wrote :

This makes vm unusable here.

Any save of the mailbox will double its size. Get a new message? Double size. Delete
spam mail? Double size. Do 20 of those and the mailbox is 128MB. Do 20 more and its
128TB. 20 more and the world doesn't have enough storage.

Any non-English (well, non-ascii) message seems to trigger this and one is all it takes.

Just loading the inbox into XEmacs as a text file and saving that does not double it.
(whew!)

Uday Reddy (reddyuday) wrote :

All right, can you try different versions of VM and XEmacs to see what is breaking? As I said, I couldn't reproduce it on Gnu Emacs and I am not much of an XEmacs user.

Cheers,
Uday

Changed in vm:
status: Won't Fix → New
Julian Bradfield (jcb+vm) wrote :

Mwelinder,

If there is more than one message in the file, do you see this effect
every time you save the folder, or only when you actually edit the
message with the non-ascii in it?

Mwelinder (mwelinder) wrote :

Version-wise, this is known:

ok with XEmacs 21.4 (patch 17)
not ok with XEmacs 21.5 (beta29)

The former appears to be a decade old, so I don't know how helpful that is.

Not ok with VM 8.2.0a
Not ok with VM 8.1.1

> If there is more than one message in the file, do you see this effect
> every time you save the folder, or only when you actually edit the
> message with the non-ascii in it?

Any save at all.

Mwelinder writes:

> Version-wise, this is known:
>
> ok with XEmacs 21.4 (patch 17)
> not ok with XEmacs 21.5 (beta29)
>
> The former appears to be a decade old, so I don't know how helpful that
> is.

Yes, 21.4 is too old to tell us anything specific. If you can run through
some of the 21.5 beta versions, at least the first release (1?) and the
latest release (31?) then we will know whether the problem is with XEmacs.

Julian, do you get the problem on your version of XEmacs?

Cheers,
Uday

Julian Bradfield (jcb+vm) wrote :

>Julian, do you get the problem on your version of XEmacs?

No, as I said, I can't reproduce it (with 21.5.b29).

Uday Reddy (reddyuday) on 2011-12-27
Changed in vm:
milestone: none → 8.2.90a
Uday Reddy (reddyuday) on 2011-12-28
Changed in vm:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments