Fails repeatably with "DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found"

Bug #458334 reported by Matt Zimmerman on 2009-10-22
This bug affects 86 people
Affects Status Importance Assigned to Milestone
nautilus (CentOS)
nautilus (Ubuntu)
Nominated for Lucid by komputes

Bug Description

Binary package hint: usb-creator

I'm trying to reformat a 4GB USB stick using usb-creator to put karmic-moblin-remix-i386.iso on it.

1. Run usb-creator-gtk
2. usb-creator shows /dev/sdb with exclamation mark, /dev/sdb with storage icon
3. I select /dev/sdb and click "Format"
4. I get a dialog with "Unable to mount 4.0 GB Filesystem" "DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found"
5. I dismiss the dialog
6. I try again to format, instead using /dev/sdb1
7. I get an identical error
8. /dev/sdb1 disappears from the list

ProblemType: Bug
Architecture: amd64
Date: Thu Oct 22 17:49:43 2009
DistroRelease: Ubuntu 9.10
Package: usb-creator 0.2.11
PackageArchitecture: all
 PATH=(custom, user)
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: usb-creator
Uname: Linux 2.6.31-14-generic x86_64

Matt Zimmerman (mdz) wrote :
Matt Zimmerman (mdz) wrote :

As a workaround, I tried zeroing out the first megabyte of the stick:

perseus:[~/iso] sudo dd if=/dev/zero of=/dev/sdb bs=1M count=1
perseus:[~/iso] sudo blockdev --rereadpt /dev/sdb

After that, usb-creator shows only /dev/sdb, and lets me format it, though the UI freezes while it does so and Nautilus opens on top of the window. I dismiss Nautilus, and /dev/sdb1 appears in the list, and I can select "Make startup disk" which seems to be working.

Would be good to know if this is reliably reproduced. It's important to be easy to spread Ubuntu this way.

Changed in usb-creator (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Ubuntu Foundations Team (ubuntu-foundations-team)
Matt Zimmerman (mdz) wrote :

After it completed, the drive was still mounted. Is this intentional?

David Mandala (davidm) wrote :

It's reproduced by me, workaround works,

Evan (ev) on 2009-10-22
Changed in usb-creator (Ubuntu):
assignee: Ubuntu Foundations Team (ubuntu-foundations-team) → Evan Dandrea (evand)
status: New → Triaged
kaij74 (kaij74) wrote :

I can reproduce it too and workaround does work.

Evan (ev) wrote :

This can be reproduced outside of usb-creator by calling the PartitionTableCreate dbus method of devicekit-disks with the 'none' parameter on the disk block device (wipe the partition table). It appears to be a bug in nautilus.

Sebastien Bacher (seb128) wrote :

Not sure what is the nautilus there by reading the bug, could you give some details Evan? Is that because the drive gets mounted?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
dupper (ervin-guth) wrote :

i have the same problem. workaround by matt did not help. usb-creator show thet there is no space on the usb..

Neil Levine (levine) wrote :

Same problem. Work around does not work for me either.

Johanna Hofinger (j-hofinger) wrote :

Same problem Workaround did not work for me.

jimmy the saint (lowid95) wrote :

Eventually I was able to get it to work.

After several failed tries, the drive was not visible in nautilus, but was still visible in usb-creator. This was not the case in previous attempts. I select sdb1, rather than sdb and it worked.

robbanl (robert-lindberg1978) wrote :

Same problem, workaround didn't work for me either. I can't format the 8gb sandisk memory and if click on install i get the message "install failed".

Arno Mauhourat (phedon) wrote :

Same problem and workaround didn't work for me.
Only after
~$ sudo mkfs -t vfat /dev/sdb1

usb-creator accepted to proceed.

Compoboe (stuffwinner) wrote :

You guys are talented, but all of this code is not needed. Does the workaround work? Yes, but there are methods now that are understandable to most of the public, which is ok, and really just comes down to good logic (in other words, get done quickly and cleanly).


Step 1: Install gparted.
Click applications -> terminal -> and write the following without quotation marks- "sudo apt-get install gparted"

Step 2: reformat the usb drive.
Open terminal and write the following without quotation marks- "gparted" -> click on drop down menu on the top right and make sure to DESELECT!! \dev\hda, and find the right hard drive. If you have a 4GiB hard drive, look for a 4 GiB for volume size, then reformat it.

Step 3: Make USB bootable drive
Click system -> administration -> USB Startup Disk Creator

Having made sure that you only have 1 USB drive connected, you will see a device with an exclamation and one without. Choose the one without an exclamation then give at least 1GiB for storage space

Click "Make Startup Disk"


Case Closed

Artur Wodejko (awodejko) wrote :

The same problem, work around works.

Compoboe (stuffwinner) on 2009-11-10
Changed in nautilus (Ubuntu):
status: Incomplete → Fix Committed
Changed in usb-creator (Ubuntu):
status: Triaged → Fix Committed
Matt Zimmerman (mdz) on 2009-11-10
Changed in nautilus (Ubuntu):
status: Fix Committed → Confirmed
Changed in usb-creator (Ubuntu):
status: Fix Committed → Confirmed
Ovidiu (ovidiu) wrote :

Issue happened to occur to me for a mobile broadband modem which is connected through USB to my Sony Vaio Laptop. This is though not always the behaviour and most often is as described in . The cause seems to be though the same.

However, workaround presented here is not applicable for a broadband mobile modem.

Notice: The system have been completely updated at 13th of November, so I don't know if the committed fix really have fixed the issue.

Devinder (devinderparmar) wrote :

the above mentioned both workarounds did not work on 20 GB portable USB 2.0 Slim drive

Have used both fdisk and gparted workaround without luck. Still get "Installation failure" when i use USB-Creator when trying to make with a desktop iso-image of karmic.

I solved my problem. I am swedish and the folder i had the image in was "Hämtningar" witch means "Download" in english. I realised that maybe USB-Creator do not have compatibility with utf-8 characters. And viola! After i moved the image to my home folder it worked.

EngMAn (peter-to) wrote :

I have made the same procedure like "revoltism" and everything just worked.
I have downloaded the ubuntu image file to "Плот" ( Plot ) which in English is translated like "Desktop" .
I moved the image to my home folder which has English name and the things gone right :)
Thank you "revoltism" for the help :)

Devinder (devinderparmar) wrote :

i solved my problem using the workaround suggested by revoltism. i moved the image file to my home folder and that is it

jakslev (jakslev) wrote :

I have followed the instruction / work-around from revoltism and it worked. I run US ubuntu, so it is hardly related to the utf-8, and the folder I had it in was also the download folder. I moved the folder to my user home folder and after having formated the stick to ext3 it worked!

I use Ubuntu 9.10 64 bit.

pioruns (pioruns) wrote :

Confirmed, Ubuntu 9.10 64 bit.
I just format drive on Gparted and then i was able to use usb-creator properly and put ubuntu installed info the stick.

Lars-Erik Jonsson (larsman) wrote :

The solution to my problems with usb-creator was to use a combination of the above:

1) Formatting the USB drive with Gparted made the drive usable by usb-creator (as sdb1)

2) Moving the image to my home directory made the file readable by usb-creator (I also had a folder with utf-8 characters)

Lars-Erik Jonsson (larsman) wrote :

To elaborate futher:
1) fixed the "DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found" error
2) fixed the "Installation failure" error

Jan Girke (jangirke) wrote :

Hi Lars
Please add information how you fixed it.

Sense Egbert Hofstede (sense) wrote :

I'm setting this to Invalid for Nautilus since that doesn't have anything to do with this, or shouldn't have any influence on the way USB Creator behaves.
Feel free to reopen it if you have evidence that show that Nautilus is secretly messing with the formatting of USB sticks.

Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
Dmitry Shachnev (mitya57) wrote :

Thank you, revoltism!

Aurora (pauldeshaw) wrote :

Reformatting drive with Gparted did not fix dbus error for Sandisk Cruzer 4GB drive.

For everyone with problems, make a FAT32 partition at the beginning for Windows computers and at the end, make at least one FAT16 partition for usb Ubuntu and restart the creator.

ShadowDeath (shadowerwtas) wrote :

It worked for me by moving the iso image file at home folder... i had it at Documents folder but my language is Greek so i guess Usb Disk Creator didn't recognised the Greek letters or something...

Moving the file from the directory with swedish letters in the name worked for me.

ruffneckc (ruffneckc) wrote :

Only after
~$ sudo mkfs -t vfat /dev/sdb1

usb-creator accepted to proceed.

Thanks phedon, the above worked for me after experiencing this bug on Ubuntu 9.10

johnnyb0y (ubuntu64) wrote :

Ubuntu 9.10 (32 bit)

I second ruffneckc's vote for the phedon post earlier.

This exactly described my problem, and was the solution that worked for me, for example:

sudo mkfs -t vfat /dev/sdb1

Formatted the USB flash drive.

Then I was able to select the volume not marked with an exclamation mark, set my size for stored data as 1Gb and away she goes!

Thanks for the original poster phedon's contribution.

JahPe (preusse) wrote :

ruffneckc worked for me also
On Ubuntu Karmic 32-bit 9.10
Occured also on two 4Gig Sticks on two Netbooks with same installation.

mmalmeida (mmalmeida) wrote :

I am experiencing the same difficulties with Usb disk-creator.

Formatting the stick outside the program (like ruffneckc suggests) works. Might there be something wrong with the formatting options in the program?

Hannes Ovrén (kigurai) wrote :

I had two entries: /dev/sdb and /dev/sdb1
By pressing the "format" button repeatedly on both entries it somehow managed to finally format the partition and I could go ahead with the installation.
Unfortunately, due to random key presses I don't know what sequence actually solves the problem.

Richdel (richdel1991) wrote :

Hannes Holm Ovren,

I found the solution same as yours my repeatedly clicking format,

not the best solution but only one of the solutions that worked for me...

dasunsrule32 (aaron.e) wrote :

Before I came upon this bug thread, I was able to get it to work correctly by creating a vfat partition and then manually formatting it. Once this was done, the usb-creator worked correctly. It is a problem with the formatting portion.

Using gparted to format first does seem to work, but that's not a realistic workaround for end-users, who would never figure this out on their own.

What's makes things worse is that usb-creator's attempt to format the drive leaves it with a corrupted formatting, causing it to be useless until you use gparted to reformat. Not good.

martinizi (martin-carlsson) wrote :

I'm too am a swede so I followed revoltism's workaround moving the .iso to my home folder and it worked like a charm.

TychoCelchu (vernet-s) wrote :

Same thing, i followed revoltism's workaround and it worked well.

ah032290 (ah032290) on 2010-01-22
Changed in usb-creator (Ubuntu):
assignee: Evan Dandrea (ev) → ah032290 (ah032290)
piera (pieraoralbertini) on 2010-01-24
Changed in usb-creator (Ubuntu):
assignee: ah032290 (ah032290) → piera (pieraoralbertini)
Changed in nautilus (Ubuntu):
status: Invalid → Incomplete
status: Incomplete → New
piera (pieraoralbertini) on 2010-01-24
Changed in nautilus (Ubuntu):
assignee: nobody → piera (pieraoralbertini)
status: New → Confirmed
axelsvag (darinsson) wrote :

I can confirm that the problem is still there. After using " sudo mkfs -t vfat /dev/sdb1 " and a reboot, the function is normal.

It afects me but none of the workarounds worked.

Sense Egbert Hofstede (sense) wrote :

Please don't open tasks without a reason.

Changed in nautilus (Ubuntu):
assignee: piera (pieraoralbertini) → nobody
status: Confirmed → Invalid
Changed in usb-creator (Ubuntu):
assignee: piera (pieraoralbertini) → nobody
gh423 (ghagensen) wrote :

I tried all of the suggestions and nothing worked. I finally did get it ot work.
The key in my case seems to be to limit the size of the partition. I I made it 1GB.
I was using a 16GB stick. I did this with parted.

First I started by "dd"ing the first 1M with zeros as suggested to make sure
I started with a clean slate. In my case the usb stick was /dev/sdb

if /dev/sdb1 is mounted, unmount it:

  sudo umount /dev/sdb1
  sudo dd if=/dev/zero of=/dev/sdb bs=1M count=1

Then in parted: "sudo parted /dev/sdb" make a msdos label
and a fat16 partition. The "unit" command allows inputs in
MB where 1000MB = 1GB.

  unit MB
  mklabel msdos
  mkpart primary fat16 0 1000

Then to format it:

  sudo mkfs -t vfat /dev/sdb1

Now usb-creator should work. I did the procedure a couple of times
and for some reason sometimes usb-creator still thinks it needs to
format and when it did I selected /dev/sdb1 to format
Sometimes it was fine without the format.

After this I could start the create.

If you don't do the formatting using mkfs.vfat, ie just the parted stuff,
usb-creator will change the partition to 16GB (in my case),
try to partition and fail. I don't know that much about vfat, but
could it be that it is size limited and usb-creator is not taking that
into account?

Ruzty (ruzty) wrote :

Thanx Revoltizm
It finaly worked!!!!
after formating by gparted
and moving sorce file out of the folder with cyrilic letters in its name
I should have remembered: the longer the pass the trickier it gets

PS After several unsuccesfull attempts (with usb creator) to write iso to preformated into FAT32 usb stick gparted could not recognize its formating. It was blackened.

Glenn (gleenn) wrote :

Another tip, if you have a CD-ROM in the drive, it shows up in the list and there is a bug calculating the usb drive size needed. I had a DVD that was bigger than the size of my USB stick, and even though I selected a small ISO image to put on the thumb drive, it was using the DVD's size to do the calculation. I removed the DVD, and then restarted the program and selected the ISO again, and it worked.

Mike (bild85) wrote :

Broken for me too on multiple platforms. I got it to work once, but that was after hours of clicking and formatting and clicking...
This is such a useful tool, why are many of the bugs unassigned? How does one generate 'heat' for a bug?

Lenin (doctortomorrow) wrote :

I find this bit rarely
"DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found"

But I frequently get the error of "Device not found : /dev/sr1"

It happened after I have upgraded to 9.10 from 9.04 which was twice upgraded from 8.04 to 8.10 as well.

I dont anymore get the automatic Mobile/EDGE modem connection working in GUI mode. But works fine from LiveCD.

I also cant use gnome-ppp to connect. Only being able to connect using wvdial from terminal. But I have to troubleshoot a lot.

Please help me give you more technical info which you might need solving this.


Michael Nagel (nailor) wrote :

heat is generated automatically and you should not game the system.
i think this is quite a nasty bug, too, but there are other bugs, too :)

more info:

Patrick Gillespie (vtpoet) wrote :

The same bug.

The command:

sudo mkfs -t vfat /dev/sdb1

Seems to have worked. It took some effort to find this solution. I hope this Bug can be remedied for the sake of more inexperienced users.

weishigoname (weishigoname) wrote :

I got the problem .too.and after this ,I got a new problem ,when the progress bar arrive at 81% ,it can not go further,and a tip "checksum do not match ,retry?".I tried ubuntu-9.10-amd64 and ubuntu-9.10-i386 ,and ubuntu-9.04-i386.the problem is the same.

Jacques Morin (jacquesmorin) wrote :

Tried the trick suggested by Revoltism. Worked really well. Don't forget that in order to copy or transfer the ISO file to he Home folder, you need to login at startup as root. When the Create a Startup Disk button becomes active, just click it to effect the wanted action. Thanks, Revolutionist for your Swedish know-how.

Jacques Morin (jacquesmorin) wrote :

Oops! I mean thanks Revoltism.

NicoDup (nicolas-dupain) wrote :

i've got the same bug.
I'm french and the default folder for download on Karmic is "Téléchargement".
I moved the .iso in my home directory and it's works.

Applause for Revoltism

Joao Teixeira (joaomrt) wrote :

Six months later I've found out I have this bug too. My folder names don't have any special character but I moved it anyway to my home directory. Then I zeroed the first megabyte and format the drive to vfat. Only after all this 3 steps usb-creator allowed me to procede.

This worked for me, in addition to previous posts I like to add point 4:

1. (re)insert usb stick, it will be mounted automatically
2. unmount it
 sudo umount /dev/sdb1
3. .. so we can format it
 sudo mkfs -t vfat /dev/sdb1
4. make sure you dont have any ISO's mounted that are too big, it seems to look at all detected ISO's in stead of only the selected one
5. start usb-creator
6. select iso, make sure you dont have any 'difficult' characters in the path
7. create

Peter McKenna (peter-mckenna) wrote :

I just tried USB Creator for the first time on 9.10 and can confirm this bug is still there. Everything seems to work fine if you don't use the format option.
Having read some of the other comments here I'm a little bit perplexed that some people think a workaround is good enough. If a user interface displays an option to format, that is exactly what it should do.

Reuben Firmin (reubenf) wrote :

Confirmed. The mkfs workaround worked for me.

revoltism wrote on 2009-11-22: #20
I solved my problem. I am swedish and the folder i had the image in was "Hämtningar" witch means "Download" in english. I realised that maybe USB-Creator do not have compatibility with utf-8 characters. And viola! After i moved the image to my home folder it worked.

Did have the exact same problem.

raczgabor (raczgabor) wrote :

revoltism wrote on 2009-11-22: #20
"I solved my problem. I am swedish and the folder i had the image in was "Hämtningar"..."
Same issue wtih the Hungarian "Letöltések" folder, and solution, thanks!

Mc Rack (mc-rack) wrote :

I am french and the folder for my iso was "Téléchargement".
Without accented characters it worked.

David Seal (davidseal1) wrote :

Same problem here. Formatting the drive to fat32 (dare I say it!) worked for me.

 /dev/sdb had and exclamation point by it; /dev/sdb1 did not. I was able to write to /dev/sdb1

I don't know what the original format was. I tried reformatting to ext3 with gparted. Same problem until I reformatted to fat32.

yj92fromnj (yj92fromnj) wrote :

Unable to format stick while other usb drive was mounted. unmounted/plugged the other usb drive and was able to install after program restart with minimal difficulty.

Yuri (linux-colombi) wrote :

Thanks revoltism: my Ubuntu is using a french localization, with a folder called Téléchargement instead of Download. Like NicoDup, a simple move of the .iso file in an another folder (without special chars in the name) solved the issue (or mare accurately: is a work around).

David Tombs (dgtombs) wrote :

I've got a duplicate, bug 525906, that says it's fixed in 10.04. Can anyone reproduce in 10.04?

David Tombs (dgtombs) wrote :

What is going on with the vandalism in this bug? Invalidating CentOS task.

Changed in nautilus (CentOS):
status: New → Invalid
nandayo (casier) wrote :

Bug existed also on Karmic, fed up with it.

For me usb-creator presents two options as target device


Formatting the latter manually using parted and chosing it as the target device seems to allow usb-creator to proceed without the error message. Not yet tried does the stick boot, though.

David Tombs (dgtombs) wrote :

Mikko: is this in Lucid?

Alhamdulillah, that's problem is success finished for me. But, when i installed in a netbook, there is show a problem, that note is:
 "SYSLINUX 3.63 Debian-2008-07-15 EBIOS Copyright (c) 1994-2008 H. Peter Anvin
Unknown keyword in configuration file.

What a solution of this problem? Could you tell me what i can do with this problem?
Thanks before.

On Thu, Oct 14, 2010 at 05:10:54AM -0000, ismail azzam wrote:
> Alhamdulillah, that's problem is success finished for me. But, when i installed in a netbook, there is show a problem, that note is:
> "SYSLINUX 3.63 Debian-2008-07-15 EBIOS Copyright (c) 1994-2008 H. Peter Anvin
> Unknown keyword in configuration file.
> boot:
> _"
> What a solution of this problem? Could you tell me what i can do with this problem?
> Thanks before.

Usually, that means there was an error writing to the USB drive. It can
happen for example when the drive is disconnected before all of the data is

i.e. you have a different problem than described in this bug. Please try

 - mdz

johnheav (johnheav-gmail) wrote :

Wilbert Volkers fix worked! (Comment #59).

This is a really insidious bug. I'm impressed with all very smart people trying to help here. Folks like this make the Internet a great thing. Thanks, Wilbert.

David Tombs (dgtombs) wrote :

Can someone please confirm that this is still a problem in Maverick? Thanks.

Changed in usb-creator (Ubuntu):
status: Confirmed → Incomplete

I am having this problem on one of my maverick machines.

Launchpad Janitor (janitor) wrote :

[Expired for usb-creator (Ubuntu) because there has been no activity for 60 days.]

Changed in usb-creator (Ubuntu):
status: Incomplete → Expired
komputes (komputes) wrote :

Last update was that this was affecting maverick. Is anyone able to reproduce this in oneiric?

Changed in usb-creator (Ubuntu):
status: Expired → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for usb-creator (Ubuntu) because there has been no activity for 60 days.]

Changed in usb-creator (Ubuntu):
status: Incomplete → Expired
sudodus (nio-wiklund) wrote :

This bugs seems to have survived into saucy, so it is a really hardy bug ;-)

usb-creator-gtk is not able to wipe the first partition of my USB drive, but when I wipe it with rm -r from a terminal window, I can use usb-creator-gtk to create a working persistent live USB drive, although I sometimes get segmentation fault, which is probably another bug.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Jonathan (miareggeti) on 2013-09-18
Changed in usb-creator (Ubuntu):
status: Expired → Confirmed
Changed in usb-creator (Ubuntu):
status: Confirmed → New
assignee: nobody → marek duda (marek-duda1984)
David Tombs (dgtombs) wrote :

Please don't change status without a comment. Thanks.

Changed in usb-creator (Ubuntu):
assignee: marek duda (marek-duda1984) → nobody
status: New → Confirmed
da6930p (da6930p) wrote :

As far as i know from the version 8.04 it is still buggy.

Nothing changed.

emili (s71instalacions) on 2014-03-30
affects: usb-creator (Ubuntu) → usb-creator (Ubuntu Linaro Evaluation Build)
affects: usb-creator (Ubuntu Linaro Evaluation Build) → usb-creator (Ubuntu)
affects: usb-creator (Ubuntu) → xubuntu-default-settings
Changed in xubuntu-default-settings:
status: Confirmed → New
Adam Niedling (krychek) on 2014-06-01
affects: xubuntu-default-settings → usb-creator
Alfredzo Nash (lfrdznash) wrote :

This bug affects Trust 14.04 as well Please see attached images

Alfredzo Nash (lfrdznash) wrote :

This bug affects Trust 14.04 as well Please see attached images

Edward Garson (egarson) wrote :

I experienced a very similar error, but not exactly the same, when trying to format a 4G USB 2.0 device. Matt's suggested workaround (near the very top of this report, using dd) worked after a couple of tries. I was getting "DBus.Python.GLib.Error" when trying to format, with the same consequences as described in this report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers