update-notifier doesn't notify about available updates

Reported by Björn Lindqvist on 2006-07-24
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
update notifier
Confirmed
Undecided
Michael Vogt

Bug Description

update-notifier is running and no update-icon is shown in the notification area. Yet when typing:

sudo apt-get update
sudo apt-get upgrade

Installs updates. It seems like update-notifier sometimes doesn't notice that there are available updates in the deb-repositories.

Topper (t-harley) on 2006-10-01
Changed in update-notifier:
status: Unconfirmed → Confirmed
Topper (t-harley) wrote :

I have this bug too since I dist-upgraded to Dapper LTS. Now I'm on Edgy and still no luck. I wonder If I'm ever going to see the update notifier again...

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Can you please run (on a terminal):
$ ps ax | grep update-notifier
and paste the output here?

What happens if you run (again on a terminal):
$ killall update-notifier; update-notifier
Is anything printed on the terminal?

Thanks,
 Michael

Changed in update-notifier:
status: Confirmed → Needs Info
Björn Lindqvist (bjourne) wrote :

$ ps aux | grep update
65:bjourne 4441 0.1 2.0 18904 10336 ? Ss 02:27 0:00 update-notifier
79:bjourne 4538 0.0 0.1 2888 820 pts/0 S+ 02:30 0:00 grep --color=auto -n update
$ killall update-notifier; update-notifier
(Nothing is printed)

More from terminal:
$ sudo apt-get update
....
$ sudo apt-get upgrade
...
Följande paket kommer att uppgraderas:
  language-pack-en language-pack-gnome-en language-pack-gnome-sv language-pack-sv xinit
...

So there definitely is updates, but update-notifier fails to indicate that.

Björn Lindqvist (bjourne) wrote :

I just noticed now that IF update-notifier is running AND you run apt-get update THEN update-notifiers icon begins to show. So I assume the problem is that update-notifier fails to run apt-get update..

Giles Weaver (gweaver) wrote :

This bug is still present in Feisty.

We have been discussing the problem here: http://ubuntuforums.org/showthread.php?t=445662
Three people have posted that they have this bug on their installations.

Please let us know if you would like us to run any diagnostic commands.

Giles Weaver (gweaver) wrote :

$ ps ax | grep update-notifier
5627 ? S 0:00 update-notifier
14750 pts/0 S+ 0:00 grep update-notifier

$ killall update-notifier; update-notifier

The second command doesn't print anything, but doesn't give me the prompt back either, is that the right behaviour?

rkh (r-hughes) wrote :

I have had the same problem for a couple of months now. I had hoped that an upgrade to Feisty would cure it, but it didn't. The normal routes for updating work (apt-get update, synaptic, manually clicking "install updates" in the update manager) but I don't get any notification that updates are available.

warjowuch (lulkoek) wrote :

I can confirm this bug too. It started when I dist-upgraded to dapper from breezy. Since then... I have no update-notifications anymore, except when I manually do sudo apt-get update. THen it notifies and recognizes the available updates. But it does not do that by itself. I am jalous on the fresh 7.04 install on my wifes pc for this :-) This notifies correctly.

warjowuch (lulkoek) wrote :

I change status to 'confirmed' since quite a lot of people seem to have this obvious problem. But who to assign it to?

Changed in update-notifier:
status: Needs Info → Confirmed
warjowuch (lulkoek) on 2007-06-09
Changed in update-notifier:
assignee: nobody → ubuntu-bugs-apt-get
Giles Weaver (gweaver) wrote :

I have Feisty on my home computer now, and the update manager works fine there. Both of my Feisty computers at work still have this problem - I wonder if it something to do with the proxy/firewall?

Any news on this?

It seems it is resolved. At least, I have made a fresh install of feisty, and after an upgrade to the final gutsy, it is still working. Nice work. (if it is due to work, and not some obscure configuration-file problem :))
_________________________________________________________________________
In 5 Schritten zur eigenen Homepage. Jetzt Domain sichern und gestalten!
Nur 3,99 EUR/Monat! http://www.maildomain.web.de/?mc=021114

On my Xubuntu gutsy fresh install and on my Xubuntu feisty upgraded to feisty it still doesn't work.
It only notifies in the systray balloon after using manually the update manager.

Giles Weaver (gweaver) wrote :

I can confirm that this is still an issue on Gutsy :(

Giles Weaver (gweaver) wrote :

This bug no longer occurs for me on Hardy:)
If anyone else can confirm, I think this bug could be closed.

Michael Vogt (mvo) wrote :

Thanks for the information in this bugreport.

Could someone please let me know if this is still a problem?

Changed in update-notifier:
status: Confirmed → Incomplete
assignee: ubuntu-bugs-apt-get → mvo
Marktrix (markgerlach) wrote :

For me there is still problem. The Notifier does not realize there is a update.

marktrix@marktrix-desktop:~$ ps ax | grep update-notifier
 6848 ? S 0:02 update-notifier
20405 pts/0 S+ 0:00 grep update-notifier

Michael Vogt (mvo) wrote :

@Marktrix: Thanks, could you please try the following:
$ sudo /usr/share/update-notifier/notify-reboot-required
$ sudo touch /var/lib/update-notifier/dpkg-run-stamp

and check if there is a "reboot required" notification (and icon) coming up?
Could you also please add the output of:
$ ls -l /var/lib/apt/periodic/

Thanks,
 Michael

Marktrix (markgerlach) wrote :

@ Michael

yeah "reboot required" coming up!

ls -l /var/lib/apt/periodic/
insgesamt 0
-rw-r--r-- 1 root root 0 2008-12-17 07:47 update-stamp
-rw-r--r-- 1 root root 0 2008-12-19 18:00 update-success-stamp

miq (miqster) wrote :

I experience this behaviour since the upgrade from hardy to intrepid. Before it worked fine...

Michael Vogt (mvo) wrote :

@miq, Marktrix:

what is the output of:
$ /usr/lib/update-notifier/apt-check
and the content of /etc/apt/sources.list ?
$ ls -l /var/lib/apt/periodic/

miq (miqster) wrote :

miq@adara:~$ /usr/lib/update-notifier/apt-check
Reading package lists... Done
Building dependency tree
Reading state information... Done
0;0miq@adara:~$

and

miq@adara:~$ ls -l /var/lib/apt/periodic/
insgesamt 0
-rw-r--r-- 1 root root 0 2008-12-05 09:09 update-stamp
-rw-r--r-- 1 root root 0 2009-01-24 11:09 update-success-stamp
miq@adara:~$

Hope this helps...

Konstigt (konstigt) wrote :

I have this problem in Jaunty.

$ apt-cache policy update-notifier
update-notifier:
  Installed: 0.76.7
  Candidate: 0.76.7
  Version table:
 *** 0.76.7 0
        500 http://se.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

kavkar (kavkar) wrote :

Same problem.
When I run update-notifier from terminal:
$** (update-notifier:5079): DEBUG: /usr/lib/update-notifier/apt-check returned 17 (security: 0)
$** (update-notifier:5079): DEBUG: crashreport_check

This is still (not) happening in karmic,

$ /usr/lib/update-notifier/apt-check
32;0

$ ls -l /var/lib/apt/periodic/
total 0
-rw-r--r-- 1 root root 0 2009-10-30 13:10 update-stamp
-rw-r--r-- 1 root root 0 2009-10-30 19:31 update-success-stamp

Changed in update-notifier:
status: Incomplete → Confirmed

Not sure why it was set to 'Incomplete' to be honest?

I've added 2 log files the first one is update-notifier ran with 'gconftool -s --type bool /apps/update-notifier/auto_launch true' and the second one it is ran with 'gconftool -s --type bool /apps/update-notifier/auto_launch false'. Basically the notification area icon does work after setting 'gconftool -s --type bool /apps/update-notifier/auto_launch false' manually. But somehow the behaviour I know from jaunty doesn't work.

Think it has something to do with the following part from the second log file:
(update-notifier:19138): hooks-DEBUG: init_already_seen_hooks
(update-notifier:19138): hooks-DEBUG: check_update_hooks()
(update-notifier:19138): hooks-DEBUG: reading '/var/lib/update-notifier/user.d/' dir
(update-notifier:19138): hooks-DEBUG: showing hooks with focus on map == FALSE
(update-notifier:19138): hooks-DEBUG: show_hooks()
(update-notifier:19138): hooks-DEBUG: no unseen hookfile found in hook list of len (0)

Especially that last line. I hope this information might help fixing this bug.

- Think it has something to do with the following part from the second log file:
+ Think it has something to do with the following part from the first log file:

It looks like update-notification does work using VirtualBox without changing anything, it's behaving the same as in jaunty. Maybe it has something to do with my specific setup? Just to be clear when I installed karmic beta, RC and final they were all clean installs and update-notification didn't/doesn't work.

UPDATE:
Hmm, somehow it stopped working in VirtualBox as well... For the record it worked once in VirtualBox.

Konstigt (konstigt) wrote :

I haven't seen any notification about available updates since Hardy IIRC. I have to start update-manager manually or wait for +7 days (if there has been a security update). I have three different Ubuntu installations.

I've found some good information from bug #369198. Especially comment #10.

[QUOTE Matthew Paul Thomas from bug #369198, comment #10]
When non-security updates are available, Update Manager should open automatically whichever is later: (a) X days after it was last open, whether that was manually or automatically, or (b) X days after updates were installed by any apt-powered method. X should default to 7.

When security updates are available, Update Manager should open automatically whichever is later: (a) Y days after it was last open, whether that was manually or automatically, or (b) Y days after updates were installed by any apt-powered method. Y should default to 1.

So yes, it is intentional that running apt-get update shouldn't cause Update Manager to open automatically. If you run apt-get update manually, it's highly likely that you're about to install updates manually too, in which case you don't want Update Manager getting in your way.
[END QUOTE]

I generally end up updating manually before 7 days that's why it didn't show up on me. So I kind of brought this bug back to life for something which isn't a bug but a feature... (I'm sorry for that :-))

Anyway, if someone reads this and wants to change it search google for '/apps/update-notifier/regular_auto_launch_interval'. I'm leaving it as default for now.

Changed in update-notifier:
status: Confirmed → Fix Released
status: Fix Released → Confirmed
Berni (jc4you) wrote :

It's still an issue in Lubuntu Beta 3. I get this from ~/.xsession-errors:

(update-notifier:1691): libgdu-WARNING **: Couldn't get daemon properties
======================================================================
Error constructing GduPool: (unspecified error)

This error suggests there's a problem with your udisks or D-Bus installation.
======================================================================

** (update-notifier:1691): WARNING **: initializing gdu failed

** (update-notifier:1691): DEBUG: error during dbus call: The name org.debian.apt was not provided by any .service files

** (update-notifier:1691): DEBUG: Skipping reboot required

Berni (jc4you) wrote :

Not only in Lubuntu, it's in Ubuntu 10.04, too.

Konstigt (konstigt) wrote :

From 9.04 and onwards there has been a change in how the user is notified if there are available updates.

Read http://www.ubuntu.com/getubuntu/releasenotes/1004#Change%20in%20notifications%20of%20available%20updates

To restore how it used to be with the orange icon, run:

gconftool -s --type bool /apps/update-notifier/auto_launch false

Berni (jc4you) wrote :

Sorry. Please forget my last comments. After I read a thread in the ubuntu forums (http://ubuntuforums.org/showthread.php?t=1130181) I understand now why it is how it is. Should have read this thread first. Sorry, folks.

Paul Crawford (psc-sat) wrote :

I am using 10.04 and prefer the 'old style' of notifier, but find it is now "unreliable".

Sometimes it shows a package manager is running (grey start) where there is no such activity (or long after there was), and often (for example, today) when security updates are available it shows the grey arrow that starts synaptic, when it should be showing the red arrow that starts the update manager (today, it was firefox among others that needed updating).

At other times it works correctly.

Dario Corsi (dareios) wrote :

Hi,
I found the same problem in 10.04: no notification of available updates.

$ ps ax | grep update-notifier
 1585 ? S 0:00 update-notifier
 2360 pts/0 S+ 0:00 grep --color=auto update-notifier

Restarting I get this result:

$ killall update-notifier
$ update-notifier &
[1] 2363
$ ** (update-notifier:2363): DEBUG: Skipping reboot required

I produced a reboot required notification in this way:
$ sudo /usr/share/update-notifier/notify-reboot-required

and the menu icon to restart it turned red. So I restarted from the same menu, confirming the dialog box.
But the problem was not resolved.

ingo (ingo-steiner) wrote :

Highly unreliable here too:
Lucid-amd64. Symptoms similar to post #38

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers