[DASH] diagonal swipe is recognized as a scroll

Bug #1152150 reported by Oren Horev on 2013-03-07
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Paty Davila
Unity 8
Daniel d'Andrada
unity8 (Ubuntu)

Bug Description

#98 on all devices

Current behaviour
Horizontal swipes in the dash are often performed with an angular aspect away form the horizontal axis. Angular swipes that have an angular component (more than +/- 30 deg) are often recognised as scrolls which can seem mistaken by the user having th intention of swiping.

Excepted behaviour
recognise the horizontal intention in swipes regardless of the angular component by evaluating ratio between horizontal /vertical speeds or distances not just angle

------ UX Comment ------

We are working on the redesign of the dash/scopes navegation, therefore this bug is not valid anymore. It'd be a waste of engineering time and effort since with Qt and qml list component there is not much we can do about that. Basically there is a horizontal list (dash and scopes) and vertical list (scope content) and we need to interpret if user is trying to do horizontal or vertical swipe and lock to that until finger released.

We'll publish an update on the new dash design as soon as it's available.

Alan Pope  (popey) on 2013-05-09
information type: Private → Public
affects: manhattan → unity
Michał Sawicz (saviq) on 2013-06-21
Changed in unity:
status: New → Invalid
no longer affects: unity/phablet
Michał Sawicz (saviq) on 2013-06-26
affects: unity → unity8
Changed in unity8:
status: Invalid → Confirmed
importance: Undecided → High
no longer affects: unity/8.0
Oren Horev (oreneeshy) on 2013-09-17
Changed in ubuntu-ux:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Oren Horev (oreneeshy)
Michał Sawicz (saviq) on 2013-09-27
Changed in unity8 (Ubuntu):
status: New → Confirmed
Oren Horev (oreneeshy) on 2013-09-30
Changed in ubuntu-ux:
importance: High → Critical
Andrea Cimitan (cimi) wrote :

I'll try...

Changed in unity8:
assignee: nobody → Andrea Cimitan (cimi)
Andrea Cimitan (cimi) on 2013-11-14
Changed in unity8:
assignee: Andrea Cimitan (cimi) → Daniel d'Andrada (dandrader)
Daniel d'Andrada (dandrader) wrote :

Let me have a shot at it...

Changed in unity8:
status: Confirmed → In Progress
Daniel d'Andrada (dandrader) wrote :

>Excepted behaviour
>recognise the horizontal intention in swipes regardless of the angular component by evaluating ratio >between horizontal /vertical speeds or distances not just angle

Too vague for a specification and even contradictory in a sense.

The ratio between horizontal and vertical distances (or speeds) translates into an angle and vice-versa.

Need more info on the expected behavior.

But I guess that what the reporter means is that a vertical scrolling can be aborted and turned into a horizontal dash-switch if the original vertical movement turned into a drastic horizontal one. And vice-versa. Because the current logic is that once a tendency (horizontal/vertical) has been identified early in the gesture, the UI movement is locked in that direction. So in practice what the reporter wants seems to be removing that direction lock. I.e. that it can be unlocked if there's a sustained, dramatic, direction change.

Daniel d'Andrada (dandrader) wrote :

I noticed that while a list is scrolling by itself (e.g. after a fast vertical flick) you cannot successfully perform a horizontal flick (there will be no dash switch). You have to first stop the list movement and then perform the horizontal flick. Is that considered a bug and, if so, is that included in this one?

Daniel d'Andrada (dandrader) wrote :

I don't know, as long as you don't try a horizontal flick while a dash list is still moving, it works fine for me.

Need details on what's expected.

Changed in unity8:
status: In Progress → Incomplete
Albert Astals Cid (aacid) wrote :

This has been incomplete for months so i'll close it as invalid

Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Invalid
Changed in unity8:
status: Incomplete → Invalid
Changed in ubuntu-ux:
assignee: Oren Horev (oreneeshy) → Paty Davila (dizzypaty)
Vesa Rautiainen (vesar) wrote :

In the new design scopes will be taken away from the dash and will act as apps in the system and in many parts of the navigation. So dash won't exist in the future as a horizontal list anymore. This will fix this usability issue and I wouldn't put any efforts at this point to fix this.

Paty Davila (dizzypaty) on 2015-09-04
Changed in ubuntu-ux:
status: Fix Committed → Won't Fix
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers